Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 11-07-2016 14:25:34

Khyxes
Membre
Distrib. : Debian 8
Noyau : Linux 3.16.0-4-amd64
(G)UI : Xfce
Inscription : 10-07-2016

Debian 8 Pilote Wifi Atheros QCA61x4A non reconnu

Bonjour

J'ai installé Debian 8 sur mon laptop Acer Aspire V3-372-57EQ il y a quelque jours tout marche bien sauf la carte wifi qui n'est pas reconnu.

Ma carte est une Qualcomm Atheros QCA61x4A, j'ai déjà lu le wiki et essayé d'installé firmware-atheros depuis le backports mais ça n'a rien changé.


Voila la liste des commandes du wiki que j'ai faites et et ce qui m'a été renvoyé

 iwconfig


eth0      no wireless extensions.
lo        no wireless extensions.






lspci -nn | grep -i network


03:00.0 Network controller [0280]: Qualcomm Atheros Device [168c:003e] (rev 32)






 lspci -k |grep -i network -A 2


03:00.0 Network controller: Qualcomm Atheros Device 003e (rev 32)
    Subsystem: Lite-On Communications Inc Device 0807





 lsusb


Bus 002 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
Bus 001 Device 004: ID 0bda:0129 Realtek Semiconductor Corp. RTS5129 Card Reader Controller
Bus 001 Device 003: ID 1bcf:2c81 Sunplus Innovation Technology Inc.
Bus 001 Device 002: ID 04ca:3016 Lite-On Technology Corp.
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub





 /sbin/ifconfig


eth0      Link encap:Ethernet  HWaddr 30:65:ec:9b:e2:b6  
          UP BROADCAST MULTICAST  MTU:1500  Metric:1
          RX packets:467 errors:0 dropped:0 overruns:0 frame:0
          TX packets:538 errors:0 dropped:47 overruns:0 carrier:0
          collisions:0 lg file transmission:1000
          RX bytes:466130 (455.2 KiB)  TX bytes:54977 (53.6 KiB)

lo        Link encap:Boucle locale  
          inet adr:127.0.0.1  Masque:255.0.0.0
          adr inet6: ::1/128 Scope:Hôte
          UP LOOPBACK RUNNING  MTU:65536  Metric:1
          RX packets:1001 errors:0 dropped:0 overruns:0 frame:0
          TX packets:1001 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 lg file transmission:0
          RX bytes:84731 (82.7 KiB)  TX bytes:84731 (82.7 KiB)



Merci d'avance

Edit à toto :
Mis les balises citations (quote)  en balise retour de commande (code). Juste que ce soit homogène et plus lisible sur le forum.

Hors ligne

#2 12-07-2016 13:04:54

phlinux
Membre
Lieu : S-M
Distrib. : Jessie
Noyau : 4.6
(G)UI : Openbox (+Rox+Feh)
Inscription : 10-05-2009

Re : Debian 8 Pilote Wifi Atheros QCA61x4A non reconnu

Bjr,
Tu as configuré ton interface manuellement ou avec Network-Manager ?
Peux-tu renvoyer le résultat de:

dmesg | grep -i wifi


Pages perso : feh, omegat, udisks, sa station de travail comme passerelle

Hors ligne

#3 13-07-2016 13:40:42

Khyxes
Membre
Distrib. : Debian 8
Noyau : Linux 3.16.0-4-amd64
(G)UI : Xfce
Inscription : 10-07-2016

Re : Debian 8 Pilote Wifi Atheros QCA61x4A non reconnu

Mon interface n'est pas encore configuré, j'ai l'intention de le faire manuellement mais si j'ai bien compris le wiki pour pouvoir le faire il faut d'abord que ma carte soit reconnu.

la commande

dmesg | grep -i wifi

  ne renvoie rien

Hors ligne

#4 13-07-2016 15:03:28

phlinux
Membre
Lieu : S-M
Distrib. : Jessie
Noyau : 4.6
(G)UI : Openbox (+Rox+Feh)
Inscription : 10-05-2009

Re : Debian 8 Pilote Wifi Atheros QCA61x4A non reconnu

Ok , je crois qu'on a la solution sur le forum. Pour vérifier, que donne

dmesg | grep ath10k

Si le module est bien présent , tu peux suivre cette manip ici >> https://debian-facile.org/viewtopic.php … 23#p155423.
Il y a aussi ce fil pour compléter si besoin >> http://ubuntuforums.org/showthread.php?t=2323812

Si tu as besoin d'aide avant, pas de problème tu postes ici


Pages perso : feh, omegat, udisks, sa station de travail comme passerelle

Hors ligne

#5 16-07-2016 23:16:15

Khyxes
Membre
Distrib. : Debian 8
Noyau : Linux 3.16.0-4-amd64
(G)UI : Xfce
Inscription : 10-07-2016

Re : Debian 8 Pilote Wifi Atheros QCA61x4A non reconnu

La commande 

dmesg | grep ath10k

ne renvoie rien.

J'ai essayé les methodes indiquées dans ces deux liens mais ça n'a rien changé

Hors ligne

#6 16-07-2016 23:42:43

phlinux
Membre
Lieu : S-M
Distrib. : Jessie
Noyau : 4.6
(G)UI : Openbox (+Rox+Feh)
Inscription : 10-05-2009

Re : Debian 8 Pilote Wifi Atheros QCA61x4A non reconnu

Tu n'as pas installé le paquet firmware-linux-nonfree ?

Pages perso : feh, omegat, udisks, sa station de travail comme passerelle

Hors ligne

#7 17-07-2016 07:48:22

Severian
Membre
Distrib. : Debian GNU/Linux 8.6 (jessie)
Noyau : Linux 4.6.0-0.bpo.1-amd64
(G)UI : Openbox 3.6.1-2
Inscription : 13-12-2014

Re : Debian 8 Pilote Wifi Atheros QCA61x4A non reconnu

bonsoir
ath10k c'est le paquet firmware-atheros smile

"il est urgent d'attendre" (bendia)
ob3-debian2-150x50.png

Hors ligne

#8 17-07-2016 13:40:02

phlinux
Membre
Lieu : S-M
Distrib. : Jessie
Noyau : 4.6
(G)UI : Openbox (+Rox+Feh)
Inscription : 10-05-2009

Re : Debian 8 Pilote Wifi Atheros QCA61x4A non reconnu

Ok. Alors pourquoi n'apparait-il pas dans dmesg ?
On peut aussi vérifier si le kernel reconnait la carte wifi

lspci -knns 03:00.0

Dernière modification par phlinux (17-07-2016 13:47:20)


Pages perso : feh, omegat, udisks, sa station de travail comme passerelle

Hors ligne

#9 17-07-2016 13:51:17

Severian
Membre
Distrib. : Debian GNU/Linux 8.6 (jessie)
Noyau : Linux 4.6.0-0.bpo.1-amd64
(G)UI : Openbox 3.6.1-2
Inscription : 13-12-2014

Re : Debian 8 Pilote Wifi Atheros QCA61x4A non reconnu

pourquoi apparaîtrait il s'il n'est pas installé ?
pourquoi le wifi apparaîtrait si la carte n'est pas reconnue ?

sinon les liens que tu donne dans le post #4 sont à mon avis de bonnes piste à suivre pour résoudre le soucis smile

"il est urgent d'attendre" (bendia)
ob3-debian2-150x50.png

Hors ligne

#10 17-07-2016 14:04:18

phlinux
Membre
Lieu : S-M
Distrib. : Jessie
Noyau : 4.6
(G)UI : Openbox (+Rox+Feh)
Inscription : 10-05-2009

Re : Debian 8 Pilote Wifi Atheros QCA61x4A non reconnu

Selon le post #1 il est installé, enfin d'après Khyxes.

Pages perso : feh, omegat, udisks, sa station de travail comme passerelle

Hors ligne

#11 17-07-2016 18:52:12

Khyxes
Membre
Distrib. : Debian 8
Noyau : Linux 3.16.0-4-amd64
(G)UI : Xfce
Inscription : 10-07-2016

Re : Debian 8 Pilote Wifi Atheros QCA61x4A non reconnu

firmware-atheros,firmware-linux-free &firmware-linux-nonfree  sont bien installé

La commande

dpkg -l '*firmware*'


(qui si j'ai bien compris renvoie la liste de tous les paquet installé contenant le mot 'firmware')

renvoie


Souhait=inconnU/Installé/suppRimé/Purgé/H=à garder
| État=Non/Installé/fichier-Config/dépaqUeté/échec-conFig/H=semi-installé/W=attend-traitement-déclenchements
|/ Err?=(aucune)/besoin Réinstallation (État,Err: majuscule=mauvais)
||/ Nom                         Version            Architecture       Description
+++-===========================-==================-==================-============================================================
ii  firmware-atheros            20160110-1~bpo8+1  all                Binary firmware for Atheros wireless cards
un  firmware-crystalhd          <aucune>           <aucune>           (aucune description n'est disponible)
un  firmware-ivtv               <aucune>           <aucune>           (aucune description n'est disponible)
ii  firmware-linux              0.43               all                Binary firmware for various drivers in the Linux kernel (met
ii  firmware-linux-free         3.3                all                Binary firmware for various drivers in the Linux kernel
ii  firmware-linux-nonfree      0.43               all                Binary firmware for various drivers in the Linux kernel
 


La commande


lspci -knns 03:00.0
 


renvoie

03:00.0 Network controller [0280]: Qualcomm Atheros Device [168c:003e] (rev 32)
  Subsystem: Lite-On Communications Inc Device [11ad:0807]
 


La commande

dmesg | grep ath10k


ne renvoie rien

Par contre

lsmod | grep ath10k
 


renvoie


ath10k_pci             36107  0
ath10k_core            99592  1 ath10k_pci
ath                    26067  1 ath10k_core
mac80211              474216  1 ath10k_core
cfg80211              405538  3 ath,mac80211,ath10k_core
 

Hors ligne

#12 17-07-2016 19:49:42

phlinux
Membre
Lieu : S-M
Distrib. : Jessie
Noyau : 4.6
(G)UI : Openbox (+Rox+Feh)
Inscription : 10-05-2009

Re : Debian 8 Pilote Wifi Atheros QCA61x4A non reconnu

Donc tu peux suivre la méthode du premier lien que je t'ai indiqué, en commençant par retirer le module qui pose problème

modprobe -r ath10k_pci

puis tu télécharges et installes le module board-2.bin, etc...

Dernière modification par phlinux (17-07-2016 19:50:26)


Pages perso : feh, omegat, udisks, sa station de travail comme passerelle

Hors ligne

#13 17-07-2016 20:39:48

Khyxes
Membre
Distrib. : Debian 8
Noyau : Linux 3.16.0-4-amd64
(G)UI : Xfce
Inscription : 10-07-2016

Re : Debian 8 Pilote Wifi Atheros QCA61x4A non reconnu

J'ai bien suivi cette méthode mais ma carte n'est toujours pas détecte.

Je ne sais pas si c'est normal mais juste après avoir suivi cette méthode la commande

lsmod | grep ath10k
 

ne renvoyait plus rien, mais après avoir redémarré le pc cette commande ce remet a renvoyé


ath10k_pci             36107  0
ath10k_core            99592  1 ath10k_pci
ath                    26067  1 ath10k_core
mac80211              474216  1 ath10k_core
cfg80211              405538  3 ath,mac80211,ath10k_core

Hors ligne

Pied de page des forums