Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 20-07-2016 01:12:46

winproof
Membre
Distrib. : debian 8
Noyau : Linux 3.16.0-4-amd64
(G)UI : sans
Inscription : 15-05-2013

compression sur un lecteur quantum DAT 72 [RESOLU]

bonjour!

j'ai un petit problème avec une debian 8:

je dois sauvegarder des données sur bande, avec un lecteur quantum DAT 72 (version SATA).

jusqu’à présent tout marchait bien, mais maintenant que la taille des données dépasse 36GO, ça plante. (normal smile )

j'en ai donc déduit que par défaut, la compression matérielle n'est pas activée sur le lecteur.

problème, comment je l'active?

j'ai essayé avec "mt -f /dev/st0 datcompression", réponse "unknown command"
"mt -f /dev/st0 compression" ne donne rien, la commande s’exécute mais aucun message, juste un retour a la ligne.

idem en essayant avec un argument...

j'ai installé mt-st, idem.

help!

merci

Dernière modification par winproof (20-07-2016 12:37:08)


Debian 8 (3.16.0-4-amd64) sur serveur perso (AM1B-itx avec Athlon 5350) et serveurs pro (PowerEdge T110 II avec Xeon-E3 1220)

Hors ligne

#2 20-07-2016 01:40:26

MicP
Membre
Distrib. : debian stable
Noyau : Linux 3.16.0-4-amd64
(G)UI : Xfce
Inscription : 29-02-2016

Re : compression sur un lecteur quantum DAT 72 [RESOLU]

Bonjour winproof

Je n'ai pas de lecteur de bande pour faire les tests, mais peut-être qu'en spécifiant une valeur pour le paramètre compression :

Pour activer la compression :

mt -f /dev/st0 compression 1


Pour désacactiver la compression :

mt -f /dev/st0 compression 0

Dernière modification par MicP (20-07-2016 01:40:50)

Hors ligne

#3 20-07-2016 01:44:18

winproof
Membre
Distrib. : debian 8
Noyau : Linux 3.16.0-4-amd64
(G)UI : sans
Inscription : 15-05-2013

Re : compression sur un lecteur quantum DAT 72 [RESOLU]

j'ai essayé, pareil...
retour a la ligne sans message.
par contre j'ai pas essayé de relancer mon script apres avoir utiliser l'argument 1, je vais tester, peut-etre que ca a activé la compression

Dernière modification par winproof (20-07-2016 01:46:43)


Debian 8 (3.16.0-4-amd64) sur serveur perso (AM1B-itx avec Athlon 5350) et serveurs pro (PowerEdge T110 II avec Xeon-E3 1220)

Hors ligne

#4 20-07-2016 01:49:04

winproof
Membre
Distrib. : debian 8
Noyau : Linux 3.16.0-4-amd64
(G)UI : sans
Inscription : 15-05-2013

Re : compression sur un lecteur quantum DAT 72 [RESOLU]

ce qui est bizarre c'est que d'apres d'autres posts sur internet, lancer mt avec l'option compression devrait afficher le reglage actuel du lecteur

Debian 8 (3.16.0-4-amd64) sur serveur perso (AM1B-itx avec Athlon 5350) et serveurs pro (PowerEdge T110 II avec Xeon-E3 1220)

Hors ligne

#5 20-07-2016 02:12:08

winproof
Membre
Distrib. : debian 8
Noyau : Linux 3.16.0-4-amd64
(G)UI : sans
Inscription : 15-05-2013

Re : compression sur un lecteur quantum DAT 72 [RESOLU]

c'est bon, j'ai trouvé.
en installant le paquet mtx j'ai pu avoir la commande tapeinfo, qui m'a permis de voir les infos du lecteurs concernant la compression.
la commande "mt -f /dev/st0 compression" ne change rien.
par contre avec "mt -f /dev/st0 compression 1" ça active bien la compression (d’après tapeinfo), et avec 0 ça la désactive.
plus qu'a lancer mon script pour vérifier smile
je ferait un retour pour confirmer.

Debian 8 (3.16.0-4-amd64) sur serveur perso (AM1B-itx avec Athlon 5350) et serveurs pro (PowerEdge T110 II avec Xeon-E3 1220)

Hors ligne

#6 20-07-2016 02:57:06

MicP
Membre
Distrib. : debian stable
Noyau : Linux 3.16.0-4-amd64
(G)UI : Xfce
Inscription : 29-02-2016

Re : compression sur un lecteur quantum DAT 72 [RESOLU]

.

Dernière modification par MicP (22-08-2016 05:53:09)

Hors ligne

#7 20-07-2016 11:09:37

winproof
Membre
Distrib. : debian 8
Noyau : Linux 3.16.0-4-amd64
(G)UI : sans
Inscription : 15-05-2013

Re : compression sur un lecteur quantum DAT 72 [RESOLU]

je confirme, çà fonctionne, la compression est activée.
merci!

Debian 8 (3.16.0-4-amd64) sur serveur perso (AM1B-itx avec Athlon 5350) et serveurs pro (PowerEdge T110 II avec Xeon-E3 1220)

Hors ligne

#8 20-07-2016 11:52:02

smolski
administrateur quasi...modo
Lieu : AIN
Distrib. : 8 (jessie) 64 bits + backports
Noyau : 4.6.0-0.bpo.1-amd64
(G)UI : gnome 3.14.1
Inscription : 21-10-2008

Re : compression sur un lecteur quantum DAT 72 [RESOLU]

winproof a écrit :

çà fonctionne, la compression est activée


Si c'est Résolu, alors :
Voir le tuto : C'est résolu ! Bravo mais il faut l'indiquer dans l'titre. tongue


"Définition d'eric besson : S'il fallait en chier des tonnes pour devenir ministre, il aurait 2 trous du cul." - JP Douillon
"L'utopie ne signifie pas l'irréalisable, mais l'irréalisée." - T Monod (source :  La zone de Siné)
"Je peux rire de tout mais pas avec n'importe qui." - P Desproges
"saque eud dun" (patois chtimi : fonce dedans)

Hors ligne

#9 20-07-2016 12:37:23

winproof
Membre
Distrib. : debian 8
Noyau : Linux 3.16.0-4-amd64
(G)UI : sans
Inscription : 15-05-2013

Re : compression sur un lecteur quantum DAT 72 [RESOLU]

fait, merci:)

Debian 8 (3.16.0-4-amd64) sur serveur perso (AM1B-itx avec Athlon 5350) et serveurs pro (PowerEdge T110 II avec Xeon-E3 1220)

Hors ligne

#10 24-07-2016 13:04:55

winproof
Membre
Distrib. : debian 8
Noyau : Linux 3.16.0-4-amd64
(G)UI : sans
Inscription : 15-05-2013

Re : compression sur un lecteur quantum DAT 72 [RESOLU]

petite précision, avec "mt -f /dev/st0 compression 1" la compression est activée, mais uniquement avec la bande actuelle, au changement de bande le lecteur revient aux paramètres par défaut du driver st (dans mon cas compression désactivée).

pour fixer définitivement le pb, il faut utiliser "mt -f /dev/st0 defcompression 1"

c'est une peu le bordel, entre mt version GNU et mt-st.

j'ai été sauvé quand je suis tombé ici:
http://wiki.zmanda.com/index.php/Hardware_compression

une fois lu tout s'éclaire! smile

Debian 8 (3.16.0-4-amd64) sur serveur perso (AM1B-itx avec Athlon 5350) et serveurs pro (PowerEdge T110 II avec Xeon-E3 1220)

Hors ligne

Pied de page des forums