Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 10-08-2016 20:48:06

Ayzak
Membre
Inscription : 10-08-2016

problème ssmtp [résolu]

Bonjour à tous, je viens d'arrivé alors ne me mangez pas s'il vous plait :3.

Voici la situation :

J'ai actuellement un serveur Nginx sur mon raspberry pi B+ (avec raspbian) et j'aimerais pouvoir envoyer des mail via ce dernier.

On m'a conseillé d'utiliser ssmtp pour rediriger le flux permettant l'envoie de mail. Soit -> je lis des tutos -> j'installe -> je relis-> je configure -> ca marche pas -> je relis, et je tombe ici https://debian-facile.org/viewtopic.php?id=14823.

Dans le post il est conseillé de faire ceci :


sudo chmod 640 /etc/ssmtp/ssmtp.conf
sudo useradd ssmtp -g nogroup -s /sbin/nologin -c "sSMTP pseudo-user"
sudo chown ssmtp /etc/ssmtp/ssmtp.conf
 




Seulement maintenant j'ai cette erreur :


$echo "mon message" | mail -v -s "test" satanas_747@hotmail.fr -r locheron.jeremy@gmail.com
send-mail: Cannot open mailhub:25
 




En passant en lecture pour les autres (chmod o+r) j'obtiens ceci:


$ echo "mon message" | mail -v -s "test" satanas_747@hotmail.fr -r locheron.jeremy@gmail.com
[<-] 220 smtp.gmail.com ESMTP bj8sm43997798wjc.49 - gsmtp
[->] EHLO contact@jeremyl.ovh
[<-] 501 5.5.4  https://support.google.com/mail/?p=helo bj8sm43997798wjc.49 - gsmtp
send-mail: Cannot open smtp.gmail.com:587
 




J'ai installé ssmtp / mailutils / heirloom-mailx .

Sur mon raspi j'ai autorisé les ports 587 via

sudo ufw allow out  587/tcp

et les règles iptables


sudo iptables -t filter -A INPUT -p tcp --dport 587 -j ACCEPT
sudo iptables -t filter -A OUTPUT -p tcp --dport 587 -j ACCEPT
 

.


Voici mes configs ssmtp :


jeje/etc/ssmtp $[1]> sudo cat ssmtp.conf
#
# Config file for sSMTP sendmail
#
# The person who gets all mail for userids < 1000
# Make this empty to disable rewriting.
root=mon_email_googl@gmail.com
#Logins
AuthUser=monEmail@gmail.com
AuthPass=*****************************
AuthMethod=LOGIN

# The place where the mail goes. The actual machine name is required no
# MX records are consulted. Commonly mailhosts are named mail.domain.com
mailhub=smtp.gmail.com:587

# Where will the mail seem to come from?
rewriteDomain=gmail.com
# The full hostname
hostname=raspi

# Are users allowed to set their own From: address?
# YES - Allow the user to specify their own From: address
# NO - Use the system generated From: address
FromLineOverride=YES
UseTLS=YES
UseStartTLS=YES
TLS_CA_File=/etc/ssl/certs/ca-certificates.crt
 




Ainsi que le contenur de revaliases:


jeje/etc/ssmtp $[0]> sudo cat revaliases
# sSMTP aliases
#
# Format:       local_account:outgoing_address:mailhub
#
# Example: root:your_login@your.domain:mailhub.your.domain[:port]
# where [:port] is an optional port number that defaults to 25.
root:monEmail@gmail.com:smtp.gmail.com:587
ssmtp:monEmail@gmail.com:smtp.gmail.com:587
 



Les droits et groupes de ces deux fichiers:


jeje/etc/ssmtp $[0]> ls -l
total 8
-rw-r----- 1 ssmtp root 286 août  10 16:21 "revaliases"
-rw-r----- 1 ssmtp root 820 août  10 16:10 "ssmtp.conf"
 




Voilà la situation .... Je commence à désespérer, ça fait presque une semaine que je bloque sur ce problème ....

Merci d'avance pour votre aide !

Dernière modification par Ayzak (29-09-2016 22:31:16)

Hors ligne

#2 14-09-2016 09:31:07

celp
Membre
Lieu : Chartres
Distrib. : Debian STABLE
Noyau : Linux 3.16.0-4-amd64
(G)UI : Mate / i3-wm
Inscription : 14-09-2016

Re : problème ssmtp [résolu]

Bonjour

Je peut t'aider. Par contre dans un premier temps, et afin de t'encourager dans ta démarche, veut tu passer par exim4? Je connais ssmtp mais exim4 est facile et ne prend pas beaucoup de ressources.
si t'es OK, je te propose de t'assister.

Hors ligne

#3 15-09-2016 02:53:28

tux12
Membre
Lieu : ./
Distrib. : Squeeze
Noyau : Linux 2.6.32-5-686-bigmem
(G)UI : KDE
Inscription : 27-02-2008

Re : problème ssmtp [résolu]

Bonjour,

Je n'ai pas regardé le reste, mais au vu des règles reproduites ci-dessous je suppose que ton parefeu n'est pas "statefull" et donc

sudo iptables -t filter -A INPUT -p tcp --dport 587 -j ACCEPT
sudo iptables -t filter -A OUTPUT -p tcp --dport 587 -j ACCEPT



serait à remplacer par

sudo iptables -t filter -A INPUT -p tcp --sport 587 -j ACCEPT
sudo iptables -t filter -A OUTPUT -p tcp --dport 587 -j ACCEPT


(sport au lieu de dport en INPUT, sinon ça n'est utile que si tu disposes d'un serveur smtp qui doit être joignable de l'extérieur sur ton serveur, et il faudrait de plus pour que ça puisse fonctionner - en entrée et en sortie - que le pare-feu gère les états des connexions et accepte les paquets ESTABLISHED -en entrée et en sortie - pour ce port.)

Cette modif devrait je pense permettre de s'affranchir du message

send-mail: Cannot open smtp.gmail.com:587




Si ça peut aider. smile

Dernière modification par tux12 (15-09-2016 03:05:39)

Hors ligne

#4 15-09-2016 07:19:32

celp
Membre
Lieu : Chartres
Distrib. : Debian STABLE
Noyau : Linux 3.16.0-4-amd64
(G)UI : Mate / i3-wm
Inscription : 14-09-2016

Re : problème ssmtp [résolu]

tux12 a écrit :

Bonjour,

Je n'ai pas regardé le reste, mais au vu des règles reproduites ci-dessous je suppose que ton parefeu n'est pas "statefull" et donc

sudo iptables -t filter -A INPUT -p tcp --dport 587 -j ACCEPT
sudo iptables -t filter -A OUTPUT -p tcp --dport 587 -j ACCEPT



serait à remplacer par

sudo iptables -t filter -A INPUT -p tcp --sport 587 -j ACCEPT
sudo iptables -t filter -A OUTPUT -p tcp --dport 587 -j ACCEPT


(sport au lieu de dport en INPUT, sinon ça n'est utile que si tu disposes d'un serveur smtp qui doit être joignable de l'extérieur sur ton serveur, et il faudrait de plus pour que ça puisse fonctionner - en entrée et en sortie - que le pare-feu gère les états des connexions et accepte les paquets ESTABLISHED -en entrée et en sortie - pour ce port.)

Cette modif devrait je pense permettre de s'affranchir du message

send-mail: Cannot open smtp.gmail.com:587




Si ça peut aider. smile



Dans certains cas, et surtout dans le siens, UFW suffit amplement.

Hors ligne

#5 15-09-2016 07:30:19

smolski
administrateur quasi...modo
Lieu : AIN
Distrib. : 8 (jessie) 64 bits + backports
Noyau : 4.6.0-0.bpo.1-amd64
(G)UI : gnome 3.14.1
Inscription : 21-10-2008

Re : problème ssmtp [résolu]

Une petite recherche de tuto dans le wiki df avec ufw donne : https://debian-facile.org/doc:systeme:ufw
L'est pas belle la vie ? big_smile

"Définition d'eric besson : S'il fallait en chier des tonnes pour devenir ministre, il aurait 2 trous du cul." - JP Douillon
"L'utopie ne signifie pas l'irréalisable, mais l'irréalisée." - T Monod (source :  La zone de Siné)
"Je peux rire de tout mais pas avec n'importe qui." - P Desproges
"saque eud dun" (patois chtimi : fonce dedans)

En ligne

#6 18-09-2016 17:46:48

Ayzak
Membre
Inscription : 10-08-2016

Re : problème ssmtp [résolu]

Bonjour,

Merci pour vos réponses. J'ai modifié la règle iptable comme me l'a conseillé @tux12 seulement j'ai toujours les mêmes erreurs ... sad

@celp Dans l'idéal j'aimerais rester avec ssmtp, mais si jamais j'en ai vraiment trop marre j'accepte que tu me guide dans les méandre d'exim4 ! smile Merci pour ta proposition!

Hors ligne

#7 18-09-2016 18:03:40

tux12
Membre
Lieu : ./
Distrib. : Squeeze
Noyau : Linux 2.6.32-5-686-bigmem
(G)UI : KDE
Inscription : 27-02-2008

Re : problème ssmtp [résolu]

Bonjour,

Il est en effet possible que UFW interagisse avec les règles introduites manuellement (sur le principe le mélange n'est pas une bonne idée mais là c'est juste "pour tester").

Je suggère de commencer par supprimer les règles que j'ai proposées précédemment, en relançant ces commandes en remplaçant pour chacune le "-A" par "-D". Ceci n'est pas utile si les règles ont été entretemps supprimées par un autre mécanisme (reboot, autre script iptables).

Ensuite et pour tenter de s'affranchir des autres règles en place, on peut tenter de relancer les mêmes règles que précédemment en remplaçant pour chacune le "-A" par un "-I" (i majuscule) ce qui à pour effet de les positionner en début de table et non en fin comme avec le "-A".
On pourra ensuite les supprimer comme précédemment en les relançant avec "-D" au lieu de "-I".

Comme dit, c'est vite fait et ça permet de tester, mais il faudra ensuite intégrer ces règles (on peut les affiner) dans UFW que je ne connais pas, ou harmoniser d'une manière quelconque la gestion des règles du pare-feu.

Dernière modification par tux12 (18-09-2016 18:08:35)

Hors ligne

#8 29-09-2016 22:30:33

Ayzak
Membre
Inscription : 10-08-2016

Re : problème ssmtp [résolu]

Bonjour à tous,

Un ami m'a conseillé de repartir d'une conf vierge :


#
# Config file for sSMTP sendmail
#
# The person who gets all mail for userids < 1000
# Make this empty to disable rewriting.
root=tonmail@gmail.com

# The place where the mail goes. The actual machine name is required no
# MX records are consulted. Commonly mailhosts are named mail.domain.com
mailhub=smtp.gmail.com:465
UseTLS=YES
#UseSTARTTLS=YES
FromLineOverride=YES
AuthUser=tonmail@gmail.com
AuthPass=*******

RewriteDomain=gmail.com


# Where will the mail seem to come from?
#rewriteDomain=

# The full hostname
hostname=tonnomdeserver

# Are users allowed to set their own From: address?
# YES - Allow the user to specify their own From: address
# NO - Use the system generated From: address
FromLineOverride=YES
 



Et de vérifier cette option https://www.google.com/settings/security/lesssecureapps.

Du coup après avoir refais ça, et suivi le tutoriel dispo sur ce forum :

apt-get install ssmtp


chmod 640 /etc/ssmtp/ssmtp.conf


chown root:mail /etc/ssmtp/ssmtp.conf



Ca fonctionne !

jeje/etc/ssmtp $[0]> 

echo "mon message" | mail -v -s "test" monautremail@hotmail.fr -r monmail@gmail.com


[<-] 220 smtp.gmail.com ESMTP f69sm410974wmg.19 - gsmtp
[->] EHLO raspi
[<-] 250 SMTPUTF8
[->] AUTH LOGIN
[<-] 334 ***************************
[->] bG9****************************************==
[<-] 334 **************************************
[<-] 235 2.7.0 Accepted
[->] MAIL FROM:<mail@gmail.com>
[<-] 250 2.1.0 OK f*********************g.19 - gsmtp
[->] RCPT TO:<monautremail@hotmail.fr>
[<-] 250 2.1.5 OK***********************.19 - gsmtp
[->] DATA
[<-] 354  Go ahead ***********************g.19 - gsmtp
[->] Received: by raspi (sSMTP sendmail emulation); Thu, 29 Sep 2016 22:15:46 +0200
[->] From: "jeje" <monmail@gmail.com>
[->] Date: Thu, 29 Sep 2016 22:15:46 +0200
[->] To: monmail@gmail.com, -r, monautremail@hotmail.fr
[->] Subject: test
[->] User-Agent: Heirloom mailx 12.5 6/20/10
[->] MIME-Version: 1.0
[->] Content-Type: text/plain; charset=us-ascii
[->] Content-Transfer-Encoding: 7bit
[->]
[->] mon message
[->] .
[<-] 250 2.0.0 OK 1475180149 f69sm410974wmg.19 - gsmtp
[->] QUIT
[<-] 221 2.0.0 closing connection f69sm410974wmg.19 - gsmtp



Edit mis les balises des Commandes séparées entre elles et de leur retour.

Hors ligne

#9 30-09-2016 07:53:34

Ayzak
Membre
Inscription : 10-08-2016

Re : problème ssmtp [résolu]

Apparemment je créeais un conflit entre SSL et TLS :s

Hors ligne

Pied de page des forums