Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 20-08-2016 18:46:03

Xunil
Membre
Distrib. : Debian GNU/Linux 7.6 - Wheezy
Noyau : 3.10.23
Inscription : 19-03-2016

[Résolu] Apache - Directive namevirtualhost

Bonjour,

J'ai configuré le https sur Apache pour 2 sites. Leur configuration sont exactement les mêmes.
Pour l'un d'entre eux j'ai ce message d'erreur :

[....] Restarting web server: apache2[Sat Aug 20 12:25:47 2016] [warn] _default_ VirtualHost overlap on port 443, the first has precedence
[Sat Aug 20 12:25:47 2016] [warn] _default_ VirtualHost overlap on port 443, the first has precedence
 ... waiting [Sat Aug 20 12:25:48 2016] [warn] _default_ VirtualHost overlap on port 443, the first has precedence
[Sat Aug 20 12:25:48 2016] [warn] _default_ VirtualHost overlap on port 443, the first has precedence

En cherchant sur le Web, j'ai vu que ce problème peut se régler avec cette directive (Doc : http://httpd.apache.org/docs/trunk/mod/ … irtualhost, ma version d'Apache est 2.2.22 ):

Avant la version 2.3.11, il était nécessaire de définir une directive NameVirtualHost pour indiquer au serveur qu'une paire adresse IP/port particulière pouvait être utilisée comme serveur virtuel à base de nom [...]

J'ai mis :

NameVirtualHost *:443

et l'erreur n'y est plus, mais je n'ai pas saisis l'explication de la doc.

Même si cette erreur n'y est plus, j'aimerais bien comprendre pourquoi j'en ai besoin pour un vhost et pas pour l'autre.
Quelqu'un à une idée ?

Merci smile

Dernière modification par Xunil (24-08-2016 18:47:03)

Hors ligne

#2 24-08-2016 18:46:08

Xunil
Membre
Distrib. : Debian GNU/Linux 7.6 - Wheezy
Noyau : 3.10.23
Inscription : 19-03-2016

Re : [Résolu] Apache - Directive namevirtualhost

Bonjour,

En effectuant plusieurs tests sur le serveur avec notamment des générations de clés Let's Encrypt, le problème à "disparu". Je n'ai plus besoin de cette directive (je ne sais pas pourquoi Apache en avait besoin au départ d'ailleurs). Peut être que j'avais mal déclaré les clés vis à vis des sous-domaines ?

Dernière modification par Xunil (24-08-2016 18:46:35)

Hors ligne

Pied de page des forums