Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 26-08-2016 17:04:59

Neko62
Membre
Distrib. : Debian 8.5
Noyau : Linux 3.16.0-4-amd64 x86_64
(G)UI : Gnome
Inscription : 26-08-2016

Installation de CUDA refusée

Bonjour à tous,

après être passé par Ubuntu, ArchLinux, Fédora, me voici avec ma toute première install d'une Debian 8.5.
Ma config actuelle est :
i7 6500, GTX970, 1 SSD pour le sytème, 1 HDD pour le home, 16 Go de DDR4

Donc, après une install par liveUSB passée sans soucis, j'installe les pilotes propriétaires de NVidia.
Là encore, aucun soucis.

Suite au reboot, je souhaite installer CUDA car je l'utilise sous Blender. Et là, le système me refuse son installation !

Ci-dessous le code correspondant :

nicolas@Debian-Nanchen:~$

grep -B2 'Module class: X.Org Video Driver'



/var/log/Xorg.0.log
[     2.309] (II) Module nvidia: vendor="NVIDIA Corporation"
[     2.309]     compiled for 4.0.2, module version = 1.0.0
[     2.309]     Module class: X.Org Video Driver


nicolas@Debian-Nanchen:~$

su



Mot de passe :


root@Debian-Nanchen:/home/nicolas#

apt-get install nvidia-cuda-toolkit



Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances      
Lecture des informations d'état... Fait
Certains paquets ne peuvent être installés. Ceci peut signifier
que vous avez demandé l'impossible, ou bien, si vous utilisez
la distribution unstable, que certains paquets n'ont pas encore
été créés ou ne sont pas sortis d'Incoming.
L'information suivante devrait vous aider à résoudre la situation :

Les paquets suivants contiennent des dépendances non satisfaites :
 nvidia-cuda-toolkit : Dépend: nvidia-profiler (= 6.0.37-5) mais ne sera
pas installé
                       Dépend: nvidia-cuda-dev (= 6.0.37-5) mais ne sera
pas installé
                       Recommande: nvidia-visual-profiler (= 6.0.37-5)
mais ne sera pas installé
E: Impossible de corriger les problèmes, des paquets défectueux sont en
mode « garder en l'état ».

 



Qu'en pensez-vous ?

D'avance merci.

Edit à toto :
Séparé les commandes user et root et mis leurs retours respectifs sous balise code simple.


Config : Intel Core i7 6700, GTX970, 16 Go de DDR4, un SSD de 120 Go System, un HDD de 1 To Home, un SSD de 240 Go Jeux

Hors ligne

#2 27-08-2016 12:07:00

raleur
Membre
Inscription : 03-10-2014

Re : Installation de CUDA refusée

apt-cache policy

Hors ligne

#3 27-08-2016 13:06:27

èfpé
Membre
Distrib. : Debian
Noyau : Linux
Inscription : 10-07-2016

Re : Installation de CUDA refusée

...

Dernière modification par èfpé (29-08-2016 17:06:12)

Hors ligne

#4 28-08-2016 23:30:39

Neko62
Membre
Distrib. : Debian 8.5
Noyau : Linux 3.16.0-4-amd64 x86_64
(G)UI : Gnome
Inscription : 26-08-2016

Re : Installation de CUDA refusée

alors la commande proposée par raleur donne :
nicolas@Debian-Nanchen:~$

apt-cache policy


Fichiers du paquet :
 100 /var/lib/dpkg/status
     release a=now
 500 http://httpredir.debian.org/debian/ jessie-backports/non-free Translation-en
 500 http://httpredir.debian.org/debian/ jessie-backports/main Translation-en
 500 http://httpredir.debian.org/debian/ jessie-backports/contrib Translation-en
 100 http://httpredir.debian.org/debian/ jessie-backports/non-free i386 Packages
     release o=Debian Backports,a=jessie-backports,n=jessie-backports,l=Debian Backports,c=non-free
     origin httpredir.debian.org
 100 http://httpredir.debian.org/debian/ jessie-backports/contrib i386 Packages
     release o=Debian Backports,a=jessie-backports,n=jessie-backports,l=Debian Backports,c=contrib
     origin httpredir.debian.org
 100 http://httpredir.debian.org/debian/ jessie-backports/main i386 Packages
     release o=Debian Backports,a=jessie-backports,n=jessie-backports,l=Debian Backports,c=main
     origin httpredir.debian.org
 100 http://httpredir.debian.org/debian/ jessie-backports/non-free amd64 Packages
     release o=Debian Backports,a=jessie-backports,n=jessie-backports,l=Debian Backports,c=non-free
     origin httpredir.debian.org
 100 http://httpredir.debian.org/debian/ jessie-backports/contrib amd64 Packages
     release o=Debian Backports,a=jessie-backports,n=jessie-backports,l=Debian Backports,c=contrib
     origin httpredir.debian.org
 100 http://httpredir.debian.org/debian/ jessie-backports/main amd64 Packages
     release o=Debian Backports,a=jessie-backports,n=jessie-backports,l=Debian Backports,c=main
     origin httpredir.debian.org
 500 http://httpredir.debian.org/debian/ jessie-updates/non-free Translation-en
 500 http://httpredir.debian.org/debian/ jessie-updates/main Translation-en
 500 http://httpredir.debian.org/debian/ jessie-updates/contrib Translation-en
 500 http://httpredir.debian.org/debian/ jessie-updates/non-free i386 Packages
     release o=Debian,a=stable-updates,n=jessie-updates,l=Debian,c=non-free
     origin httpredir.debian.org
 500 http://httpredir.debian.org/debian/ jessie-updates/contrib i386 Packages
     release o=Debian,a=stable-updates,n=jessie-updates,l=Debian,c=contrib
     origin httpredir.debian.org
 500 http://httpredir.debian.org/debian/ jessie-updates/main i386 Packages
     release o=Debian,a=stable-updates,n=jessie-updates,l=Debian,c=main
     origin httpredir.debian.org
 500 http://httpredir.debian.org/debian/ jessie-updates/non-free amd64 Packages
     release o=Debian,a=stable-updates,n=jessie-updates,l=Debian,c=non-free
     origin httpredir.debian.org
 500 http://httpredir.debian.org/debian/ jessie-updates/contrib amd64 Packages
     release o=Debian,a=stable-updates,n=jessie-updates,l=Debian,c=contrib
     origin httpredir.debian.org
 500 http://httpredir.debian.org/debian/ jessie-updates/main amd64 Packages
     release o=Debian,a=stable-updates,n=jessie-updates,l=Debian,c=main
     origin httpredir.debian.org
 500 http://httpredir.debian.org/debian/ jessie/non-free Translation-en
 500 http://httpredir.debian.org/debian/ jessie/main Translation-fr
 500 http://httpredir.debian.org/debian/ jessie/main Translation-en
 500 http://httpredir.debian.org/debian/ jessie/contrib Translation-en
 500 http://httpredir.debian.org/debian/ jessie/non-free i386 Packages
     release v=8.5,o=Debian,a=stable,n=jessie,l=Debian,c=non-free
     origin httpredir.debian.org
 500 http://httpredir.debian.org/debian/ jessie/contrib i386 Packages
     release v=8.5,o=Debian,a=stable,n=jessie,l=Debian,c=contrib
     origin httpredir.debian.org
 500 http://httpredir.debian.org/debian/ jessie/main i386 Packages
     release v=8.5,o=Debian,a=stable,n=jessie,l=Debian,c=main
     origin httpredir.debian.org
 500 http://httpredir.debian.org/debian/ jessie/non-free amd64 Packages
     release v=8.5,o=Debian,a=stable,n=jessie,l=Debian,c=non-free
     origin httpredir.debian.org
 500 http://httpredir.debian.org/debian/ jessie/contrib amd64 Packages
     release v=8.5,o=Debian,a=stable,n=jessie,l=Debian,c=contrib
     origin httpredir.debian.org
 500 http://httpredir.debian.org/debian/ jessie/main amd64 Packages
     release v=8.5,o=Debian,a=stable,n=jessie,l=Debian,c=main
     origin httpredir.debian.org
 500 http://ftp.fr.debian.org/debian/ jessie-updates/main Translation-en
 500 http://ftp.fr.debian.org/debian/ jessie-updates/main i386 Packages
     release o=Debian,a=stable-updates,n=jessie-updates,l=Debian,c=main
     origin ftp.fr.debian.org
 500 http://ftp.fr.debian.org/debian/ jessie-updates/main amd64 Packages
     release o=Debian,a=stable-updates,n=jessie-updates,l=Debian,c=main
     origin ftp.fr.debian.org
 500 http://security.debian.org/ jessie/updates/non-free Translation-en
 500 http://security.debian.org/ jessie/updates/main Translation-en
 500 http://security.debian.org/ jessie/updates/contrib Translation-en
 500 http://security.debian.org/ jessie/updates/non-free i386 Packages
     release v=8,o=Debian,a=stable,n=jessie,l=Debian-Security,c=non-free
     origin security.debian.org
 500 http://security.debian.org/ jessie/updates/contrib i386 Packages
     release v=8,o=Debian,a=stable,n=jessie,l=Debian-Security,c=contrib
     origin security.debian.org
 500 http://security.debian.org/ jessie/updates/main i386 Packages
     release v=8,o=Debian,a=stable,n=jessie,l=Debian-Security,c=main
     origin security.debian.org
 500 http://security.debian.org/ jessie/updates/non-free amd64 Packages
     release v=8,o=Debian,a=stable,n=jessie,l=Debian-Security,c=non-free
     origin security.debian.org
 500 http://security.debian.org/ jessie/updates/contrib amd64 Packages
     release v=8,o=Debian,a=stable,n=jessie,l=Debian-Security,c=contrib
     origin security.debian.org
 500 http://security.debian.org/ jessie/updates/main amd64 Packages
     release v=8,o=Debian,a=stable,n=jessie,l=Debian-Security,c=main
     origin security.debian.org
 500 http://ftp.fr.debian.org/debian/ jessie/main Translation-fr
 500 http://ftp.fr.debian.org/debian/ jessie/main Translation-en
 500 http://ftp.fr.debian.org/debian/ jessie/main i386 Packages
     release v=8.5,o=Debian,a=stable,n=jessie,l=Debian,c=main
     origin ftp.fr.debian.org
 500 http://ftp.fr.debian.org/debian/ jessie/main amd64 Packages
     release v=8.5,o=Debian,a=stable,n=jessie,l=Debian,c=main
     origin ftp.fr.debian.org
 500 cdrom://[Debian GNU/Linux 8 _Jessie_ - Official Snapshot amd64 LIVE/INSTALL Binary 20160609-11:56]/ jessie/main amd64 Packages
     origin Debian GNU/Linux 8 _Jessie_ - Official Snapshot amd64 LIVE/INSTALL Binary 20160609-11:56
Paquets épinglés :
 



Qu'en pensez-vous ?

Edit à toto :
Séparer les balises de la commande user de son retour.


Config : Intel Core i7 6700, GTX970, 16 Go de DDR4, un SSD de 120 Go System, un HDD de 1 To Home, un SSD de 240 Go Jeux

Hors ligne

#5 29-08-2016 23:52:51

Neko62
Membre
Distrib. : Debian 8.5
Noyau : Linux 3.16.0-4-amd64 x86_64
(G)UI : Gnome
Inscription : 26-08-2016

Re : Installation de CUDA refusée

alors si je fais un :

root@Debian-Nanchen:/home/nicolas# apt-cache policy nvidia-cuda-toolkit
nvidia-cuda-toolkit:
  Installé : (aucun)
  Candidat : 6.0.37-5
 Table de version :
     6.5.19-3~bpo8+1 0
        100 http://httpredir.debian.org/debian/ jessie-backports/non-free amd64 Packages
     6.0.37-5 0
        500 http://httpredir.debian.org/debian/ jessie/non-free amd64 Packages




ce qui m'incite à installer le paquet Cuda en backports:

root@Debian-Nanchen:/home/nicolas# aptitude -t jessie-backports install nvidia-cuda-toolkit
Les NOUVEAUX paquets suivants vont être installés :    
  g++-4.9{a} gcc-4.9-base:i386{a} libc6:i386{a} libc6-i686:i386{a} libcublas6.5{a} libcuda1{a} libcuda1:i386{a} libcuda1-i386:i386{a}
  libcudart6.5{a} libcufft6.5{a} libcufftw6.5{a} libcuinj64-6.5{a} libcurand6.5{a} libcusparse6.5{a} libdrm-amdgpu1{a} libdrm-dev{a}
  libgcc1:i386{a} libgl1-mesa-dev{a} libnppc6.5{a} libnppi6.5{a} libnpps6.5{a} libnvblas6.5{a} libnvcuvid1{a} libnvidia-compiler{a}
  libnvidia-ml1:i386{a} libnvtoolsext1{a} libnvvm2{a} libpthread-stubs0-dev{a} libstdc++-4.9-dev{a} libthrust-dev{a} libvdpau-dev{a}
  libx11-dev{a} libx11-doc{a} libx11-xcb-dev{a} libxau-dev{a} libxcb-dri2-0-dev{a} libxcb-dri3-dev{a} libxcb-glx0-dev{a}
  libxcb-present-dev{a} libxcb-randr0-dev{a} libxcb-render0-dev{a} libxcb-shape0-dev{a} libxcb-sync-dev{a} libxcb-xfixes0-dev{a}
  libxcb1-dev{a} libxdamage-dev{a} libxdmcp-dev{a} libxext-dev{a} libxfixes-dev{a} libxshmfence-dev{a} libxxf86vm-dev{a} mesa-common-dev{a}
  nvidia-cuda-dev{a} nvidia-cuda-doc{a} nvidia-cuda-gdb{a} nvidia-cuda-toolkit nvidia-libopencl1{a} nvidia-opencl-common{a}
  nvidia-opencl-dev{a} nvidia-opencl-icd{a} nvidia-persistenced:i386{ab} nvidia-profiler{a} nvidia-smi{ab} nvidia-smi:i386{ab}
  nvidia-visual-profiler{a} opencl-headers{a} x11proto-core-dev{a} x11proto-damage-dev{a} x11proto-dri2-dev{a} x11proto-fixes-dev{a}
  x11proto-gl-dev{a} x11proto-input-dev{a} x11proto-kb-dev{a} x11proto-xext-dev{a} x11proto-xf86vidmode-dev{a} xorg-sgml-doctools{a}
  xtrans-dev{a}
Les paquets suivants seront mis à jour :
  libdrm-intel1 libdrm-nouveau2 libdrm-radeon1 libdrm2 libgl1-mesa-glx libglapi-mesa
6 paquets mis à jour, 77 nouvellement installés, 0 à enlever et 153 non mis à jour.
Il est nécessaire de télécharger 554 Mo d'archives. Après dépaquetage, 1 150 Mo seront utilisés.
Les paquets suivants ont des dépendances non satisfaites :
 nvidia-persistenced : Est en conflit avec: nvidia-persistenced:i386 mais 358.09-1~bpo8+1 doit être installé.
 nvidia-persistenced:i386 : Est en conflit avec: nvidia-persistenced mais 358.09-1~bpo8+1 est installé.
 libegl1-mesa-drivers : Dépend: libglapi-mesa (= 10.3.2-1+deb8u1) mais 11.1.3-1~bpo8+1 doit être installé.
 libgles2-mesa : Dépend: libglapi-mesa (= 10.3.2-1+deb8u1) mais 11.1.3-1~bpo8+1 doit être installé.
 libgles1-mesa : Dépend: libglapi-mesa (= 10.3.2-1+deb8u1) mais 11.1.3-1~bpo8+1 doit être installé.
 nvidia-smi : Est en conflit avec: nvidia-smi:i386 mais 352.79-10~bpo8+1 doit être installé.
 nvidia-smi:i386 : Est en conflit avec: nvidia-smi mais 352.79-10~bpo8+1 doit être installé.
Les actions suivantes permettront de résoudre ces dépendances :

      Supprimer les paquets suivants :                          
1)      digikam                                                  
2)      digikam-private-libs                                    
3)      dolphin                                                  
4)      kde-baseapps-bin                                        
5)      kde-runtime                                              
6)      kdenlive                                                
7)      kfind                                                    
8)      kipi-plugins                                            
9)      konqueror                                                
10)     konqueror-nsplugins                                      
11)     libegl1-mesa-drivers                                    
12)     libgles1-mesa                                            
13)     libgles2-mesa                                            
14)     libkonq-common                                          
15)     libkonq5abi1                                            
16)     libmarblewidget19                                        
17)     marble-plugins                                          
18)     nvidia-persistenced                                      
19)     phonon                                                  
20)     phonon-backend-vlc                                      
21)     vlc                                                      
22)     vlc-plugin-pulse                                        

      Conserver les paquets suivants dans leur version actuelle :
23)     nvidia-smi:i386 [Non installé]                          

      Laisser les dépendances suivantes non satisfaites :        
24)     konqueror recommande dolphin                            
25)     konqueror recommande kfind                              
26)     kdenlive-data recommande kdenlive                        
27)     libegl1-mesa recommande libegl1-mesa-drivers            
28)     libwayland-egl1-mesa recommande libegl1-mesa-drivers    
29)     phonon-backend-vlc recommande vlc                        
30)     kdelibs5-plugins recommande kde-runtime                  
31)     libcuda1 recommande nvidia-persistenced                  
32)     nvidia-driver recommande nvidia-persistenced            
33)     libcuda1:i386 recommande nvidia-smi:i386                


Accepter cette solution ? [Y/n/q/?]




mais j'ai l'impression que ça va me foutre tout en l'aire en me supprimant pas de logiciels dont certains ( darktable, vlc, kdenlive... ) qui me sont très utiles.
et engendrer de dépendances non satisfaites.

Donc comment dois-je m'y prendre ?


Config : Intel Core i7 6700, GTX970, 16 Go de DDR4, un SSD de 120 Go System, un HDD de 1 To Home, un SSD de 240 Go Jeux

Hors ligne

#6 01-09-2016 17:43:47

Neko62
Membre
Distrib. : Debian 8.5
Noyau : Linux 3.16.0-4-amd64 x86_64
(G)UI : Gnome
Inscription : 26-08-2016

Re : Installation de CUDA refusée

Je me permets de relancer ce sujet car je souhaite pouvoir utiliser Cuda pour Blender.
N'y a t'il pas moyen d'installer "nvidia-cuda-toolkit" directement à partir d'une version installable à partir du site de Nvidia ?

En fait je ne comprends pas pourquoi il me refuse l'installation de Cuda alors que j'ai respecté le process d'installation de mon pilote graphique à partir de la page web suivante pour le pilote Nvidia dans la section "Pilote graphique Nvidia récente installation via backports (Debian jessie stable)":
https://debian-facile.org/doc:materiel: … ia:accueil

Config : Intel Core i7 6700, GTX970, 16 Go de DDR4, un SSD de 120 Go System, un HDD de 1 To Home, un SSD de 240 Go Jeux

Hors ligne

#7 01-09-2016 19:40:44

robert2a
Membre
Lieu : France
Distrib. : Stretch
Noyau : Linux 4.8.0-1-amd64
(G)UI : Mate 1.16.1
Inscription : 15-11-2014

Re : Installation de CUDA refusée

Bonjour
désolé , l été je laisse tomber un peu l informatique

pour cuda le mieux c est Stretch et le driver nvidia non-free des depots debian avec le cuda qui va bien

pour jessie je pense qu il y a toujours le probleme entre le driver et cuda

pour faire court  smile

jessie + 3.16 + driver nvidia + cuda  =>  mauvais (peut etre avec les versions de base de jessie , eviter les backports)
stretch + 4.6 + driver nvidia + cuda => bon (bien sur a partir des depots de debian stretch)

ps: il faut que je redemarre mes machines mais au debut de l été tout etait correct (j utilise folding@home + le driver proprio debian + cuda + Stretch + bureau Mate)
actuellement j ai un souci entre le dernier driver debian non-free et le kernel 4.3 (ne supporte pas le 4.6 ) , toujours avec stretch , le driver bug et je me retrouve en console

si ces infos te sont utiles smile

@++

Hors ligne

#8 01-09-2016 20:18:18

Neko62
Membre
Distrib. : Debian 8.5
Noyau : Linux 3.16.0-4-amd64 x86_64
(G)UI : Gnome
Inscription : 26-08-2016

Re : Installation de CUDA refusée

En fait je suis un peu frileux de passer en stretch.
Je cherchais de la stabilité et je crains de passer sur un système instable !!!!

Config : Intel Core i7 6700, GTX970, 16 Go de DDR4, un SSD de 120 Go System, un HDD de 1 To Home, un SSD de 240 Go Jeux

Hors ligne

#9 01-09-2016 20:20:37

robert2a
Membre
Lieu : France
Distrib. : Stretch
Noyau : Linux 4.8.0-1-amd64
(G)UI : Mate 1.16.1
Inscription : 15-11-2014

Re : Installation de CUDA refusée

re
je remet une machine récente en service a base de I3 et une GTX950 , aprés la mise a jour je regarde si tout est correct pour cuda
voila ma config
commande


lspci
 


retour commande


00:00.0 Host bridge: Intel Corporation Sky Lake Host Bridge/DRAM Registers (rev 07)
00:01.0 PCI bridge: Intel Corporation Sky Lake PCIe Controller (x16) (rev 07)
00:14.0 USB controller: Intel Corporation Sunrise Point-H USB 3.0 xHCI Controller (rev 31)
00:16.0 Communication controller: Intel Corporation Sunrise Point-H CSME HECI #1 (rev 31)
00:17.0 SATA controller: Intel Corporation Sunrise Point-H SATA controller [AHCI mode] (rev 31)
00:1c.0 PCI bridge: Intel Corporation Sunrise Point-H PCI Express Root Port #3 (rev f1)
00:1c.3 PCI bridge: Intel Corporation Sunrise Point-H PCI Express Root Port #4 (rev f1)
00:1d.0 PCI bridge: Intel Corporation Sunrise Point-H PCI Express Root Port #9 (rev f1)
00:1f.0 ISA bridge: Intel Corporation Sunrise Point-H LPC Controller (rev 31)
00:1f.2 Memory controller: Intel Corporation Sunrise Point-H PMC (rev 31)
00:1f.3 Audio device: Intel Corporation Sunrise Point-H HD Audio (rev 31)
00:1f.4 SMBus: Intel Corporation Sunrise Point-H SMBus (rev 31)
01:00.0 VGA compatible controller: NVIDIA Corporation GM206 [GeForce GTX 950] (rev a1)
01:00.1 Audio device: NVIDIA Corporation Device 0fba (rev a1)
02:00.0 PCI bridge: ASMedia Technology Inc. ASM1083/1085 PCIe to PCI Bridge (rev 04)
04:00.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller (rev 15).
 


quelques infos sur ta machine peut etre  ?
j'ai le dernier driver debian non-free de stretch et le dernier cuda de stretch

voila le retour de mon logiciel



18:09:53:******************************* System ********************************
18:09:53:        CPU: Intel(R) Core(TM) i3-6100 CPU @ 3.70GHz
18:09:53:     CPU ID: GenuineIntel Family 6 Model 94 Stepping 3
18:09:53:       CPUs: 4
18:09:53:     Memory: 15.59GiB
18:09:53:Free Memory: 15.31GiB
18:09:53:    Threads: POSIX_THREADS
18:09:53: OS Version: 4.6
18:09:53:Has Battery: false
18:09:53: On Battery: false
18:09:53: UTC Offset: 2
18:09:53:        PID: 2584

18:09:53:         OS: Linux 4.6.0-1-amd64 x86_64
18:09:53:    OS Arch: AMD64
18:09:53:       GPUs: 1
18:09:53:      GPU 0: NVIDIA:5 GM206 [GeForce GTX 950]
18:09:53:       CUDA: 5.2
18:09:53:CUDA Driver: 7050
18:09:53:***********************************************************************
 

Hors ligne

#10 01-09-2016 20:25:42

robert2a
Membre
Lieu : France
Distrib. : Stretch
Noyau : Linux 4.8.0-1-amd64
(G)UI : Mate 1.16.1
Inscription : 15-11-2014

Re : Installation de CUDA refusée

ok , mais ça me fait sourire de mélanger une stable avec des paquets des backports (issu d une testing/sid) , mais bon je n insiste pas roll

je reboot et je te confirme quand meme la version du driver et de cuda si correct sur un noyau 4.6

ps:

voila tout est correct , ça bosse dur wink


18:29:52:WU00:FS01:0x21:Completed 0 out of 520000 steps (0%)
18:29:52:WU00:FS01:0x21:Temperature control disabled. Requirements: single Nvidia GPU, tmax must be < 110 and twait >= 900
18:31:57:WU00:FS01:0x21:Completed 5200 out of 520000 steps (1%)
18:34:00:WU00:FS01:0x21:Completed 10400 out of 520000 steps (2%)
 



avec cette config (ci dessous), tourner avec jessie ça equivaut a utiliser win98  hmm  (materiel de 2016 )


Config : Intel Core i7 6700, GTX970, 16 Go de DDR4, un SSD de 120 Go System, un HDD de 1 To Home, un SSD de 240 Go Jeux
 



pourtant je suis pas un gamin (helas) mais je vous trouve frileux sur debian (double boot jessie/stretch) et tu verra la difference et qui est stable smile

driver 352.79-10  et cuda 7.5.18-3
ps: pour les cartes j utilise GTX 950 / 960 / 970 / 980 , sur des platerformes entre 2006 et 2016 (intel ou amd ) tout en stretch
par contre j utilise le bureau Mate , je sais que gnome est plus lourd et peut etre sujet a probleme sur stretch , la je sais pas .

Dernière modification par robert2a (01-09-2016 20:45:54)

Hors ligne

#11 01-09-2016 20:50:04

Neko62
Membre
Distrib. : Debian 8.5
Noyau : Linux 3.16.0-4-amd64 x86_64
(G)UI : Gnome
Inscription : 26-08-2016

Re : Installation de CUDA refusée

la commande lspci donne :

00:00.0 Host bridge: Intel Corporation Device 191f (rev 07)
00:01.0 PCI bridge: Intel Corporation Device 1901 (rev 07)
00:14.0 USB controller: Intel Corporation Device a12f (rev 31)
00:14.2 Signal processing controller: Intel Corporation Device a131 (rev 31)
00:16.0 Communication controller: Intel Corporation Device a13a (rev 31)
00:17.0 SATA controller: Intel Corporation Device a102 (rev 31)
00:1b.0 PCI bridge: Intel Corporation Device a167 (rev f1)
00:1c.0 PCI bridge: Intel Corporation Device a110 (rev f1)
00:1c.3 PCI bridge: Intel Corporation Device a113 (rev f1)
00:1c.4 PCI bridge: Intel Corporation Device a114 (rev f1)
00:1d.0 PCI bridge: Intel Corporation Device a118 (rev f1)
00:1d.4 PCI bridge: Intel Corporation Device a11c (rev f1)
00:1f.0 ISA bridge: Intel Corporation Device a145 (rev 31)
00:1f.2 Memory controller: Intel Corporation Device a121 (rev 31)
00:1f.3 Audio device: Intel Corporation Device a170 (rev 31)
00:1f.4 SMBus: Intel Corporation Device a123 (rev 31)
01:00.0 VGA compatible controller: NVIDIA Corporation Device 13c2 (rev a1)
01:00.1 Audio device: NVIDIA Corporation Device 0fbb (rev a1)
03:00.0 PCI bridge: Intel Corporation Device 1578
04:00.0 PCI bridge: Intel Corporation Device 1578
04:01.0 PCI bridge: Intel Corporation Device 1578
04:02.0 PCI bridge: Intel Corporation Device 1578
04:04.0 PCI bridge: Intel Corporation Device 1578
07:00.0 USB controller: Intel Corporation Device 15b6
09:00.0 Ethernet controller: Qualcomm Atheros Killer E220x Gigabit Ethernet Controller (rev 10)




Comment puis je passer en stretch à partir de mon environnement actuel en espérant ne pas tout casser ?


Config : Intel Core i7 6700, GTX970, 16 Go de DDR4, un SSD de 120 Go System, un HDD de 1 To Home, un SSD de 240 Go Jeux

Hors ligne

#12 01-09-2016 21:09:49

Neko62
Membre
Distrib. : Debian 8.5
Noyau : Linux 3.16.0-4-amd64 x86_64
(G)UI : Gnome
Inscription : 26-08-2016

Re : Installation de CUDA refusée

mon fichier sources.list comporte les lignes suivantes pour l'instant :

# deb cdrom:[Debian GNU/Linux 8 _Jessie_ - Official Snapshot amd64 LIVE/INSTALL Binary 20160609-11:56]/ jessie main

# deb cdrom:[Debian GNU/Linux 8 _Jessie_ - Official Snapshot amd64 LIVE/INSTALL Binary 20160609-11:56]/ jessie main  

deb http://ftp.fr.debian.org/debian/ jessie main
deb-src http://ftp.fr.debian.org/debian/ jessie main

deb http://security.debian.org/ jessie/updates main
deb-src http://security.debian.org/ jessie/updates main

# jessie-updates, previously known as 'volatile'
deb http://ftp.fr.debian.org/debian/ jessie-updates main
deb-src http://ftp.fr.debian.org/debian/ jessie-updates main

# Debian Jessie, dépôt principal + paquets non libres
deb http://httpredir.debian.org/debian/ jessie main contrib non-free
# Debian Jessie, mises-à-jour de sécurité + paquets non libres
deb http://security.debian.org/ jessie/updates non-free contrib main  
# Debian Jessie, mises-à-jour "volatiles" + paquets non libres
deb http://httpredir.debian.org/debian/ jessie-updates main contrib non-free
# Debian Jessie, dépôt de rétroportages ("backports")
deb http://httpredir.debian.org/debian/ jessie-backports non-free contrib main  


Config : Intel Core i7 6700, GTX970, 16 Go de DDR4, un SSD de 120 Go System, un HDD de 1 To Home, un SSD de 240 Go Jeux

Hors ligne

#13 01-09-2016 21:56:08

èfpé
Membre
Distrib. : Debian
Noyau : Linux
Inscription : 10-07-2016

Re : Installation de CUDA refusée

Bonsoir (tant pis si c'est ringard),

Très accessoirement, ce sources.list comporte quelques doublons... les 8 dernières lignes suffiraient.

Hors ligne

#14 01-09-2016 22:10:57

Neko62
Membre
Distrib. : Debian 8.5
Noyau : Linux 3.16.0-4-amd64 x86_64
(G)UI : Gnome
Inscription : 26-08-2016

Re : Installation de CUDA refusée

effectivement j'ai commenté les premières lignes pour éviter les doublons.

Donc, maintenant, si je veux passer à stretch, je remplace "jessie" par stretch de la manière suivante ? :

# Debian Strech, dépôt principal + paquets non libres
deb http://httpredir.debian.org/debian/ stretch main contrib non-free
# Debian Stretch, mises-à-jour de sécurité + paquets non libres
deb http://security.debian.org/ stretch/updates non-free contrib main  
# Debian Stretch, mises-à-jour "volatiles" + paquets non libres
deb http://httpredir.debian.org/debian/ stretch-updates main contrib non-free
# Debian Stretch, dépôt de rétroportages ("backports")
deb http://httpredir.debian.org/debian/ stretch-backports non-free contrib main  



et ensuite un petit "apt-get update" suivi d'un grand "apt-get dist-upgrade" ?


Config : Intel Core i7 6700, GTX970, 16 Go de DDR4, un SSD de 120 Go System, un HDD de 1 To Home, un SSD de 240 Go Jeux

Hors ligne

#15 01-09-2016 22:52:14

èfpé
Membre
Distrib. : Debian
Noyau : Linux
Inscription : 10-07-2016

Re : Installation de CUDA refusée

Re-,

Alors à ma connaissance, le dépôt stretch-backports n'existe pas (logique, sid n'étant pas stable).
Par ailleurs ça vaut le coup de lire (et comprendre) : migrer d'une branche à une autre supérieure.

Toi qui n'osais pas installer le noyau backports tu vas être servi wink

Hors ligne

#16 01-09-2016 23:35:33

robert2a
Membre
Lieu : France
Distrib. : Stretch
Noyau : Linux 4.8.0-1-amd64
(G)UI : Mate 1.16.1
Inscription : 15-11-2014

Re : Installation de CUDA refusée

pour le depot backport stretch il faut commenter la ligne (n existe pas encore )

pour une mise a jour vers stretch il faut supprimer le driver video et cuda
faire le apt-get upgrade en console ainsi que le dist-upgrade (c est a dire serveur X a l arret  )
par la commande :
tu fait la combinaison de touches "Ctrl+Alt+F1" a l invite de logging graphique puis apres t etre loggué en root


service gdm stop
 


c est plus facile , sans le bureau graphique a mettre a jour et moins de risque d erreur .

ce qui donne : (pour basculer en stretch proprement )

en console pure :
purger le driver


apt-get remove --purge nvidia*
 


ensuite purger  l inutile (normalement les paquets cuda sont enlevé aussi)


apt-get autoremove --purge
 



pour info si tu a un fichier /etc/X11/xorg.conf il faut l effacer (pour info inutile de le creer avec cette version du driver a l installation )


rm /etc/X11/xorg.conf
 



mettre a jour le cache


apt-get update
 



purger le cache


apt-get autoclean
 



pour la forme encore un


apt-get update
 



mettre les outils a jour


apt-get upgrade
 



ensuite basculer en stretch


apt-get dist-upgrade
 



ensuite tu redemarre , et tu dois demarrer avec le driver nouveau

a ce momment la si tout est correct (sur le bureau)
tu peut installer le driver (il va modifier le noyau )
un reboot
puis cuda (il va modifier le noyau )
un reboot
tout doit etre fonctionnel

l installation peut se faire par la console ou par synaptic comme tu est le plus a l aise

ps: je te conseille de voir les paquets disponible avec synaptic  , pour le driver et pour cuda (tout n est pas installé par defaut)

dans la recherche synaptic tu tape "nvidia" tu aura la liste des paquets libres et non-free dans les differentes versions pour stretch
bien sur pas de melange de version
pour le driver nouveau et autres ils sont installé de base (ne pas toucher ) . en cas de desinstallation du non-free ils seront utile.

la commande "apt-get autoremove --purge" enlevera ce qui peut l etre
nota : pour cuda lors de la purge au debut , l autoremove --purge a du le retirer (apres le apt-get remove --purge nvidia* )

je pense que je n ai rien oublie
le plus gros morceau c est la mise a niveau vers stretch (avec gnome) pour ainsi dire tous les paquets sont remplacés

nota : si tu upgrade vers stretch avec le driver non-free (et ou cuda ) ça va planter

Dernière modification par robert2a (02-09-2016 00:12:05)

Hors ligne

#17 02-09-2016 14:56:59

robert2a
Membre
Lieu : France
Distrib. : Stretch
Noyau : Linux 4.8.0-1-amd64
(G)UI : Mate 1.16.1
Inscription : 15-11-2014

Re : Installation de CUDA refusée

nota: pour info  => https://packages.debian.org/source/unst … cs-drivers

en préparation sur sid , on l aura peut etre sur stretch avant le passage a stable smile

aprés relecture , tu a bien conflit avec le driver et cuda , pire tu a des conflits avec le systeme (enlever pas mal de paquets )

autre remarque a ceci => aptitude -t jessie-backports install nvidia-cuda-toolkit

plutot ceci


apt-get -s install -t jessie-backports nvidia-cuda-toolkit
 



l option -s te permet de simuler sans installer  smile  (et d avoir les éventuel conflit )

sinon de mémoire pour cuda le paquet "nvidia-cuda-toolkit" ne suffit pas , personnellement j utilise synaptic pour cuda et je selectionne tous les paquets cuda (dans la bonne  version )
et aussi il faut que le driver soit installe correctement (paquet relatif au cuda en version 352.xx )

ps: avec jessie il y a le driver constructeur qui fonctionne bien , mais je le conseille pas , déja utiliser du non-free c est pas top , mais utiliser des paquets exterieur a debian je l ai banni sur mes machines tongue (le cuda est intégré dans le driver du constructeur )

ce tuto est incomplet => https://debian-facile.org/doc:install:m … is-windows
(le titre est bizzare  tongue )

une bonne migration c est d abord un nettoyage , dans ton cas supprimer le driver non-free et cuda , et faire la migration en mode console (pas graphique)

derniere chose , le noyau + cuda + driver forme un tout , melanger un noyau jessie avec un driver backport et un cuda jessie ça ne fonctionnera pas  tongue
meme noyau backport , driver backport et cuda backport , j ai eu des soucis  (cuda non détecté par mon application )

Dernière modification par robert2a (02-09-2016 15:14:05)

Hors ligne

#18 10-09-2016 19:55:33

Neko62
Membre
Distrib. : Debian 8.5
Noyau : Linux 3.16.0-4-amd64 x86_64
(G)UI : Gnome
Inscription : 26-08-2016

Re : Installation de CUDA refusée

Bonsoir,

en restant avec ma Debian Jessy, j'ai retenté un :

apt-get install nvidia-cuda-toolkit


ce qui donne :

Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances      
Lecture des informations d'état... Fait
Certains paquets ne peuvent être installés. Ceci peut signifier
que vous avez demandé l'impossible, ou bien, si vous utilisez
la distribution unstable, que certains paquets n'ont pas encore
été créés ou ne sont pas sortis d'Incoming.
L'information suivante devrait vous aider à résoudre la situation :

Les paquets suivants contiennent des dépendances non satisfaites :
 nvidia-cuda-toolkit : Dépend: nvidia-profiler (= 6.0.37-5) mais ne sera pas installé
                       Dépend: nvidia-cuda-dev (= 6.0.37-5) mais ne sera pas installé
                       Recommande: nvidia-visual-profiler (= 6.0.37-5) mais ne sera pas installé
E: Impossible de corriger les problèmes, des paquets défectueux sont en mode « garder en l'état ».
root@Debian-Nanchen:/home/nicolas# aptitude -t jessie-backports install nvidia-cuda-toolkit
Les NOUVEAUX paquets suivants vont être installés :    
  libcublas6.5{a} libcuda1{a} libcuda1:i386{a} libcuda1-i386:i386{a} libcudart6.5{a} libcufft6.5{a} libcufftw6.5{a} libcuinj64-6.5{a} libcurand6.5{a} libcusparse6.5{a} libnppc6.5{a}
  libnppi6.5{a} libnpps6.5{a} libnvblas6.5{a} libnvcuvid1{a} libnvidia-compiler{a} libnvidia-ml1:i386{a} libnvtoolsext1{a} libnvvm2{a} libthrust-dev{a} libvdpau-dev{a}
  nvidia-cuda-dev{a} nvidia-cuda-doc{a} nvidia-cuda-gdb{a} nvidia-cuda-toolkit nvidia-opencl-common{a} nvidia-opencl-dev{a} nvidia-opencl-icd{a} nvidia-persistenced:i386{ab}
  nvidia-profiler{a} nvidia-smi{ab} nvidia-smi:i386{ab} nvidia-visual-profiler{a} opencl-headers{a}
0 paquets mis à jour, 34 nouvellement installés, 0 à enlever et 181 non mis à jour.
Il est nécessaire de télécharger 519 Mo d'archives. Après dépaquetage, 1 066 Mo seront utilisés.
Les paquets suivants ont des dépendances non satisfaites :
 nvidia-persistenced : Est en conflit avec: nvidia-persistenced:i386 mais 358.09-1~bpo8+1 doit être installé.
 nvidia-persistenced:i386 : Est en conflit avec: nvidia-persistenced mais 358.09-1~bpo8+1 est installé.
 nvidia-smi : Est en conflit avec: nvidia-smi:i386 mais 352.79-10~bpo8+1 doit être installé.
 nvidia-smi:i386 : Est en conflit avec: nvidia-smi mais 352.79-10~bpo8+1 doit être installé.
Les actions suivantes permettront de résoudre ces dépendances :

     Conserver les paquets suivants dans leur version actuelle :
1)     nvidia-persistenced:i386 [Non installé]                  
2)     nvidia-smi:i386 [Non installé]                          

     Laisser les dépendances suivantes non satisfaites :        
3)     libcuda1:i386 recommande nvidia-smi:i386                
4)     libcuda1:i386 recommande nvidia-persistenced:i386        


Accepter cette solution ? [Y/n/q/?] q



Donc j'ai tenté :

apt-get install nvidia-persistenced:i386



ce qui donne :

Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances      
Lecture des informations d'état... Fait
Les paquets suivants seront ENLEVÉS :
  nvidia-persistenced
Les NOUVEAUX paquets suivants seront installés :
  nvidia-persistenced:i386
0 mis à jour, 1 nouvellement installés, 1 à enlever et 1 non mis à jour.
Il est nécessaire de prendre 18,8 ko dans les archives.
Après cette opération, 5 120 o d'espace disque seront libérés.



Donc ma question est :
le remplacement des versions 64 bits par les version i386 des paquets "nvidia-smi" et "nvidia-persistenced" va t'il me mettre le souk dans ma Debian nativement en 64 bits ?

D'avance merci.

Edit à toto :
Mis les retours des commandes root sous les balises code simple.


Config : Intel Core i7 6700, GTX970, 16 Go de DDR4, un SSD de 120 Go System, un HDD de 1 To Home, un SSD de 240 Go Jeux

Hors ligne

#19 10-09-2016 23:29:37

robert2a
Membre
Lieu : France
Distrib. : Stretch
Noyau : Linux 4.8.0-1-amd64
(G)UI : Mate 1.16.1
Inscription : 15-11-2014

Re : Installation de CUDA refusée

je crois que tu ne m'a pas compris:

pour faire clair jessie + driver nvidia jessie + cuda jessie

ou stretch + driver stretch + cuda stretch

si tu veus installer un cuda 6 sur un driver 352 ça ne fonctionne pas

abandonne l idée des backports

soit tu utilise jessie avec son driver nvidia et son cuda (donc version stable )
soit tu installe stretch et tu utilise son driver nvidia et son cuda (version 352.xx et 7.xx
tant que tu mélange ça n ira pas et tu va casser ton installation
tu vois que cuda veut installer la version 6 (ci dessous)


nvidia-cuda-toolkit : Dépend: nvidia-profiler (= 6.0.37-5) mais ne sera pas installé
 



j'ai du te dire de faire apt-get -s install pour simuler (c est plus propre , ne touche pas au systeme et te donne les problemes )

donc je sais pas ou tu en est de ton installation
soit tu utilise jessie avec le vieux driver et le vieux cuda
soit tu utilise la derniere mouture de stretch driver + cuda
oublie les backports de jessie (le cuda des backports n 'est pas compatible avec le driver des backports )
selon ta carte , a mon avis tu n'a pas trop le choix

cuda est un trés gros morceaux , en Mo il est plus grand que le drivers tongue

le driver du constructeur contient l ensemble (driver + cuda ) , c'est déja bien que l on puisse l utiliser sur debian

a chaque sorti d un nouveau driver correspond un cuda.

j'espere avoir été plus clair , je vai te mettre les liens pour que tu vois les versions disponibles

ceci => VGA compatible controller: NVIDIA Corporation Device 13c2 (rev a1)  est une GTX970  , pour moi faut oublier jessie (elle n est capable de la gérer que avec le driver linux nvidia du site nvidia )
chose que j ai fait avec jessie pendant pas mal de temps avec le risque lors d une mise a jour du noyau de perdre l installation

voila le lien du driver => https://packages.qa.debian.org/n/nvidia … ivers.html

voila le lien du cuda => https://packages.qa.debian.org/n/nvidia … olkit.html

tu vois que entre stable-bpo (backports) il y a un souci de version entre driver (version 352 ) et cuda (version 6 ), en plus du noyau 4.6 . il faudrait  352 et 7.xx
pour stretch (testing ) les versions disponnibles sont correcte

le lien vers le constructeur (pour jessie seulement )  => http://www.nvidia.fr/download/driverRes … /106813/fr

la doc du constructeur nvidia => http://us.download.nvidia.com/XFree86/L … index.html

il te faudra préparer jessie , dans le cas ou tu choisi cette option

bonne chance , je t ai donné tout ce que je connais sur le sujet

nota : derniere chose , tu a un paquet nvidia-detect qui te donne la version qu il faut , sur une jessie (propre) il va te dire désolé il n existe pas de paquet pour votre materiel , la carte vidéo est trop récente pour cette version de debian

la description du paquet : => https://packages.debian.org/jessie/x11/nvidia-detect

Dernière modification par robert2a (10-09-2016 23:56:07)

Hors ligne

#20 13-09-2016 13:13:32

robert2a
Membre
Lieu : France
Distrib. : Stretch
Noyau : Linux 4.8.0-1-amd64
(G)UI : Mate 1.16.1
Inscription : 15-11-2014

Re : Installation de CUDA refusée

Bonjour
ce matin upgrade de nvidia et cuda sur stretch

cuda passe a la version 7.5.18-4 et le driver a la version 361.45.18-2
je pense qu a terme stretch sera compatible avec les cartes serie GTX1xxx (1060 , 1070 et 1080 ) , si ce n est pas déja le cas (pas effectué encore de test )

voila , je sais pas ou tu en est de ton installation de cuda  smile

pour blender ça va etre le top

@++

nota: le driver cuda passe a la version 8000
le couple driver + cuda fonctionne pour l instant avec une GTX750TI
ça te donnera peut etre envie d installer stretch wink  (en experimental j'ai vu un driver 367.xx en test dans les liens que je t ai donné )

=> https://packages.qa.debian.org/n/nvidia … ivers.html

la fin du fichier des cartes prise en charge (rien de neuf par rapport au 352.xx , correction de bug et amélioration )



361.45.18 driver (liste partielle )

GeForce 945M                          1399               E
    GeForce GTX 950M                      139A               E
    GeForce GTX 950A                      139A 17AA 362C     E
    GeForce GTX 950A                      139A 17AA 362F     E
    GeForce GTX 950A                      139A 17AA 363F     E
    GeForce GTX 950A                      139A 17AA 3640     E
    GeForce GTX 950A                      139A 17AA 3647     E
    GeForce GTX 950A                      139A 17AA 36B9     E
    GeForce GTX 960M                      139B               E
    GeForce GTX 750 Ti                    139B 1025 107A     E
    GeForce GTX 860M                      139B 1028 06A3     D
    GeForce GTX 960A                      139B 103C 2B4C     E
    GeForce GTX 750Ti                     139B 17AA 3649     E
    GeForce GTX 750 Ti                    139B 19DA C248     E
    GeForce GTX 750Ti                     139B 1AFA 8A75     E
    GeForce 940M                          139C               E
    GeForce GTX 750 Ti                    139D               E
    GeForce GTX 980                       13C0               E
    GeForce GTX 970                       13C2               E
    GeForce GTX 980M                      13D7               E
    GeForce GTX 970M                      13D8               E
    GeForce GTX 960                       13D8 1462 1198     E
    GeForce GTX 960                       13D8 1462 1199     E
    GeForce GTX 960                       13D8 19DA B282     E
    GeForce GTX 960                       13D8 19DA B284     E
    GeForce GTX 960                       13D8 19DA B286     E
    GeForce GTX 965M                      13D9               E
    GeForce GTX 980                       13DA               E
    GeForce GTX 960                       1401               F
    GeForce GTX 950                       1402               F
    GeForce GTX 960                       1406               F
    GeForce GTX 750                       1407               E
    GeForce GTX 965M                      1427               E
    GeForce GTX 950                       1427 1458 D003     F
    GeForce GTX 980M                      1617               E
    GeForce GTX 970M                      1618               E
    GeForce GTX 965M                      1619               E
    GeForce GTX 980                       161A               E
    GeForce GTX 965M                      1667               E
    GeForce 940MX                         179C               E
    GeForce GTX TITAN X                   17C2               E
    GeForce GTX 980 Ti                    17C8               E
 



le fichier se trouve dans:  /usr/share/doc/nvidia-driver/readme.txt.gz

Dernière modification par robert2a (13-09-2016 14:34:23)

Hors ligne

#21 13-09-2016 21:41:17

Neko62
Membre
Distrib. : Debian 8.5
Noyau : Linux 3.16.0-4-amd64 x86_64
(G)UI : Gnome
Inscription : 26-08-2016

Re : Installation de CUDA refusée

Bonsoir,

c'est vraiment tentant de passer à Stretch mais je viens de passer les 15 derniers jours à me faire une Jessy aux petits oignons.
Seul Cuda manque à l'appel. Mon i7-6700 fait le boulot à la place sous Blender !
Et je crains de casser tout ça en passant à Stretch !
Peut être attendre sa sortie officielle l'année prochaine ?

Config : Intel Core i7 6700, GTX970, 16 Go de DDR4, un SSD de 120 Go System, un HDD de 1 To Home, un SSD de 240 Go Jeux

Hors ligne

Pied de page des forums