Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 29-08-2016 19:06:03

nounours
Adhérent(e)
Lieu : hourtin 33
Distrib. : Jessie bureaux : mate et Handylinux basé sur Jessi
Noyau : linux 3.2.0-4-686-pae
(G)UI : mate
Inscription : 11-02-2012

hplip 3.16

Bonjour à tous.

J'ai installé une imprimante HP ENVY 4520 qui figure sur la liste de hplip version 3.16.8
La machine est une debian version 8.5 xfce dont la version hplip par défaut est 3.14.6

J'ai utilisé le tuto d'ubuntu
https://doc.ubuntu-fr.org/hplip#install … on_d_hplip

qui correspond à mon cas :
''La version dans les dépôts est trop ancienne : installez la dernière version d'HPLIP.''

Je dois dire que tout fonctionne….alors de quoi je me plains !!!!.

Je ne comprends pas pourquoi on ne trouve pas avec synaptic, les paquets hplip version 3.16.8.
- On voit que les paquets 3.14.6 sont désinstallés comme prévus.
- On remarque que lors de l'exécution du script on voit passer la commande dpkg ce qui fait penser a des paquets debian (.deb ?)
- Ou sont les paquets hplip 3.16 ?.

Merci à la personne qui voudra bien me répondre.

N'achetez pas Windaube !. Volez-le !. Au moins vous en aurez pour votre argent.

Hors ligne

#2 29-08-2016 20:12:54

stephgarg
Membre
Lieu : Périgueux
Distrib. : Debian GNU/Linux Stable (Jessie)
Noyau : Linux 3.16.0-4-amd64
(G)UI : KDE 4.14.2
Inscription : 01-01-2015

Re : hplip 3.16

Bonjour à tous.

nounours a écrit :

J'ai installé une imprimante HP ENVY 4520 qui figure sur la liste de hplip version 3.16.8
La machine est une debian version 8.5 xfce dont la version hplip par défaut est 3.14.6

Je ne comprends pas pourquoi on ne trouve pas avec synaptic, les paquets hplip version 3.16.8.



nounours : A la page d'HP Linux Imaging and Printing concernant le modèle HP Envy 4520 All-in-one Printer - j'imagine qu'il s'agit bien de ce modéle dont tu parles -, il est précisé que la version minimale d'HPLIP est 3.15.11.

Si, pour Jessie, Debian propose bien la version 3.14.6, je constate qu'à la page de recherche de paquet 'hplip' pour toutes les versions, il y a la version 3.16.5 dans les dépôts de rétroportages - en anglais, backports - pour Jessie et 3.16.7 pour Stretch (version testing) et Sid (version unstable).

A priori, les versions 3.16.5 ou 3.16.7 devraient être suffisantes pour utiliser le modèle HP Envy 4520 All-in-one Printer. smile

Si tu veux rester sous la version stable actuelle et utiliser l'imprimante précitée, la solution la plus simple est d'utiliser les dépots de rétroportages en suivant les instructions indiquées par une de deux pages suivantes :
- Debian Backports - Instructions - attention, c'est en anglais... wink
- APT : fichier sources.list - Les rétroportages (dépôt "backports")

A bientôt.


Trois PC dont un fixe Sirius, un transportable Canopus et un miniportable Arcturus. smile
Sirius : AMD Athlon 64 X2 à 3 GHz, SDRAM DDR2 800 MHz de 8 Gio, 2 WD VelociRaptor SATA2 de 1000 Go.
Canopus : Intel Core 2 Duo à 2 GHz, SDRAM DDR2 667 MHz de 4 Gio, WD Black Mobile SATA2 de 750 Go.
Arcturus : Intel Atom N270 à 1,6 Ghz, SDRAM DDR2 533 MHz de 2 Gio, Hitachi SATA2 de 160 Go.

Hors ligne

#3 29-08-2016 20:13:59

Philou92
Adhérent(e)
Lieu : Hauts de Seine
Distrib. : Debian Jessie 8.6
Noyau : Linux 3.16.0-4-amd64
(G)UI : Gnome 3.14
Inscription : 29-04-2015

Re : hplip 3.16

Hello,

Personnellement j'ai une ENVY 5640.

Installation des paquets hplip et hplip-gui jessie backports  https://packages.debian.org/jessie-backports/hplip et hop tout fonctionne. cool

Hors ligne

#4 29-08-2016 20:46:48

nounours
Adhérent(e)
Lieu : hourtin 33
Distrib. : Jessie bureaux : mate et Handylinux basé sur Jessi
Noyau : linux 3.2.0-4-686-pae
(G)UI : mate
Inscription : 11-02-2012

Re : hplip 3.16

Merci à tous pour vos réponses ultrarapides.

Comme je disais plus haut, tout fonctionne en utilisant le scrpt de hplip, je n'ai pas tout compris mais ça marche. Qu'est ce que je risque de tout laisser tel quel ?.
@Philou92
Dans mes sources.list, j'ai bien :

# jessie-backports, previously on backports.debian.org
deb http://ftp.fr.debian.org/debian/ jessie-backports main contrib non-free

Quelle aurait été la commande pour installer hplip a partir des bakport ?.

 apt-get -t jessie-backports <hplip ????>

Dernière modification par nounours (29-08-2016 20:47:41)


N'achetez pas Windaube !. Volez-le !. Au moins vous en aurez pour votre argent.

Hors ligne

#5 29-08-2016 21:11:28

Philou92
Adhérent(e)
Lieu : Hauts de Seine
Distrib. : Debian Jessie 8.6
Noyau : Linux 3.16.0-4-amd64
(G)UI : Gnome 3.14
Inscription : 29-04-2015

Re : hplip 3.16

C'est bon pour le "source.list"

Pour installer le paquet :

apt-get -t jessie-backports install hplip



où mieux en installant l'utilitaire graphique en même temps :

apt-get -t jessie-backports install hplip hplip-gui

Dernière modification par Philou92 (29-08-2016 21:13:55)

Hors ligne

#6 29-08-2016 21:31:04

nounours
Adhérent(e)
Lieu : hourtin 33
Distrib. : Jessie bureaux : mate et Handylinux basé sur Jessi
Noyau : linux 3.2.0-4-686-pae
(G)UI : mate
Inscription : 11-02-2012

Re : hplip 3.16

Merci à tous.
je prends note pour la prochaine fois.

N'achetez pas Windaube !. Volez-le !. Au moins vous en aurez pour votre argent.

Hors ligne

#7 29-08-2016 21:32:08

èfpé
Membre
Distrib. : Debian
Noyau : Linux
Inscription : 10-07-2016

Re : hplip 3.16

Bonsoir,

nounours a écrit :

Comme je disais plus haut, tout fonctionne en utilisant le script de hplip, je n'ai pas tout compris mais ça marche. Qu'est-ce que je risque de tout laisser tel quel ?


Tout ce que tu risques est de ne pas bénéficier 'automatiquement' des éventuelles mises à jour (de sécurité notamment). Contrairement à Synaptic, Dpkg ne va pas chercher les paquets dans les dépôts. En l'occurrence, tu as exécuté un installeur automatique (à la Windows) dans le même style que celui directement fourni par NVIDIA pour ses pilotes propriétaires. Note que le projet HPLIP documente la procédure de désinstallation, si tu veux savoir où sont les binaires et autres fichiers de configuration...

Hors ligne

#8 29-08-2016 22:12:00

nounours
Adhérent(e)
Lieu : hourtin 33
Distrib. : Jessie bureaux : mate et Handylinux basé sur Jessi
Noyau : linux 3.2.0-4-686-pae
(G)UI : mate
Inscription : 11-02-2012

Re : hplip 3.16

@èfpé
Merci.
La prochaine, j'installerai un imprimante hp en utilisant les backports (quand c'est possible) ; au moins de cette façon on comprend ce que l'on fait.

N'achetez pas Windaube !. Volez-le !. Au moins vous en aurez pour votre argent.

Hors ligne

#9 29-08-2016 23:00:10

Philou92
Adhérent(e)
Lieu : Hauts de Seine
Distrib. : Debian Jessie 8.6
Noyau : Linux 3.16.0-4-amd64
(G)UI : Gnome 3.14
Inscription : 29-04-2015

Re : hplip 3.16

èfpé a écrit :

Tout ce que tu risques est de ne pas bénéficier 'automatiquement' des éventuelles mises à jour (de sécurité notamment).



èfpé a raison et c'est déjà un problème sérieux pour ton système qui risque de devenir instable. Tu devrais jeter un coup d'oeil au log de dpkg pour voir ce que l'utilitaire d'installation à installé sur ton système :

cat /var/log/dpkg.log
 



Personnellement j'envisagerai de faire machine arrière (désinstallation des paquets exotiques) et d'installer proprement les paquets hplip via le dépôt "jessie-backports".

Hors ligne

#10 30-08-2016 06:58:41

nounours
Adhérent(e)
Lieu : hourtin 33
Distrib. : Jessie bureaux : mate et Handylinux basé sur Jessi
Noyau : linux 3.2.0-4-686-pae
(G)UI : mate
Inscription : 11-02-2012

Re : hplip 3.16

@Philou92
Merci
Désolé, j'ai rendu la machine à Mme Michu.

N'achetez pas Windaube !. Volez-le !. Au moins vous en aurez pour votre argent.

Hors ligne

#11 29-10-2016 03:33:05

Nidza
Membre
Inscription : 29-10-2016

Re : hplip 3.16

Philou92, merci infiniment !

Dernière modification par Nidza (29-10-2016 03:33:58)

Hors ligne

#12 29-10-2016 23:04:00

Philou92
Adhérent(e)
Lieu : Hauts de Seine
Distrib. : Debian Jessie 8.6
Noyau : Linux 3.16.0-4-amd64
(G)UI : Gnome 3.14
Inscription : 29-04-2015

Re : hplip 3.16

Hello Nidza,

Super. smile

Mais alors pour nounours...

Voir le tuto : C'est résolu ! Bravo mais il faut l'indiquer dans l'titre

Double résolution = 2 points choco ?? wiscot.png question.gif

Hors ligne

Pied de page des forums