Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 21-09-2016 02:15:56

Antidentity
Membre
Distrib. : Debian Jessie
Noyau : Linux 3.16.0-4 amd64
(G)UI : Openbox
Inscription : 03-08-2016

Crachottement lorsque pas de son en écoute

Bonsoir,

J'ai un léger problème de crachottement de son avec un ordinateur Dell Inspiron 3551 Intel(R) Celeron(R) CPU N2840 avec une debian jessie + openbox + alsa + pulseaudio + pavucontrol 2.0-3 + pnmixer 0.5.1 . Le crachottement a lieu quand aucun son n'est diffusé. Par contre, quand je mets le son en sourdine, le grésillement disparaît.

lshw


*-multimedia
             description: Audio device
             produit: Atom Processor Z36xxx/Z37xxx Series High Definition Audio Controller
             fabriquant: Intel Corporation
             identifiant matériel: 1b
             information bus: pci@0000:00:1b.0
             version: 0e
             bits: 64 bits
             horloge: 33MHz
             fonctionnalités: bus_master cap_list
             configuration: driver=snd_hda_intel latency=0



Quelqu'un aurait-il une solution? Merci d'avance

Dernière modification par Antidentity (21-09-2016 02:23:21)

Hors ligne

#2 21-09-2016 12:35:57

otyugh
Membre
Lieu : Quimperlé/Arzano
Distrib. : Debian Stable
Inscription : 20-09-2016

Re : Crachottement lorsque pas de son en écoute

##C'est pas forcément la faute de l'ordi si c'est des enceintes avec un ampli de mauvaise qualité.

La solution la plus simple est probablement de vérifier que tu n'a pas le son principal à 10% et l'amplification du son logiciel à 120% (se vérifie donc dans pulseaudio : il y a le son de la "sortie" physique, et le son du logiciel ; si l'un d'eux est à fond, c'est souvent source de bruits).

Après il y a une fonction "anti bruit" dans pulseaudio dans "/etc/pulse/default.pa" ; vérifier la présence de "load-module module-echo-cancel" ; si il y est déjà, beh, zut ; le tuyau vient de archlinux tongue
Si y avait pas avant, l'ajouter, et relancer pulseaudio ; "pulseaudio -k", "pulseaudio --start".

Après, certains ordinateurs ont vraiment des cartes son pourries, ça peut valoir le coup de tout laisser "au milieu" (en son) sur l'ordi, quitte à amplifier le son avec des baffles en externe. Voir encore mieux, y a du matériel aujourd'hui avec leur propres cartes son, branchable en USB, c'est vraiment pas mal sur les vieux systèmes (aujourd'hui cependant les cartes mères ont tendance à embarquer des cartes son de qualité décente, je trouve).

Dernière modification par otyugh (21-09-2016 12:39:15)

Hors ligne

#3 21-09-2016 13:06:22

Antidentity
Membre
Distrib. : Debian Jessie
Noyau : Linux 3.16.0-4 amd64
(G)UI : Openbox
Inscription : 03-08-2016

Re : Crachottement lorsque pas de son en écoute

Merci de ta proposition malheureusement cela n'a pas fonctionné. Je n'avais pas la présence de la ligne "load-module module-echo-cancel" dans le fichier default.pa. Je l'ai donc rajouté en début de fichier. J'ai arrêté le service pulseaudio avec pulseaudio -k et il m'a ensuite tout de suite proposé de relancer alsa. Le pulseaudio --start m'a indiqué une erreur  comme quoi il ne savait pas lancer pulseaudio et j'ai donc redémarré l'ordinateur pour forcer le lancement de pulseaudio. Mais une fois redémarré, j'avais toujours le crachottement et en allant sur contrôle du volume, il était indiqué que pulseaudio ne s'était pas lancé et allait se relancer dans x secondes. J'ai donc supprimé la ligne du fichier default.pa (peut-être l'avais-je placé à un mauvais endroit?) et redémarré l'ordi.

L'ordinateur est assez récent et avait été acheté avec Ubuntu préinstallé qui n'avait pas ce souci de crachottement. Ce qui me fait dire qu'il s'agit d'un problème de configuration logiciel.

Hors ligne

#4 21-09-2016 13:10:21

otyugh
Membre
Lieu : Quimperlé/Arzano
Distrib. : Debian Stable
Inscription : 20-09-2016

Re : Crachottement lorsque pas de son en écoute

Il y a quelques appplications connues pour déconner avec pulseaudio. (notamment Skype) - avoir le moins d'apps lancées à la fois peut aider à cerner le problème

>Tu as vérifié ce que je disais au début sur les niveaux de volume dans pulseaudio ?


N'ayant jamais eu ce genre de souçi je tourne un peu à l'aveuglette, désolé ; comme tout problème pour le cerner, il faut diminuer le nombre de facteurs : idéalement il faudrait just avoir une souris et un clavier de brancher, avec aucune application lancée, et voir si le problème persiste. Puis tuer pulseaudio ; voir si le problème persiste. Ça permettrai de s'assurer que ça ne vienne pas d'une interférence d'une app ou d'une périphérique, et aussi de savoir si ça vient vraiment de pulsaudio.

Si on est certain que c'est pulseaudio et rien d'autre, bon, on a déjà une indication pour creuser ; mais avant ça on est pas sûr.

Dernière modification par otyugh (21-09-2016 13:16:36)

Hors ligne

#5 21-09-2016 13:16:01

smolski
administrateur quasi...modo
Lieu : AIN
Distrib. : 8 (jessie) 64 bits + backports
Noyau : 4.6.0-0.bpo.1-amd64
(G)UI : gnome 3.14.1
Inscription : 21-10-2008

Re : Crachottement lorsque pas de son en écoute

Le crachotement... un câble mal fichu ou mal connecté ? ... scratchhead.gif

"Définition d'eric besson : S'il fallait en chier des tonnes pour devenir ministre, il aurait 2 trous du cul." - JP Douillon
"L'utopie ne signifie pas l'irréalisable, mais l'irréalisée." - T Monod (source :  La zone de Siné)
"Je peux rire de tout mais pas avec n'importe qui." - P Desproges
"saque eud dun" (patois chtimi : fonce dedans)

Hors ligne

#6 21-09-2016 13:18:26

otyugh
Membre
Lieu : Quimperlé/Arzano
Distrib. : Debian Stable
Inscription : 20-09-2016

Re : Crachottement lorsque pas de son en écoute

Ha et justement ! Le moyen le plus simple de vérifier si le problème n'est pas juste physique : boot sur un liveCD/USB Ubuntu ou quoique ce soit, et vois si ça le fait.

Dernière modification par otyugh (21-09-2016 13:18:49)

Hors ligne

#7 21-09-2016 13:25:51

Antidentity
Membre
Distrib. : Debian Jessie
Noyau : Linux 3.16.0-4 amd64
(G)UI : Openbox
Inscription : 03-08-2016

Re : Crachottement lorsque pas de son en écoute

Oui pardon, j'ai oublié de répondre par rapport aux niveaux de volume. Apparemment, ils sont corrects. Sous pulseaudio, je suis en-dessous des 100% et via alsamixer sous le terminal, pour le master idem (normal) et le speaker et pcm sont automatiquement à 100.

J'avais également le problème quand pulseaudio n'était pas lancé. Le souci c'est qu'il ne le fait pas tout le temps. C'est plutôt aléatoire.

Hors ligne

#8 21-09-2016 13:29:03

otyugh
Membre
Lieu : Quimperlé/Arzano
Distrib. : Debian Stable
Inscription : 20-09-2016

Re : Crachottement lorsque pas de son en écoute

Je connais un problème similaire pour le RaspberryPi où son design fait qu'en cas de charge CPU ou de forte entrées/sorties, y a du bruit immonde, qui s’entend particulièrement quand y a pas de son - j'espère que c'est pas juste ça tongue

Démarrer sur un système live est une bonne solution pour être sûr que le problème est bien logiciel, c'est vrai qu'à tout les coups, c'est juste matériel.

Hors ligne

#9 21-09-2016 13:31:56

bendia
Admin stagiaire
Distrib. : Jessie
Noyau : 3.16.0-4-amd64
(G)UI : Gnome + XFCE + Console
Inscription : 20-03-2012
Site Web

Re : Crachottement lorsque pas de son en écoute

Salut smile

Ca pourrait être matériel, genre défaut de masse. Ce qui doit être branché avec une terre l'est bien d'un point de vue électrique (genre l'alim du PC ou la multiprise éventuelle) ?

Ben
___________________
La seule question bête, c'est celle qu'on ne pose pas.
file-Re06858991f6f328b4907296ac5cea283

Hors ligne

#10 21-09-2016 13:39:35

Antidentity
Membre
Distrib. : Debian Jessie
Noyau : Linux 3.16.0-4 amd64
(G)UI : Openbox
Inscription : 03-08-2016

Re : Crachottement lorsque pas de son en écoute

smolski a écrit :

Le crachotement... un câble mal fichu ou mal connecté ? ... https://debian-facile.org/img/smilies/x … chhead.gif



J'ai l'impression que ce n'est pas un problème de câble comme il ne le faisait pas sous ubuntu. Mais tu me mets un doute vu que j'avais remplacé le hdd par un sdd. J'ai peut-être été contre un des câbles en ouvrant le boitier, j'espère que non...! scratchhead.gif En tout cas, c'est lié aux baffles interne puisque si je mets des écouteurs ou des baffles connectés via la prise jack, ça ne le fait pas.


otyugh a écrit :

Ha et justement ! Le moyen le plus simple de vérifier si le problème n'est pas juste physique : boot sur un liveCD/USB Ubuntu ou quoique ce soit, et vois si ça le fait.


C'est une bonne idée, je vais essayer ça! Je crois que j'ai encore ma liveUSB de la dernière ubuntu en plus.


bendia a écrit :


Ca pourrait être matériel, genre défaut de masse. Ce qui doit être branché avec une terre l'est bien d'un point de vue électrique (genre l'alim du PC ou la multiprise éventuelle) ?


Ca aurait pu être une possibilité vu que l'adaptateur fait pas un peu de bruit (lors de l'utilisation du CPU) mais les baffles le font aussi quand l'ordi n'est que sur batterie.

Hors ligne

Pied de page des forums