Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 27-09-2016 13:36:15

Philanthrope
Membre
Lieu : Quelques part chez les Ch'tis
Distrib. : Xubuntu 16.04.2 LTS / Debian 8 Jessy
Noyau : Linux 4.4.0-31-generic / Linux 3.16.0-4-amd64
(G)UI : xfce / xfce
Inscription : 26-05-2016

[Résolu] VLC Rien que le son sur les vidéos video/x-msvideo

Bonjour à tous, bonjour à toutes

Depuis quelques temps, je ne sais pas pourquoi, mais je ne peux plus visionner avec VLC les vidéos en avi avec le codec XVID en vidéo et mp3 en audio
La partie audio fonctionne parfaitement mais je reste avec la première image avec la vidéo

J'ai déjà essayé de supprimer les dossiers VLC de .cache, .config et .local
Essayé de supprimer complètement tout ce qui se rapporte à VLC (sudo apt-get purge, supprission des dossiers VLC y compris dans /usr/share etc... et supprimer les différents autres éléments de VLC avec sinaptic en plus des purges) mais rien n'y fait.
Les fichiers en .ts. .mkv, .mp4 fonctionnent parfaitement

J'ai ce problème depuis peu car au début, ces vidéos fonctionnaient normalement avec Xubuntu (comme il fonctionnait sous ubuntu 14-04)
afin d'éviter d'utiliser la méthode bourrin, y-a-t-il quelqu'un qui aurait une idée ?
Je pense que ce problème est arrivé lorsque j'ai changé le pilote de ma carte graphique, j'ai voulu essayé de remettre le pilote mais sans résultat (je veux dire que cela n'a pas réglé le problème)

Est-ce qu'une personne a une idée ?

Ce qui est drôle c'est sous Xubuntu 16-04.1 que j'ai également dans une machine virtuelle, j'arrive sans problème à lire ces vidéos

Je ne sais pas quoi faire

Quelqu'un aurait-il une idée ?

Dernière modification par Philanthrope (01-10-2016 23:03:35)


La présent est un passé en évolution

Hors ligne

#2 27-09-2016 14:00:24

chalu
Adhérent(e)
Lieu : Anjou
Distrib. : Debian Jessie (saveur Handylinux 2.5) à jour
Noyau : Linux 3.16.0-4-amd64
(G)UI : XFCE xfwm4
Inscription : 11-03-2016

Re : [Résolu] VLC Rien que le son sur les vidéos video/x-msvideo

Bonjour smile
Sur la machine virtuelle est-ce que c'est la même version de xubuntu et VLC ?
Je n'ai pas compris si la machine virtuel était installé sur le xubuntu qui ne veut plus lire les fichiers ?
Si oui, tu as désinstallé des codecs ? Peut être les comparer.

Dernière modification par chalu (27-09-2016 15:41:58)


Bien débuter sur Debian :
->Les cahiers du débutant
->Le projet DFlinux (DebianFacileLinux) deux images ISOs (i386 et amd64) basées sur Debian stable et agrémentées d'outils facilitants pour les débutants

Hors ligne

#3 27-09-2016 16:10:15

Philanthrope
Membre
Lieu : Quelques part chez les Ch'tis
Distrib. : Xubuntu 16.04.2 LTS / Debian 8 Jessy
Noyau : Linux 4.4.0-31-generic / Linux 3.16.0-4-amd64
(G)UI : xfce / xfce
Inscription : 26-05-2016

Re : [Résolu] VLC Rien que le son sur les vidéos video/x-msvideo

Oui, j'ai la dernière version de xubuntu, c'est à dire la 16-04-1

Je ne sais pas comment voir les codecs, est-ce que tu parles des greffons ?

J'ai comparé avec synaptic, tout ce qui est sur xubuntu (VM) l'est avec xubuntu (Hote)

ce qui est un peu étrange c'est que apparemment certaines vidéos video/x-msvideo passe bien
j'ai remarqué que ce qui passe bien sont ceux où, sur la partie vidéo il y a

Video
ID                                       : 0
Format                                   : MPEG-4 Visual
Format profile                           : Advanced Simple@L5



par contre ceci pose problème

ID                                       : 0
Format                                   : MPEG-4 Visual
Format profile                           : Simple@L3
Format settings, BVOP                    : No


ne sachant pas ce que c'est exactement je ne sais pas si cela à un rapport


La présent est un passé en évolution

Hors ligne

#4 27-09-2016 19:51:35

chalu
Adhérent(e)
Lieu : Anjou
Distrib. : Debian Jessie (saveur Handylinux 2.5) à jour
Noyau : Linux 3.16.0-4-amd64
(G)UI : XFCE xfwm4
Inscription : 11-03-2016

Re : [Résolu] VLC Rien que le son sur les vidéos video/x-msvideo

Si une même vidéo peut se lire sur xubuntu (VM) mais pas sur la même xubuntu (hôte) et que tu as vérifié que tu avais les même paquets installés sur l'hôte et la VM alors regarde du côté des réglages de VLC mais là j'avoue que je ne comprends pas bien.

Bien débuter sur Debian :
->Les cahiers du débutant
->Le projet DFlinux (DebianFacileLinux) deux images ISOs (i386 et amd64) basées sur Debian stable et agrémentées d'outils facilitants pour les débutants

Hors ligne

#5 27-09-2016 20:20:51

Philanthrope
Membre
Lieu : Quelques part chez les Ch'tis
Distrib. : Xubuntu 16.04.2 LTS / Debian 8 Jessy
Noyau : Linux 4.4.0-31-generic / Linux 3.16.0-4-amd64
(G)UI : xfce / xfce
Inscription : 26-05-2016

Re : [Résolu] VLC Rien que le son sur les vidéos video/x-msvideo

@chalu
Je suis moi-même étonné de cette situation et j'essaie d'en comprendre les causes

La présent est un passé en évolution

Hors ligne

#6 27-09-2016 20:35:35

chalu
Adhérent(e)
Lieu : Anjou
Distrib. : Debian Jessie (saveur Handylinux 2.5) à jour
Noyau : Linux 3.16.0-4-amd64
(G)UI : XFCE xfwm4
Inscription : 11-03-2016

Re : [Résolu] VLC Rien que le son sur les vidéos video/x-msvideo

As-tu essayé de lancé VLC avec un terminal pour récupérer une éventuelle erreur ?

Tu ouvres avec un clic droit un terminal dans le dossier de ta video et

vlc nom_de_la_video.extension_de_la_video


En comparant entre VM et hôte peut-être que ça te donnera des idées, ça et la comparaison des réglages ....

Dernière modification par chalu (27-09-2016 20:35:56)


Bien débuter sur Debian :
->Les cahiers du débutant
->Le projet DFlinux (DebianFacileLinux) deux images ISOs (i386 et amd64) basées sur Debian stable et agrémentées d'outils facilitants pour les débutants

Hors ligne

#7 29-09-2016 11:22:56

Philanthrope
Membre
Lieu : Quelques part chez les Ch'tis
Distrib. : Xubuntu 16.04.2 LTS / Debian 8 Jessy
Noyau : Linux 4.4.0-31-generic / Linux 3.16.0-4-amd64
(G)UI : xfce / xfce
Inscription : 26-05-2016

Re : [Résolu] VLC Rien que le son sur les vidéos video/x-msvideo

A dire vrai j'ai déjà essayé ce système et  je n'ai pas d'erreur mais je vais retenter pour voir la comparaison (Hote / VM)

Machine Hôte :

cd "/media/Disque_sdc1/Captvty/Directs/avi"


vlc "Sauveur Giordano (Chérie 25)_2016_09_25_20_26_82.avi"


VLC media player 2.2.2 Weatherwax (revision 2.2.2-0-g6259d80)
[00000000022a5b78] skins2 interface: skin: Unnamed Theme  author: Shambuku
[00000000022a5b78] skins2 interface error: pls, check bitmap sizes for id: PlayerMute
[00000000022a5b78] skins2 interface error: pls, check bitmap sizes for id: PlayerMute
[00000000022a5b78] skins2 interface error: video: resize policy and autoresize are not compatible
[00007f1d24c044c8] avcodec decoder: Using NVIDIA VDPAU Driver Shared Library  361.42  Tue Mar 22 17:29:16 PDT 2016 for hardware decoding.



Machine Virtuelle :

cd /media/sf_Captvty/Directs/avi


vlc "Sauveur Giordano (Chérie 25)_2016_09_25_20_26_82.avi"


VLC media player 2.2.2 Weatherwax (revision 2.2.2-0-g6259d80)
[0000000000f8d148] core libvlc: Lancement de vlc avec l'interface par défaut. Utilisez « cvlc » pour démarrer VLC sans interface.
Failed to open VDPAU backend libvdpau_nvidia.so: Ne peut ouvrir le fichier d'objet partagé: Aucun fichier ou dossier de ce type
Failed to open VDPAU backend libvdpau_nvidia.so: Ne peut ouvrir le fichier d'objet partagé: Aucun fichier ou dossier de ce type
[00000000010c0db8] xcb_xv vout display error: no available XVideo adaptor



Merci pour ton aide

Edit à toto :
Séparé les commandes entre elles.

Dernière modification par Philanthrope (29-09-2016 11:23:16)


La présent est un passé en évolution

Hors ligne

#8 29-09-2016 12:01:04

chalu
Adhérent(e)
Lieu : Anjou
Distrib. : Debian Jessie (saveur Handylinux 2.5) à jour
Noyau : Linux 3.16.0-4-amd64
(G)UI : XFCE xfwm4
Inscription : 11-03-2016

Re : [Résolu] VLC Rien que le son sur les vidéos video/x-msvideo

Tu as essayé de réinitialiser toutes les préférences de VLC dans outils/préférences ?
Mettre le décodage matériel sur désactiver pour voir ?
Je n'ai pas vraiment l'impression d'aider, ça m'échappe complètement ton souci.

Bien débuter sur Debian :
->Les cahiers du débutant
->Le projet DFlinux (DebianFacileLinux) deux images ISOs (i386 et amd64) basées sur Debian stable et agrémentées d'outils facilitants pour les débutants

Hors ligne

#9 29-09-2016 12:39:55

bendia
Admin stagiaire
Distrib. : Jessie
Noyau : 3.16.0-4-amd64
(G)UI : Gnome + XFCE + Console
Inscription : 20-03-2012
Site Web

Re : [Résolu] VLC Rien que le son sur les vidéos video/x-msvideo

Salut smile

J'ai pas la solution, mais l'erreur semble bien provenir d'une histoore de pillote. J'ai pas tout compris à ton installation (qui est en dur, qui est en virtuel), mais je dirais que là, ça fonctionne

00007f1d24c044c8] avcodec decoder: Using NVIDIA VDPAU Driver Shared Library  361.42  Tue Mar 22 17:29:16 PDT 2016 for hardware decoding.


Et là non

Failed to open VDPAU backend libvdpau_nvidia.so: Ne peut ouvrir le fichier d'objet partagé: Aucun fichier ou dossier de ce type



J'ai donc l'impression que c'est OK sur la machine hôte, en passant effectivement par le décodage matérielle comme dit chalu, et qu'en virtuel, le système essaye d'utiliser aussi le décodage matériel, mais sans y parvenir. Il s'agit peut-être de réglages dans virtualbox, si c'est ça que tu utilises, genre accélération 3D, ou bonne installation/mise à jour des addons invités ?


Ben
___________________
La seule question bête, c'est celle qu'on ne pose pas.
file-Re06858991f6f328b4907296ac5cea283

Hors ligne

#10 29-09-2016 13:32:10

chalu
Adhérent(e)
Lieu : Anjou
Distrib. : Debian Jessie (saveur Handylinux 2.5) à jour
Noyau : Linux 3.16.0-4-amd64
(G)UI : XFCE xfwm4
Inscription : 11-03-2016

Re : [Résolu] VLC Rien que le son sur les vidéos video/x-msvideo

en fait j'avais compris le contraire et ce que je voulais lui dire, c'est de ne pas utiliser le décodage matériel VDPAU Driver sur la machine hote pour que ça fasse comme dans la machine virtuelle car c'est sur la machine virtuelle que la vidéo se lit correctement avec VLC et non sur l'hôte d'après son premier message.

Dernière modification par chalu (29-09-2016 13:38:21)


Bien débuter sur Debian :
->Les cahiers du débutant
->Le projet DFlinux (DebianFacileLinux) deux images ISOs (i386 et amd64) basées sur Debian stable et agrémentées d'outils facilitants pour les débutants

Hors ligne

#11 29-09-2016 13:37:21

Philanthrope
Membre
Lieu : Quelques part chez les Ch'tis
Distrib. : Xubuntu 16.04.2 LTS / Debian 8 Jessy
Noyau : Linux 4.4.0-31-generic / Linux 3.16.0-4-amd64
(G)UI : xfce / xfce
Inscription : 26-05-2016

Re : [Résolu] VLC Rien que le son sur les vidéos video/x-msvideo

Bonjour bendia et merci d'essayé de m'aider

Perdu, c'est l'inverse wink
sur la machine virtuel sa fonctionne à merveille mais pas sur le système Hôte

@chalu
et bien @chalu, je ne sais pas si c'est un coup de pot mais le fait de désactiver le décodage matériel ça fonctionne à nouveau
IL doit y avoir un souci quelque part, il faut dire c'est arrivé une foi que j'ai changé le pilote de ma carte graphique afin de ne plus avoir de reboot aléatoire

En tous les cas mon problème est résolu, ton impression de ne pas m'aider était fausse smile

Merci à tous les deux

La présent est un passé en évolution

Hors ligne

#12 29-09-2016 13:41:03

chalu
Adhérent(e)
Lieu : Anjou
Distrib. : Debian Jessie (saveur Handylinux 2.5) à jour
Noyau : Linux 3.16.0-4-amd64
(G)UI : XFCE xfwm4
Inscription : 11-03-2016

Re : [Résolu] VLC Rien que le son sur les vidéos video/x-msvideo

yes.gif big_smile
On trouve d'autres fils sur le net où ce VDPAU pose souci et du coup en le désactivant ça marche.
C'était réglé sur automatique avant ou sur VDPAU ?

Bien débuter sur Debian :
->Les cahiers du débutant
->Le projet DFlinux (DebianFacileLinux) deux images ISOs (i386 et amd64) basées sur Debian stable et agrémentées d'outils facilitants pour les débutants

Hors ligne

#13 29-09-2016 13:42:29

bendia
Admin stagiaire
Distrib. : Jessie
Noyau : 3.16.0-4-amd64
(G)UI : Gnome + XFCE + Console
Inscription : 20-03-2012
Site Web

Re : [Résolu] VLC Rien que le son sur les vidéos video/x-msvideo

Philanthrope a écrit :

sur la machine virtuel sa fonctionne à merveille mais pas sur le système Hôte

t'es certain de ne pas avoir inverser le retour des commandes sur le fofo ?


Ben
___________________
La seule question bête, c'est celle qu'on ne pose pas.
file-Re06858991f6f328b4907296ac5cea283

Hors ligne

#14 29-09-2016 13:59:38

chalu
Adhérent(e)
Lieu : Anjou
Distrib. : Debian Jessie (saveur Handylinux 2.5) à jour
Noyau : Linux 3.16.0-4-amd64
(G)UI : XFCE xfwm4
Inscription : 11-03-2016

Re : [Résolu] VLC Rien que le son sur les vidéos video/x-msvideo

Non je ne crois pas qu'il ait inversé, regarde chez moi (en réel sur mon PC avec HL non-free et une carte ATI Mobility radeon HD 5470)

 chalu@handylinux ~/Vidéos
 $ vlc essai.mp4
 


VLC media player 2.2.4 Weatherwax (revision 2.2.3-37-g888b7e89)
[0000000001a1b118] core libvlc: Lancement de vlc avec l'interface par défaut. Utilisez « cvlc » pour démarrer VLC sans interface.
Failed to open VDPAU backend libvdpau_r600.so: Ne peut ouvrir le fichier d'objet partagé: Aucun fichier ou dossier de ce type
Failed to open VDPAU backend libvdpau_r600.so: Ne peut ouvrir le fichier d'objet partagé: Aucun fichier ou dossier de ce type


Et VLC se lance et lit la vidéo smile
Mon réglage pour VLC est en automatique (ça doit être celui par défaut, j'ai touché à rien) dans Outils/Préférences/Codecs --> décodage matériel
Le problème vient si on force l'utilisation de VDPAU par contre ça ne le fait peut-être pas avec toutes les cartes graphiques

Dernière modification par chalu (29-09-2016 14:02:25)


Bien débuter sur Debian :
->Les cahiers du débutant
->Le projet DFlinux (DebianFacileLinux) deux images ISOs (i386 et amd64) basées sur Debian stable et agrémentées d'outils facilitants pour les débutants

Hors ligne

#15 29-09-2016 14:06:18

Philanthrope
Membre
Lieu : Quelques part chez les Ch'tis
Distrib. : Xubuntu 16.04.2 LTS / Debian 8 Jessy
Noyau : Linux 4.4.0-31-generic / Linux 3.16.0-4-amd64
(G)UI : xfce / xfce
Inscription : 26-05-2016

Re : [Résolu] VLC Rien que le son sur les vidéos video/x-msvideo

@Chalu,
Étant donné que je ne me souviens pas l'avoir touché je pense que c'était en automatique
je viens d'allez voir sur la VM, il fonctionne en automatique
donc "Désactiver" en Hôte  et "Automatique" en VM
Bizarre cette affaire

@bendia
Oui, oui, c'est sûr

Excuse moi de ne pas respecter les règles concernant les code mais il m'est impossible de te le montrer autrement

:~$ cd /media/sf_Captvty/Directs/avi
:/media/sf_Captvty/Directs/avi$ vlc "Sauveur Giordano (Chérie 25)_2016_09_25_20_26_82.avi"
VLC media player 2.2.2 Weatherwax (revision 2.2.2-0-g6259d80)
[0000000001fe8148] core libvlc: Lancement de vlc avec l'interface par défaut. Utilisez « cvlc » pour démarrer VLC sans interface.
Failed to open VDPAU backend libvdpau_nvidia.so: Ne peut ouvrir le fichier d'objet partagé: Aucun fichier ou dossier de ce type
Failed to open VDPAU backend libvdpau_nvidia.so: Ne peut ouvrir le fichier d'objet partagé: Aucun fichier ou dossier de ce type
[00000000020d6de8] xcb_xv vout display error: no available XVideo adaptor
QObject::~QObject: Timers cannot be stopped from another thread
:/media/sf_Captvty/Directs/avi$


les dossiers du type "sf_Captvty" viennent de Virtualbox, le dossier vrai nom du dossier c'est "Captvty"


La présent est un passé en évolution

Hors ligne

#16 29-09-2016 14:09:27

bendia
Admin stagiaire
Distrib. : Jessie
Noyau : 3.16.0-4-amd64
(G)UI : Gnome + XFCE + Console
Inscription : 20-03-2012
Site Web

Re : [Résolu] VLC Rien que le son sur les vidéos video/x-msvideo

OK smile

Ca parraît étrange de voir une erreur alors que non, et l'inverse. La réponse est là https://trac.videolan.org/vlc/ticket/16741 (in english, sorry) wink

Ben
___________________
La seule question bête, c'est celle qu'on ne pose pas.
file-Re06858991f6f328b4907296ac5cea283

Hors ligne

#17 29-09-2016 14:28:18

Philanthrope
Membre
Lieu : Quelques part chez les Ch'tis
Distrib. : Xubuntu 16.04.2 LTS / Debian 8 Jessy
Noyau : Linux 4.4.0-31-generic / Linux 3.16.0-4-amd64
(G)UI : xfce / xfce
Inscription : 26-05-2016

Re : [Résolu] VLC Rien que le son sur les vidéos video/x-msvideo

Parlant anglais comme une vache espagnole, je n'ai rien  compris
Désolé big_smile

La présent est un passé en évolution

Hors ligne

#18 29-09-2016 14:33:48

bendia
Admin stagiaire
Distrib. : Jessie
Noyau : 3.16.0-4-amd64
(G)UI : Gnome + XFCE + Console
Inscription : 20-03-2012
Site Web

Re : [Résolu] VLC Rien que le son sur les vidéos video/x-msvideo

En fait, le Failed n'indique pas une erreur, mais juste que VLC a essayé d'ouvrir le backend VDPAU et n'a pas réussi wink

Ben
___________________
La seule question bête, c'est celle qu'on ne pose pas.
file-Re06858991f6f328b4907296ac5cea283

Hors ligne

#19 29-09-2016 14:36:47

chalu
Adhérent(e)
Lieu : Anjou
Distrib. : Debian Jessie (saveur Handylinux 2.5) à jour
Noyau : Linux 3.16.0-4-amd64
(G)UI : XFCE xfwm4
Inscription : 11-03-2016

Re : [Résolu] VLC Rien que le son sur les vidéos video/x-msvideo

Et le paradoxe c'est que lorsque VLC arrive à ouvrir le backend VDPAU, il peut planter mais pas de message d'erreur
En fait c'est le VDPAU qui doit planter dans certains cas, pas réussir à décoder.

Bien débuter sur Debian :
->Les cahiers du débutant
->Le projet DFlinux (DebianFacileLinux) deux images ISOs (i386 et amd64) basées sur Debian stable et agrémentées d'outils facilitants pour les débutants

Hors ligne

Pied de page des forums