Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 29-09-2016 15:19:50

Hub49
Membre
Distrib. : Debian 8 Jessie Mate desktop
Noyau : linux 3.2-0-4-realtime-686-pae
(G)UI : MATE 1.81
Inscription : 11-02-2016

installation asterisk impossible

Bonjour à toutes et tous,
Je souhaiterais installer asterisk. Dans le terminal, j'a ieu ce message d'erreur:

 asterisk
 asterisk-voicemail
N: « ring-nightly-man.listsudo » dans le répertoire « /etc/apt/sources.list.d/ » a été ignoré car il utilise une extension non valable
N: « ring-nightly-man.listsudo » dans le répertoire « /etc/apt/sources.list.d/ » a été ignoré car il utilise une extension non valable
E: Sub-process /usr/bin/dpkg returned an error code (1)
 



Comment résoudre ce problème? je ne vois pas de quelle extension il s'agit.

Hors ligne

#2 29-09-2016 15:37:32

otyugh
Membre
Lieu : Quimperlé/Arzano
Distrib. : Debian Stable
Inscription : 20-09-2016

Re : installation asterisk impossible

Que donne "cat /etc/apt/sources.list.d/ring-nightly-man.listsudo" ?
Et qu'à tu fait pour "installer" asterisk ?

Dernière modification par otyugh (29-09-2016 15:38:06)

Hors ligne

#3 29-09-2016 15:53:06

Hub49
Membre
Distrib. : Debian 8 Jessie Mate desktop
Noyau : linux 3.2-0-4-realtime-686-pae
(G)UI : MATE 1.81
Inscription : 11-02-2016

Re : installation asterisk impossible

Salut,
Le fichier donne ça:

deb https://dl.ring.cx/ring-nightly/debian_8/ ring main


J'ai voulu installer asterisk via synaptic

Dernière modification par Hub49 (29-09-2016 15:56:03)

Hors ligne

#4 30-09-2016 19:15:32

Hub49
Membre
Distrib. : Debian 8 Jessie Mate desktop
Noyau : linux 3.2-0-4-realtime-686-pae
(G)UI : MATE 1.81
Inscription : 11-02-2016

Re : installation asterisk impossible

Autant pour moi, je me suis trompé. la citation du dessus n'est pas la  bonne. smile)

Voici ce que me donne le résultat de la manip d'installation des dépendances pour la compilation:

insserv: Starting .depend.start depends on plymouth and therefore on system facility `$all' which can not be true!
insserv: Starting .depend.stop depends on plymouth and therefore on system facility `$all' which can not be true!
insserv: Starting .depend.boot depends on plymouth and therefore on system facility `$all' which can not be true!
insserv: Starting .depend.start depends on plymouth and therefore on system facility `$all' which can not be true!
insserv: Starting .depend.stop depends on plymouth and therefore on system facility `$all' which can not be true!
insserv: exiting now without changing boot order!
update-rc.d: error: insserv rejected the script header
dpkg: erreur de traitement du paquet udev (--configure) :
 le sous-processus script post-installation installé a retourné une erreur de sortie d'état 1
Traitement des actions différées (« triggers ») pour initramfs-tools (0.120+deb8u2) ...
update-initramfs: Generating /boot/initrd.img-3.16.0-4-686-pae
Des erreurs ont été rencontrées pendant l'exécution :
 udev
N: « ring-nightly-man.listsudo » dans le répertoire « /etc/apt/sources.list.d/ » a été ignoré car il utilise une extension non valable
N: « ring-nightly-man.listsudo » dans le répertoire « /etc/apt/sources.list.d/ » a été ignoré car il utilise une extension non valable
E: Sub-process /usr/bin/dpkg returned an error code (1)
 



Après, j'ai tenté un petit:

root@Host-001:~# cd /usr/src/
root@Host-001:/usr/src# mkdir asterisk
mkdir: impossible de créer le répertoire « asterisk »: Le fichier existe
 


pour voir, on sait jamais tongue

Bref, c'est  la cata...


Edit:
J'ai avancé dans l'installation d'asterisk et je me retrouve avec cette erreur:

configure: error: *** termcap support not found (on modern systems, this typically means the ncurses development package is missing)
root@Host-001:/usr/src/asterisk/asterisk-13.11.2# make menuselect Makefile:105: makeopts: Aucun fichier ou dossier de ce type
****
**** The configure script must be executed before running 'make'.
****               Please run "./configure".
****
Makefile:339: recipe for target 'makeopts' failed
make: *** [makeopts] Error 1
root@Host-001:/usr/src/asterisk/asterisk-13.11.2#
 



Je suis l'installation à partir de ce tuto https://www.youtube.com/watch?v=lk5bnoy7YcE

Vous avez une idée de l'origine du problème ?

Dernière modification par Hub49 (30-09-2016 19:52:09)

Hors ligne

Pied de page des forums