Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 11-10-2016 10:41:06

romain
Membre
Lieu : Suisse
Distrib. : Debian, "Jessie"
Noyau : Linux 3.16.0-4-amd64
(G)UI : XFCE, LXDE ou openbox
Inscription : 31-01-2013

[résolu] Sid: downgrade un paquet

Bonjour,

Je suis nouveau sur Sid. J'ai configurer mon bureau à ma manière et j'utilise conky pour suivre le système. Je l'installé via apt-get. Sur jessie, la version du paquet est 1.9.0 et sur Sid la version est 1.10.0. Maintenant mon joli moniteur conky ne fonctionne plus. En lisant les rapports d'erreurs et quelques page sur le web, je constate que la nouvelle version à changer quelques points de syntaxe pour le fichier de config. Je n'ai pas envie de me plancher sur les changement pour l'instant. Je voudrais juste downgrader le paquet. Comment faire?

Merci
Salutation

Dernière modification par romain (14-10-2016 11:17:07)

Hors ligne

#2 11-10-2016 10:54:34

smolski
administrateur quasi...modo
Lieu : AIN
Distrib. : 8 (jessie) 64 bits + backports
Noyau : 4.6.0-0.bpo.1-amd64
(G)UI : gnome 3.14.1
Inscription : 21-10-2008

Re : [résolu] Sid: downgrade un paquet

Si tu as les sources stables d'activées, après avoir désinstallé conky, tu dois pouvoir installer la version stable de conky, genre :

aptitude -t jessie install conky


Préférer la commande aptitude pour la gestion de testing ou sid.
character0275.gif

Dernière modification par smolski (11-10-2016 10:57:03)


"Définition d'eric besson : S'il fallait en chier des tonnes pour devenir ministre, il aurait 2 trous du cul." - JP Douillon
"L'utopie ne signifie pas l'irréalisable, mais l'irréalisée." - T Monod (source :  La zone de Siné)
"Je peux rire de tout mais pas avec n'importe qui." - P Desproges
"saque eud dun" (patois chtimi : fonce dedans)

En ligne

#3 11-10-2016 11:42:54

romain
Membre
Lieu : Suisse
Distrib. : Debian, "Jessie"
Noyau : Linux 3.16.0-4-amd64
(G)UI : XFCE, LXDE ou openbox
Inscription : 31-01-2013

Re : [résolu] Sid: downgrade un paquet

Ok merci pour l'info! Depuis des années j'utilise apt-get et je pensais que cette la solution préférée. Pour aptitude, je pense que ce n'est pas propre à Sid mais au version stable aussi? Pourquoi faut-il préférer une commande qu'une autre? Aptitude n'est pas une sur couche d'apt-get (j'entends par la qu'il réutilise la commande apt-get pour fonctionner)? Je vais allé lire ton tuto après et tacher de prendre l'habitude d'utiliser aptitude.  AAAAHH les habitudes dur à changer parfois wink

Sinon tip top, le retours de conky, je revois enfin (en même temps je l'ai perdu que quelques heures) l'utilisation des mes ressources. Merci pour cette réponse rapide.
Salutation

Hors ligne

#4 11-10-2016 11:54:29

smolski
administrateur quasi...modo
Lieu : AIN
Distrib. : 8 (jessie) 64 bits + backports
Noyau : 4.6.0-0.bpo.1-amd64
(G)UI : gnome 3.14.1
Inscription : 21-10-2008

Re : [résolu] Sid: downgrade un paquet

apt-get ne propose pas d'alternative lors de son utilisation alors que aptitude si.
En stable, les alternatives ne nont pas nécessaires alors qu'en testing et sid plutôt deux fois qu'une ! big_smile

"Définition d'eric besson : S'il fallait en chier des tonnes pour devenir ministre, il aurait 2 trous du cul." - JP Douillon
"L'utopie ne signifie pas l'irréalisable, mais l'irréalisée." - T Monod (source :  La zone de Siné)
"Je peux rire de tout mais pas avec n'importe qui." - P Desproges
"saque eud dun" (patois chtimi : fonce dedans)

En ligne

#5 11-10-2016 11:56:21

bendia
Admin stagiaire
Distrib. : Jessie
Noyau : 3.16.0-4-amd64
(G)UI : Gnome + XFCE + Console
Inscription : 20-03-2012
Site Web

Re : [résolu] Sid: downgrade un paquet

Salut smile

aptitude est plus efficace dans la résolution de dépendances, et proposera plusieurs choix pour essayer d'arriver à la solution (ce n'est pas toujours le premier le meilleur). Ceci-dit il est plus gourmand, plus complexe, et donne parfois l'impression qu'il y a un problème là où il n'en existe aucun.

Ce genre de fonctionalité étant inutile pour Stable, il vaut mieux lui préférer apt-get pour sa gestion, ce qui évite de se prendre la tête. Si apt-get pose un problème, c'est qu'il existe vraiment, et il faut donc s'attacher à le résoudre wink Qui plus est, lorsque il échoue, il s'arrête sans chercher plus loin, et c'est donc plus sécurisant.

Edit : griller par smolski coyotus.png

Ben
___________________
La seule question bête, c'est celle qu'on ne pose pas.
file-Re06858991f6f328b4907296ac5cea283

En ligne

#6 11-10-2016 12:04:03

romain
Membre
Lieu : Suisse
Distrib. : Debian, "Jessie"
Noyau : Linux 3.16.0-4-amd64
(G)UI : XFCE, LXDE ou openbox
Inscription : 31-01-2013

Re : [résolu] Sid: downgrade un paquet

Merci les gars, je comprends! Alors maintenant que je suis passé à Sid pour mon poste de travail, je vais découvrir aptitude et ces joies! Par contre je vais continuer à utiliser apt-get pour mes serveurs et stations stables.

Bon appétit

Hors ligne

#7 11-10-2016 12:04:36

deuchdeb
Moderato ma non troppo
Lieu : Pays de Cocagne
Distrib. : Jessie 8 + backports
Noyau : linux-image-3.16
(G)UI : KDE4.14 - Mate
Inscription : 13-01-2010

Re : [résolu] Sid: downgrade un paquet

Tu peux aussi utiliser le pinning.


Package: conky
Pin: release o=Debian,a=stable
Pin-Priority: 1001



aptitude update



aptitude upgrade



Cela devrait permettre de remettre la version stable de conky. Par contre pour les dépendances ??????

Extrait du manuel de référence Debian: https://www.debian.org/doc/manuals/debi … f_archives

priorité d’épinglage     conséquence de l’épinglage apt sur le paquet
1001     installer le paquet même s’il s’agit d’un retour en arrière

Hors ligne

#8 12-10-2016 09:14:19

nono47
Membre
Lieu : dans l'engrenage ...
Distrib. : sid
Noyau : Linux 4.8.0-1-amd64
(G)UI : gnome-shell
Inscription : 09-05-2012

Re : [résolu] Sid: downgrade un paquet

Salut,

Une page de Le cahier de l'administrateur Debian qui explique les subtilités des commandes aptitude, apt-get et apt : https://debian-handbook.info/browse/fr- … t-get.html
smile

Hors ligne

#9 14-10-2016 11:42:21

romain
Membre
Lieu : Suisse
Distrib. : Debian, "Jessie"
Noyau : Linux 3.16.0-4-amd64
(G)UI : XFCE, LXDE ou openbox
Inscription : 31-01-2013

Re : [résolu] Sid: downgrade un paquet

Je viens quand même conclure ce sujet. Merci nono47 pour le lien du cahier de l'administrateur de Debian car il y a toutes les bonnes informations liées à APT. Mieux vaut lire la chapitre 6 en entier. https://debian-handbook.info/browse/fr- … e/apt.html.
Après analyse des commandes, aptitude, apt-get ou apt vont proposer le même paramètre -t

# apt-get -t Jessie conky


ou

# aptitude -t Jessie conky


ou

# apt -t Jessie conky


Si j'en crois mes lectures, apt-get a évolué avec le temps afin de proposer plus ou moins les même fonction que aptitude sauf de proposer des solutions alternative pour les dépendances. Mais je ne suis pas forcément convaincu par les solutions alternatives. En lisant le cahier de l'admin Debian, j'ai vu qu'il conseillais maintenant d'utiliser apt (encore un truc à creuser).

Cette méthode d'installation ne va pas résoudre mon problème liée au mise à jour (oui le paquet s'installe à la version la plus récente), il faut utiliser le pinning comme l'a suggéré deuchdeb. Une bonne explication se trouve bien entandu dans le cahier de l'admin Debian: https://debian-handbook.info/browse/fr- … priorities

Merci encore à tous, maintenant je vais réussir à mieux gérer mes paquets et leurs priorités

Hors ligne

Pied de page des forums