Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#176 29-10-2016 19:48:53

tryf
Membre
Distrib. : debian-8.6.0-powerpc-DVD-1
Inscription : 16-10-2016

Re : écran noir ppc et radeon 9200

plop6 a écrit :

Le soucis viens d'un soucis au niveau de X: version de Xorg et cie, je ne me souviens plus exactement la version a partir de laquelle ça a commencer a planter


Tu veut dire, le soucis sous Debian7 ?

Bon, moi j'aimerai bien lire des vidéos sur cet eMac, car j'adore le contraste des écrans à tube.
Du coup, Mate ne me donne qu'un curseur de souris tout seul
et startx me donne un bureau en 8bits ou du moins en très basse résolution...

Ce n'est pas seulement l'accélération 3D que je n'ai pas...
sad

j'ai essayé :

nano /etc/yaboot.conf


et rajouter en dessous du premier
"initrd=/boot/initrd.img":

append="nomodeset video=radeonfb:1280x960-32@72 video=offb:off"


et pareil

Dernière modification par tryf (29-10-2016 20:02:42)

Hors ligne

#177 30-10-2016 10:23:47

tryf
Membre
Distrib. : debian-8.6.0-powerpc-DVD-1
Inscription : 16-10-2016

Re : écran noir ppc et radeon 9200

Bonjour!

J'ai mis la wheezy,
avec le bureau debian coché par défaut (je pense que c'est un bureau basé sur gnome)


passage de wheezy a jessie :
J'ai fait ceci!!! :


Ne PAS passer a systemd... :
Pin Systemd Packages
Prevent apt from installing systemd packages in the future :

echo -e 'Package: systemd\nPin: release *\nPin-Priority: -1' > /etc/apt/preferences.d/systemd


Prevent apt from installing any systemd-like packages in the future (note the star before and after systemd) :

echo -e '\n\nPackage: *systemd*\nPin: release *\nPin-Priority: -1' >> /etc/apt/preferences.d/systemd


Note: This prevents the installation of the package systemd-shim as well. However this is a emulation of systemd functions, so you can install software which depends on systemd. So if you get "Package systemd-shim is not available, but is referred to by another package." you might temporary disable the three lines in the preferences.d/systemd file.

Je n'ai pas fait cela :
In the case your system uses multiarch (mixed 32 and 64bit packages), you need to pin the 64bit version of systemd too. Otherwise apt-get could still install it as dependency later.

echo -e '\nPackage: systemd:amd64\nPin: release *\nPin-Priority: -1' >> /etc/apt/preferences.d/systemd


In other multiarch cases where amd64 is the default architecture, you may have to pin the i386 package to prevent APT from installing it:

echo -e '\nPackage: systemd:i386\nPin: release *\nPin-Priority: -1' >> /etc/apt/preferences.d/systemd


Mais ceci  :

echo -e '\nPackage: systemd:powerpc\nPin: release *\nPin-Priority: -1' >> /etc/apt/preferences.d/systemd


(c'est juste mon petit doigt qui m'as dit de faire comme ça...
Je me trompe pas?)

Puis j'ai fait :
Upgrade de Debian 7 vers Debian 8 :
http://blogmotion.fr/systeme/debian-8-stable-13068
Je détailles :

Pour passer de debian 7 (7.8) vers debian 8.0, faites vos backups parce qu'on ne sait jamais. Un collègue à vous qui utiliserait un backport oldschool qui ferait foirer la mise à jour à cause de dépendances, ce serait dommage.
(pas fait de backup, mais ma wheezy est fraîche, aucun fichier, rien à moi)

Évitez de faire la mise à jour via SSH, privilégiez le terminal (donc la console sur vSphere Client) pour éviter la coupure en plein milieu.
Arrêtez les services critiques comme Apache, MySQL, Centreon, etc pour éviter tout conflit lors de la mise à jour.
(Je n'ai pas arrêté les services...)

Quand vous êtes prêt, précéder chaque commande de sudo (si non root), vérifiez que votre système est à jour :

apt-get update && apt-get upgrade



Puis modifiez le fichier /etc/apt/sources.list :

sed -i 's/wheezy/jessie/g' /etc/apt/sources.list



Attention si vous avez d'autres fichiers sources.list (mariaDB, dotdeb, etc), pensez à les éditer. Voici un exemple pour mariadb :

sed -i 's/wheezy/jessie/g' /etc/apt/sources.list.d/mariadb.list


(Je n'ai rien dans le repertoire
sources.list.d)

Enfin :

apt-get update


Tout se fait niquel

apt-get upgrade


donne :

Les paquets suivants ont été conservés :
  accountsservice aisleriot alacarte alsa-utils anacron apache2.2-bin apt apt-utils apt-xapian-index aptdaemon aptitude aptitude-common
  argyll at at-spi2-core avahi-daemon baobab base-passwd bind9-host binfmt-support bluez bogofilter-bdb brasero brasero-common bsdutils
  caribou caribou-antler cheese cheese-common colord consolekit cpp cron cryptsetup-bin cups cups-bsd cups-client cups-filters
  cups-pk-helper cups-ppdc db5.1-util dbus dconf-gsettings-backend dconf-service dconf-tools default-jre default-jre-headless
  dictionaries-common dmsetup dnsmasq-base dnsutils dpkg empathy empathy-common eog evince evince-common evolution evolution-common
  evolution-data-server evolution-data-server-common evolution-plugins exim4 exim4-base exim4-config exim4-daemon-light file-roller
  foomatic-db-compressed-ppds gcalctool gconf-service gconf2 gconf2-common gcr gdebi gdebi-core gdm3 gedit gedit-common gedit-plugins
  geoclue geoclue-hostip geoclue-localnet geoclue-manual geoclue-yahoo ghostscript gimp gimp-data gir1.2-accountsservice-1.0
  gir1.2-atk-1.0 gir1.2-atspi-2.0 gir1.2-caribou-1.0 gir1.2-clutter-1.0 gir1.2-clutter-gst-1.0 gir1.2-cogl-1.0 gir1.2-coglpango-1.0
  gir1.2-evince-3.0 gir1.2-folks-0.6 gir1.2-freedesktop gir1.2-gck-1 gir1.2-gcr-3 gir1.2-gdata-0.0 gir1.2-gdkpixbuf-2.0 gir1.2-gkbd-3.0
  gir1.2-glib-2.0 gir1.2-gmenu-3.0 gir1.2-gnomebluetooth-1.0 gir1.2-gnomekeyring-1.0 gir1.2-goa-1.0 gir1.2-gtk-3.0 gir1.2-gtkclutter-1.0
  gir1.2-gtksource-3.0 gir1.2-javascriptcoregtk-3.0 gir1.2-json-1.0 gir1.2-mutter-3.0 gir1.2-networkmanager-1.0 gir1.2-panelapplet-4.0
  gir1.2-pango-1.0 gir1.2-peas-1.0 gir1.2-polkit-1.0 gir1.2-rb-3.0 gir1.2-soup-2.4 gir1.2-telepathyglib-0.12 gir1.2-telepathylogger-0.2
  gir1.2-totem-1.0 gir1.2-totem-plparser-1.0 gir1.2-upowerglib-1.0 gir1.2-vte-2.90 gir1.2-webkit-3.0 gir1.2-wnck-3.0 gjs gkbd-capplet gksu
  glchess glib-networking glib-networking-common glib-networking-services glines gnect gnibbles gnobots2 gnome gnome-accessibility-themes
  gnome-applets gnome-applets-data gnome-backgrounds gnome-bluetooth gnome-color-manager gnome-contacts gnome-control-center
  gnome-control-center-data gnome-core gnome-desktop3-data gnome-dictionary gnome-disk-utility gnome-documents gnome-font-viewer
  gnome-games gnome-keyring gnome-menus gnome-nettool gnome-online-accounts gnome-orca gnome-packagekit gnome-panel gnome-panel-data
  gnome-power-manager gnome-screensaver gnome-screenshot gnome-session gnome-session-bin gnome-session-common gnome-session-fallback
  gnome-settings-daemon gnome-shell gnome-shell-common gnome-shell-extensions gnome-sudoku gnome-sushi gnome-system-log
  gnome-system-monitor gnome-terminal gnome-terminal-data gnome-themes-standard gnome-themes-standard-data gnome-tweak-tool
  gnome-user-share gnome-video-effects gnomine gnotravex gnotski gnuplot gnuplot-nox gsettings-desktop-schemas gstreamer0.10-plugins-bad
  gstreamer0.10-plugins-base gstreamer0.10-plugins-good gstreamer0.10-plugins-ugly gstreamer0.10-pulseaudio gstreamer0.10-x gtali
  gtk2-engines gucharmap guile-2.0-libs gvfs gvfs-backends gvfs-bin gvfs-common gvfs-daemons gvfs-libs hplip hplip-data hunspell-fr iagno
  iceweasel iceweasel-l10n-fr imagemagick initscripts inkscape iproute iptables iputils-ping isc-dhcp-client isc-dhcp-common libaacs0
  libaccountsservice0 libapache2-mod-dnssd libaprutil1 libaprutil1-dbd-sqlite3 libaprutil1-ldap libapt-pkg4.12 libasound2
  libasound2-plugins libatasmart4 libatk-adaptor libatk-bridge2.0-0 libatk-wrapper-java-jni libatk1.0-0 libatk1.0-data libatkmm-1.6-1
  libatspi2.0-0 libavahi-gobject0 libavahi-ui-gtk3-0 libblas3 libbluetooth3 libbonobo2-0 libbonobo2-common libbonoboui2-0
  libbrasero-media3-1 libcairo-perl libcairo2 libcanberra-gtk-module libcanberra-gtk0 libcanberra-gtk3-0 libcanberra-gtk3-module
  libcaribou-common libcaribou-gtk-module libcaribou-gtk3-module libcaribou0 libchamplain-0.12-0 libchamplain-gtk-0.12-0 libck-connector0
  libclutter-1.0-0 libclutter-gst-1.0-0 libclutter-gtk-1.0-0 libclutter-imcontext-0.1-0 libclutter-imcontext-0.1-bin
  libcluttergesture-0.0.2-0 libcryptsetup4 libcups2 libcupscgi1 libcupsfilters1 libcupsimage2 libcupsmime1 libcupsppdc1 libcurl3-gnutls
  libcwidget3 libdb-java libdee-1.0-4 libdevmapper-event1.02.1 libdevmapper1.02.1 libdjvulibre21 libdmapsharing-3.0-2 libenchant1c2a
  libepc-1.0-3 libepc-common libepc-ui-1.0-3 libept1.4.12 libevdocument3-4 libevolution libevview3-3 libexttextcat-data libfarstream-0.1-0
  libfftw3-3 libfolks-eds25 libfolks-telepathy25 libfolks25 libgail-3-0 libgail-common libgail18 libgcc1 libgck-1-0 libgconf-2-4
  libgconf2-4 libgcr-3-1 libgdict-1.0-6 libgdiplus libgdk-pixbuf2.0-0 libgdk-pixbuf2.0-common libgegl-0.2-0 libgeoclue0 libgeocode-glib0
  libgfortran3 libgimp2.0 libgirepository-1.0-1 libgksu2-0 libgl1-mesa-dri libgl1-mesa-glx libglade2-0 libglapi-mesa libglib-perl
  libglib2.0-0 libglib2.0-bin libglib2.0-cil libglibmm-2.4-1c2a libgmime-2.6-0 libgmime2.6-cil libgnome-keyring-common libgnome-keyring0
  libgnome-menu-3-0 libgnome2-0 libgnomecanvas2-0 libgnomeui-0 libgnomevfs2-0 libgoa-1.0-common libgomp1 libgpgme11 libgpod-common
  libgpod4 libgs9 libgs9-common libgssdp-1.0-3 libgstreamer-plugins-bad0.10-0 libgstreamer-plugins-base0.10-0 libgstreamer0.10-0
  libgtk-3-0 libgtk-3-bin libgtk-3-common libgtk-vnc-2.0-0 libgtk2-perl libgtk2.0-0 libgtk2.0-bin libgtk2.0-cil libgtkhtml-4.0-0
  libgtkhtml-4.0-common libgtkhtml-editor-4.0-0 libgtkmm-2.4-1c2a libgtkmm-3.0-1 libgtksourceview-3.0-common libgtkspell0
  libgucharmap-2-90-7 libgudev-1.0-0 libgupnp-1.0-4 libgupnp-av-1.0-2 libgvnc-1.0-0 libgxps2 libhpmud0 libhsqldb-java libhtml-parser-perl
  libhttp-message-perl libio-socket-ssl-perl libjasper1 libjavascriptcoregtk-1.0-0 libjavascriptcoregtk-3.0-0 libjson-glib-1.0-0 libjson0
  libldap-2.4-2 liblocale-gettext-perl liblvm2app2.2 libmailtools-perl libmission-control-plugins0 libmng1 libmono-addins-gui0.2-cil
  libmono-addins0.2-cil libmono-cairo4.0-cil libmono-corlib4.0-cil libmono-i18n-west4.0-cil libmono-i18n4.0-cil libmono-posix4.0-cil
  libmono-security4.0-cil libmono-sharpzip4.84-cil libmono-system-configuration4.0-cil libmono-system-core4.0-cil
  libmono-system-drawing4.0-cil libmono-system-security4.0-cil libmono-system-xml4.0-cil libmono-system4.0-cil libmozjs185-1.0
  libmtp-runtime libmtp9 libmx-1.0-2 libmx-common libnautilus-extension1a libneon27-gnutls libnet-dbus-perl libnet-ssleay-perl
  libnetfilter-conntrack3 libnetpbm10 libnice10 libnm-glib4 libnm-gtk-common libnm-gtk0 libnm-util2 libnotify4 libofa0 libopenexr6
  libopenraw1 liborbit2 libp11-kit0 libpam-ck-connector libpam-modules libpam-modules-bin libpam0g libpanel-applet-4-0 libpango-perl
  libpango1.0-0 libpangomm-1.4-1 libpaper1 libpeas-1.0-0 libpolkit-agent-1-0 libpolkit-backend-1-0 libpolkit-gobject-1-0 libpoppler-glib8
  libpstoedit0c2a libpulse-mainloop-glib0 libpulse0 libpurple0 libpython2.7 libquvi7 librdf0 libreoffice libreoffice-base
  libreoffice-base-core libreoffice-calc libreoffice-common libreoffice-core libreoffice-draw libreoffice-emailmerge libreoffice-evolution
  libreoffice-gnome libreoffice-gtk libreoffice-help-en-us libreoffice-help-fr libreoffice-impress libreoffice-l10n-fr libreoffice-math
  libreoffice-report-builder-bin libreoffice-style-galaxy libreoffice-style-tango libreoffice-writer librest-0.7-0 librest-extras-0.7-0
  librsvg2-2 librsvg2-common libsane libsane-common libsane-hpaio libsasl2-2 libsemanage-common libsemanage1 libsmbclient libsnmp-base
  libsocket-perl libsoup-gnome2.4-1 libsoup2.4-1 libspandsp2 libssh2-1 libstdc++6 libtelepathy-glib0 libtext-charwidth-perl
  libtext-iconv-perl libtotem0 libusb-1.0-0 libuuid-perl libv4l-0 libv4lconvert0 libva1 libvte-2.90-9 libvte-2.90-common
  libwebkitgtk-1.0-0 libwebkitgtk-3.0-0 libwmf-bin libwmf0.2-7 libwnck-3-0 libwnck22 libxapian22 libxml-parser-perl libxslt1.1 libyelp0
  libzbar0 lightsoff linux-image-powerpc login lp-solve m4 mahjongg mesa-utils metacity metacity-common modemmanager mono-4.0-gac mono-gac
  mono-runtime mount mousetweaks mutt mutter-common nautilus nautilus-data netpbm network-manager network-manager-gnome nmap
  notification-daemon ntfs-3g obex-data-server openprinting-ppds packagekit packagekit-tools passwd perl perl-base perl-modules perlmagick
  pidgin-data policykit-1 poppler-utils ppp printer-driver-all printer-driver-escpr printer-driver-foo2zjs printer-driver-hpcups
  printer-driver-hpijs printer-driver-m2300w printer-driver-postscript-hp printer-driver-ptouch printer-driver-pxljr printer-driver-splix
  procps pulseaudio pulseaudio-module-x11 pulseaudio-utils python python-apt python-aptdaemon python-aptdaemon.gtk3widgets python-brlapi
  python-chardet python-debian python-gconf python-gi python-gi-cairo python-gnome2 python-gobject python-gobject-2 python-gtk2
  python-imaging python-mako python-minimal python-notify python-numpy python-pexpect python-pkg-resources python-pyatspi python-pyatspi2
  python-pycurl python-pyorbit python-reportbug python-reportlab python-soappy python-uno python-xapian python2.7 python2.7-minimal
  quadrapassel reportbug rhythmbox rhythmbox-data rhythmbox-plugin-cdrecorder rhythmbox-plugins rsyslog rygel rygel-playbin
  rygel-preferences rygel-tracker samba-common samba-common-bin sane-utils seahorse shared-mime-info shotwell shotwell-common simple-scan
  smbclient software-properties-common software-properties-gtk sound-juicer speech-dispatcher sudo swell-foop synaptic sysv-rc sysvinit
  sysvinit-utils telepathy-gabble telepathy-haze telepathy-idle telepathy-logger telepathy-mission-control-5 telepathy-rakia
  telepathy-salut texinfo tomboy totem totem-common totem-plugins tracker tracker-extract tracker-gui tracker-miner-fs tracker-utils
  transmission-common transmission-gtk ttf-dejavu ttf-dejavu-core ttf-dejavu-extra udev udisks ufraw-batch unattended-upgrades uno-libs3
  unoconv upower ure usb-modeswitch usb-modeswitch-data usbmuxd util-linux util-linux-locales vinagre vino wget xbrlapi xdg-user-dirs-gtk
  xorg xserver-xephyr xserver-xorg xserver-xorg-core xserver-xorg-input-evdev xserver-xorg-input-synaptics xserver-xorg-input-wacom
  xserver-xorg-video-ati xserver-xorg-video-fbdev xserver-xorg-video-mach64 xserver-xorg-video-mga xserver-xorg-video-nouveau
  xserver-xorg-video-r128 xserver-xorg-video-radeon xserver-xorg-video-savage xserver-xorg-video-sisusb xserver-xorg-video-tdfx
  xserver-xorg-video-trident yelp zeitgeist-core zenity zenity-common
0 mis à jour, 0 nouvellement installés, 0 à enlever et 675 non mis à jour.



Maintenant, seule la commande

apt-get dist-upgrade -y


me donne une erreur :

Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances      
Lecture des informations d'état... Fait
Calcul de la mise à jour... Échec
Les paquets suivants contiennent des dépendances non satisfaites :
 modemmanager : Casse: network-manager (< 0.9.8.2-1) mais 0.9.4.0-10 devra être installé
E: Erreur, pkgProblem::Resolve a généré des ruptures, ce qui a pu être causé par les paquets devant être gardés en l'état.



Enfin, redémarrez votre serveur.


Bidouille prévu pour un serveur, normalement...
Sinon, mon système va beaucoup plus vite, plus réactif dans les menus, bon, il faudra que je teste car c'est sans doute très "bidouille" mais bon, c'est cool!
Faut que je teste un film en 1280x960
comment je peu savoir si les couleurs sont bien en 32bits?
C'est 1280x960, ça c'est niquel, c'est le maxi de ma carte graphique. Mais 24 ou 32bits? je ne sais pas ou cela est notifié...
72Hz sous wheezy mais depuis jessie, cela ne s'affiche pas non plu.

A noter que mon écran est inconnu

Dernière modification par tryf (30-10-2016 11:31:39)

Hors ligne

#178 30-10-2016 10:33:30

tryf
Membre
Distrib. : debian-8.6.0-powerpc-DVD-1
Inscription : 16-10-2016

Re : écran noir ppc et radeon 9200

Voici mon source.list :

deb http://ftp.fr.debian.org/debian/ jessie main
deb-src http://ftp.fr.debian.org/debian/ jessie main

deb http://security.debian.org/ jessie/updates main
deb-src http://security.debian.org/ jessie/updates main

# jessie-updates, previously known as 'volatile'
deb http://ftp.fr.debian.org/debian/ jessie-updates main
deb-src http://ftp.fr.debian.org/debian/ jessie-updates main



Que doit je faire pour avoir firefox au lieu de iceweasel 31.8.0?
Si je suis bien renseigné, debian 8 est revenu a firefox et fini iceweasel

Quels autres dépôts pourrait être intéressant d'ajouter, sans trop de risque de planter mon système bidouillé?

Merci!!!

PS :
Les
deb-src
Ont t-elles une quelconque utilité?

Dernière modification par tryf (30-10-2016 11:04:08)

Hors ligne

#179 30-10-2016 11:22:12

robert2a
Membre
Lieu : France
Distrib. : Stretch
Noyau : Linux 4.8.0-1-amd64
(G)UI : Mate 1.16.1
Inscription : 15-11-2014

Re : écran noir ppc et radeon 9200

au vu de ce que tu poste tu est encore en wheezy et surement avec le meme noyau mais avec des paquets de jessie , debian c'est du robuste tongue

Hors ligne

#180 30-10-2016 11:30:06

tryf
Membre
Distrib. : debian-8.6.0-powerpc-DVD-1
Inscription : 16-10-2016

Re : écran noir ppc et radeon 9200

Ah oui....
dist-upgrade n'as pas fonctionné...

Bon. big_smile

Hors ligne

Pied de page des forums