Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 17-10-2016 10:47:20

zorzi
Membre
Distrib. : Debian Jessie + Backports
Noyau : Linux 3.16.0-4-amd64
Inscription : 30-09-2015

(résolu) Gnome 3, méta-paquets, dépendances et "prise d'otage"...

Bonjour à tout le monde,

Un rapide mot pour signaler mon retour chez Debian pur après un an de Debian Mint.

Je me familiarise doucement avec l'interface Gnome-Shell que je trouve très sympa à utiliser.

Mais certaines choses me gênent et notamment certains problèmes de dépendances.

Je voulais au départ retirer les logiciels que je n'utilise habituellement pas: Evolution, Rhythmbox, et Iceweasel (juste le paquet de transition pour éviter d'avoir deux icônes firefox qui se balladent).

Ainsi:

nicolas@pc-2008:~$ sudo aptitude remove iceweasel
[sudo] password for nicolas:
Les paquets suivants seront ENLEVÉS :                  
  iceweasel
0 paquets mis à jour, 0 nouvellement installés, 1 à enlever et 0 non mis à jour.
Il est nécessaire de télécharger 0 o d'archives. Après dépaquetage, 259 ko seront libérés.
Les paquets suivants ont des dépendances non satisfaites :
 gnome-core : Dépend: iceweasel (>= 30) mais il ne sera pas installé.
Les actions suivantes permettront de résoudre ces dépendances :

     Supprimer les paquets suivants :                                          
1)     gnome                                                                    
2)     gnome-core                                                              
3)     task-gnome-desktop                                                      

     Laisser les dépendances suivantes non satisfaites :                        
4)     task-desktop recommande task-gnome-desktop | task-xfce-desktop | task-kde
5)     task-gnome-desktop recommande gnome                                      
6)     task-gnome-desktop recommande iceweasel                                  


Accepter cette solution ? [Y/n/q/?] q
Abandon de tous les efforts pour rechercher une solution à ces dépendances.
Abandon.
nicolas@pc-2008:~$ sudo aptitude remove rhythmbox
Les paquets suivants seront ENLEVÉS :                  
  rhythmbox
0 paquets mis à jour, 0 nouvellement installés, 1 à enlever et 0 non mis à jour.
Il est nécessaire de télécharger 0 o d'
archives. Après dépaquetage, 674 ko seront libérés.
Les paquets suivants ont des dépendances non satisfaites :
 rhythmbox-plugins : Dépend: rhythmbox (= 3.1-1) mais il ne sera pas installé.
 rhythmbox-plugin-cdrecorder : Dépend: rhythmbox (= 3.1-1) mais il ne sera pas installé.
 gnome : Dépend: rhythmbox (>= 3.0) mais il ne sera pas installé.
Les actions suivantes permettront de résoudre ces dépendances :

     Supprimer les paquets suivants :                  
1)     gnome                                            
2)     rhythmbox-plugin-cdrecorder                      
3)     rhythmbox-plugins                                

     Laisser les dépendances suivantes non satisfaites :
4)     rhythmbox-data recommande rhythmbox              
5)     task-gnome-desktop recommande gnome              


Accepter cette solution ? [Y/n/q/?] q
Abandon de tous les efforts pour rechercher une solution à ces dépendances.
Abandon.
nicolas@pc-2008:~$ sudo aptitude remove evolution
Les paquets suivants seront ENLEVÉS :                  
  evolution
0 paquets mis à jour, 0 nouvellement installés, 1 à enlever et 0 non mis à jour.
Il est nécessaire de télécharger 0 o d'archives. Après dépaquetage, 366 ko seront libérés.
Les paquets suivants ont des dépendances non satisfaites :
 evolution-plugins : Dépend: evolution (= 3.12.9~git20141130.241663-1+b1) mais il ne sera pas installé.
 gnome : Dépend: evolution (>= 3.12) mais il ne sera pas installé.
Les actions suivantes permettront de résoudre ces dépendances :

     Supprimer les paquets suivants :                  
1)     evolution-plugins                                
2)     gnome                                            

     Laisser les dépendances suivantes non satisfaites :
3)     evolution-common recommande evolution            
4)     libreoffice-evolution recommande evolution      
5)     task-gnome-desktop recommande gnome              


Accepter cette solution ? [Y/n/q/?]



Le méta-paquet gnome peut-il être retiré sans souci ? Quels sont les risques pour l'avenir ? J'ai beau le passer en installation manuelle, rien ne semble y faire.

J'ai installé à partir d'une image live. Y aurait-il eu moins de problèmes avec une netisntall minimale ou cela n'a t'il rien à voir ?

Merci d'avance.

Dernière modification par zorzi (17-10-2016 21:03:22)


Desktop: HP Pavilion a6435 (Athlon64 2x 2,6Ghz, Radeon X1650 Pro, Ram 4 Go, DD 500 Go) / Debian Jessie (Gnome)
Laptop: Packard-Bell EasyNote G1320 (Celeron 1,3 Ghz, ATI Mobility Radeon 9100 IGP, Ram 1,2 Go, DD 40 Go) / Debian Jessie (Mate)

Hors ligne

#2 17-10-2016 12:06:40

bendia
Admin stagiaire
Distrib. : Jessie
Noyau : 3.16.0-4-amd64
(G)UI : Gnome + XFCE + Console
Inscription : 20-03-2012
Site Web

Re : (résolu) Gnome 3, méta-paquets, dépendances et "prise d'otage"...

Salut smile

Il y a la méthode dans le wiki sur aptitude pour virer le meta-paquet sans soucis smile

Ben
___________________
La seule question bête, c'est celle qu'on ne pose pas.
file-Re06858991f6f328b4907296ac5cea283

Hors ligne

#3 17-10-2016 13:57:41

zorzi
Membre
Distrib. : Debian Jessie + Backports
Noyau : Linux 3.16.0-4-amd64
Inscription : 30-09-2015

Re : (résolu) Gnome 3, méta-paquets, dépendances et "prise d'otage"...

Hello et merci.

Je suis en train d'étudier ça. Supprimer les méta-paquets ne risque pas de poser de problèmes à l'avenir (mises à jour etc.) ?

Desktop: HP Pavilion a6435 (Athlon64 2x 2,6Ghz, Radeon X1650 Pro, Ram 4 Go, DD 500 Go) / Debian Jessie (Gnome)
Laptop: Packard-Bell EasyNote G1320 (Celeron 1,3 Ghz, ATI Mobility Radeon 9100 IGP, Ram 1,2 Go, DD 40 Go) / Debian Jessie (Mate)

Hors ligne

#4 17-10-2016 14:02:57

bendia
Admin stagiaire
Distrib. : Jessie
Noyau : 3.16.0-4-amd64
(G)UI : Gnome + XFCE + Console
Inscription : 20-03-2012
Site Web

Re : (résolu) Gnome 3, méta-paquets, dépendances et "prise d'otage"...

De mise à jour je ne pense pas, les paquets ne sont pas marqué comme à conserver en l'état.

Ben
___________________
La seule question bête, c'est celle qu'on ne pose pas.
file-Re06858991f6f328b4907296ac5cea283

Hors ligne

#5 17-10-2016 20:51:33

Mercredi
Membre
Distrib. : Testing
Noyau : 4.8
(G)UI : Gnome
Inscription : 25-09-2015

Re : (résolu) Gnome 3, méta-paquets, dépendances et "prise d'otage"...

Bonsoir,
Chez moi les méta paquets sont supprimés depuis pas mal de temps et pas de soucis (je fais ça avec Synaptic par contre).
Bon dé-Gnommage big_smile

Dernière modification par Mercredi (17-10-2016 20:52:34)


De toutes les forces de l'univers, la plus dure à surmonter, c'est la force de l'habitude. T.Pratchett - Trois Soeurcières.

Hors ligne

#6 17-10-2016 21:02:59

zorzi
Membre
Distrib. : Debian Jessie + Backports
Noyau : Linux 3.16.0-4-amd64
Inscription : 30-09-2015

Re : (résolu) Gnome 3, méta-paquets, dépendances et "prise d'otage"...

Ok, j'ai pu supprimer les méta-paquets sans encombres grâce au tuto fourni par Bendia.

Merci à tout le monde.

Desktop: HP Pavilion a6435 (Athlon64 2x 2,6Ghz, Radeon X1650 Pro, Ram 4 Go, DD 500 Go) / Debian Jessie (Gnome)
Laptop: Packard-Bell EasyNote G1320 (Celeron 1,3 Ghz, ATI Mobility Radeon 9100 IGP, Ram 1,2 Go, DD 40 Go) / Debian Jessie (Mate)

Hors ligne

#7 26-10-2016 21:12:15

zorzi
Membre
Distrib. : Debian Jessie + Backports
Noyau : Linux 3.16.0-4-amd64
Inscription : 30-09-2015

Re : (résolu) Gnome 3, méta-paquets, dépendances et "prise d'otage"...

Je réitère quand même ma question suite à certaines lectures sur le web:

L'absence des méta-paquets (gnome, gnome-core) ne peut-elle pas poser problème lors d'un dist-upgrade, ou d'une mise à jour de jessie à stretch par exemple (et oui je prépare l'avenir wink ) ?

Desktop: HP Pavilion a6435 (Athlon64 2x 2,6Ghz, Radeon X1650 Pro, Ram 4 Go, DD 500 Go) / Debian Jessie (Gnome)
Laptop: Packard-Bell EasyNote G1320 (Celeron 1,3 Ghz, ATI Mobility Radeon 9100 IGP, Ram 1,2 Go, DD 40 Go) / Debian Jessie (Mate)

Hors ligne

#8 26-10-2016 21:45:48

Frosch
Adhérent(e)
Lieu : Sion (CH)
Distrib. : Chakra
Noyau : Linux 4.5.7
(G)UI : Plasma 5.8
Inscription : 09-12-2015
Site Web

Re : (résolu) Gnome 3, méta-paquets, dépendances et "prise d'otage"...

Ben disons que tout ce que ça change, c'est s'il y a des paquets qui font nouvellement partie du meta-paquet gnome alors qu'ils n'y étaient pas dans Jessie, ils ne seront pas installés alors qu'ils le seraient si tu laisse le meta-paquet. Mais franchement, on s'en fiche. Sur openSUSE c'est le même problème, et j'ai toujours enlevé le meta-paquet.

Schokolade ist keine Lüge.

Hors ligne

#9 26-10-2016 22:01:24

Mercredi
Membre
Distrib. : Testing
Noyau : 4.8
(G)UI : Gnome
Inscription : 25-09-2015

Re : (résolu) Gnome 3, méta-paquets, dépendances et "prise d'otage"...

Bonsoir,
Fait l'essai il n'y a pas si longtemps Jessie -> dist-upgrade -> Testing avec des meta paquets de Gnome manquants car virés bien avant et pas eu de souci.

De toutes les forces de l'univers, la plus dure à surmonter, c'est la force de l'habitude. T.Pratchett - Trois Soeurcières.

Hors ligne

#10 27-10-2016 00:27:10

zorzi
Membre
Distrib. : Debian Jessie + Backports
Noyau : Linux 3.16.0-4-amd64
Inscription : 30-09-2015

Re : (résolu) Gnome 3, méta-paquets, dépendances et "prise d'otage"...

Ok, merci pour vos précisions.

A bientôt.

Desktop: HP Pavilion a6435 (Athlon64 2x 2,6Ghz, Radeon X1650 Pro, Ram 4 Go, DD 500 Go) / Debian Jessie (Gnome)
Laptop: Packard-Bell EasyNote G1320 (Celeron 1,3 Ghz, ATI Mobility Radeon 9100 IGP, Ram 1,2 Go, DD 40 Go) / Debian Jessie (Mate)

Hors ligne

Pied de page des forums