Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 19-10-2016 17:27:28

klosius
Membre
Distrib. : Jessie - 8.6
Noyau : Linux 3.16.0-4-amd64
Inscription : 03-09-2016

demarrer l'application "fichiers" en sudo

Bonsoir a tous

il y a une applications qui s'appelle "Fichiers" et j'aimerai bien accéder a des répertoires dont j'ai pas accès en tant que "user lamda".
dans un terminal j'y accède avec la commande sudo, mais en mode graphique comme faire?

merci d'avant de vos aides smile

Dernière modification par klosius (25-10-2016 17:41:12)


" il n'y a pas de question idiote, seulement une réponse idiote" Albert Einstein

Hors ligne

#2 19-10-2016 17:42:17

Frosch
Adhérent(e)
Lieu : Sion (CH)
Distrib. : Chakra
Noyau : Linux 4.5.7
(G)UI : Plasma 5.8
Inscription : 09-12-2015
Site Web

Re : demarrer l'application "fichiers" en sudo

Salut,

Tu peux utiliser gksu.
Une fois installé, crée un lanceur, et définis comme commande "gksudo nautilus".

Schokolade ist keine Lüge.

Hors ligne

#3 19-10-2016 17:52:43

klosius
Membre
Distrib. : Jessie - 8.6
Noyau : Linux 3.16.0-4-amd64
Inscription : 03-09-2016

Re : demarrer l'application "fichiers" en sudo

Merci Frosch,

donc, je supose,  il faut l'installer en premier
sudo apt-get install gksu
mais après...? créer un lanceur?

" il n'y a pas de question idiote, seulement une réponse idiote" Albert Einstein

Hors ligne

#4 19-10-2016 17:57:54

Mercredi
Membre
Distrib. : Testing
Noyau : 4.8
(G)UI : Gnome
Inscription : 25-09-2015

Re : demarrer l'application "fichiers" en sudo

Sinon il y a le paquet nautilus-admin dispo dans les backports.
Il ajoute une entrée "ouvrir en tant qu'administrateur" lors d'un clic droit sur un fichier dans Nautilus et demande le mot de passe admin.
À utiliser avec précautions et discernement bien sur wink

De toutes les forces de l'univers, la plus dure à surmonter, c'est la force de l'habitude. T.Pratchett - Trois Soeurcières.

Hors ligne

#5 19-10-2016 18:18:15

bendia
Admin stagiaire
Distrib. : Jessie
Noyau : 3.16.0-4-amd64
(G)UI : Gnome + XFCE + Console
Inscription : 20-03-2012
Site Web

Re : demarrer l'application "fichiers" en sudo

klosius a écrit :

mais après...? créer un lanceur?

C'est une idée le lanceur. Sinon, en console

gksu ton_application


Ben
___________________
La seule question bête, c'est celle qu'on ne pose pas.
file-Re06858991f6f328b4907296ac5cea283

En ligne

#6 19-10-2016 18:19:12

Frosch
Adhérent(e)
Lieu : Sion (CH)
Distrib. : Chakra
Noyau : Linux 4.5.7
(G)UI : Plasma 5.8
Inscription : 09-12-2015
Site Web

Re : demarrer l'application "fichiers" en sudo

klosius a écrit :

donc, je supose,  il faut l'installer en premier
sudo apt-get install gksu

Oui, c'est ça.

klosius a écrit :

mais après...? créer un lanceur?

Hmm, je ne suis pas certain comment on fait ça sous Gnome. Je pense à l'aide de menulibre ou alacarte.

Mais je pense que pour ce que tu veux faire, la solution proposée par Mercredi est la plus simple et la plus pratique smile


Schokolade ist keine Lüge.

Hors ligne

#7 19-10-2016 19:58:40

klosius
Membre
Distrib. : Jessie - 8.6
Noyau : Linux 3.16.0-4-amd64
Inscription : 03-09-2016

Re : demarrer l'application "fichiers" en sudo

Merci messieurs pour cette aide

j'ai finalement installé gksu

et démarrer nautilus en ligne de commande gksu nautilus

mais par curiausité je vais aussi essayer la methode Mercredi avec le packet nautilus-admin

Merci encore

" il n'y a pas de question idiote, seulement une réponse idiote" Albert Einstein

Hors ligne

#8 25-10-2016 17:33:18

klosius
Membre
Distrib. : Jessie - 8.6
Noyau : Linux 3.16.0-4-amd64
Inscription : 03-09-2016

Re : demarrer l'application "fichiers" en sudo

Bonsoir a tous,

je remarque  que, à chaque fois que j'utilise la commande gksu nautilus
j'ai un message
Gtk-Message: Failed to load module " canberra-gtk-module"

a quoi ça sert ce module? et comment l'activer?

merci encore

" il n'y a pas de question idiote, seulement une réponse idiote" Albert Einstein

Hors ligne

#9 25-10-2016 17:43:09

bendia
Admin stagiaire
Distrib. : Jessie
Noyau : 3.16.0-4-amd64
(G)UI : Gnome + XFCE + Console
Inscription : 20-03-2012
Site Web

Re : demarrer l'application "fichiers" en sudo

Salut smile

J'ai trouvé ça là http://www.linuxquestions.org/questions … le-936168/ avec https://www.qwant.com/?q=canberra-gtk-m … opensearch

Il semble manquer libcanberra-gtk3-module. C'était pour Wheezy ceci-dit, mais ça vaut le coup de voir si ce paquet est installé

apt-cache policy libcanberra-gtk3-module


Ben
___________________
La seule question bête, c'est celle qu'on ne pose pas.
file-Re06858991f6f328b4907296ac5cea283

En ligne

#10 26-10-2016 10:06:55

klosius
Membre
Distrib. : Jessie - 8.6
Noyau : Linux 3.16.0-4-amd64
Inscription : 03-09-2016

Re : demarrer l'application "fichiers" en sudo

Merci Bendia, oui ce module est bien installé.

si je pose toutes ses questions c'est que, au final j'aimerai, en me connectant a distance via ssh avec mon user klosius, qui fait parti du groupe sudo, pouvoir visionner de jpg dans un répertoire  que klosius n'a pas accès.

en local j'ouvre le répertoire en utilisant le gksu nautilus, il le demarrer en root et hop g accès a tout.


mais a distance , en installant xming , je démarre le nautilus, c'est nikel mais j'arrive pas a accèder au réertoire en question alors je fait un gksu nautilus et la il me demande le mot de passe administrateur mais j'ai beau écrire le mot de passe mais rien s'affiche, même pas des ***** , j'essai quand meme et après il y a une erreur "echec lors de la communication avec gksu-run-helper ...

alors peut-être en accédant au répertoire en question en sudo en ligne de commande puis ouvrir le fichier jpg directement sans passer par nautilus... mais comment ouvrir un fichier jpg en ligne de commande?

désolé si mes explications partent dans tous les sens sad

Dernière modification par klosius (26-10-2016 10:09:29)


" il n'y a pas de question idiote, seulement une réponse idiote" Albert Einstein

Hors ligne

#11 26-10-2016 10:16:41

greenmerlin
Membre
Lieu : 127.0.0.1
Distrib. : Archlinux/TinycoreLinux(CorePure 64-6.4.1)/Jessie
Noyau : 4.2.2-1 / 4.4
(G)UI : wmaker
Inscription : 23-01-2016

Re : demarrer l'application "fichiers" en sudo

Bonjour,

oui c'est normal.

Essaye de configurer gksu pour qu'il utilise su à la place de sudo

gksu-properties



@+


" La plus importante et la plus négligée de toutes les conversations, c'est l'entretien avec soi-même. "
Chancelier Oxenstiern.

536920766f7573206172726976657220c3a0206c69726520c3a7612c20632765737420717565206e6f757320706172746167656f6e73206c6573206dc3aa6d65732063656e747265732064e28099696e74c3a972c3aa74732e

Hors ligne

#12 26-10-2016 10:36:58

klosius
Membre
Distrib. : Jessie - 8.6
Noyau : Linux 3.16.0-4-amd64
Inscription : 03-09-2016

Re : demarrer l'application "fichiers" en sudo

merci greenmerlin,
mais il y est déjà en su
j'ai aussi essayé en sudo mais ça ne fonctionne pas non plus

" il n'y a pas de question idiote, seulement une réponse idiote" Albert Einstein

Hors ligne

#13 26-10-2016 10:46:53

greenmerlin
Membre
Lieu : 127.0.0.1
Distrib. : Archlinux/TinycoreLinux(CorePure 64-6.4.1)/Jessie
Noyau : 4.2.2-1 / 4.4
(G)UI : wmaker
Inscription : 23-01-2016

Re : demarrer l'application "fichiers" en sudo

re,

ouvre un terminal depuis ton waindows^$ en utilsant xming puis

xhost +

dans le terminal

puis
lance lance nautilus avec gksu dans ce meme terminal

je crois savoir ce que c'est


" La plus importante et la plus négligée de toutes les conversations, c'est l'entretien avec soi-même. "
Chancelier Oxenstiern.

536920766f7573206172726976657220c3a0206c69726520c3a7612c20632765737420717565206e6f757320706172746167656f6e73206c6573206dc3aa6d65732063656e747265732064e28099696e74c3a972c3aa74732e

Hors ligne

#14 26-10-2016 11:08:52

klosius
Membre
Distrib. : Jessie - 8.6
Noyau : Linux 3.16.0-4-amd64
Inscription : 03-09-2016

Re : demarrer l'application "fichiers" en sudo

alors,
1. j'ai démarrer un terminal avec la commande xterm
2. j'ai écris xhost + mais j'ai une erreur: access control desabled, clients can connect from any host (c'est quoi cette commande "xhost +"?
3, j'ai quand méme démarrer le nautilus en gksu, il démarre bien nautilus en root après avoir mis le mot de passe et j'arrive a y accéder au répertoire  en question, ça marche smile par contre sur la fenêtre du terminal a chaque fois que je changer de répertoire ou de fichier j'ai des erreurs.

" il n'y a pas de question idiote, seulement une réponse idiote" Albert Einstein

Hors ligne

#15 26-10-2016 11:33:34

bendia
Admin stagiaire
Distrib. : Jessie
Noyau : 3.16.0-4-amd64
(G)UI : Gnome + XFCE + Console
Inscription : 20-03-2012
Site Web

Re : demarrer l'application "fichiers" en sudo

Et sinon, régler les droits pour que tu ais accès sans les droits root, y'a pas moyen ?

Ben
___________________
La seule question bête, c'est celle qu'on ne pose pas.
file-Re06858991f6f328b4907296ac5cea283

En ligne

#16 26-10-2016 12:05:10

greenmerlin
Membre
Lieu : 127.0.0.1
Distrib. : Archlinux/TinycoreLinux(CorePure 64-6.4.1)/Jessie
Noyau : 4.2.2-1 / 4.4
(G)UI : wmaker
Inscription : 23-01-2016

Re : demarrer l'application "fichiers" en sudo

klosius a écrit :

avoir mis le mot de passe et j'arrive a y accéder au répertoire  en question, ça marche smile



j'en conclu que ça fonctionne.

klosius a écrit :

access control disabled, clients can connect from any host



Ce n'est pas un message d'erreur smile

En ce qui concerne la commande xhosts + je te fait un petit RTFM m'en veux pas

http://www.linux-tutorial.info/modules. … pps-6.html

et pour finir les messages que tu vois dans ton xterm ne sont pas des messages d'erreurs mais plutôt des informations qui servent à ceux qui développe en Gtk.

@+


" La plus importante et la plus négligée de toutes les conversations, c'est l'entretien avec soi-même. "
Chancelier Oxenstiern.

536920766f7573206172726976657220c3a0206c69726520c3a7612c20632765737420717565206e6f757320706172746167656f6e73206c6573206dc3aa6d65732063656e747265732064e28099696e74c3a972c3aa74732e

Hors ligne

#17 26-10-2016 12:18:00

crousti
Membre
Distrib. : debian testing/sid
Noyau : Linux 4.3.0-1-686-pae
(G)UI : dwm, fluxbox ou lxde
Inscription : 20-11-2015

Re : demarrer l'application "fichiers" en sudo

Salut , il existe des scripts pour nautilus.
http://g-scripts.sourceforge.net/cat-executing.php
ça me parrait plus simple

Le script en question à placer dans .local/share/nautilus/scripts/

#!/bin/bash

#Open nautilus as root in your home directory
##########################################################################
#                 Nautilus "OpenAsRoot" Script                #
##########################################################################
#                                                                        #
# Created by GnomaS&TrolaS                                                   #
# Emails: kmgkara@abv.bg                                 #
#                                                                        #
##########################################################################
#----language setting-------------------------------------#

gksu nautilus $NAUTILUS_SCRIPT_CURRENT_URI

Dernière modification par crousti (26-10-2016 12:27:24)

Hors ligne

#18 26-10-2016 17:58:07

leonlemouton
Adhérent(e)
Distrib. : Jessie
Noyau : Linux 3.16.0-4-686-pae
(G)UI : Mate 1.8.1
Inscription : 14-08-2012

Re : demarrer l'application "fichiers" en sudo

Bonsoir,
Sinon il y a gnome-commander qui propose une fonction ouvrir en tant que root par défaut je crois.

Leonlemouton
°(")°

Hors ligne

Pied de page des forums