Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 14-07-2009 15:54:52

jrev
Membre
Distrib. : Lenny
Noyau : 2.6.26-2-686
(G)UI : LXDE
Inscription : 28-04-2009

Connexion lenny lxde à l'Internet (résolu)

Bonjour,

Je viens d'installer la lenny sur un PC de RAM 86Mo et cherche à passer la première commande pour me connecter au net.

Il ne répond pas à la commande

lspci | grep ethernet


ifconfig ne passe pas non plus. J'ai bien un eth1 je crois alors

[large]quelle est la première commande à passer pour reconnaître les lieux ?[/large]
Le ping ne passe pas. Élémentaire mon cher Smolsky ...

Je suis toujours en IP fixes et il me semble que toute la connexion se configure à la main dans le fichier /etc/network/interfaces.

Merci pour votre petit coup de pouce:)

Dernière modification par jrev (15-07-2009 14:00:57)


Ubuntu 10.04,  Debian lxde 6.0.0

Hors ligne

#2 14-07-2009 17:00:10

smolski
administrateur quasi...modo
Lieu : AIN
Distrib. : 8 (jessie) 64 bits + backports
Noyau : 4.6.0-0.bpo.1-amd64
(G)UI : gnome 3.14.1
Inscription : 21-10-2008

Re : Connexion lenny lxde à l'Internet (résolu)

Yop jrev,

Pas de ifconfig..?
Il y a une carte réseau sur ton truc ?

C'est une install depuis un cd rom et non par netinstall ? I presum, sir..?

as-tu lu la configuration reseau à la mano ici :
http://debian-facile.org/wiki/commande: … ion-reseau

My name is james... James Bond...

Amitié, Joel

Dernière modification par smolski (14-07-2009 17:59:14)


"Définition d'eric besson : S'il fallait en chier des tonnes pour devenir ministre, il aurait 2 trous du cul." - JP Douillon
"L'utopie ne signifie pas l'irréalisable, mais l'irréalisée." - T Monod (source :  La zone de Siné)
"Je peux rire de tout mais pas avec n'importe qui." - P Desproges
"saque eud dun" (patois chtimi : fonce dedans)

En ligne

#3 15-07-2009 06:26:40

jrev
Membre
Distrib. : Lenny
Noyau : 2.6.26-2-686
(G)UI : LXDE
Inscription : 28-04-2009

Re : Connexion lenny lxde à l'Internet (résolu)

Tout d'abord je préfère configurer la connexion à la Debian et éviter les GUI's défectueux.
J'ai suivi ton lien et ai une remarque :
Il est impossible que deux modules Ethernet0 et 1 aient la même adresse machine donc modifier l'une des deux serait plus logique.

D'autre part, il serait intéressant d'indiquer que cette commande ifconfig est passée pour découvrir s'il y a des modules Ethernet et s'ils sont reconnus et équipés du pilote adéquat.
Il serait bon de faire un renvoi pour la marche à suivre dans le cas où il faut installer le pilote, ce qui est mon cas aujourd'hui sur une machine un peu ancienne.
Les nouvelles versions du noyau ont du mettre ce vieux pilote à la retraite.

J'avais oublié dans mon premier post une caractéristique de Debian de ne pas fournir à l'utilisateur le résultat de la commande "ifconfig"

Dernière modification par jrev (15-07-2009 06:32:43)


Ubuntu 10.04,  Debian lxde 6.0.0

Hors ligne

#4 15-07-2009 07:17:01

smolski
administrateur quasi...modo
Lieu : AIN
Distrib. : 8 (jessie) 64 bits + backports
Noyau : 4.6.0-0.bpo.1-amd64
(G)UI : gnome 3.14.1
Inscription : 21-10-2008

Re : Connexion lenny lxde à l'Internet (résolu)

jrev écrit :

Il est impossible que deux modules Ethernet0 et 1 aient la même adresse machine donc modifier l'une des deux serait plus logique.


Oui, toutafé jrev... wink
Aussi, je configure l'une en static pour mon reseau local, et l'autre en dhcp... pour la connection internet. cool
Je cours donc illico l'indiquer dans le tuto pour la clarté du débat, merci ! big_smile

Et encore :

cette commande ifconfig est passée pour découvrir s'il y a des modules Ethernet et s'ils sont reconnus et équipés du pilote adéquat.


Je pense que ifconfig est utilisée pour indiquer la configuration actuelle du reseau.
Si il n'y a pas de connection, ifconfig est silencieux, puisqu'il n'y a pas de connection... hein ?

J'en déduis, mon cher Watson, que ifconfig est une commande pour reseau et pilote en état de marche et qu'il n'est que périphérique à son action d'indiquer si un pilote adéquate est installé, un câble branché et le thé servi... Is'nt ?

Friendly, Jojo The Bad Gy...

Dernière modification par smolski (15-07-2009 07:18:33)


"Définition d'eric besson : S'il fallait en chier des tonnes pour devenir ministre, il aurait 2 trous du cul." - JP Douillon
"L'utopie ne signifie pas l'irréalisable, mais l'irréalisée." - T Monod (source :  La zone de Siné)
"Je peux rire de tout mais pas avec n'importe qui." - P Desproges
"saque eud dun" (patois chtimi : fonce dedans)

En ligne

#5 15-07-2009 08:30:56

jrev
Membre
Distrib. : Lenny
Noyau : 2.6.26-2-686
(G)UI : LXDE
Inscription : 28-04-2009

Re : Connexion lenny lxde à l'Internet (résolu)

Débranche ton câble réseau et tu verras que ifconfig  te donne la même indication
Déconnecte ta carte réseau et tu verras que ifconfig ne t'indiquera que la boucle locale et pas la ligne commençant par "etho".
insère une carte réseau qui n'est pas reconnue par le noyau et tu auras le même résultat. smile

Ubuntu 10.04,  Debian lxde 6.0.0

Hors ligne

#6 15-07-2009 09:50:32

smolski
administrateur quasi...modo
Lieu : AIN
Distrib. : 8 (jessie) 64 bits + backports
Noyau : 4.6.0-0.bpo.1-amd64
(G)UI : gnome 3.14.1
Inscription : 21-10-2008

Re : Connexion lenny lxde à l'Internet (résolu)

Aaaaaaah Aux echecs, la défense sicilienne est une ouverture des plus intéressante... Toujours inattendue quand à l'issue qui sera choisi au final !

Ainsi en est-il de ta réponse jrev... a écrit :

Débranche ton câble réseau et tu verras que ifconfig  te donne la même indication


Et ben non, ifconfig ne donne aucune ip, broadcoast ou masque si le câble est débranché de la carte sous dhcp...

Seule la ligne static, configurée à la mano, conserve son intégrité, logique... Is'nt ?

De même, qu'une carte reseau non installée OU non reconnue ne donne aucun eth n'est pas des plus inattendus... cool

Comme je l'indiquais dans mon post, il me semble que cet état de fait est "périphérique" à la commande ifconfig.

C'est à dire que c'est par déduction de cette absence d'eth que l'on peu dire que la carte n'est ni reconnue OU ni insérée...

Pour le thé, je dois faire des essais... Yop !

Clic, le blitz est à toi... tic, tac... tic, tac...

Tchibâââ ! lol

Dernière modification par smolski (15-07-2009 10:21:43)


"Définition d'eric besson : S'il fallait en chier des tonnes pour devenir ministre, il aurait 2 trous du cul." - JP Douillon
"L'utopie ne signifie pas l'irréalisable, mais l'irréalisée." - T Monod (source :  La zone de Siné)
"Je peux rire de tout mais pas avec n'importe qui." - P Desproges
"saque eud dun" (patois chtimi : fonce dedans)

En ligne

#7 15-07-2009 13:37:02

jrev
Membre
Distrib. : Lenny
Noyau : 2.6.26-2-686
(G)UI : LXDE
Inscription : 28-04-2009

Re : Connexion lenny lxde à l'Internet (résolu)

Ta sicilienne est valable pour DHCP puisque tu le dis.

En ce qui me concerne pour la carte non reconnue je l'ai échangée contre celle d'un PC qui en avait deux.
C'est je pense plus simple qu'un tripotage du noyau. D'autre part une nouvelle carte Ethernet doit coûter dans les 10 euros... avec de bonnes chances de reconnaissance par les noyaux récents

Tout de même on pourrait peut-être indiquer dans le wiki, si le cas se présente, les commandes suivantes destinées à valider un pilote au reboot :

#lspci | grep Ethernet
locate .ko | grep code de la carte
#nano /etc/modules


Et ainsi ajouter un module au démarrage si la carte Ethernet n'est pas reconnue.

J'ai ainsi fait reconnaître une carte SIS900 en chargeant son module sous ubuntu.

Ma conclusion : c'est bien par la commande "ifconfig" qu'il faut démarrer pour configurer la connexion Internet.
Puis configurer le connexion dans "/etc/network/interfaces"
Merci pour cet échange  ...

Dernière modification par jrev (15-07-2009 14:11:28)


Ubuntu 10.04,  Debian lxde 6.0.0

Hors ligne

#8 21-07-2009 04:57:03

smolski
administrateur quasi...modo
Lieu : AIN
Distrib. : 8 (jessie) 64 bits + backports
Noyau : 4.6.0-0.bpo.1-amd64
(G)UI : gnome 3.14.1
Inscription : 21-10-2008

Re : Connexion lenny lxde à l'Internet (résolu)

Ho ho jvrev,

Merci à toi de nous aider à voir plus clair dans les tutos...
jrev a écrit :

Tout de même on pourrait peut-être indiquer dans le wiki, si le cas se présente, les commandes suivantes destinées à valider un pilote au reboot :

#lspci | grep Ethernet
    locate .ko | grep code de la carte
    #nano /etc/modules


Et ainsi ajouter un module au démarrage si la carte Ethernet n'est pas reconnue.


Là, je ne comprends pas ce que tu indiques entre le listage par lspci... et l'écriture par nano... queue j'aimerai plus explicité, genre :
pourquoi faire :

#lspci | grep Ethernet


sous root ?
et :

locate .ko | grep code de la carte


C'est quoi ? Le résultat de la commande précédente ?
et :

#nano /etc/modules


Ben que fait-on après l'ouverture de cet éditeur ? On écrit quoi ?

Bien sûr, un débianeux tellement averti que moi a tout compris... hum hum hum... Mais fait comme si j'étais un neuneu voir un peu... roll

En tant que membre, tu peux mettre l'ajout tel que tu le percois dans le forum Docuwiki (compléter si le sujet est déjà présent, sinon, nouvelle discussion...), et même aussi dans le wiki concerné s'il existe ! Ouep mon gars...

Les petites zabeilles redactos seront là, auprès de toi, pour en arranger le pollen si nécessaire et fabriquer ainsi le miel pour tous ! big_smile

Bzzz bzzz bzzz, Joel

Dernière modification par smolski (21-07-2009 05:04:38)


"Définition d'eric besson : S'il fallait en chier des tonnes pour devenir ministre, il aurait 2 trous du cul." - JP Douillon
"L'utopie ne signifie pas l'irréalisable, mais l'irréalisée." - T Monod (source :  La zone de Siné)
"Je peux rire de tout mais pas avec n'importe qui." - P Desproges
"saque eud dun" (patois chtimi : fonce dedans)

En ligne

Pied de page des forums