Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 17-11-2016 20:15:46

robert2a
Membre
Lieu : France
Distrib. : Stretch
Noyau : Linux 4.8.0-1-amd64
(G)UI : Mate 1.16.1
Inscription : 15-11-2014

[info] steam et driver non free nvidia 367.xx

Bonsoir

sur l installation de steam sur stretch + gnome j'ai eu un probleme avec le driver non free nvidia des dépots debian
il y a un paquet libgl1-nvidia-glx qui est remplacé par un paquet libgl1-glvnd-nvidia-glx
avec le second steam ne fonctionne pas ( erreur fichier .so manquant peut etre un rapport avec le 32 et 64 )
j'avais bien le driver avec les paquets 64 et i386
l'installation du premier (désinstallation du second ) a résolu le probleme

je ne connais pas encore la différence entre ces 2 paquets (les deux restent présent sur les serveurs debian )

si quelqu un a ce probleme roll


libgl1-nvidia-glx
These binary libraries provide optimized hardware acceleration of OpenGL applications via a direct-rendering X Server.
 



libgl1-glvnd-nvidia-glx
This package contains a libGL.so.1 stub that dispatches to vendor implementations via GLVND
 



je trouverai une réponse si je découvre ce qu'est "implementations via GLVND"

ça reste technique tongue  roll



https://devtalk.nvidia.com/default/topic/915640/unix-graphics-announcements-and-news/multiple-glx-client-libraries-in-the-nvidia-linux-driver-installer-package/

https://www.x.org/wiki/Events/XDC2016/Program/xdc-2016-glvnd-status.pdf

 

Dernière modification par robert2a (17-11-2016 20:34:14)

Hors ligne

#2 23-11-2016 01:09:43

robert2a
Membre
Lieu : France
Distrib. : Stretch
Noyau : Linux 4.8.0-1-amd64
(G)UI : Mate 1.16.1
Inscription : 15-11-2014

Re : [info] steam et driver non free nvidia 367.xx

Bonsoir

une petite info sur le driver nvidia qui passe de 367.57-1 a 367.57-2 a cause d un bug sur le noyau 4.9


nvidia-graphics-drivers (367.57-2) unstable; urgency=medium

  [ Luca Boccassi ]
  * Add nvidia-user-pages.patch to fix nvidia kernel module build failure
    for Linux 4.9.

 -- Andreas Beckmann <anbe@debian.org>  Fri, 11 Nov 2016 14:58:38 +0100
 



le noyau 4.9 ne devrait pas tarder  roll

je me suis pas trompé sur la signification du message ?

Hors ligne

Pied de page des forums