Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 19-11-2016 20:55:06

hotwater
Membre
Inscription : 19-11-2016

[résolu] Problème avec FIREFOX

Bonjour,

Je viens d'installer HANDYLINUX sur un pc portable Aurora de chez ldlc.

sur certains sites, comme 20minutes.fr,  Firefox plante et se ferme de suite. voila les messages d'erreur:


libGL error: pci id for fd 94: 8086:1906, driver (null)
ATTENTION: default value of option force_s3tc_enable overridden by environment.
[intel_init_bufmgr:1068] Error initializing buffer manager.
libGL error: failed to create dri screen
libGL error: failed to load driver: i965
ATTENTION: default value of option force_s3tc_enable overridden by environment.
LLVM ERROR: Cannot select: intrinsic %llvm.x86.sse41.pblendvb

 



un problème avec ma carte graphique???
en cherchant un peu, j'ai vu que certains avaient des problèmes avec le noyau 3.16. Je suis donc passé au noyau 4.7.0-0.bpo.1-amd64.

merci de votre aide

Dernière modification par hotwater (20-11-2016 20:04:43)

Hors ligne

#2 19-11-2016 22:18:32

èfpé
Membre
Inscription : 10-07-2016

Re : [résolu] Problème avec FIREFOX

Bonsoir et bienvenue hotwater smile

Il y a effectivement un petit souci avec OpenGL ; as-tu upgradé ou installé d'autres paquets que linux-image-amd64 ? Que retournent les commandes :

lspci -nn | grep -i vga


apt-cache policy xserver-xorg-video-intel firmware-misc-nonfree libgl1-mesa-glx libgl1-mesa-dri


Pourrais-tu par ailleurs préciser le modèle exact du portable ?

Hors ligne

#3 19-11-2016 22:19:09

robert2a
Membre
Lieu : France
Distrib. : Stretch 9
Noyau : Linux 4.9.0-3 4.9.30-2
(G)UI : Mate
Inscription : 15-11-2014

Re : [résolu] Problème avec FIREFOX

pour confirmer un probleme vidéo , décoche dans les parametres de firefox "utiliser l'acceleration graphique si disponible" dans l'onglet "avancé => général "

voir si ça bug toujours , a priori c'est un probleme de driver

ps: le driver xserver-xorg-video-intel peut etre pas nécessaire , le noyau 4.7 prend en charge les gpu intel récent


L'utilisation de ce pilote est déconseillée si la version de hw est récente
(à partir de 2007, environ). Il est possible de désinstaller ce pilote et
laisser le serveur utiliser à la place son pilote intégré modesetting.
 


et ça fonctionne plutot bien

Dernière modification par robert2a (19-11-2016 22:24:38)

Hors ligne

#4 19-11-2016 22:37:18

hotwater
Membre
Inscription : 19-11-2016

Re : [résolu] Problème avec FIREFOX

re,

J'ai désactivé l'accélération matériel dans firefox et j'ai tjs le problème.
Quand j'ai upgradé j'ai installé :  xserver-xorg-video-intel firmware-misc-nonfree firmware-realtek firmware-iwlwifi


 lspci -nn | grep -i vga
00:02.0 VGA compatible controller [0300]: Intel Corporation Device [8086:1906] (rev 07)
 




apt-cache policy xserver-xorg-video-intel firmware-misc-nonfree libgl1-mesa-glx libgl1-mesa-dri
xserver-xorg-video-intel:
  Installé : (aucun)
  Candidat : 2:2.21.15-2+b2
 Table de version :
     2:2.99.917+git20160706-1 0
        100 /var/lib/dpkg/status
     2:2.99.917+git20160706-1~bpo8+1 0
        100 http://ftp.debian.org/debian/ jessie-backports/main amd64 Packages
     2:2.21.15-2+b2 0
        500 http://httpredir.debian.org/debian/ jessie/main amd64 Packages
firmware-misc-nonfree:
  Installé : 20160824-1~bpo8+1
  Candidat : 20160824-1~bpo8+1
 Table de version :
 *** 20160824-1~bpo8+1 0
        100 http://ftp.debian.org/debian/ jessie-backports/non-free amd64 Packages
        100 /var/lib/dpkg/status
libgl1-mesa-glx:
  Installé : 10.3.2-1+deb8u1
  Candidat : 10.3.2-1+deb8u1
 Table de version :
     12.0.4-2~bpo8+1 0
        100 http://ftp.debian.org/debian/ jessie-backports/main amd64 Packages
 *** 10.3.2-1+deb8u1 0
        500 http://httpredir.debian.org/debian/ jessie/main amd64 Packages
        100 /var/lib/dpkg/status
libgl1-mesa-dri:
  Installé : 10.3.2-1+deb8u1
  Candidat : 10.3.2-1+deb8u1
 Table de version :
     12.0.4-2~bpo8+1 0
        100 http://ftp.debian.org/debian/ jessie-backports/main amd64 Packages
 *** 10.3.2-1+deb8u1 0
        500 http://httpredir.debian.org/debian/ jessie/main amd64 Packages
        100 /var/lib/dpkg/status
 



Le portable est un LDLC Aurore PC5-2-S1  avec Intel HD Graphics 510 comme carte graphique

Hors ligne

#5 19-11-2016 22:50:08

èfpé
Membre
Inscription : 10-07-2016

Re : [résolu] Problème avec FIREFOX

Re-,

Il semble que le paquet xserver-xorg-video-intel n'est pas installé que donne donc

 lspci -nnk | grep -iA 2 vga


À voir s'il serait pertinent d'upgrader libgl1-mesa-dri et libgl1-mesa-glx ?

Dernière modification par èfpé (19-11-2016 23:14:08)

Hors ligne

#6 19-11-2016 22:55:34

hotwater
Membre
Inscription : 19-11-2016

Re : [résolu] Problème avec FIREFOX

lspci -nnk | grep -iA 2 vga
00:02.0 VGA compatible controller [0300]: Intel Corporation Device [8086:1906] (rev 07)
  Subsystem: CLEVO/KAPOK Computer Device [1558:2425]
  Kernel driver in use: i915
 




Je dois installer xserver-xorg-video-intel  ?

Hors ligne

#7 19-11-2016 23:02:04

hotwater
Membre
Inscription : 19-11-2016

Re : [résolu] Problème avec FIREFOX

ça a l'air de fonctionner en faisant l'upgrade de :  libgl1-mesa-dri et libgl1-mesa-glx

sudo apt-get -t jessie-backports install libgl1-mesa-dri libgl1-mesa-glx



merci !!!!  big_smile:D:D:D

Hors ligne

#8 19-11-2016 23:08:24

èfpé
Membre
Inscription : 10-07-2016

Re : [résolu] Problème avec FIREFOX

Re-,

Bon ben il n'y a plus qu'à indiquer '[Résolu] ' dans le titre de ton premier message... j'étais en train de répondre au post #6 mais je réponds au suivant du coup big_smile

Hors ligne

Pied de page des forums