Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 20-11-2016 17:03:02

Blogus
Membre
Lieu : Au pied de l'arbre...
Distrib. : DFLinux ou Handylinux selon l'humeur
Noyau : 3.16.0-4-amd64
(G)UI : Xfce
Inscription : 17-09-2016

Google Earth : erreur lors de l'installation

Bonjour,

Je tente d'installation google earth sur un pc amd64 avec la méthode de chalu qui a fait ses preuves ( https://debian-facile.org/viewtopic.php … 0#p199650) mais dans le cas présent j'ai une erreur :

Préparation du dépaquetage de googleearth_6.0.3.2197+1.2.0-1_amd64.deb ...
Dépaquetage de googleearth (6.0.3.2197+1.2.0-1) ...
dpkg: des problèmes de dépendances empêchent la configuration de googleearth :
 googleearth dépend de libgl1-mesa-glx:i386.

dpkg: erreur de traitement du paquet googleearth (--install) :
 problèmes de dépendances - laissé non configuré
Traitement des actions différées (« triggers ») pour mime-support (3.58) ...
Traitement des actions différées (« triggers ») pour gnome-menus (3.13.3-6) ...
Traitement des actions différées (« triggers ») pour desktop-file-utils (0.22-1) ...
Traitement des actions différées (« triggers ») pour shared-mime-info (1.3-1) ...
Unknown media type in type 'all/all'
Unknown media type in type 'all/allfiles'
Unknown media type in type 'uri/mms'
Unknown media type in type 'uri/mmst'
Unknown media type in type 'uri/mmsu'
Unknown media type in type 'uri/pnm'
Unknown media type in type 'uri/rtspt'
Unknown media type in type 'uri/rtspu'
[b]Des erreurs ont été rencontrées pendant l'exécution :
 googleearth[/b]



En effet google earth ne s'exécute pas.

J'ai bien un paquet libgl1-mesa-glx dans synaptic

En faisant apt-get -f install  j'ai ceci :

Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances      
Lecture des informations d'état... Fait
Correction des dépendances... Fait
Les paquets suivants ont été installés automatiquement et ne sont plus nécessaires :
  at libbsd0:i386 libcurl3:i386 libdrm-intel1:i386 libdrm-nouveau2:i386
  libdrm-radeon1:i386 libdrm2:i386 libedit2:i386 libelf1:i386 libfreeimage3
  libgcrypt20:i386 libgl1-mesa-dri:i386 libgpg-error0:i386
  libgssapi-krb5-2:i386 libidn11:i386 libk5crypto3:i386 libkeyutils1:i386
  libkrb5-3:i386 libkrb5support0:i386 libllvm3.5:i386 libpciaccess0:i386
  librtmp1:i386 libsigsegv2 libssh2-1:i386 libstdc++6:i386
  libtxc-dxtn-s2tc0:i386 libxt6:i386 lsb-core lsb-security m4 ncurses-term pax
  time
Veuillez utiliser « apt-get autoremove » pour les supprimer.
Les paquets suivants seront ENLEVÉS :
  googleearth
0 mis à jour, 0 nouvellement installés, 1 à enlever et 5 non mis à jour.
1 partiellement installés ou enlevés.
 


L'homme est le seul animal à penser qu'il n'est pas un animal

Hors ligne

#2 20-11-2016 17:47:57

chalu
Adhérent(e)
Lieu : Anjou
Distrib. : Debian Jessie (saveur Handylinux 2.5) à jour
Noyau : Linux 3.16.0-4-amd64
(G)UI : XFCE xfwm4
Inscription : 11-03-2016

Re : Google Earth : erreur lors de l'installation

Et si tu fais

apt-get -s install libgl1-mesa-glx:i386


Option -s pour faire juste une simulation de l'installation.


Bien débuter sur Debian :
->Les cahiers du débutant
->Le projet DFlinux (DebianFacileLinux) deux images ISOs (i386 et amd64) basées sur Debian stable et agrémentées d'outils facilitants pour les débutants

Hors ligne

#3 20-11-2016 17:54:43

Blogus
Membre
Lieu : Au pied de l'arbre...
Distrib. : DFLinux ou Handylinux selon l'humeur
Noyau : 3.16.0-4-amd64
(G)UI : Xfce
Inscription : 17-09-2016

Re : Google Earth : erreur lors de l'installation

Voilà :

Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances      
Lecture des informations d'état... Fait
Vous pouvez lancer « apt-get -f install » pour corriger ces problèmes :
Les paquets suivants contiennent des dépendances non satisfaites :
 libgl1-mesa-glx : Casse: libgl1-mesa-glx:i386 (!= 12.0.4-2~bpo8+1) mais 10.3.2-1+deb8u1 devra être installé
 libgl1-mesa-glx:i386 : Dépend: libglapi-mesa:i386 (= 10.3.2-1+deb8u1) mais ne sera pas installé
                        Dépend: libx11-xcb1:i386 mais ne sera pas installé
                        Dépend: libxcb-dri2-0:i386 (>= 1.8) mais ne sera pas installé
                        Dépend: libxcb-dri3-0:i386 mais ne sera pas installé
                        Dépend: libxcb-glx0:i386 (>= 1.8) mais ne sera pas installé
                        Dépend: libxcb-present0:i386 mais ne sera pas installé
                        Dépend: libxcb-sync1:i386 mais ne sera pas installé
                        Dépend: libxshmfence1:i386 mais ne sera pas installé
                        Dépend: libxxf86vm1:i386 mais ne sera pas installé
                        Dépend: libudev1:i386 mais ne sera pas installé
                        Casse: libgl1-mesa-glx (!= 10.3.2-1+deb8u1) mais 12.0.4-2~bpo8+1 devra être installé
E: Dépendances non satisfaites. Essayez « apt-get -f install » sans paquet
(ou indiquez une solution).
 


L'homme est le seul animal à penser qu'il n'est pas un animal

Hors ligne

#4 20-11-2016 18:31:10

Blogus
Membre
Lieu : Au pied de l'arbre...
Distrib. : DFLinux ou Handylinux selon l'humeur
Noyau : 3.16.0-4-amd64
(G)UI : Xfce
Inscription : 17-09-2016

Re : Google Earth : erreur lors de l'installation

Dans synaptic le paquet googleearth apparaît cassé .
Les propriétés suggèrent des paquets suivants (manquants ?) :

1479659346.png

À noter l'installation de la version 7 (via téléchargement .deb google) va à son terme normalement mais le champ "rechercher" n'étant pas fonctionnel...on en a déjà parlé wink

Dernière modification par Blogus (20-11-2016 18:32:43)


L'homme est le seul animal à penser qu'il n'est pas un animal

Hors ligne

#5 20-11-2016 18:51:32

chalu
Adhérent(e)
Lieu : Anjou
Distrib. : Debian Jessie (saveur Handylinux 2.5) à jour
Noyau : Linux 3.16.0-4-amd64
(G)UI : XFCE xfwm4
Inscription : 11-03-2016

Re : Google Earth : erreur lors de l'installation

Casse: libgl1-mesa-glx:i386 (!= 12.0.4-2~bpo8+1)


Visiblement tu as la version des backports qui est déjà installé sans doute. Tu peux le vérifier

apt-cache policy libgl1-mesa-glx:i386



D'autre part :

Les paquets suivants ont été installés automatiquement et ne sont plus nécessaires :
  at libbsd0:i386 libcurl3:i386 libdrm-intel1:i386 libdrm-nouveau2:i386
  libdrm-radeon1:i386 libdrm2:i386 libedit2:i386 libelf1:i386 libfreeimage3
  libgcrypt20:i386 libgl1-mesa-dri:i386 libgpg-error0:i386
  libgssapi-krb5-2:i386 libidn11:i386 libk5crypto3:i386 libkeyutils1:i386
  libkrb5-3:i386 libkrb5support0:i386 libllvm3.5:i386 libpciaccess0:i386
  librtmp1:i386 libsigsegv2 libssh2-1:i386 libstdc++6:i386
  libtxc-dxtn-s2tc0:i386 libxt6:i386 lsb-core lsb-security m4 ncurses-term pax
  time
Veuillez utiliser « apt-get autoremove » pour les supprimer.
Les paquets suivants seront ENLEVÉS :
  googleearth
0 mis à jour, 0 nouvellement installés, 1 à enlever et 5 non mis à jour.


Tu aurais des paquets inutiles sur le système (avec prudence car il ne faudrait pas désinstaller quelque chose d'important !) et 5 paquets pas à jour ?

Les dépendances de googleearth sont les suivantes :

apt-cache depends googleearth


googleearth
  Dépend: fonts-liberation
  Dépend: libfreeimage3
  Dépend: lsb-core
  Dépend: libqtcore4
  Dépend: libgl1-mesa-glx
  Dépend: libglu1-mesa
  Dépend: libcurl3:i386
  Dépend: libsm6:i386
  Dépend: libfontconfig1:i386
  Dépend: libxt6:i386
  Dépend: libxrender1:i386
  Dépend: libxext6:i386
  Dépend: libgl1-mesa-glx:i386
  Dépend: libgl1-mesa-dri:i386


La procédure d'installation est basée sur les dépôts stables. Je pense que pour un autre paquet tu avais déjà installé  libgl1-mesa-glx:i386 des backports et que la procédure demande l'installation de  libgl1-mesa-glx du dépôt stable (par défaut). Si j'ai bon il faudrait installer le paquet des backports pour "être raccord"

apt-get -t jessie-backports install libgl1-mesa-glx


Mais bon je ne suis pas sûre de moi donc commence par vérifier

apt-cache policy libgl1-mesa-glx libgl1-mesa-glx:i386

Dernière modification par chalu (20-11-2016 20:29:27)


Bien débuter sur Debian :
->Les cahiers du débutant
->Le projet DFlinux (DebianFacileLinux) deux images ISOs (i386 et amd64) basées sur Debian stable et agrémentées d'outils facilitants pour les débutants

Hors ligne

#6 20-11-2016 20:06:02

Blogus
Membre
Lieu : Au pied de l'arbre...
Distrib. : DFLinux ou Handylinux selon l'humeur
Noyau : 3.16.0-4-amd64
(G)UI : Xfce
Inscription : 17-09-2016

Re : Google Earth : erreur lors de l'installation

apt-cache policy libgl1-mesa-glx:i386


donne

libgl1-mesa-glx:i386:
  Installé : (aucun)
  Candidat : 10.3.2-1+deb8u1
 Table de version :
     12.0.4-2~bpo8+1 0
        100 http://ftp.debian.org/debian/ jessie-backports/main i386 Packages
     10.3.2-1+deb8u1 0
        500 http://httpredir.debian.org/debian/ jessie/main i386 Packages
 



Les paquets superflus apparaissent après la commande apt-get -f install


apt-cache policy libgl1-mesa-glx libgl1-mesa-glx:i386


donne

libgl1-mesa-glx:
  Installé : 12.0.4-2~bpo8+1
  Candidat : 12.0.4-2~bpo8+1
 Table de version :
 *** 12.0.4-2~bpo8+1 0
        100 http://ftp.debian.org/debian/ jessie-backports/main amd64 Packages
        100 /var/lib/dpkg/status
     10.3.2-1+deb8u1 0
        500 http://httpredir.debian.org/debian/ jessie/main amd64 Packages
libgl1-mesa-glx:i386:
  Installé : (aucun)
  Candidat : 10.3.2-1+deb8u1
 Table de version :
     12.0.4-2~bpo8+1 0
        100 http://ftp.debian.org/debian/ jessie-backports/main i386 Packages
     10.3.2-1+deb8u1 0
        500 http://httpredir.debian.org/debian/ jessie/main i386 Packages
 


L'homme est le seul animal à penser qu'il n'est pas un animal

Hors ligne

#7 20-11-2016 20:12:34

chalu
Adhérent(e)
Lieu : Anjou
Distrib. : Debian Jessie (saveur Handylinux 2.5) à jour
Noyau : Linux 3.16.0-4-amd64
(G)UI : XFCE xfwm4
Inscription : 11-03-2016

Re : Google Earth : erreur lors de l'installation

C'est bien un souci de backports mais dans le sens que je pensais :
le paquet libgl1-mesa-glx vient bien des backports, il faut lui installer le paquet libgl1-mesa-glx:i386 des backports, on fait une simulation pour voir

apt-get -s -t jessie-backports install libgl1-mesa-glx:i386

Dernière modification par chalu (20-11-2016 20:28:52)


Bien débuter sur Debian :
->Les cahiers du débutant
->Le projet DFlinux (DebianFacileLinux) deux images ISOs (i386 et amd64) basées sur Debian stable et agrémentées d'outils facilitants pour les débutants

Hors ligne

#8 20-11-2016 20:24:29

Blogus
Membre
Lieu : Au pied de l'arbre...
Distrib. : DFLinux ou Handylinux selon l'humeur
Noyau : 3.16.0-4-amd64
(G)UI : Xfce
Inscription : 17-09-2016

Re : Google Earth : erreur lors de l'installation

 apt-get -s -t jessie-backports  libgl1-mesa-glx:i386
 


E: L'option « s » de la ligne de commande [d'origine -s] est inconnue.


L'homme est le seul animal à penser qu'il n'est pas un animal

Hors ligne

#9 20-11-2016 20:26:30

Blogus
Membre
Lieu : Au pied de l'arbre...
Distrib. : DFLinux ou Handylinux selon l'humeur
Noyau : 3.16.0-4-amd64
(G)UI : Xfce
Inscription : 17-09-2016

Re : Google Earth : erreur lors de l'installation


apt-get install -s -t jessie-backports libgl1-mesa-glx:i386
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances      
Lecture des informations d'
état... Fait
Certains paquets ne peuvent être installés. Ceci peut signifier
que vous avez demandé l'impossible, ou bien, si vous utilisez
la distribution unstable, que certains paquets n'
ont pas encore
été créés ou ne sont pas sortis d'Incoming.
L'
information suivante devrait vous aider à résoudre la situation :

Les paquets suivants contiennent des dépendances non satisfaites :
 libpam-systemd : Dépend: systemd (= 230-7~bpo8+2)
 udev : Casse: ifupdown (< 0.8.5~)
        Casse: ifupdown:i386 (< 0.8.5~)
        Casse: systemd (< 224-2)
E: Erreur, pkgProblem::Resolve a généré des ruptures, ce qui a pu être causé par les paquets devant être gardés en l'état.

Dernière modification par Blogus (20-11-2016 20:26:58)


L'homme est le seul animal à penser qu'il n'est pas un animal

Hors ligne

#10 20-11-2016 20:26:43

chalu
Adhérent(e)
Lieu : Anjou
Distrib. : Debian Jessie (saveur Handylinux 2.5) à jour
Noyau : Linux 3.16.0-4-amd64
(G)UI : XFCE xfwm4
Inscription : 11-03-2016

Re : Google Earth : erreur lors de l'installation

Ah oui zut j'ai oublié la commande lol

apt-get -s -t jessie-backports install libgl1-mesa-glx:i386



Edit : oh ne te précipite pas wink

Dernière modification par chalu (20-11-2016 20:28:12)


Bien débuter sur Debian :
->Les cahiers du débutant
->Le projet DFlinux (DebianFacileLinux) deux images ISOs (i386 et amd64) basées sur Debian stable et agrémentées d'outils facilitants pour les débutants

Hors ligne

#11 20-11-2016 20:28:41

Blogus
Membre
Lieu : Au pied de l'arbre...
Distrib. : DFLinux ou Handylinux selon l'humeur
Noyau : 3.16.0-4-amd64
(G)UI : Xfce
Inscription : 17-09-2016

Re : Google Earth : erreur lors de l'installation

Oui j'ai vu

apt-get install -s -t jessie-backports libgl1-mesa-glx:i386
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances      
Lecture des informations d'
état... Fait
Certains paquets ne peuvent être installés. Ceci peut signifier
que vous avez demandé l'impossible, ou bien, si vous utilisez
la distribution unstable, que certains paquets n'
ont pas encore
été créés ou ne sont pas sortis d'Incoming.
L'
information suivante devrait vous aider à résoudre la situation :

Les paquets suivants contiennent des dépendances non satisfaites :
 libpam-systemd : Dépend: systemd (= 230-7~bpo8+2)
 udev : Casse: ifupdown (< 0.8.5~)
        Casse: ifupdown:i386 (< 0.8.5~)
        Casse: systemd (< 224-2)
E: Erreur, pkgProblem::Resolve a généré des ruptures, ce qui a pu être causé par les paquets devant être gardés en l'état.


L'homme est le seul animal à penser qu'il n'est pas un animal

Hors ligne

#12 20-11-2016 20:35:59

chalu
Adhérent(e)
Lieu : Anjou
Distrib. : Debian Jessie (saveur Handylinux 2.5) à jour
Noyau : Linux 3.16.0-4-amd64
(G)UI : XFCE xfwm4
Inscription : 11-03-2016

Re : Google Earth : erreur lors de l'installation

Ok bon je vais passer le relais à d'autres hmm
Il faudrait sans doute savoir pourquoi tu as le paquet libgl1-mesa-glx installé depuis les backports et gérer la question des dépendances mais bon là j'ai vraiment peur de te faire faire des bêtises sur ton système...

Voilà ce que donne la commande de simulation sur mon système Handylinux-amd64 noyau 3.16 avec le paquet googleearth déjà installé

sudo apt-get -s -t jessie-backports install libgl1-mesa-glx:i386
[sudo] mot de passe pour chalu :      
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances      
Lecture des informations d'état... Fait
Les paquets supplémentaires suivants seront installés :
  libgl1-mesa-glx libglapi-mesa libglapi-mesa:i386 libgles1-mesa libgles2-mesa
Les paquets suivants seront mis à jour :
  libgl1-mesa-glx libgl1-mesa-glx:i386 libglapi-mesa libglapi-mesa:i386
  libgles1-mesa libgles2-mesa
6 mis à jour, 0 nouvellement installés, 0 à enlever et 145 non mis à jour.
Inst libgles2-mesa [10.3.2-1+deb8u1] (12.0.4-2~bpo8+1 Debian Backports:jessie-backports [amd64]) []
Inst libgles1-mesa [10.3.2-1+deb8u1] (12.0.4-2~bpo8+1 Debian Backports:jessie-backports [amd64]) []
Inst libgl1-mesa-glx [10.3.2-1+deb8u1] (12.0.4-2~bpo8+1 Debian Backports:jessie-backports [amd64]) [libgl1-mesa-glx:amd64 on libgl1-mesa-glx:i386] [libgl1-mesa-glx:i386 on libgl1-mesa-glx:amd64] [libgl1-mesa-glx:i386 ]
Inst libgl1-mesa-glx:i386 [10.3.2-1+deb8u1] (12.0.4-2~bpo8+1 Debian Backports:jessie-backports [i386]) []
Inst libglapi-mesa:i386 [10.3.2-1+deb8u1] (12.0.4-2~bpo8+1 Debian Backports:jessie-backports [i386]) [libglapi-mesa:amd64 on libglapi-mesa:i386] [libglapi-mesa:i386 on libglapi-mesa:amd64] [libglapi-mesa:amd64 ]
Inst libglapi-mesa [10.3.2-1+deb8u1] (12.0.4-2~bpo8+1 Debian Backports:jessie-backports [amd64])
Conf libglapi-mesa (12.0.4-2~bpo8+1 Debian Backports:jessie-backports [amd64])
Conf libglapi-mesa:i386 (12.0.4-2~bpo8+1 Debian Backports:jessie-backports [i386])
Conf libgles2-mesa (12.0.4-2~bpo8+1 Debian Backports:jessie-backports [amd64])
Conf libgles1-mesa (12.0.4-2~bpo8+1 Debian Backports:jessie-backports [amd64])
Conf libgl1-mesa-glx:i386 (12.0.4-2~bpo8+1 Debian Backports:jessie-backports [i386])
Conf libgl1-mesa-glx (12.0.4-2~bpo8+1 Debian Backports:jessie-backports [amd64])
 


Pas de lien avec systemd ou ifupdown qui restent à leur version du dépôt jessie.

Dernière modification par chalu (21-11-2016 22:04:50)


Bien débuter sur Debian :
->Les cahiers du débutant
->Le projet DFlinux (DebianFacileLinux) deux images ISOs (i386 et amd64) basées sur Debian stable et agrémentées d'outils facilitants pour les débutants

Hors ligne

#13 21-11-2016 19:41:04

Blogus
Membre
Lieu : Au pied de l'arbre...
Distrib. : DFLinux ou Handylinux selon l'humeur
Noyau : 3.16.0-4-amd64
(G)UI : Xfce
Inscription : 17-09-2016

Re : Google Earth : erreur lors de l'installation

Bonsoir un p'tit up svp...

Préparation du dépaquetage de googleearth_6.0.3.2197+1.2.0-1_amd64.deb ...
Dépaquetage de googleearth (6.0.3.2197+1.2.0-1) ...
dpkg: des problèmes de dépendances empêchent la configuration de googleearth :
 googleearth dépend de libgl1-mesa-glx:i386.


.....


L'homme est le seul animal à penser qu'il n'est pas un animal

Hors ligne

Pied de page des forums