Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 25-11-2016 15:50:05

Blogus
Membre
Lieu : Au pied de l'arbre...
Distrib. : DFLinux ou Handylinux selon l'humeur
Noyau : 3.16.0-4-amd64
(G)UI : Xfce
Inscription : 17-09-2016

[Résolu]Problème libgl1-mesa-glx:i386.

Bonjour

Debian 8.6 (DFlinux) Noyau : Linux 3.16.0-4-amd64

Voulant installé google earth, j'ai ceci :

Préparation du dépaquetage de googleearth_6.0.3.2197+1.2.0-1_amd64.deb ...
Dépaquetage de googleearth (6.0.3.2197+1.2.0-1) ...
dpkg: des problèmes de dépendances empêchent la configuration de googleearth :
 googleearth dépend de libgl1-mesa-glx:i386.



Puis :

apt-get -s install libgl1-mesa-glx:i386



Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances      
Lecture des informations d'état... Fait
Certains paquets ne peuvent être installés. Ceci peut signifier
que vous avez demandé l'impossible, ou bien, si vous utilisez
la distribution unstable, que certains paquets n'ont pas encore
été créés ou ne sont pas sortis d'Incoming.
L'information suivante devrait vous aider à résoudre la situation :

Les paquets suivants contiennent des dépendances non satisfaites :
 libgl1-mesa-glx:i386 : Dépend: libglapi-mesa:i386 (= 10.3.2-1+deb8u1) mais ne sera pas installé
 vlc : Dépend: libgl1-mesa-glx mais ne sera pas installé ou
                libgl1
       Recommande: vlc-plugin-notify (= 2.2.4-1~deb8u1) mais ne sera pas installé
       Recommande: vlc-plugin-samba (= 2.2.4-1~deb8u1) mais ne sera pas installé
E: Erreur, pkgProblem::Resolve a généré des ruptures, ce qui a pu être causé par les paquets devant être gardés en l'état.



En fait je me suis rendu compte que j'avais le paquet libgl1-mesa-glx installé depuis les backports !!
J'ai donc simulé :

apt-get -s -t jessie-backports install libgl1-mesa-glx:i386


Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances      
Lecture des informations d'état... Fait
Certains paquets ne peuvent être installés. Ceci peut signifier
que vous avez demandé l'impossible, ou bien, si vous utilisez
la distribution unstable, que certains paquets n'ont pas encore
été créés ou ne sont pas sortis d'Incoming.
L'information suivante devrait vous aider à résoudre la situation :

Les paquets suivants contiennent des dépendances non satisfaites :
 libpam-systemd : Dépend: systemd (= 230-7~bpo8+2)
 udev : Casse: ifupdown (< 0.8.5~)
        Casse: ifupdown:i386 (< 0.8.5~)
        Casse: systemd (< 224-2)
E: Erreur, pkgProblem::Resolve a généré des ruptures, ce qui a pu être causé par les paquets devant être gardés en l'état.



Bon, pour tout dire je me fous un peu de google earth mais j'aimerais comprendre ce qui se passe et réparer ce qui doit l'être smile

Dernière modification par Blogus (27-11-2016 12:53:53)


L'homme est le seul animal à penser qu'il n'est pas un animal

Hors ligne

#2 25-11-2016 15:59:44

chalu
Adhérent(e)
Lieu : Anjou
Distrib. : Debian Jessie (saveur Handylinux 2.5) à jour
Noyau : Linux 3.16.0-4-amd64
(G)UI : XFCE xfwm4
Inscription : 11-03-2016

Re : [Résolu]Problème libgl1-mesa-glx:i386.

Bonjour,
Ce message est en lien direct avec ce fil
Fallait-il créer un nouveau fil ?
Je n'ai toujours pas d'idée pour résoudre ton problème mais tu peux donner des infos sur tes versions des paquets systemd et ifupdown avec la commande :

apt-cache policy systemd ifupdown


Tu as raison de dire que tu veux réparer car pour avoir fait la même commande et ne pas avoir le même résultat, il doit y avoir un peu de bazar dans le système.

Que donne la commande donnée dans un autre fil par bendia :

bendia a écrit :

il faudrait voir tout ce qui a été installé et qui n'est pas en provenance des dépôts officiels avec

aptitude search '~S ~i !~ODebian !~o'
 


Si ça râle que aptitude n'est pas installé, il faudra le faire

Dernière modification par chalu (25-11-2016 16:01:38)


Bien débuter sur Debian :
->Les cahiers du débutant
->Le projet DFlinux (DebianFacileLinux) deux images ISOs (i386 et amd64) basées sur Debian stable et agrémentées d'outils facilitants pour les débutants

Hors ligne

#3 25-11-2016 16:27:47

Blogus
Membre
Lieu : Au pied de l'arbre...
Distrib. : DFLinux ou Handylinux selon l'humeur
Noyau : 3.16.0-4-amd64
(G)UI : Xfce
Inscription : 17-09-2016

Re : [Résolu]Problème libgl1-mesa-glx:i386.

Bonjour,

En absence de suite... j'ai pensé qu'il fallait créer un nouveau fil effectivement .
Comme je l'indique, en fait je me fous un peu de google earth mais je suis intéressé pour "réparer" ce qui doit l'être smile

apt-cache policy systemd ifupdown


systemd:
  Installé : 215-17+deb8u5
  Candidat : 215-17+deb8u5
 Table de version :
     230-7~bpo8+2 0
        100 http://ftp.debian.org/debian/ jessie-backports/main amd64 Packages
 *** 215-17+deb8u5 0
        500 http://httpredir.debian.org/debian/ jessie/main amd64 Packages
        100 /var/lib/dpkg/status
ifupdown:
  Installé : 0.7.53.1
  Candidat : 0.7.53.1
 Table de version :
     0.8.13~bpo8+1 0
        100 http://ftp.debian.org/debian/ jessie-backports/main amd64 Packages
 *** 0.7.53.1 0
        500 http://httpredir.debian.org/debian/ jessie/main amd64 Packages
        100 /var/lib/dpkg/status
 


Puis :

aptitude search '~S ~i !~ODebian !~o'


i   dropbox                         - cloud synchronization engine - CLI and Nau
i   libdvdcss2                      - library designed for accessing DVDs


L'homme est le seul animal à penser qu'il n'est pas un animal

Hors ligne

#4 27-11-2016 12:53:24

Blogus
Membre
Lieu : Au pied de l'arbre...
Distrib. : DFLinux ou Handylinux selon l'humeur
Noyau : 3.16.0-4-amd64
(G)UI : Xfce
Inscription : 17-09-2016

Re : [Résolu]Problème libgl1-mesa-glx:i386.

Bonjour,

J'ai réinstallé le système avec la version stable de DFlinux et installé Google Earth sans souci avec ta méthode cool : https://debian-facile.org/viewtopic.php … 50#p199650

L'homme est le seul animal à penser qu'il n'est pas un animal

Hors ligne

#5 27-11-2016 21:10:49

chalu
Adhérent(e)
Lieu : Anjou
Distrib. : Debian Jessie (saveur Handylinux 2.5) à jour
Noyau : Linux 3.16.0-4-amd64
(G)UI : XFCE xfwm4
Inscription : 11-03-2016

Re : [Résolu]Problème libgl1-mesa-glx:i386.

Bonsoir,
C'est radical comme méthode mais efficace lol

Bien débuter sur Debian :
->Les cahiers du débutant
->Le projet DFlinux (DebianFacileLinux) deux images ISOs (i386 et amd64) basées sur Debian stable et agrémentées d'outils facilitants pour les débutants

Hors ligne

#6 27-11-2016 21:18:46

Blogus
Membre
Lieu : Au pied de l'arbre...
Distrib. : DFLinux ou Handylinux selon l'humeur
Noyau : 3.16.0-4-amd64
(G)UI : Xfce
Inscription : 17-09-2016

Re : [Résolu]Problème libgl1-mesa-glx:i386.

Oui ! smile... c'est la sortie cette nuit de la version stable qui m'a décidé...
En fait ça m'a pris 1 heure tout compris. J'avais sauvegardé tout ce qui pouvait l'être, notamment les profils de applications et autres fichiers de configuration.

L'homme est le seul animal à penser qu'il n'est pas un animal

Hors ligne

Pied de page des forums