Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 02-12-2016 15:34:31

drsky
Membre
Distrib. : Debian GNU/Linux 8 (jessie)
Noyau : Linux 4.8.11
(G)UI : KDE
Inscription : 02-12-2016

steam erreur

Bonjour, j'essaye d'installer steam mais une fois l'installation finit j'ai plusieurs erreur :

Steam needs to install these additional packages:
        libgl1-mesa-dri:i386, libgl1-mesa-glx:i386
[sudo] password for drsky:
.....................................................W: Duplicate sources.list entry http://security.debian.org/ jessie/updates/main amd64 Packages (/var/lib/apt/lists/security.debian.org_dists_jessie_updates_main_binary-amd64_Packages)
W: Duplicate sources.list entry http://security.debian.org/ jessie/updates/main i386 Packages (/var/lib/apt/lists/security.debian.org_dists_jessie_updates_main_binary-i386_Packages)
W: Vous pouvez lancer « apt-get update » pour corriger ces problèmes.

Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances      
Lecture des informations d'état... Fait
Certains paquets ne peuvent être installés. Ceci peut signifier
que vous avez demandé l'impossible, ou bien, si vous utilisez
la distribution unstable, que certains paquets n'ont pas encore
été créés ou ne sont pas sortis d'Incoming.
L'information suivante devrait vous aider à résoudre la situation :

Les paquets suivants contiennent des dépendances non satisfaites :
 libgl1-mesa-dri:i386 : Dépend: libdrm-intel1:i386 (>= 2.4.48) mais ne sera pas installé
                        Dépend: libdrm-nouveau2:i386 (>= 2.4.38) mais ne sera pas installé
                        Dépend: libdrm-radeon1:i386 (>= 2.4.31) mais ne sera pas installé
                        Dépend: libdrm2:i386 (>= 2.4.38) mais ne sera pas installé
 libgl1-mesa-glx:i386 : Dépend: libdrm2:i386 (>= 2.3.1) mais ne sera pas installé
                        Dépend: libglapi-mesa:i386 (= 10.3.2-1+deb8u1) mais ne sera pas installé
                        Dépend: libudev1:i386 mais ne sera pas installé
 libkcddb4 : Dépend: libkcompactdisc4 mais ne sera pas installé
 libkonq5abi1 : Dépend: libkonq-common (>= 4:4.14.2-1) mais ne sera pas installé
E: Erreur, pkgProblem::Resolve a généré des ruptures, ce qui a pu être causé par les paquets devant être gardés en l'état.
 



ensuite une fenêtre steam s'ouvre :

openGL GLX extension not supported by display debian


Merci d'avance si quelqu'un peut m'aider

Hors ligne

#2 02-12-2016 16:37:31

nIQnutn
Modérateur
Lieu : Lyon
Distrib. : Stretch
Noyau : Linux 4.9.0-3-amd64
(G)UI : Gnome
Inscription : 16-03-2012
Site Web

Re : steam erreur

tu peux nous dire comment tu as installer Steam ?

donne nous le résultat de la commande

cat /etc/apt/sources.list  /etc/apt/sources.list.d/*.list ;




et en même temps:
Voir le tuto : Trop cool d'indiquer son installation dans son profil !

Hors ligne

#3 02-12-2016 16:39:38

drsky
Membre
Distrib. : Debian GNU/Linux 8 (jessie)
Noyau : Linux 4.8.11
(G)UI : KDE
Inscription : 02-12-2016

Re : steam erreur

j'ai suivi ce tuto

https://wiki.debian.org/fr/Steam


#

# deb cdrom:[Debian GNU/Linux 8 _Jessie_ - Official Snapshot amd64 LIVE/INSTALL Binary 20160917-15:03]/ jessie main

#deb cdrom:[Debian GNU/Linux 8 _Jessie_ - Official Snapshot amd64 LIVE/INSTALL Binary 20160917-15:03]/ jessie main

# Line commented out by installer because it failed to verify:
deb http://security.debian.org/ jessie/updates main
# Line commented out by installer because it failed to verify:
deb-src http://security.debian.org/ jessie/updates main
## DEBIAN JESSSIE-BACKPORTS
deb http://http.debian.net/debian/ jessie-backports main
deb http://httpredir.debian.org/debian/ jessie main contrib non-free
deb http://security.debian.org/ jessie/updates main contrib non-free
deb http://httpredir.debian.org/debian/ jessie-updates main contrib non-free
deb http://repository.spotify.com stable non-free
deb [arch=amd64,i386] http://repo.steampowered.com/steam/ precise steam
deb-src [arch=amd64,i386] http://repo.steampowered.com/steam/ precise steam
 

Hors ligne

#4 03-12-2016 15:38:36

robert2a
Membre
Lieu : France
Distrib. : Stretch 9
Noyau : Linux 4.9.0-3 4.9.30-2
(G)UI : Mate
Inscription : 15-11-2014

Re : steam erreur

Bonjour
le sources.list pour debian et steam


deb http://security.debian.org/ jessie/updates main contrib non-free
deb http://httpredir.debian.org/debian/ jessie main contrib non-free
deb http://httpredir.debian.org/debian/ jessie-updates main contrib non-free
deb http://httpredir.debian.org/debian/ jessie-backports main contrib non-free
 



aprés avoir suivi le tuto , en amd64 le paquet "libgl1-glx:i386"  pour le driver libre et "libgl1-nvidia-glx:i386"  pour le driver non free nvidia par exemple

steam installé a partir des dépots debian n a besoin de rien d autres . (au lancement il se mettra a jour )

nota : utiliser des dépots tier (pas debian ) tu risque de casser ton installation

Dernière modification par robert2a (03-12-2016 15:44:11)

Hors ligne

Pied de page des forums