Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 08-12-2016 21:46:46

joeCool
Membre
Inscription : 08-12-2016

Impossible d'installer le multiarch

Salut à tous,

J'ai beau fouiller un peu partout, je ne trouve pas la solution à mon problème. J'essaye d'installer Teamviewer sur ma Debian mais le paquet dispo n'est qu'en 32 bits. Le site conseille cette version pour des architectures 64 bits et donc, d'être en multiarch.

Ma config est un Debian qui tourne sous VirtualBox.
Le 'uname -a' me donne ceci: "Linux yoda 3.16.0-4-amd64 #1 SMP Debian 3.16.7-ckt20-1+deb8u1 (2015-12-14) x86_64 GNU/Linux"

Lorsque j'essaye de rajouter l'archi i386, voilà ce que cela donne:
*------------------------------------------------------------------------------------------------------------------------------------------*
Ign http://ftp.fr.debian.org jessie InRelease
Atteint http://ftp.fr.debian.org jessie-updates InRelease                                                                                           
Ign http://uk.archive.ubuntu.com quantal InRelease                                                                                                   
Atteint http://security.debian.org jessie/updates InRelease                                                                                   
Atteint http://ftp.fr.debian.org jessie Release.gpg                                                                                           
Ign http://uk.archive.ubuntu.com quantal Release.gpg                                           
Atteint http://ftp.fr.debian.org jessie Release                                                 
Ign http://uk.archive.ubuntu.com quantal Release                                                                                             
Réception de : 1 http://ftp.fr.debian.org jessie-updates/main amd64 Packages/DiffIndex [6 916 B]             
Réception de : 2 http://ftp.fr.debian.org jessie-updates/main i386 Packages/DiffIndex [6 916 B]                         
Réception de : 3 http://ftp.fr.debian.org jessie-updates/main Translation-en/DiffIndex [2 704 B]                       
Atteint http://ftp.fr.debian.org jessie/main Sources                                                           
Atteint http://security.debian.org jessie/updates/main Sources                                                                       
Atteint http://security.debian.org jessie/updates/main amd64 Packages                     
Atteint http://security.debian.org jessie/updates/main i386 Packages                                                       
Réception de : 4 http://ftp.fr.debian.org jessie/main Translation-fr [846 kB]                                               
Atteint http://security.debian.org jessie/updates/main Translation-en                                                         
Atteint http://ftp.fr.debian.org jessie-updates/main Sources                                                                         
Atteint http://ftp.fr.debian.org jessie/main amd64 Packages                                                                         
Réception de : 5 http://ftp.fr.debian.org jessie/main i386 Packages [6 789 kB]                                                       
Atteint http://ftp.fr.debian.org jessie/main Translation-en                                               
Atteint http://ftp.fr.debian.org jessie/main Sources                                                                           
Atteint http://ftp.fr.debian.org jessie/main amd64 Packages                                                                   
Atteint http://ftp.fr.debian.org jessie/main Translation-fr                                                                       
Err http://uk.archive.ubuntu.com quantal/main amd64 Packages                                                                                         
  404  Not Found [IP : 91.189.88.161 80]
Err http://uk.archive.ubuntu.com quantal/universe amd64 Packages                                                                                     
  404  Not Found [IP : 91.189.88.161 80]
Err http://uk.archive.ubuntu.com quantal/main i386 Packages                                                                                         
  404  Not Found [IP : 91.189.88.161 80]
Err http://uk.archive.ubuntu.com quantal/universe i386 Packages                                                                                     
  404  Not Found [IP : 91.189.88.161 80]
Ign http://uk.archive.ubuntu.com quantal/main Translation-fr_FR                                                                                     
Ign http://uk.archive.ubuntu.com quantal/main Translation-fr                                                                                         
Ign http://uk.archive.ubuntu.com quantal/main Translation-en                                                                                         
Ign http://uk.archive.ubuntu.com quantal/universe Translation-fr_FR                                                                                 
Ign http://uk.archive.ubuntu.com quantal/universe Translation-fr                                                                                     
Ign http://uk.archive.ubuntu.com quantal/universe Translation-en                                                                                     
3 277 ko réceptionnés en 9s (332 ko/s)                                                                                                               
W: Impossible de récupérer http://uk.archive.ubuntu.com/ubuntu/dis … 4/Packages  404  Not Found [IP : 91.189.88.161 80]

W: Impossible de récupérer http://uk.archive.ubuntu.com/ubuntu/dis … 4/Packages  404  Not Found [IP : 91.189.88.161 80]

W: Impossible de récupérer http://uk.archive.ubuntu.com/ubuntu/dis … 6/Packages  404  Not Found [IP : 91.189.88.161 80]

W: Impossible de récupérer http://uk.archive.ubuntu.com/ubuntu/dis … 6/Packages  404  Not Found [IP : 91.189.88.161 80]

E: Le téléchargement de quelques fichiers d'index a échoué, ils ont été ignorés, ou les anciens ont été utilisés à la place.
*------------------------------------------------------------------------------------------------------------------------------------------*

Je ne comprends vraiment pas pourquoi cela me donne ce résultat. J'ai vu qu'il y avait un fichier () qui contient les sources apt. Je vous donne le mien au-cas-où:
---------------------------
#

deb [arch=amd64,i386] http://uk.archive.ubuntu.com/ubuntu/ quantal main universe

# deb cdrom:[Debian GNU/Linux 8.2.0 _Jessie_ - Official amd64 CD Binary-1 201509
06-11:13]/ jessie main

# deb cdrom:[Debian GNU/Linux 8.2.0 _Jessie_ - Official amd64 CD Binary-1 201509
06-11:13]/ jessie main

deb http://ftp.fr.debian.org/debian/ jessie main
deb-src http://ftp.fr.debian.org/debian/ jessie main

deb http://security.debian.org/ jessie/updates main
deb-src http://security.debian.org/ jessie/updates main

# jessie-updates, previously known as 'volatile'
deb http://ftp.fr.debian.org/debian/ jessie-updates main
deb-src http://ftp.fr.debian.org/debian/ jessie-updates main
---------------------------

Petite précision, voilà le résultat de deux commandes:
root@yoda:/# dpkg --print-architecture
amd64

root@yoda:/# dpkg --print-foreign-architectures
i386

Que dois-je faire, d'après vous, pour résoudre ce problème ?
D'où viennent ces erreurs ?

Je crois avoir lu que 'quantal' était une vieille version de debian et qu'elle n'est plus supportée, d'où ces messages.
Mais que fait alors ce quantal à cet endroit-là ??

Un très grand merci.
++

Dernière modification par joeCool (08-12-2016 21:51:31)

Hors ligne

#2 08-12-2016 22:19:58

greenmerlin
Membre
Lieu : 127.0.0.1
Distrib. : Archlinux/TinycoreLinux(CorePure 64-6.4.1)/Jessie
Noyau : 4.2.2-1 / 4.4
(G)UI : wmaker
Inscription : 23-01-2016

Re : Impossible d'installer le multiarch

Bonjour,

tu te mélange un peu les pinceaux entre Debian et Ubuntu™ cette ligne n'a rien a faire sur une distrib Debian

deb [arch=amd64,i386] http://uk.archive.ubuntu.com/ubuntu/ quantal main universe



je te recommande la lecture de https://debian-facile.org/doc:systeme:apt:sources.list

pour passer en multiarch


dpkg --add-architecture i386


apt-get update



@+

Edit à toto :
Mis la ligne source trranscrite sous les codes=apt_sources que c'est plus zoli....

Dernière modification par greenmerlin (08-12-2016 22:25:22)


" La plus importante et la plus négligée de toutes les conversations, c'est l'entretien avec soi-même. "
Chancelier Oxenstiern.

536920766f7573206172726976657220c3a0206c69726520c3a7612c20632765737420717565206e6f757320706172746167656f6e73206c6573206dc3aa6d65732063656e747265732064e28099696e74c3a972c3aa74732e

Hors ligne

#3 08-12-2016 23:12:15

joeCool
Membre
Inscription : 08-12-2016

Re : Impossible d'installer le multiarch

Ha oui, tu as raison, je ne comprends pas ce que cette ligne fait là ... Merci de ton coup d'oeil....

Je viens de refaire la manip sans cette ligne et à la fin du apt-get update, j'ai ceci:
"Lecture des listes de paquets... Fait"

Ensuite, le dpkg --print-architecture me donne
amd64

Ne devrais-je pas voir i386 également ?
Est-ce normal que le 'apt-get update' se termine comme ça, je veux dire, juste par "Lecture des listes de paquets... Fait" ??

Hors ligne

#4 08-12-2016 23:25:42

smolski
administrateur quasi...modo
Lieu : AIN
Distrib. : 8 (jessie) 64 bits + backports
Noyau : 3.16.0-4-amd64 - 3.16.39-1
(G)UI : gnome 1:3.14+3
Inscription : 21-10-2008

Re : Impossible d'installer le multiarch

update est la mise en cache des paquets, il te reste à opérer concrètement les changements avec l'upgrade :

apt-get upgrade



Voir la commande apt-get dans le wiki :
https://debian-facile.org/doc:systeme:apt:apt-get


"Théo et Adama te rappellent pourquoi Zyed et Bouna couraient…"
"L'utopie ne signifie pas l'irréalisable, mais l'irréalisée." - T Monod (source :  La zone de Siné)
"Je peux rire de tout mais pas avec n'importe qui." - P Desproges
"saque eud dun" (patois chtimi : fonce dedans)

Hors ligne

#5 08-12-2016 23:37:08

joeCool
Membre
Inscription : 08-12-2016

Re : Impossible d'installer le multiarch

Ok et merci pour le lien. Après l'upgrade, il me dit ceci:


root@yoda:/home/jved/Téléchargements#

apt-get upgrade


Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances      
Lecture des informations d'état... Fait
Calcul de la mise à jour... Les paquets suivants ont été installés automatiquement et ne sont plus nécessaires :
  libasn1-8-heimdal libgssapi3-heimdal libhcrypto4-heimdal libheimbase1-heimdal libheimntlm0-heimdal libhx509-5-heimdal libkrb5-26-heimdal
  libroken18-heimdal libwind0-heimdal
Veuillez utiliser « apt-get autoremove » pour les supprimer.
Fait
0 mis à jour, 0 nouvellement installés, 0 à enlever et 0 non mis à jour.
root@yoda:/home/jved/Téléchargements# dpkg --print-architecture
amd64
 



Par contre, je ne sais pas si je débloque mais toujours pas de i386 avec la commande dpkg --print-architecture.
Est-ce normal ?

La bonne nouvelle, c'est que l'installation de teamviewer (i386) est bien passée...

Edit à toto :
Séparée la commande root de son retour dans un autre bloc code. C'est bien plus lisible par tous ainsi.

Hors ligne

#6 09-12-2016 00:48:56

smolski
administrateur quasi...modo
Lieu : AIN
Distrib. : 8 (jessie) 64 bits + backports
Noyau : 3.16.0-4-amd64 - 3.16.39-1
(G)UI : gnome 1:3.14+3
Inscription : 21-10-2008

Re : Impossible d'installer le multiarch

l'installation de teamviewer (i386) est bien passée...


Est la réponse affirmative à ton interrogation d'installation du multiarch... i386, sinon, comment veux-tu... comment veux-tu... big_smile


"Théo et Adama te rappellent pourquoi Zyed et Bouna couraient…"
"L'utopie ne signifie pas l'irréalisable, mais l'irréalisée." - T Monod (source :  La zone de Siné)
"Je peux rire de tout mais pas avec n'importe qui." - P Desproges
"saque eud dun" (patois chtimi : fonce dedans)

Hors ligne

#7 09-12-2016 08:48:50

chalu
Modératrice
Lieu : Anjou
Distrib. : Debian Stretch
Noyau : Linux 4.9.0-3-amd64
(G)UI : Mate 1.16
Inscription : 11-03-2016

Re : Impossible d'installer le multiarch

Bonjour,
La commande pour avoir les architectures ajoutées

dpkg --print-foreign-architectures

Hors ligne

#8 09-12-2016 14:09:36

joeCool
Membre
Inscription : 08-12-2016

Re : Impossible d'installer le multiarch

Je vous remercie pour vos précisions.

J'ai relu une page sur le multiarch et voilà ce qui en sort:

1. La commande dpkg --print-architecture donne l'architecture courante donc, c'est normal de n'en voir qu'une (en l'occurence amd64).

2. Les autres architectures disponibles sont visibles grâce à la commande dpkg --print-foreign-architectures.

Ok, mais d'après vous, que veut dire ce disponible ?  "les autres architectures installées à ce moment là" ou "les autres architectures que vous pourriez installer mais qui ne le sont pas encore" ??

Dernière modification par joeCool (09-12-2016 14:09:59)

Hors ligne

#9 09-12-2016 14:21:56

smolski
administrateur quasi...modo
Lieu : AIN
Distrib. : 8 (jessie) 64 bits + backports
Noyau : 3.16.0-4-amd64 - 3.16.39-1
(G)UI : gnome 1:3.14+3
Inscription : 21-10-2008

Re : Impossible d'installer le multiarch

teste la commande voir un peu ? smile

"Théo et Adama te rappellent pourquoi Zyed et Bouna couraient…"
"L'utopie ne signifie pas l'irréalisable, mais l'irréalisée." - T Monod (source :  La zone de Siné)
"Je peux rire de tout mais pas avec n'importe qui." - P Desproges
"saque eud dun" (patois chtimi : fonce dedans)

Hors ligne

#10 09-12-2016 14:48:04

joeCool
Membre
Inscription : 08-12-2016

Re : Impossible d'installer le multiarch

Je n'arrête pas ^^ !

Quelques commandes:

dpkg --print-architecture


amd64



dpkg --print-architecture[dpkg --print-foreign-architectures


i386



... et l'aide de dpkg me donne ceci:

--print-foreign-architectures      Affiche les architectures étrangères autorisées



Donc, pas clair d'après moi tongue !

Hors ligne

#11 09-12-2016 17:09:55

chalu
Modératrice
Lieu : Anjou
Distrib. : Debian Stretch
Noyau : Linux 4.9.0-3-amd64
(G)UI : Mate 1.16
Inscription : 11-03-2016

Re : Impossible d'installer le multiarch

Ce sont les autres architectures installées
À noter qu'on le voit aussi dans Synaptic si on a un trou de mémoire pour la commande tongue

Hors ligne

#12 10-12-2016 13:20:10

joeCool
Membre
Inscription : 08-12-2016

Re : Impossible d'installer le multiarch

Merci beaucoup pour les réponses... J'y vois plus clair smile !!

Hors ligne

Pied de page des forums