Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 23-07-2009 19:32:14

bUZZ
Membre
Distrib. : Lenny
Noyau : 2.6.26-2-686
(G)UI : GNOME
Inscription : 08-07-2009
Site Web

Problème de création des comptes users via "smbldap-tools" !!!

Bonjour,

j'ai décidé d'installer sur mon portable LENNY un serveur "SAMBA+LDAP" pour tester, mais j'ai ce message d'erreur aprés avoir lancer la commande de création du compte "test":


LENNY:/etc/ldap# useradd -G dom_users -m -d/home/samba/home/test -c "utilisateur test" -s /bin/false test


LENNY:/etc/ldap# smbpasswd -a test
failed to bind to server ldap://127.0.0.1/ with dn="cn=admin,dc=barack,dc=local" Error: Invalid credentials
    (unknown)
Connection to LDAP server failed for the 1 try!
Connection to LDAP server failed for the 2 try!
Connection to LDAP server failed for the 3 try!
Connection to LDAP server failed for the 4 try!
Connection to LDAP server failed for the 5 try!
Connection to LDAP server failed for the 6 try!
Connection to LDAP server failed for the 7 try!
Connection to LDAP server failed for the 8 try!
Connection to LDAP server failed for the 9 try!
Connection to LDAP server failed for the 10 try!
Connection to LDAP server failed for the 11 try!
Connection to LDAP server failed for the 12 try!
Connection to LDAP server failed for the 13 try!
Connection to LDAP server failed for the 14 try!
Connection to LDAP server failed for the 15 try!
New SMB password:
Retype new SMB password:
Connection to LDAP server failed for the 1 try!
Connection to LDAP server failed for the 2 try!
Connection to LDAP server failed for the 3 try!
Connection to LDAP server failed for the 4 try!
Connection to LDAP server failed for the 5 try!
Connection to LDAP server failed for the 6 try!
Connection to LDAP server failed for the 7 try!
Connection to LDAP server failed for the 8 try!
Connection to LDAP server failed for the 9 try!
Connection to LDAP server failed for the 10 try!
Connection to LDAP server failed for the 11 try!
Connection to LDAP server failed for the 12 try!
Connection to LDAP server failed for the 13 try!
Connection to LDAP server failed for the 14 try!
Connection to LDAP server failed for the 15 try!
Connection to LDAP server failed for the 1 try!
Connection to LDAP server failed for the 2 try!
Connection to LDAP server failed for the 3 try!
Connection to LDAP server failed for the 4 try!
Connection to LDAP server failed for the 5 try!
Connection to LDAP server failed for the 6 try!
Connection to LDAP server failed for the 7 try!
Connection to LDAP server failed for the 8 try!
Connection to LDAP server failed for the 9 try!
Connection to LDAP server failed for the 10 try!
Connection to LDAP server failed for the 11 try!
Connection to LDAP server failed for the 12 try!
Connection to LDAP server failed for the 13 try!
Connection to LDAP server failed for the 14 try!
Connection to LDAP server failed for the 15 try!
Failed to add entry for user test.
Failed to modify password entry for user test


j'ai vérifier que le daemon tourne:

LENNY:/etc/ldap# ps aux | grep slapd
openldap  3733  0.0  1.6  24820  4144 ?        Ssl  18:15   0:00 /usr/sbin/slapd -g openldap -u openldap -f /etc/ldap/slapd.conf
root      3771  0.0  0.3   3144   784 pts/1    S+   18:21   0:00 grep slapd


LENNY:/etc/ldap# testparm
Load smb config files from /etc/samba/smb.conf
Processing section "[netlogon]"
Processing section "[homes]"
Processing section "[compta]"
Processing section "[partage]"
Loaded services file OK.
Server role: ROLE_DOMAIN_BDC
Press enter to see a dump of your service definitions

[global]
    dos charset = 850
    unix charset = ISO8859-1
    server string = Samba-LDAP PDC Server
    passdb backend = ldapsam:ldap://127.0.0.1/
    add user script = /usr/local/sbin/smbldap-useradd -m "%u"
    add group script = /usr/local/sbin/smbldap-groupadd -p "%g"
    add user to group script = /usr/local/sbin/smbldap-groupmod -m "%u" "%g"
    delete user from group script = /usr/local/sbin/smbldap-groupmod -x "%u" "%g"
    set primary group script = /usr/local/sbin/smbldap-usermod -g "%g" "%u"
    add machine script = /usr/local/sbin/smbldap-useradd -w "%u"
    domain logons = Yes
    os level = 40
    local master = No
    domain master = No
    ldap admin dn = cn=admin,dc=barack,dc=local
    ldap delete dn = Yes
    ldap group suffix = ou=Groups
    ldap machine suffix = ou=Computers
    ldap passwd sync = Yes
    ldap suffix = dc=barack,dc=local
    ldap user suffix = ou=Users

[netlogon]
    path = /home/samba/netlogon
    write list = Administrateur
    browseable = No

[homes]
    comment = Répertoire personnel
    valid users = %U
    read only = No
    browseable = No

[compta]
    path = /home/samba/groups/compta
    valid users = Comptabilité
    read only = No
    create mask = 0750
    guest ok = Yes

[partage]
    comment = Répertoire commun
    path = /home/samba/partage
    read only = No



pour vérifier que SAMBA  fonctionne sans mot de passe en local:

lenny@LENNY:~$ smbclient -L localhost
Enter lenny's password: "appuyer entrer"
Receiving SMB: Server stopped responding
session setup failed: Call timed out: server did not respond after 20000 milliseconds


J'ai arrêter le serveur slapd = stop
et j'ai ce résultat aprés avoir lancer la commande: /usr/sbin/slapd -d 256 (pour voir le details des requêtes passés au serveur en live)

Please provide a password for the domain root:
Argument "" isn't numeric in addition (+) at /usr/share/perl5/Net/LDAP.pm line 468.
No such object at /usr/share/perl5/smbldap_tools.pm line 353.
LENNY:/var/lib/ldap# smbldap-useradd -a -P -c "test 2" test2
Argument "" isn't numeric in addition (+) at /usr/share/perl5/Net/LDAP.pm line 468.
failed to perform search; No such object at /usr/share/perl5/smbldap_tools.pm line 374.
Error looking for next uid in sambaDomainName=LENNY,dc=barack,dc=local:No such object at /usr/share/perl5/smbldap_tools.pm line 1071.


En vous remerciant d'avance, je compte sur votre esprit de Linuxien:D

::: le partage est une vertu qui fera avancer le monde :::

Hors ligne

#2 23-07-2009 20:17:13

smolski
administrateur quasi...modo
Lieu : AIN
Distrib. : 8 (jessie) 64 bits + backports
Noyau : 4.6.0-0.bpo.1-amd64
(G)UI : gnome 3.14.1
Inscription : 21-10-2008

Re : Problème de création des comptes users via "smbldap-tools" !!!

Tagada tagada... espriiiiiiiiit linuxien.... es-tu lààààààààààà ?

C'est le p'tit bout d'la queue du chat...
Qui passait par là.....

Désolé, rien de mieux... wink

En t'espérant une réponse moins facétueuse, amitié, Joel

"Définition d'eric besson : S'il fallait en chier des tonnes pour devenir ministre, il aurait 2 trous du cul." - JP Douillon
"L'utopie ne signifie pas l'irréalisable, mais l'irréalisée." - T Monod (source :  La zone de Siné)
"Je peux rire de tout mais pas avec n'importe qui." - P Desproges
"saque eud dun" (patois chtimi : fonce dedans)

Hors ligne

Pied de page des forums