Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 12-12-2016 12:12:51

robert2a
Membre
Lieu : France
Distrib. : Stretch 9
Noyau : Linux 4.9.0-3 4.9.30-2
(G)UI : Mate
Inscription : 15-11-2014

[résolu] jessie et gpu nvidia maxwell GTX750 (TI) ou GTX9xx

Bonjour
pour installer rapidement une debian jessie avec un gpu maxwell (GTX750(TI) , ou GTX9xx )
ps: je suppose que vous avez quelques bases sur debian (voir wiki du forum )
prendre un support d installation (j ai utilisé une clé usb avec le DVD1 d installation de jessie )
bouter dessus , installation (non graphique ) , choisir un dépot debian pour les mises a jours , au moment du choix des programmes ne garder que la dernière case coché (installation minimale )
finir l installation et redémarrer .
nota : il y a de forte chance que le noyau 3.16 vous donne une erreur a propos de votre carte graphique
rentrer votre logging "root" et votre mot de passe root
ouvrir votre fichier des sources


nano /etc/apt/sources.list
 


modifier votre sources.list comme ci dessous


#depot jessie
deb http://ftp.fr.debian.org/debian/ jessie main contrib non-free
#deb-src http://ftp.fr.debian.org/debian/ jessie main contrib non-free
#depot securité
deb http://security.debian.org/ jessie/updates main contrib non-free
#deb-src http://security.debian.org/ jessie/updates main contrib non-free
# jessie-updates, previously known as 'volatile'
deb http://ftp.fr.debian.org/debian/ jessie-updates main contrib non-free
#deb-src http://ftp.fr.debian.org/debian/ jessie-updates main contrib non-free
#depot backports
deb http://ftp.fr.debian.org/debian/ jessie-backports main contrib non-free
#deb-src http://ftp.fr.debian.org/debian/ jessie-backports main contrib non-free
 


lancer une mise a jour du cache apt


apt-get update
 


vérifier que votre jessie est a jour


apt-get upgrade
 


installation du noyau 4.7 des backports


apt-get install -t jessie-backports linux-image-amd64
 


a la fin de l installation , redémarrer la machine


reboot
 


nota: normalement votre debian prend en compte maintenant une résolution native de l'écran et vous ne devez plus avoir d erreur a propos du gpu
installation d un bureau minimal


apt-get install lightdm mate-core synaptic gedit gdebi
 


redémarrer


reboot
 


vous devez avoir une invite graphique pour vous connecter au bureau
je n ai testé que la GTX750 , si un problème taper la combinaison de touches " Ctrl+Alt+F1 " pour vous remettre sur une console pure
sinon utiliser la console du bureau Mate en root
installer le driver non-free des backports


apt-get install -t jessie-backports xserver-xorg-video-nvidia nvidia-driver nvidia-driver-bin nvidia-settings
 


la fin de l installation doit ressembler a cela


Paramétrage de nvidia-kernel-dkms (367.57-2~bpo8+1) ...
Loading new nvidia-current-367.57 DKMS files...
Building for 4.7.0-0.bpo.1-amd64
Building initial module for 4.7.0-0.bpo.1-amd64
Done.

nvidia-current:
Running module version sanity check.
 - Original module
   - No original module exists within this kernel
 - Installation
   - Installing to /lib/modules/4.7.0-0.bpo.1-amd64/updates/dkms/

nvidia-current-modeset.ko:
Running module version sanity check.
 - Original module
   - No original module exists within this kernel
 - Installation
   - Installing to /lib/modules/4.7.0-0.bpo.1-amd64/updates/dkms/

nvidia-current-drm.ko:
Running module version sanity check.
 - Original module
   - No original module exists within this kernel
 - Installation
   - Installing to /lib/modules/4.7.0-0.bpo.1-amd64/updates/dkms/

nvidia-current-uvm.ko:
Running module version sanity check.
 - Original module
   - No original module exists within this kernel
 - Installation
   - Installing to /lib/modules/4.7.0-0.bpo.1-amd64/updates/dkms/

depmod..........

DKMS: install completed.
Paramétrage de nvidia-driver (367.57-2~bpo8+1) ...
Traitement des actions différées (« triggers ») pour libc-bin (2.19-18+deb8u6) ...
Traitement des actions différées (« triggers ») pour update-glx (0.7.3~bpo8+1) ...
Traitement des actions différées (« triggers ») pour glx-alternative-nvidia (0.7.3~bpo8+1) ...
update-alternatives: utilisation de « /usr/lib/nvidia » pour fournir « /usr/lib/glx » (glx) en mode automatique
Traitement des actions différées (« triggers ») pour menu (2.1.47) ...
Traitement des actions différées (« triggers ») pour libc-bin (2.19-18+deb8u6) ...
Traitement des actions différées (« triggers ») pour initramfs-tools (0.120+deb8u2) ...
update-initramfs: Generating /boot/initrd.img-4.7.0-0.bpo.1-amd64
 


puis redémarrer


reboot
 


maintenant vous avez la prise en charge de votre carte graphique
pour les utilisateurs de Blender
installation de Cuda


apt-get install -t jessie-backports nvidia-cuda-toolkit
 


redémarrer la machine
vous pouvez installer gnome sans souci smile


apt-get install gdm3 gnome
 


spécifier que vous voulez utiliser gdm3 comme lanceur de gnome
au prochain logging sur gnome vous pouvez (ou pas ) supprimer mate et lightdm

ps: j ai testé ce qui est noté ci dessus , tout est fonctionnel
pour ceux qui veulent rester en stable , pour les dernières cartes (pascal series GTX10xx ) c est moins évident , j aurai peut etre l occasion de tester la méthode avec jessie

nota: j'ai vu qu il y a pas mal de questions a propos de ce genre de configuration , une manière de vous sortir d affaire  smile

Dernière modification par robert2a (12-12-2016 12:45:29)

Hors ligne

#2 12-12-2016 13:21:02

Guppy88
Membre
Lieu : Rambervillers Vosges
Distrib. : Testing Stretch + Jessie
Noyau : Linux 4.8.0-1-amd64 + Linux 3.16.0-4-amd64
(G)UI : Mate et Gnome 3.18.2
Inscription : 07-01-2012

Re : [résolu] jessie et gpu nvidia maxwell GTX750 (TI) ou GTX9xx

Je confirme que sous Jessie cela fonctionne bien, sous Gnome, et avec une GeForce GTX 980.
Guppy

Dernière modification par Guppy88 (12-12-2016 13:21:44)

Hors ligne

Pied de page des forums