Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 23-12-2016 18:20:35

Henry33
Membre
Inscription : 23-12-2016

[Résolu]Xorg planté suite à installation driver non libre nvidia

Bonjour à vous,

Je suis un débutant rouillé sur Debian. Aprés avoir installé Debian 8 sur une machine, j'ai planté Xorg en voulant installer les pilotes Nvidia...

Précision : l'ordinateur est un portable avec une carte Intel HD Graphic 3000 ET une carte Nvidia 119M (610M). Je n'ai pas touché aux driver Intel, juste les Nvidia.

Maintenant, au démarrage, il y a un ecran gris avec le message : "Oh no! Something has wrong..."

Ce que j'ai fait :

# startx stop
# nvidia-installer --uninstall
# modprobe -r nvidia
# find /lib/modules/`uname -r` -name "*nvidia*" -delete
# apt-get install module-assistant nvidia-kernel-source
# m-a prepare
# m-a clean nvidia-kernel
# m-a a-i -i nvidia-kernel-source
# apt-get install nvidia-glx
# Xorg -configure

Puis copier fichier .conf de /root vers /etc/X11, j'ai modifier le fichier Xorg.conf pour qu'il ai les références de nvidia.

Je ne comprends pas d'où vient la panne car je n'ai pas un grand un niveau en Linux... D'où vient le problème et comment depanner la machine ??


Un grand merci par avance pour le coup de main !


Résultats lspci :

00:2.0 VGA compatible controller : Intel Corporation 2nd Generation Core Processor ...
01:00.0 VGA coompatible controller : NVIDIA Coportation GF119M [GeForce6110M]

Est-ce qu'il y a des informations supplémentaires que je puisse vous donner ??



SOLUTION :

Voir message #6


.
.

Dernière modification par Henry33 (24-12-2016 11:32:09)

Hors ligne

#2 23-12-2016 18:31:46

Croutons
Membre
Distrib. : Handylinux 2.5 vers debian 8.7
Noyau : Linux 3.16.0-4-686-pae
(G)UI : xfce
Inscription : 16-12-2016

Re : [Résolu]Xorg planté suite à installation driver non libre nvidia

Bonjour
Tu trouveras peut être ton bonheur
Nvidia

Hors ligne

#3 23-12-2016 19:04:13

Henry33
Membre
Inscription : 23-12-2016

Re : [Résolu]Xorg planté suite à installation driver non libre nvidia

Merci pour ta réponse.

Ce lien donne la procédure pour le driver libre (nouveau) alors que je souhaite installer les drivers propriétaires. Malgré tout, ça m'a donné une piste, j'ai donc fait :

# apt-get install nvidia-xconfig
# nvidia-xconfig
# reboot

Je n'ai plus d'ecran gris, juste le cluster qui reste figé en haut à gauche de l'écran... Donc c'est pire je crois...

Hors ligne

#4 23-12-2016 19:13:13

robert2a
Membre
Lieu : France
Distrib. : Sid
Noyau : Linux
(G)UI : Mate
Inscription : 15-11-2014

Re : [Résolu]Xorg planté suite à installation driver non libre nvidia

Bonsoir
pourquoi tu n utilise pas le tuto nvidia ?
ton portable a besoin de bumblebee ou pas (carte intel + carte auxilliaire nvidia ) ?

pour optimus => https://debian-facile.org/doc:materiel: … ia:optimus
ps: il me semble qu ils mettent a jours ce wiki

pour nvidia => https://debian-facile.org/doc:materiel: … ia:accueil

ps: pour bumblebee , le driver nvidia ne doit pas etre installé.
supprimer l installation du driver nvidia et supprimer le xorg.log devrait te redonner le bureau graphique .(carte intel )
ensuite lire la doc optimus (bumblebee )  pour installation

Dernière modification par robert2a (23-12-2016 19:20:16)

En ligne

#5 23-12-2016 19:18:17

Henry33
Membre
Inscription : 23-12-2016

Re : [Résolu]Xorg planté suite à installation driver non libre nvidia

Je voulais avoir les deux cartes mais je vais suivre le procédure pour les pilotes libre puis basculer sur les non-libre ensuite, ça dépannera la machine et ça sera plus simple.


Merci à vous.

Hors ligne

#6 24-12-2016 11:30:55

Henry33
Membre
Inscription : 23-12-2016

Re : [Résolu]Xorg planté suite à installation driver non libre nvidia

Bonjour,

J'ai réglé mon problème.

Solution :

([Ctrl] + [Alt] + [F1] pour obtenir une console) - (le "#" en début de ligne signifie que les commandes sont exécutées en tant que root)

# apt-get remove --purge nvidia*    <- pour ceux qui ne l'auraient pas vu, le "*" est important
# reboot

- Retour à l'interface graphique
- Installation par Synaptic de nvidia-kernel-dkms
- Redémarrage

# apt-get install bumblebee-nvidia primus

[ Au cas où :

# apt-get install primus-libs:i386
]

# reboot

# nano /etc/X11/xorg.conf

Le fichier xorg.conf n'a pas l'air d'avoir été mis à jour au moment de l'installation des paquets donc :

- Vérifier (dans mon cas) que les drivers "intel" sont rattachés à "Card0" et que les drivers "nvidia" à "Card1"

# reboot

Retour à l'interface graphique


PS : Il est bien sûr possible de raccourcir cette procédure, je la livre telle que je l'ai exécuté (avec tous les reboot) car c'est la procédure qui a marché pour moi.

A plus !

Dernière modification par Henry33 (24-12-2016 11:35:49)

Hors ligne

Pied de page des forums