Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 30-12-2016 01:13:46

Antidentity
Membre
Distrib. : Debian Jessie
Noyau : Linux 3.16.0-4 amd64
(G)UI : Openbox
Inscription : 03-08-2016

[Résolu] Problème installation flash pour chromium

Bonsoir,

Avant j'utilisais le pepperflash pour accéder au contenu flash avec chromium mais j'ai appris que le pepperflash était obsolète. J'ai donc voulu installer le plugin flash pour chromium en suivant le tuto du wiki ici: https://debian-facile.org/utilisateurs: … :flash-bug mais, ça ne fonctionne pas chez moi. L'installation debian est toute fraîche et je n'avais donc pas encore installé de plugin flash dessus. Il y a alors probablement quelque chose que je n'ai pas compris au tuto du wiki, je devais quand même installer le paquet pepperflashplugin-nonfree avant de réaliser le point 3.1?

Dernière modification par Antidentity (31-12-2016 12:09:15)

Hors ligne

#2 30-12-2016 13:30:40

chalu
Modératrice
Lieu : Anjou
Distrib. : Debian Jessie (saveur Handylinux 2.5) à jour
Noyau : Linux 3.16.0-4-amd64
(G)UI : XFCE - xfwm4
Inscription : 11-03-2016

Re : [Résolu] Problème installation flash pour chromium

Bonjour,
Tu télécharges le fichier ici :
https://get.adobe.com/fr/flashplayer/otherversions/
en sélectionnant linux 64-bit et FP-24.0 for linux 64-bit (.tar.gz)-PPAPI
ensuite tu vas dans ton dossier Téléchargements et tu extrais l'archive
tu crées le dossier si tu ne l'as pas fait

 mkdir /usr/lib/pepperflashplugin-nonfree


ensuite tu copies le fichier en ouvrant un terminal dans le dossier du téléchargements :

cp libpepflashplayer.so /usr/lib/pepperflashplugin-nonfree


Bien débuter sur Debian :
->Les cahiers du débutant + le wiki Découvrir les principales commandes Linux
-> Le projet DFlinux (DebianFacileLinux) pour débutants: ISOs (i386 et amd64) basées sur Debian Jessie avec des outils facilitants
-> Retours et avis sur DFLinux dans ce fil

Hors ligne

#3 30-12-2016 16:36:19

Antidentity
Membre
Distrib. : Debian Jessie
Noyau : Linux 3.16.0-4 amd64
(G)UI : Openbox
Inscription : 03-08-2016

Re : [Résolu] Problème installation flash pour chromium

Merci de t'être penché sur mon problème. Malheureusement ça ne fonctionne pas, j'avais téléchargé le paquet via le lien:

wget -P $HOME/Téléchargements/flashppapi https://fpdownload.adobe.com/pub/flashplayer/pdc/24.0.0.186/flash_player_ppapi_linux.x86_64.tar.gz


et appliqué la copie comme dans le tuto.

Je viens de retélécharger via ton lien et recopié le libpepflashplayer.so comme indiqué (puis redémarré l'ordi pour être sûr) mais toujours rien.
J'ai lancé chromium via la commande:

chromium --ppapi-flash-path=/usr/lib/pepperflashplugin-nonfree/libpepflashplayer.so –ppapi-flash-version=24.0.0.186


qui me lance chromium sans flash et avec ce message:

Ce site est inaccessible

Impossible de trouver l'adresse DNS du serveur xn--ppapi-flash-version%3D24-u78n.0.0.186.


dont ceci dans la barre d'adresse:

http://xn--ppapi-flash-version%3D24-u78n.0.0.186/



Donc, j'ai réessayé en lançant la commande (sans l'argument de version):

chromium --ppapi-flash-path=/usr/lib/pepperflashplugin-nonfree/libpepflashplayer.so

qui m'indique:

sed: -e expression n°1, caractère 1: commande inconnue: `'
/usr/bin/chromium: 3: /etc/chromium.d/pepperflashplugin-nonfree: –ppapi-flash-path=“/usr/lib/pepperflashplugin-nonfree/libpepflashplayer.so”: not found



Pourtant la commande:

ls /usr/lib/pepperflashplugin-nonfree

me renvoie bien:

libpepflashplayer.so



Edit: il n'y aurait pas une erreur de frappe avec les guillemets dans le tuto au point 3.1?

Dernière modification par Antidentity (30-12-2016 16:42:19)

Hors ligne

#4 30-12-2016 20:02:32

èfpé
Membre
Distrib. : Debian
Noyau : Linux
Inscription : 10-07-2016

Re : [Résolu] Problème installation flash pour chromium

Bonsoir Antidentity,

Le tuto à nounours comporte effectivement un certain nombre d'erreurs dont une au point 3.1 (guillemets typographiques au lieu de guillemets droits -- interprétation inappropriée du moteur wiki en l'absence de balises adéquates) et une au point 3.2 (tiret typographique au lieu d'un double tiret simple -- possible interprétation inappropriée d'un traitement de texte) ; les texte et commande corrects (et exclusifs, il s'agit d'alternatives) sont :

flashso="/usr/lib/pepperflashplugin-nonfree/libpepflashplayer.so"
flashversion=`strings $flashso 2> /dev/null | grep LNX | cut -d ' ' -f 2 | sed -e "s/,/./g"`
CHROMIUM_FLAGS="$CHROMIUM_FLAGS --ppapi-flash-path=$flashso --ppapi-flash-version=$flashversion"

ou

chromium --ppapi-flash-path=/usr/lib/pepperflashplugin-nonfree/libpepflashplayer.so --ppapi-flash-version=<version>


edit: l'erreur portant sur la ligne de commande n'est pas vraiment bloquante par contre les erreurs (guillemets anglais et tiret demi-cadratin) portant sur le fichier de configuration le restent tant que ce fichier existe :

rm /etc/chromium.d/pepperflashplugin-nonfree*


La présence de l'astérisque permet de neutraliser les éventuelles copies foireuses.

Dernière modification par èfpé (31-12-2016 06:24:32)

En ligne

#5 30-12-2016 21:35:57

enicar
Membre
Lieu : Grenoble
Distrib. : debian/sid
Noyau : Linux 4.8.15
(G)UI : openbox
Inscription : 26-08-2010

Re : [Résolu] Problème installation flash pour chromium

Désolé de voler ce fil, mais pour information :
sur le chromium de debian/sid, j'ai copié libpepflashplayer.so dans
/usr/lib/pepperflashplugin-nonfree/. J'ai rajouté les bons arguments au lancement de chrome :


 chromium --ppapi-flash-path="/usr/lib/pepperflashplugin-nonfree/" --ppapi-flash-version="24.0.0.186"
 


Malheureusement dans chromium, le plugin flash n'apparaît pas et un tour sur pluzz.fr m'a
confirmé que je ne pouvais pas lire les vidéos flash… dommage hmm

Dernière modification par enicar (30-12-2016 21:39:15)


La machine, c'est dépassé ! On va tout remplacer par des humains big_smile

Hors ligne

#6 30-12-2016 22:04:42

èfpé
Membre
Distrib. : Debian
Noyau : Linux
Inscription : 10-07-2016

Re : [Résolu] Problème installation flash pour chromium

Bonsoir également,

La commande citée au post #4 avait été testée/validée sous Chromium 53 (elle était d'ailleurs donnée par Chromium itself). Possible que les choses aient changé, sous Chromium 55 (auquel cas un utilisateur effectif et perspicace de ce navigateur mettra généreusement la bonne commande à la disposition de tous).

edit: vérification faite, la commande donnée reste parfaitement valide en version 55, il faut simplement s'abstenir d'y ajouter un maximum d'erreurs sa touche personnelle (ai pu mater l'épisode 3180 de Plus belle la vie et faire une photo souvenir big_smile)

Dernière modification par èfpé (31-12-2016 06:40:42)

En ligne

#7 30-12-2016 22:15:41

chalu
Modératrice
Lieu : Anjou
Distrib. : Debian Jessie (saveur Handylinux 2.5) à jour
Noyau : Linux 3.16.0-4-amd64
(G)UI : XFCE - xfwm4
Inscription : 11-03-2016

Re : [Résolu] Problème installation flash pour chromium

J'ai fait ce que j'ai écrit au post #2 et ça a mis à jour flash sur chromium, j'ai vérifié ici :
https://www.adobe.com/fr/software/flash/about/
ça fonctionne car c'est une mise à jour ?

Je crois bien me souvenir que j'avais la manip de ce message pour chromium :
https://debian-facile.org/viewtopic.php … 56#p197056

Dernière modification par chalu (30-12-2016 22:24:25)


Bien débuter sur Debian :
->Les cahiers du débutant + le wiki Découvrir les principales commandes Linux
-> Le projet DFlinux (DebianFacileLinux) pour débutants: ISOs (i386 et amd64) basées sur Debian Jessie avec des outils facilitants
-> Retours et avis sur DFLinux dans ce fil

Hors ligne

#8 30-12-2016 22:28:42

èfpé
Membre
Distrib. : Debian
Noyau : Linux
Inscription : 10-07-2016

Re : [Résolu] Problème installation flash pour chromium

Bonsoir également,

Ça suffit parce qu'il ne s'agit que d'une simple mise à jour du plugin effectivement wink

Dernière modification par èfpé (31-12-2016 12:04:42)

En ligne

#9 30-12-2016 22:44:30

chalu
Modératrice
Lieu : Anjou
Distrib. : Debian Jessie (saveur Handylinux 2.5) à jour
Noyau : Linux 3.16.0-4-amd64
(G)UI : XFCE - xfwm4
Inscription : 11-03-2016

Re : [Résolu] Problème installation flash pour chromium

Dans ce cas Antidentity peut suivre le tuto et ensuite pour les mises à jour comme j'ai fait ?
Il faudrait le reporter dans le wiki sur flash rubrique chromium
maintenant qu'il n'y a plus de souci avec Firefox, on va retrouver les soucis avec chromium tongue

Bien débuter sur Debian :
->Les cahiers du débutant + le wiki Découvrir les principales commandes Linux
-> Le projet DFlinux (DebianFacileLinux) pour débutants: ISOs (i386 et amd64) basées sur Debian Jessie avec des outils facilitants
-> Retours et avis sur DFLinux dans ce fil

Hors ligne

#10 30-12-2016 22:49:25

enicar
Membre
Lieu : Grenoble
Distrib. : debian/sid
Noyau : Linux 4.8.15
(G)UI : openbox
Inscription : 26-08-2010

Re : [Résolu] Problème installation flash pour chromium

Pour info la liste des commutateurs (switches) qu'il est possible de passer à chromium se trouve
ici
Apparemment ce sont toujours les mêmes… mais bon, je vais jeter un œil aux sources wink

La machine, c'est dépassé ! On va tout remplacer par des humains big_smile

Hors ligne

#11 31-12-2016 11:21:20

Antidentity
Membre
Distrib. : Debian Jessie
Noyau : Linux 3.16.0-4 amd64
(G)UI : Openbox
Inscription : 03-08-2016

Re : [Résolu] Problème installation flash pour chromium

Merci! J'ai donc rectifié via

nano /etc/chromium.d/pepperflashplugin-nonfree


et il n'y a plus le message d'erreur quand je lance via le terminal. Par contre, flash ne fonctionne toujours pas hmm J'ai dû avoir oublié quelque chose...

Si je compare le tuto et le topic du forum ici: https://debian-facile.org/viewtopic.php … 56#p197056, je n'avais pas copié le "manifest.json" mais ce dernier n'est utile que pour firefox, non? Je viens de le copier pour être sûr mais toujours rien.

Dans le wiki, on ne parle pas du paquet "browser-plugin-freshplayer-pepperflash", dois-je quand même l'installer?

Hors ligne

#12 31-12-2016 11:42:32

èfpé
Membre
Distrib. : Debian
Noyau : Linux
Inscription : 10-07-2016

Re : [Résolu] Problème installation flash pour chromium

Bonjour,

Effectivement il semble que Chromium n'a pas besoin du fichier manifest.json, et comme cela est signalé le paquet browser-plugin-freshplayer-pepperflash est obsolète depuis qu'Adobe a repris le développement de la version NPAPI pour Firefox.

Chromium : Flash est-il activé ('Toujours autoriser l'exécution' coché) sous chrome://plugins ? Enfin, est-il clair pour toi que si tu as créé un fichier de configuration correct avec nano, alors il n'y a pas lieu d'utiliser la fameuse ligne de commande ?

Dernière modification par èfpé (31-12-2016 11:52:32)

En ligne

#13 31-12-2016 12:05:52

Antidentity
Membre
Distrib. : Debian Jessie
Noyau : Linux 3.16.0-4 amd64
(G)UI : Openbox
Inscription : 03-08-2016

Re : [Résolu] Problème installation flash pour chromium

èfpé a écrit :

Chromium : Flash est-il activé ('Toujours autoriser l'exécution' coché) sous chrome://plugins ?



Ouhhh, j'ai fait le boulet! ops.gifbig_smile Effectivement, le flash n'était pas activé! Merci èfpé, merci chalu! Et meilleurs voeux de fin d'année! wink

Hors ligne

Pied de page des forums