Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 07-01-2017 18:37:53

cmm
Adhérent(e)
Lieu : Meudon
Distrib. : jessie
Noyau : 3.16.0-4-amd64
(G)UI : mate / openbox
Inscription : 23-09-2008
Site Web

[Résolu] Problème d'installation de Debian 8.6.0 sur eeepc cause UEFI

Résolu!

Bonjour et bonne année à toutes et tous!

Je viens d'essayer à deux ou trois reprises d'installer Debian 8.6.0 sur un assez vieux eeepc, modèle R051CX, initialement sous Ubuntu, car l'installation existante ne marchait plus très bien (je n'arrivais plus à faire des mises à jour). J'ai mis sur une clef usb Debian netinstall 386 et démarré l'installation. Au démarrage j'ai vu qu'il s'agissait du Debian Gnu/Linux UEFI Installer. Je ne sais pas ce qu'est l'UEFI et j'ai fait l'installation qui, apparemment, s'est parfaitement déroulée. J'avais choisi de faire l'installation sur le disque entier, un message m'ayant averti qu'à cause de l'UEFI le système déjà installé sur le disque (Ubuntu) risquait de ne plus être accessible. J'ai poursuivi quand même puisque Ubuntu ne marchait plus très bien.

Et voilà, j'ai eu tort, car une fois l'installation terminée mon Bios ne trouve pas de système bootable sur mon eeepc!

Que dois-je faire? Dois-je chercher une Debian netintall qui n'est pas UEFI, s'il en existe, et refaire l'installation? ou refaire avec la clé USB netinstall que j'ai déjà, mais en m'arrangeant (comment?) pour faire comprendre à l'installateur que mon ordinateur n'a pas d'UEFI?

J'ai cherché dans le Bios de mon eeepc et je n'ai rien trouvé permettant de faire cela.

Merci d'avance à qui pourra me dépanner!

Pour mémoire: mon eeepc fonctionne sur une clef usb bootable sur laquelle j'avais fait une copie d'Ubuntu (que je pourrais éventiellement mettre sur le disque dur si je n'arrive pas à installer Debian). Ce n'est donc pas un problème de matériel.

Dernière modification par cmm (07-01-2017 21:40:12)

Hors ligne

#2 07-01-2017 21:32:29

cmm
Adhérent(e)
Lieu : Meudon
Distrib. : jessie
Noyau : 3.16.0-4-amd64
(G)UI : mate / openbox
Inscription : 23-09-2008
Site Web

Re : [Résolu] Problème d'installation de Debian 8.6.0 sur eeepc cause UEFI

Bon mon problème est résolu, je ne comprends pas vraiment comment, mais j'ai réussi à installer Debian 8.6.0 avec bureau Mate sur mon eeepc.

J'ai démarré avec une clef usb live et reformaté le disque dur, créé une partition primaire formatée en ext4 pour / sur le disque dur, une partition étendue contenant une petite partition swap et une partition étendue formatée en ext4 pour /home. Puis j'ai recommencé l'installation avec la clef usb Debian Netinstall. A un moment l'installateur a vu qu'il existait déjà une unstallation existante sur le disque et a demandé si je voulais continuer en uefi. J'ai choisi Non, l'installation a continué est s'est bien terminée. Le système nouveau a bien consenti à démarrer sans problème.

Bonne soirée!

Hors ligne

#3 07-01-2017 22:43:06

raleur
Membre
Inscription : 03-10-2014

Re : [Résolu] Problème d'installation de Debian 8.6.0 sur eeepc cause UEFI

Les vieux firmwares UEFI sont souvent buggés. Par exemple le firmware d'une vieille série de HP Elitebook ignorait totalement l'enregistrement du chargeur d'amorçage EFI pourtant bien présent dans les variables d'amorçage EFI. Il ne prenait en compte que le chemin du chargeur par défaut. Dans l'installateur Debian, la solution était de répondre "oui" à la question demandant s'il fallait installer une copie du chargeur dans le chemin de périphérique amovible. Ce que je recommande dans tous les cas où Debian est seul sur la machine de toute façon.

L'installateur Debian est amorçable aussi bien en mode BIOS qu'en mode EFI. C'est le firmware de la machine qui décide dans quel mode il l'amorce, en fonction de sa configuration ou bien via son menu de démarrage.

Tu n'as pas résolu le problème d'amorçage en mode EFI, tu l'as juste contourné en installant un amorçage en mode BIOS. Comme tu l'écris toi-même, tu n'as pas vraiment compris ce qui s'est passé. Profites-en tant que tu as une machine dont le firmware UEFI a encore un mode de compatibilité BIOS, mais ce n'est déjà plus le cas de toutes et cela le sera de moins en moins.

Hors ligne

#4 08-01-2017 09:45:32

cmm
Adhérent(e)
Lieu : Meudon
Distrib. : jessie
Noyau : 3.16.0-4-amd64
(G)UI : mate / openbox
Inscription : 23-09-2008
Site Web

Re : [Résolu] Problème d'installation de Debian 8.6.0 sur eeepc cause UEFI

Merci pour ces explications!

A noter encore un petit problème mineur. Une fois sur trois environ, mon eeepc plante au démarrage. Cela semble dû à une carte SSD présente en permanence sur laquelle je fais mes sauvegardes. Je crois que l'installation en UEFI que j'ai faite une première fois et qui a été un échec a écrit, sur tous
les disques présents (le disque dur et cette carte SSD), des choses mauvaises qui expliquent ce plantage. Je me suis débarrassé de celles écrites sur le disque dur en le reformatant, mais pas de celles présentes sur cette carte SSD. Je vais l'enlever ou la reformater sur un autre ordinateur.

Bonne journée!

Hors ligne

#5 08-01-2017 11:30:52

raleur
Membre
Inscription : 03-10-2014

Re : [Résolu] Problème d'installation de Debian 8.6.0 sur eeepc cause UEFI

Le PC plante de quelle façon, à quel moment ?
Tu parles d'un SSD interne (format mSATA ou M.2) ou d'une carte SD (amovible), ce qui n'est pas du tout la même chose ?
L'installateur n'écrit rien de plus ou différemment sur les disques non système en mode EFI qu'en mode BIOS.

Dernière modification par raleur (08-01-2017 11:31:50)

Hors ligne

#6 08-01-2017 12:26:45

MicP
Membre
Distrib. : debian stable
Noyau : Linux 3.16.0-4-amd64
(G)UI : Xfce
Inscription : 29-02-2016

Re : [Résolu] Problème d'installation de Debian 8.6.0 sur eeepc cause UEFI

Bonjour

Pourquoi installer une version 32 bits (netinstall i386) alors qu'il s'agit d'une machine utilisant un microprocesseur 64 bits ?
Il aurait mieux valu utiliser la version 64bits : netinstall amd64

Est-que la table des partitions créée est bien au format msdos (et pas GPT) ?

Hors ligne

#7 08-01-2017 12:56:24

raleur
Membre
Inscription : 03-10-2014

Re : [Résolu] Problème d'installation de Debian 8.6.0 sur eeepc cause UEFI

MicP a écrit :

Pourquoi installer une version 32 bits (netinstall i386) alors qu'il s'agit d'une machine utilisant un microprocesseur 64 bits ?


Peut-être parce qu'un système 64 bits n'offre pas d'avantage significatif sur une machine ancienne et peu puissante avec seulement 2 Gio de RAM.

Ou bien parce que cette machine a un firmware EFI 32 bits (à vérifier), et que l'installateur Debian amd64 n'est pas compatible avec un firmware EFI 32 bits (hors mode de compatibilité BIOS - au passage, ça aurait été un bon moyen de forcer le démarrage de l'installateur en mode BIOS). L'installateur multi-arch amd64+i386 l'est, mais je ne me souviens plus s'il permet d'installer un système 64 bits lorsqu'il a été amorcé en mode EFI 32 bits. Ceci dit, si on amorce en mode de compatibilité BIOS, ce détail est sans objet.

Je note que cette machine était fournie en standard avec Windows 7 Starter, qui n'est disponible qu'en version 32 bits.

Dernière modification par raleur (08-01-2017 12:57:57)

Hors ligne

#8 08-01-2017 13:38:21

raleur
Membre
Inscription : 03-10-2014

Re : [Résolu] Problème d'installation de Debian 8.6.0 sur eeepc cause UEFI

MicP a écrit :

Est-que la table des partitions créée est bien au format msdos (et pas GPT) ?


Dans le message #2, cmm parle de partitions primaire et étendue, donc oui.
Mais pourquoi cette question ?

Dernière modification par raleur (08-01-2017 13:40:08)

Hors ligne

#9 08-01-2017 20:29:40

cmm
Adhérent(e)
Lieu : Meudon
Distrib. : jessie
Noyau : 3.16.0-4-amd64
(G)UI : mate / openbox
Inscription : 23-09-2008
Site Web

Re : [Résolu] Problème d'installation de Debian 8.6.0 sur eeepc cause UEFI

Merci de vous intéresser à mes problèmes!

L'eeepc modèle R051CX est équipé d'un processeur Atom N 2600 32 bits. Je l'ai acheté chez LDLC équipé d'Ubuntu en 20111.  J'ai essayé d'installer dessus une Debian 64 bits, çà ne marche pas. C'est d'ailleurs un processeur bas de gamme qui a fait couler pas mal d'encre quand il est sorti car avec les versions précédentes de debian il fallait recompiler le noyau pour que la puce graphique intégrée au processeur fournisse une résolution de 1024x600 sans quoi on n'avait que 800x600 ou du 800x512. Maintenant avec Debian 8 et même Debian 7 il n'est plus nécessaire de recompiler le noyau.

Le plantage au démarrage qui a lieu de temps en temps indique qu'il y a une tâche en cours d'exécution, avec un compte à rebours de 1 minute 30 qui ne s'achève jamais car quand la minute 30 est écoulée il y en a une autre qui commence aussitôt! Lorsque cela se produit, j'arrache sauvagement la batterie et le câble d'alimentation pour stopper le compte à rebours indéfini, puis je redémarre. Ce n'est pas beau mais je ne vois pas comment faire autrement! Parfois il faut le faire 2 ou 3 fois de suite. Aussi lorsque je serai plus en fonds j'investirai dans un autre petit portable peut-être un Dell latitude 12,5 pouces avec un intel core i5 ou un HP Elite book 12,5 pouces core i5 d'occasion. On en trouve entre 200 et 300 euros ce qui est compatible avec mon budget modeste.

La prochaine fois qu'un tel plantage se produira je recopierai les messages d'erreur qui s'affichent à l'écran (je ne sais pas comment faire pour trouver, après coup, les logs indiquant ces messages d'erreur).

J'ai parlé de disque dur et de carte SD. Mon eeepc n'a qu'un seul disque dur interne de 360 G ce qui est largement suffisant pour un portable d'appoint. Il y a un emplacement pour une carte ssd du type qu'on met dans les appareils photo. Je l'utilise pour y mettre une carte de 32 G c'est plus pratique qu'une clef usb parce que çà ne dépasse pas du boîtier et je m'en sers pour sauvegarder les documents sur lesquels je travaille (essentiellement des fichiers textes écrits en LaTeX et compilés en pdf, cà ne prend pas beaucoup de place, j'ai cette carte depuis plusieurs années et elle est loin d'être pleine).

Je crois vraiment que lors de ma tentative infructueuse d'installation de Debian en mode UEFI (alors que ce eeepc n'est absolument pas uefi) quelque chose de mauvais a été écrit, à la fois sur le disque interne et sur la carte SD car au lancement du bios, auquel on accède en appuyant sur la touche F2 au démarrage, pour démarrer sur la clef d'installation Netinstall, le choix du périphérique sur lequel démarrer me proposait UEFI Multicard, et j'ai dû une fois cliquer dessus. Mais je me trompe peu-être, j'utilise des ordinateurs sous linux depuis des années mais je n'y connais pas grand chose! je fais les choses routinièrement, en essayant cependant de réfléchir un peu...

Le partitionnepent du disque interne 360G que j'ai fait a été fait avec l'outil gparted. Je ne sais pas trop si c'est du msdos ou du gpt, je ne connais pas la différence entre les deux.

Bonne soirée!

C.-M. M.

Dernière modification par cmm (08-01-2017 20:33:14)

Hors ligne

#10 08-01-2017 20:48:42

robert2a
Membre
Lieu : France
Distrib. : Stretch 9.0
Noyau : Linux 4.9.0-1-amd64
(G)UI : Mate 1.16.1 Nvidia 375.26-1 Cuda 8.0.44-3
Inscription : 15-11-2014

Re : [Résolu] Problème d'installation de Debian 8.6.0 sur eeepc cause UEFI

Bonsoir
avec gparted , dans le menu affichage => information
tu ouvre une fenetre a gauche qui te donne en autre le type " de la table de partition "
quand tu la créer a mon avis par défaut il affecté " msdos " si tu n a rien sélectionné .

j'ai pas suivi la discussion  , mais j espere que tu a un bureau trés léger (gdm3 et gnome a éviter ) , ton profil ne correspond peut etre pas a cette installation.

Dernière modification par robert2a (08-01-2017 20:58:11)

Hors ligne

#11 08-01-2017 20:52:11

cmm
Adhérent(e)
Lieu : Meudon
Distrib. : jessie
Noyau : 3.16.0-4-amd64
(G)UI : mate / openbox
Inscription : 23-09-2008
Site Web

Re : [Résolu] Problème d'installation de Debian 8.6.0 sur eeepc cause UEFI

Oui, tu as raison, c'est bien MSDOS.

Merci pour ton commentaire!

Hors ligne

#12 08-01-2017 21:25:38

raleur
Membre
Inscription : 03-10-2014

Re : [Résolu] Problème d'installation de Debian 8.6.0 sur eeepc cause UEFI

cmm a écrit :

L'eeepc modèle R051CX est équipé d'un processeur Atom N 2600 32 bits.


En fait d'après Wikipédia ce processeur Atom N2600 de la famille Cedarview supporte le jeu d'instructions 64 bits, mais seulement avec un chipset et un BIOS "compatibles 64 bits". J'avoue que j'ignore ce que cela signifie. Mais en bref, toutes les machines équipées de ce processeur ne supportent pas forcément les systèmes d'exploitation 64 bits.

cmm a écrit :

Le plantage au démarrage qui a lieu de temps en temps indique qu'il y a une tâche en cours d'exécution, avec un compte à rebours de 1 minute 30 qui ne s'achève jamais car quand la minute 30 est écoulée il y en a une autre qui commence aussitôt! Lorsque cela se produit, j'arrache sauvagement la batterie et le câble d'alimentation pour stopper le compte à rebours indéfini,


Ce n'est pas un plantage, c'est juste systemd qui attend quelque chose et normalement c'est écrit juste au dessus.
Il n'est pas nécessaire en plus d'être risqué d'éteindre brutalement la machine, un simple Ctrl+Alt+Suppr ou au pire une séquence de "touches magiques" se terminant par Alt+ImpEcran+b pour redémarrer proprement devrait suffire.

cmm a écrit :

J'ai parlé de disque dur et de carte SD.


Ok. Pas de SSD.

cmm a écrit :

Il y a un emplacement pour une carte ssd


Carte SD ! Merci d'être précis et d'éviter toute source de confusion.

cmm a écrit :

alors que ce eeepc n'est absolument pas uefi


Bien sûr que si. Autrement, l'installateur Debian ne démarrerait pas en mode EFI.

cmm a écrit :

quelque chose de mauvais a été écrit, à la fois sur le disque interne et sur la carte SD


Je doute fort que quoi que ce soit ait été écrit par l'installateur sur la carte SD. Mais, si elle est formatée en FAT, tu peux vérifier s'il y a un répertoire "efi" à la racine de la carte. S'il n'y en a pas, elle n'est pas concernée par l'amorçage en mode EFI.

cmm a écrit :

le choix du périphérique sur lequel démarrer me proposait UEFI Multicard, et j'ai dû une fois cliquer dessus


Si le firmware était un simple BIOS non UEFI, il ne proposerait pas un démarrage UEFI.
Que s'est-il passé lorsque tu as cliqué dessus ?

J'ai pas mal bidouillé avec l'UEFI, alors je m'y connais un peu.

Hors ligne

#13 08-01-2017 23:08:38

smolski
administrateur quasi...modo
Lieu : AIN
Distrib. : 8 (jessie) 64 bits + backports
Noyau : 3.16.0-4-amd64 - 3.16.39-1
(G)UI : gnome 1:3.14+3
Inscription : 21-10-2008

Re : [Résolu] Problème d'installation de Debian 8.6.0 sur eeepc cause UEFI

Heureusement que le post est marqué en Resolu, sinon, qu'est-ce que ce seraient comme questions réponses maintenant !
... character0277.gif

"Théo et Adama te rappellent pourquoi Zyed et Bouna couraient…"
"L'utopie ne signifie pas l'irréalisable, mais l'irréalisée." - T Monod (source :  La zone de Siné)
"Je peux rire de tout mais pas avec n'importe qui." - P Desproges
"saque eud dun" (patois chtimi : fonce dedans)

Hors ligne

#14 08-01-2017 23:56:19

cmm
Adhérent(e)
Lieu : Meudon
Distrib. : jessie
Noyau : 3.16.0-4-amd64
(G)UI : mate / openbox
Inscription : 23-09-2008
Site Web

Re : [Résolu] Problème d'installation de Debian 8.6.0 sur eeepc cause UEFI

Oui Joël a raison, j'arrête. J'ai sans doute dit des bêtises, mais je persiste à affirmer que le système netinstall de Debian marche maintenant beaucoup mois bien qu'autrefois et qu'il m'a joué un sale tour.

Depuis le passage de debian de 7 à 8, rien ne va plus, et pas rien que pour l'installateur. Gnome est devenu hideux (normal, après tout, pour un gnome!), et Mate est toujours aussi inachevé..

Ce n'est pas la première fois que j'installe debian sur cet eeepc. Les autres fois, il n'était pas question d'uefi et l'installation se passait correctement, même si une fois l'installation  faite j'avais une faible résolution et j'étais obligé de recompiler le noyau, ou si le port vga restait invisible.. Cette fois-ci çà part en uefi (pourquoi???), çà cafouille et je n'en sors pas vraiment.

Cette fois le message d'erreur que j'ai eu est

A start job is running for LSB: NFC support files co... /no limits


qu'est-ce que c'est que LSB? et NFC support files??

Et pas moyen darrêter çà avec une combinaison de touches magique, il faut enlever la batterie!

Bonne nuit!

Hors ligne

#15 09-01-2017 03:04:04

smolski
administrateur quasi...modo
Lieu : AIN
Distrib. : 8 (jessie) 64 bits + backports
Noyau : 3.16.0-4-amd64 - 3.16.39-1
(G)UI : gnome 1:3.14+3
Inscription : 21-10-2008

Re : [Résolu] Problème d'installation de Debian 8.6.0 sur eeepc cause UEFI

Ouvrir un nouveau post concernant les problèmes et questionnements soulevés après pourrait être plus profitable plutôt que de suivre sur cette installation qui a été résolu dans son aspect général il me semble ?

Toutefois, ce topic t'appartient et je me garderai bien de t'imposer quelque chose (sauf humour tel que se voulait l'intervention précédente, mais bon, tout le monde ne tire pas deux fois la fève royale sans se monter un petit peu du col, non ?).

... character0286.gif

Un petit air pour un sourire :
http://musictonic.com/music/Film+Un+Hom … wAfq9uCvbk

"Théo et Adama te rappellent pourquoi Zyed et Bouna couraient…"
"L'utopie ne signifie pas l'irréalisable, mais l'irréalisée." - T Monod (source :  La zone de Siné)
"Je peux rire de tout mais pas avec n'importe qui." - P Desproges
"saque eud dun" (patois chtimi : fonce dedans)

Hors ligne

#16 09-01-2017 09:20:26

MicP
Membre
Distrib. : debian stable
Noyau : Linux 3.16.0-4-amd64
(G)UI : Xfce
Inscription : 29-02-2016

Re : [Résolu] Problème d'installation de Debian 8.6.0 sur eeepc cause UEFI

Bonjour

cmm a écrit :

…qu'est-ce que c'est que LSB? et NFC support files?? …

NFC <=> Near Field Communication
LSB <=> Linux Standard Base

Hors ligne

#17 09-01-2017 12:12:17

cmm
Adhérent(e)
Lieu : Meudon
Distrib. : jessie
Noyau : 3.16.0-4-amd64
(G)UI : mate / openbox
Inscription : 23-09-2008
Site Web

Re : [Résolu] Problème d'installation de Debian 8.6.0 sur eeepc cause UEFI

Merci MicP pour cette information (qui pour moi est assez cryptique!).

Merci aussi à raleur pour la séquence de touches Control Alt Del qui, effectivement, m'évite d'arracher la batterie!

Merci à Joël Smolski pour la belle musique!

Pour moi, fin de ce post, mon eeepc est suffisamment opérationnel pour être à nouveau utilisable, bien que le démarrage cafouille souvent. Mais je crains fort qu'on ne puisse pas faire beaucoup mieux avec ce matériel. Je vais tout de même vérifier avec mon téléviseur si les sorties vga et hdmi sont reconnues (elles ne l'étaient pas avec Debian 7, et assez mal avec ubuntu), car c'est utile pour les présentations.

Hors ligne

#18 09-01-2017 12:17:51

robert2a
Membre
Lieu : France
Distrib. : Stretch 9.0
Noyau : Linux 4.9.0-1-amd64
(G)UI : Mate 1.16.1 Nvidia 375.26-1 Cuda 8.0.44-3
Inscription : 15-11-2014

Re : [Résolu] Problème d'installation de Debian 8.6.0 sur eeepc cause UEFI

Bonjour
c'est plutot un problème matériel que logiciel :

https://forum.ubuntu-fr.org/viewtopic.php?id=1017271
https://forum.ubuntu-fr.org/viewtopic.php?id=1012511

pour la compatibilité a priori le cpu utilise un chipset ce qui n est plus le cas sur nos cartes mères récente , le pont nord (traduction fr a disparut) , il ne reste plus que le southbrige pour les périphériques lent
nos cpu récent ont un controleur mémoire intégré et une liaison directe sur le PCIe
seul les périphériques lent comme l ide , sata , port com , usb , bus pci (et autres ) ont besoin du chipset sud qui fait interface avec ces périphériques .
Intel n'a pas fait que de bonnes choses , voir les cpu Pentium 4 qui n ont pas été une réussite (consommation et puissance ) , le dual core a inversé la tendance

dire que gnome et mate ne sont pas terrible comme bureau c'est peut etre inexacte wink  tongue

donc la réflexion de raleur sur bios et chipset compatible 64 pour ce cpu utilisé en 64 me rappelle la vieille époque old_geek.gif
a ce sujet il me semble que c est Amd qui a sorti le premier des plateformes vraiment compatible 64

donc comme j ai dit plus haut , gnome + gdm3 est a proscrire sur ce genre de machine , et a priori très difficile d'avoir un rendu graphique correct sous linux avec cette machine .

@cmm

désolé pour mon intervention smile
j'ai pas trop d'experience sur du matèriel mobile de ce genre , a priori pas que du bon roll

Dernière modification par robert2a (09-01-2017 12:23:14)

Hors ligne

Pied de page des forums