Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 09-02-2017 01:35:18

d33p
Adhérent(e)
Lieu : Lorraine
Distrib. : Debian testing buster 64bits
Noyau : En fonction des updates testing buster
(G)UI : En fonction des updates testing buster
Inscription : 01-12-2015

[RESOLU] masque clavier & entrée en session - KDM

Hello,

Je viens d'installer Debian sur un laptop (je commence à le propager partout tongue )

J'ai configuré le clavier en français Belge, c'est juste.
L'os j'ai laissé en anglais au niveau langue.
Juste à l'ecran de login avant l'entrée en session KDE, lorsqu'il faut taper le mot de passe le masque du clavier est anglais.
Dans la session KDE aucun souci, il est en "be"

Et pour info voici le contenu du fichier  /etc/default/keyboard

# KEYBOARD CONFIGURATION FILE

# Consult the keyboard(5) manual page.

XKBMODEL="logiaccess"
XKBLAYOUT="be"
XKBVARIANT=""
XKBOPTIONS="terminate:ctrl_alt_bksp"

BACKSPACE="guess"



Et au cas ou, j'ai deja testé ceci:

sudo dpkg-reconfigure keyboard-configuration



Cela ne change rien...

Est ce que quelqu'un sait ou bricoler à part dans ce fichier?
Et c'est louche qu'il me mette un masque anglais, je ne lui ai jamais demandé...


d33p

Dernière modification par d33p (09-02-2017 23:55:23)


science sans conscience n'est que ruine de l'âme...

Hors ligne

#2 09-02-2017 09:15:18

chalu
Modératrice
Lieu : Anjou
Distrib. : Debian Stretch
Noyau : Linux 4.9.0-3-amd64
(G)UI : Mate 1.16
Inscription : 11-03-2016

Re : [RESOLU] masque clavier & entrée en session - KDM

Bonjour,
Le modèle pc105 ne convient pas pour le modèle à la place de logiaccess ?

Hors ligne

#3 09-02-2017 09:33:31

robert2a
Membre
Lieu : France
Distrib. : Buster 10
Noyau : Linux 4.14.0-1 4.14.2-1
(G)UI : Mate/Gnome
Inscription : 15-11-2014

Re : [RESOLU] masque clavier & entrée en session - KDM

Bonjour
a l'invite de logging il me semble que tu a le choix du clavier , enfin avec gnome et mate . (pour mate c'est en haut a gauche )

Hors ligne

#4 09-02-2017 10:14:56

chalu
Modératrice
Lieu : Anjou
Distrib. : Debian Stretch
Noyau : Linux 4.9.0-3-amd64
(G)UI : Mate 1.16
Inscription : 11-03-2016

Re : [RESOLU] masque clavier & entrée en session - KDM

Hors ligne

#5 09-02-2017 12:10:03

d33p
Adhérent(e)
Lieu : Lorraine
Distrib. : Debian testing buster 64bits
Noyau : En fonction des updates testing buster
(G)UI : En fonction des updates testing buster
Inscription : 01-12-2015

Re : [RESOLU] masque clavier & entrée en session - KDM

Hello, j'aurais cette machine sous la main ce soir apres le boulot.
Je testerais par rapport à vos differentes reponses.
Je vous tiens au jus!

merci, à bientot

d33p

science sans conscience n'est que ruine de l'âme...

Hors ligne

#6 09-02-2017 12:34:42

èfpé
Membre
Inscription : 10-07-2016

Re : [RESOLU] masque clavier & entrée en session - KDM

Salut,

C'est KDM le gestionnaire de connexion ? dans ce cas il semble que ça se passe de ce côté :

System Settings > System Administration > Login Screen


Enfin un truc du genre (#doctoutepourrie #flemmedelancerunlivekde) tu vois quoi !

Dernière modification par èfpé (09-02-2017 13:34:42)

Hors ligne

#7 09-02-2017 12:48:38

d33p
Adhérent(e)
Lieu : Lorraine
Distrib. : Debian testing buster 64bits
Noyau : En fonction des updates testing buster
(G)UI : En fonction des updates testing buster
Inscription : 01-12-2015

Re : [RESOLU] masque clavier & entrée en session - KDM

salut, oui c'est kdm.
c'est louche quand meme depuis le debut de l'installation j'ai precisé clavier "belgian/french" et que je me retrouve avec l'entrée en session en clavier "english"
menfin ^^

science sans conscience n'est que ruine de l'âme...

Hors ligne

#8 09-02-2017 22:39:51

d33p
Adhérent(e)
Lieu : Lorraine
Distrib. : Debian testing buster 64bits
Noyau : En fonction des updates testing buster
(G)UI : En fonction des updates testing buster
Inscription : 01-12-2015

Re : [RESOLU] masque clavier & entrée en session - KDM

Je suis en train de faire les tests, le probleme c'est uniquement au login car si je demarre en mode recovery, dans la console je suis en clavier "be"....

Dernière modification par d33p (09-02-2017 23:12:22)


science sans conscience n'est que ruine de l'âme...

Hors ligne

#9 09-02-2017 23:01:50

d33p
Adhérent(e)
Lieu : Lorraine
Distrib. : Debian testing buster 64bits
Noyau : En fonction des updates testing buster
(G)UI : En fonction des updates testing buster
Inscription : 01-12-2015

Re : [RESOLU] masque clavier & entrée en session - KDM

j'ai trouvé ceci:
https://wiki.archlinux.org/index.php/KD … leshooting

Mais le repertoire config dans usr/share/ n'existe plus...

science sans conscience n'est que ruine de l'âme...

Hors ligne

#10 09-02-2017 23:11:18

d33p
Adhérent(e)
Lieu : Lorraine
Distrib. : Debian testing buster 64bits
Noyau : En fonction des updates testing buster
(G)UI : En fonction des updates testing buster
Inscription : 01-12-2015

Re : [RESOLU] masque clavier & entrée en session - KDM

j'ai testé ça aussi:
https://wiki.archlinux.fr/Xorg
creation du fichier

Fichier: "/etc/X11/xorg.conf.d/10-keyboard-layout.conf"

Section "InputClass"
    Identifier         "Keyboard Layout"
    MatchIsKeyboard    "yes"
    Option             "XkbLayout"  "be"
    Option             "XkbVariant" "latin9" # accès aux caractères spéciaux plus logique avec "Alt Gr" (ex : « » avec "Alt Gr" w x)
EndSection



Et la c'est magique, l'interface graphique est out lol, j'vais faire un roll back...


science sans conscience n'est que ruine de l'âme...

Hors ligne

#11 09-02-2017 23:13:05

d33p
Adhérent(e)
Lieu : Lorraine
Distrib. : Debian testing buster 64bits
Noyau : En fonction des updates testing buster
(G)UI : En fonction des updates testing buster
Inscription : 01-12-2015

Re : [RESOLU] masque clavier & entrée en session - KDM

le probleme à l'air de venir de KDM ...
mais je seche un peu la...
si qqun a une idée tongue

science sans conscience n'est que ruine de l'âme...

Hors ligne

#12 09-02-2017 23:14:14

èfpé
Membre
Inscription : 10-07-2016

Re : [RESOLU] masque clavier & entrée en session - KDM

(réponse au post #9)

Oui, c'est un des liens postés plus haut... tu n'as pas trouvé en graphique ?

1486842121.png1486842180.png

Le fichier de config serait actuellement /etc/kde4/kdm/Xsetup, selon le man.

edit: un (mauvais) choix de paramètres régionaux est peut-être la cause neutral

Dernière modification par èfpé (11-02-2017 22:24:24)

Hors ligne

#13 09-02-2017 23:52:45

d33p
Adhérent(e)
Lieu : Lorraine
Distrib. : Debian testing buster 64bits
Noyau : En fonction des updates testing buster
(G)UI : En fonction des updates testing buster
Inscription : 01-12-2015

Re : [RESOLU] masque clavier & entrée en session - KDM

Hello èfpé,

Bien vu, j'avais fait une erreur de bon debutant, j'avais fait un locate sur xsetup, mais sans le "X" en majuscule, donc forcement comme la casse est prise en compte, je ne l'avais pas trouvé tongue
J'ai donc modifié le fichier /etc/kde4/kdm/Xsetup et ajouté comme decrit:

setxkbmap be


Et en effet, maintenant à l'entrée en session j'ai bien le masque "be"

Mais de là decoule une autre question, j'ai installé depuis quelques temps quelques Debian et je n'ai jamais eu à configurer ce fichier avant pour que cela fonctionne.
J'ai verifié sur mon autre Debian, qui a la meme config, et ce fichier est par defaut sans la manip decrite ci-dessus...
C'est tres louche...

Donc, oui ça fonctionne, mais je reste sur ma faim en ne comprenant pas pourquoi cela reagit differemment avec des installations identiques...

merci èfpé pour m'avoir remis sur la voie ^^

@ bientot
d33p

Dernière modification par d33p (09-02-2017 23:54:04)


science sans conscience n'est que ruine de l'âme...

Hors ligne

Pied de page des forums