Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 13-02-2017 16:25:06

jchenri
Membre
Distrib. : Debian 8.7 Jessie
Noyau : Linux 3.16.0-4-amd64
(G)UI : KDE
Inscription : 05-02-2017

[Résolu] numlock clavier sans fil

bonjour,

j'ai lu tous les posts concernant numlock AU DEMARRAGE
dans un 1er temps j'ai installé numlockx
j'ai essayé toutes les propositions:

1) dans /etc/kde4/kdm/Xsetup ajout:

if [ -x /usr/bin/numlockx ]; then
        /usr/bin/numlockx on
fi



2) dans  /etc/kde4/kdm/kdmrc :
décommenter la ligne #NumLock = Off
pour avoir : NumLock = On

etc...
Sans succès.

Une question me vient à l'esprit :
  Ces commandes peuvent elles marcher avec un CLAVIER SANS FIL

Merci
jchenri

Hors ligne

#2 13-02-2017 16:31:27

chalu
Modératrice
Lieu : Anjou
Distrib. : Debian Jessie (saveur Handylinux 2.5) à jour
Noyau : Linux 3.16.0-4-amd64
(G)UI : XFCE - xfwm4
Inscription : 11-03-2016

Re : [Résolu] numlock clavier sans fil

Bonjour smile
au démarrage tu veux dire pour l’écran de connexion ou c'est dans la session après s'être connecté ?

Bien débuter sur Debian :
->Les cahiers du débutant + le wiki Découvrir les principales commandes Linux
-> Le projet DFlinux (DebianFacileLinux) pour débutants: ISOs (i386 et amd64) basées sur Debian stable avec des outils facilitants
-> Retours et avis sur DFLinux dans ce fil

En ligne

#3 13-02-2017 16:38:23

jchenri
Membre
Distrib. : Debian 8.7 Jessie
Noyau : Linux 3.16.0-4-amd64
(G)UI : KDE
Inscription : 05-02-2017

Re : [Résolu] numlock clavier sans fil

merci chalu pour ta réponse

je veux dire    pour l'écran de connexion,
AVANT d'entrer mon mot de passe et d'être loggé sur la session

jchenri

Hors ligne

#4 13-02-2017 16:51:33

chalu
Modératrice
Lieu : Anjou
Distrib. : Debian Jessie (saveur Handylinux 2.5) à jour
Noyau : Linux 3.16.0-4-amd64
(G)UI : XFCE - xfwm4
Inscription : 11-03-2016

Re : [Résolu] numlock clavier sans fil

ok smile
As-tu activé le pavé numérique dans les paramètres clavier de KDE et constates-tu que le pavé s'active après connexion ?

Bien débuter sur Debian :
->Les cahiers du débutant + le wiki Découvrir les principales commandes Linux
-> Le projet DFlinux (DebianFacileLinux) pour débutants: ISOs (i386 et amd64) basées sur Debian stable avec des outils facilitants
-> Retours et avis sur DFLinux dans ce fil

En ligne

#5 13-02-2017 17:06:59

jchenri
Membre
Distrib. : Debian 8.7 Jessie
Noyau : Linux 3.16.0-4-amd64
(G)UI : KDE
Inscription : 05-02-2017

Re : [Résolu] numlock clavier sans fil

effectivement, dans configuration -> Périphériques d'entrée -> Clavier
le verrouillage numérique n'était pas activé

j'ai mis ce réglage sur Activé, puis j'ai redémarré la machine
une fois sur l'écran de connexion, le pavé numérique n'était toujours pas activé.

en fait à ce stade là  KDE n'est pas encore chargé (je crois)

peut-être n'y a t il pas de retour PC vers clavier sans fil ?

jchenri

Hors ligne

#6 13-02-2017 17:10:32

èfpé
Membre
Distrib. : Debian
Noyau : Linux
Inscription : 10-07-2016

Re : [Résolu] numlock clavier sans fil

Bonjour,

Juste une question (et demi smile) en passant : s'agit-il d'un portable ? et si oui, le paquet laptop-detect est-il installé ?

Hors ligne

#7 13-02-2017 17:12:03

jchenri
Membre
Distrib. : Debian 8.7 Jessie
Noyau : Linux 3.16.0-4-amd64
(G)UI : KDE
Inscription : 05-02-2017

Re : [Résolu] numlock clavier sans fil

non non,
c'est un desktop classique , un PC bureau

Hors ligne

#8 13-02-2017 17:22:30

chalu
Modératrice
Lieu : Anjou
Distrib. : Debian Jessie (saveur Handylinux 2.5) à jour
Noyau : Linux 3.16.0-4-amd64
(G)UI : XFCE - xfwm4
Inscription : 11-03-2016

Re : [Résolu] numlock clavier sans fil

oui mais une fois la session lancée sans que tu ais activé le pavé, est-ce qu'il s'active tout seul avec le réglage fait dans les paramètres de kde ?
sinon vérifie ton fichier plus haut

if [ -x /usr/bin/numlockx ]; then
exec /usr/bin/numlockx on
fi


il manque exec ? ou un mauvais copier coller

Quand j'ai testé KDE, j'avais réglé les paramètres de KDE pour activer le pavé numérique et ça fonctionnait seulement après m'être connectée. Les modifs que tu as fait avaient permis de l'activer dès l'ecran de connexion ce qui était pratique.


Bien débuter sur Debian :
->Les cahiers du débutant + le wiki Découvrir les principales commandes Linux
-> Le projet DFlinux (DebianFacileLinux) pour débutants: ISOs (i386 et amd64) basées sur Debian stable avec des outils facilitants
-> Retours et avis sur DFLinux dans ce fil

En ligne

#9 13-02-2017 17:34:32

èfpé
Membre
Distrib. : Debian
Noyau : Linux
Inscription : 10-07-2016

Re : [Résolu] numlock clavier sans fil

Re-,

As-tu testé une syntaxe plus simple 'numlockx on' dans le fichier de configuration /etc/kde4/kdm/Xsetup, justement ?

Hors ligne

#10 13-02-2017 19:03:19

Croutons
Membre
Distrib. : Handylinux 2.5 vers debian 8.6
Noyau : Linux 3.16.0-4-686-pae
(G)UI : xfce
Inscription : 16-12-2016

Re : [Résolu] numlock clavier sans fil

Bonsoir
Il faudrait regarder dans le BIOS, je me rappel avoir vu un paramètre pour le numlock
Mais comme c'est un Biosnausaure je sais pas si il y a se genre d'option sur les plus récent

En ligne

#11 13-02-2017 19:18:07

jchenri
Membre
Distrib. : Debian 8.7 Jessie
Noyau : Linux 3.16.0-4-amd64
(G)UI : KDE
Inscription : 05-02-2017

Re : [Résolu] numlock clavier sans fil

désolé pour l'attente de ma réponse,
j'ai du m'absenter une petite heure et je reprends.

tout d'abord merci à èfpé et à Croutons, qui se sont joints à la discussion.

j'ai essayé en ajoutant exec

if [ -x /usr/bin/numlockx ]; then
exec /usr/bin/numlockx on
fi


mais ça ne marche pas.
j'avais aussi essayé de mettre simplement  numlockx on dans le fichier Xsetup,
sans succès non plus.

Pour voir éventuellement avec le bios, comment je fais

merci
jchenri

Hors ligne

#12 13-02-2017 20:58:33

èfpé
Membre
Distrib. : Debian
Noyau : Linux
Inscription : 10-07-2016

Re : [Résolu] numlock clavier sans fil

Re-,

L'entrée dans l'interface de configuration du BIOS se fait au (re)démarrage de la machine après le POST (bip), par l'appui sur la touche indiquée à l'écran, par exemple <Suppr> ; pour une aide plus précise :

dmesg | grep DMI:


Qui devrait nous indiquer les références de la machine/carte mère et du BIOS...

Dernière modification par èfpé (15-02-2017 18:48:33)

Hors ligne

#13 14-02-2017 11:12:10

jchenri
Membre
Distrib. : Debian 8.7 Jessie
Noyau : Linux 3.16.0-4-amd64
(G)UI : KDE
Inscription : 05-02-2017

Re : [Résolu] numlock clavier sans fil

Bonjour,

Je me suis décidé à changer mon mot de passe de connexion
je n'ai gardé que des lettres et enlevé les chiffres
donc je peux me connecter SANS appuyer sur la touche Verrouillage numérique

une fois la connexion établie, je suis sous KDE avec num lock sans avoir manipulé la touche
donc les réglages ( numlockx = on   ...etc) fonctionnent bien

En fait, lorsque j'était sous fedora, je n'avais pas ce problème, vu que je me connectait
sans mot de passe et après essai, même sous fedora, je n'était pas en ver num, tant que je
n'était pas connecté.

petite parenthèse sur fedora :
j'ai largué fedora 25 à cause de son instabilité phénoménale, alors
que j'étais fedora depuis 10 ans, sans problème avant la 25.
J'ai trouvé avec Debian stable,   un havre de paix,
certe les applications ne sont pas forcément au dernier cri (KDE 4, par exemple),
mais quelle tranquilité,    merci Debian

En tout cas, merci à vous tous de m'avoir suivi dans cette discussion

jchenri

ps: dois je marquer cette discussion comme résolue, et comment je fais?

Hors ligne

#14 14-02-2017 13:10:45

Croutons
Membre
Distrib. : Handylinux 2.5 vers debian 8.6
Noyau : Linux 3.16.0-4-686-pae
(G)UI : xfce
Inscription : 16-12-2016

Re : [Résolu] numlock clavier sans fil

jchenri a écrit :

ps: dois je marquer cette discussion comme résolue, et comment je fais?


Tu édites ton premier message

En ligne

#15 14-02-2017 16:17:19

èfpé
Membre
Distrib. : Debian
Noyau : Linux
Inscription : 10-07-2016

Re : [Résolu] numlock clavier sans fil

Bonjour,

Les bidouillages sur les fichiers de configuration de KDM ne concernant que KDM, il est hautement probable que le verrouillage observé une fois la session ouverte soit le résultat de la manip décrite au post #5 :

Configuration du système > Matériel > Périphériques d'entrée > Clavier


Pour ce qui est de KDM, tu n'as rien trouvé par ici ?

Configuration du système > Administration du système > Écran de connexion


Quoi qu'il en soit le tag [Contourné] ou [Impossible] conviendra mieux que [Résolu] hmm

Hors ligne

#16 14-02-2017 17:18:51

jchenri
Membre
Distrib. : Debian 8.7 Jessie
Noyau : Linux 3.16.0-4-amd64
(G)UI : KDE
Inscription : 05-02-2017

Re : [Résolu] numlock clavier sans fil

Bonjour,

Je pense comme toi èfpé, que le réglage dans

Configuration du système > Matériel > Périphériques d'entrée > Clavier

a soldé le problème.
Je vais en rester là.
jchenri

Hors ligne

#17 15-02-2017 12:38:22

chalu
Modératrice
Lieu : Anjou
Distrib. : Debian Jessie (saveur Handylinux 2.5) à jour
Noyau : Linux 3.16.0-4-amd64
(G)UI : XFCE - xfwm4
Inscription : 11-03-2016

Re : [Résolu] numlock clavier sans fil

Ok donc tu as retrouvé la situation connue sur fedora.
Pour passer en résolu, il suffit de cliquer sur modifier dans ton premier message et d'ajouter ensuite [Résolu] dans le titre.
Je vais le faire cette fois-ci et tu le feras pour les prochains fils si tu en crées smile

Bien débuter sur Debian :
->Les cahiers du débutant + le wiki Découvrir les principales commandes Linux
-> Le projet DFlinux (DebianFacileLinux) pour débutants: ISOs (i386 et amd64) basées sur Debian stable avec des outils facilitants
-> Retours et avis sur DFLinux dans ce fil

En ligne

Pied de page des forums