Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 13-02-2017 17:25:58

leverrid
Membre
Inscription : 13-02-2017

Probleme PXE

Bonjour,

Alors voilà sa fais deux semaines que je me cogne la tête contre une serveur PXE ^^

J'ai donc à l'heure actuel un serveur debian (8.7) avec les services isc-dhcp-server, tftp-hpa et pxe; ainsi qu'un client.

L'ensemble est virtualisé sous un ESX au siens d'un VLAN dédier.

Lorsque que le client boot sur le serveur PXE, j'ai ces erreurs là :


PXE-T01: File not found
PXE-E3B: TFTP Error - File Not Found
PXE-M0F: Exiting Intel PXE ROM
 



Mes nombreuses recherches me dise que le soucis viens de mon service DHCP. voici la partie du fichier de configuration qui concerne le PXE:


# PXE
subnet 192.168.117.0 netmask 255.255.255.0 {
    authoritative;
    allow unknown-clients;
    # range dynamic-bootp 192.168.117.120 192.168.117.145;
    range dynamic-bootp 192.168.117.120 192.168.117.145;
    option domain-name-servers 8.8.8.8, 192.168.10.1;
    option routers 192.168.117.254;
    option subnet-mask 255.255.255.0;
    option broadcast-address 192.168.117.255;
    default-lease-time 43200;
    max-lease-time 86400;
    option tftp-server-name "PXE";
    option bootfile-name "pxe/pxelinux.0";
    }
 



Quelqu'un à une piste, parce que là clairement je sèche sad

Merci bonne journée

Hors ligne

#2 13-02-2017 20:41:29

robert2a
Membre
Lieu : France
Distrib. : Stretch 9
Noyau : Linux 4.9.0-3 4.9.30-2
(G)UI : Mate
Inscription : 15-11-2014

Re : Probleme PXE

Bonsoir
ceci me dérange


option tftp-server-name "PXE";
    option bootfile-name "pxe/pxelinux.0";
 


plutot ceci


option domain-name-servers 192.168.1.1; # ici tu met l ip de ton serveur
filename "pxelinux.0";

group {
      next-server 192.168.1.1; # ip du serveur pxe
      host tftpclient {
           filename "pxelinux.0";
      }
 



j'ai repris l exemple sur le tuto clonezilla  =>  https://debian-facile.org/doc:reseau:se … clonezilla

ton client pxe se voit attribuer une ip ?

Dernière modification par robert2a (13-02-2017 20:44:23)

Hors ligne

#3 13-02-2017 22:30:58

leverrid
Membre
Inscription : 13-02-2017

Re : Probleme PXE

J'ai enfin réussie à booter sur le pxe (j'affiche le menu pxe).
Et effectivement y avait un problème sur mon fichier de configuration dhcp.
Au final il ressemble à sa :


# PXE
subnet 192.168.117.0 netmask 255.255.255.0 {
    authoritative;
    allow unknown-clients;
    # range dynamic-bootp 192.168.117.120 192.168.117.145;
    range dynamic-bootp 192.168.117.120 192.168.117.145;
    option domain-name-servers 8.8.8.8, 192.168.10.1;
    option routers 192.168.117.254;
    option subnet-mask 255.255.255.0;
    option broadcast-address 192.168.117.255;
    default-lease-time 43200;
    max-lease-time 86400;
    option tftp-server-name "192.168.117.201";
    option bootfile-name "pxe/pxelinux.0";
    }
 



Mais j'avais également une faute de frappe dans le fichier de configuration de mon service tftp. 192.169.117.200 à la place de 192.168.117.200 sa fonctionne moins bien ^^

Mais j'ai un autre problème maintenant :

Lorsque je suis arrive sur le menu pxe j'ai beau sélectionner n'importe quel option dans le menu mais rien ne se passe.
Seul l'option pour démarrer sur le disque dur fonctionne.

J'ai suivie ce tuto :
http://monblog.system-linux.net/blog/20 … us-debian/

Je mais également le code du fichier de configuration du service tftp :


# /etc/default/tftpd-hpa
TFTP_USERNAME="tftp"
TFTP_DIRECTORY="/media/data/tftpboot/"
TFTP_ADDRESS="192.168.117.201:69"
TFTP_OPTIONS="--secure --create --listen --verbose"
 



Le code du fichier pxegonfig/default est identique à celui présent dans le tuto

Voilà voilà je ne sais pas si j'ai était clair. Mais je veux bien un coups de mains smile

Dernière modification par leverrid (13-02-2017 22:42:19)

Hors ligne

Pied de page des forums