Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#51 23-02-2017 20:54:03

NoobMaster
Membre
Inscription : 23-02-2017

Re : Le wifi se coupe tout seul

Hello smile , j'ai eu le soucis moi aussi,

le fait de ne laisser que "auto lo et iface lo inet loopback" à résolu mon problème, pas besoin de changer de manager pour ma part.

Bon courage

Hors ligne

#52 23-02-2017 21:24:32

Anaxagone
Membre
Distrib. : Debian 8.7 (Jessie)
Noyau : Linux 4.9.0-0.bpo.1-amd64
(G)UI : Gnome 3.14.1
Inscription : 13-02-2017

Re : Le wifi se coupe tout seul

NoobMaster a écrit :

Hello smile , j'ai eu le soucis moi aussi,

le fait de ne laisser que "auto lo et iface lo inet loopback" à résolu mon problème, pas besoin de changer de manager pour ma part.

Bon courage


Justement, c'est ce que j'avais à la base. Il y avait d'autres lignes chez toi ?

Bon, j'ai eu une coupure et j'ai dû redémarrer (je précise que je n'ai pas redémarré le PC après avoir fait les manipulations précédentes).
Donc j'ai redémarré, et toujours pas de wifi.
J'ai donc fait (en root) :

NetworkManager down


Et là, j'ai eu internet et l’icône du wifi est revenue big_smile je peux de nouveau choisir les réseaux wifi auxquels je souhaite me connecter.

Je vais voir si j'ai internet sans coupure big_smile
(je dois retourner sur Windows (dualboot), ce soir je ne pourrais pas tester)

Dernière modification par Anaxagone (23-02-2017 21:25:48)


"Je commence à comprendre ce que je suis. Je suis défectueuse. Endommagée. Mais la lucidité que j'ai me donne la force de faire ce que tu ne peux pas. C'est ce que je peux être : ta force."

Hors ligne

#53 26-02-2017 13:20:21

Anaxagone
Membre
Distrib. : Debian 8.7 (Jessie)
Noyau : Linux 4.9.0-0.bpo.1-amd64
(G)UI : Gnome 3.14.1
Inscription : 13-02-2017

Re : Le wifi se coupe tout seul

Salut smile

Bon bah non, ça ne marche toujours pas.
À chaque démarrage, je dois faire (en root) un "NetworkManager down" pour que internet fonctionne et que wicd prenne le relais.
Mais j'ai encore des coupures (je dois désactiver et réactiver le wifi). Comme avant. mad mad

"Je commence à comprendre ce que je suis. Je suis défectueuse. Endommagée. Mais la lucidité que j'ai me donne la force de faire ce que tu ne peux pas. C'est ce que je peux être : ta force."

Hors ligne

#54 26-02-2017 14:04:42

èfpé
Membre
Inscription : 10-07-2016

Re : Le wifi se coupe tout seul

Hello sad

Si tu as effectivement suivi le post #45, NetworkManager est désactivé au (re)démarrage de la machine... as-tu par contre configuré la connexion via l'interface graphique de Wicd, qui ne peut pas deviner la clé WPA ?

Il serait par ailleurs intéressant de documenter de façon rigoureuse ces fameuses coupures, qui semblent parfois sélectives, notamment quand tu accèdes toujours à la box, par exemple :

ping -c 4 192.168.1.1


Ou, comme suggéré au post #43, comparer les sorties du script avant/pendant une 'coupure' (éventuellement après avoir installé les paquets manquants) ; au moins les sorties des classiques : ifconfig, iwconfig et 'ip a' neutral

edit: je ne sais pas si la commande 'NetworkManager down' a été valide autrefois ou s'il ne s'agissait que d'une interprétation erronée du man, mais de nos jours cette commande est bidon (la commande 'NetworkManager' n'accepte que des --options, et tu peux très bien remplacer down par up, tartempion ou encore ladigueducul) :

1 user@debian:~$ sudo ping -c 1 192.168.1.1
  connect: Network is unreachable
2 user@debian:~$ sudo NetworkManager down   [retour de l'icône nm-applet]
3 user@debian:~$ sudo ping -c 1 192.168.1.1
  PING 192.168.1.1 (192.168.1.1) 56(84) bytes of data.
  64 bytes from 192.168.1.1: icmp_seq=1 ttl=64 time=0.533 ms
  --- 192.168.1.1 ping statistics ---
  1 packets transmitted, 1 received, 0% packet loss, time 0ms
  rtt min/avg/max/mdev = 0.533/0.533/0.533/0.000 ms
4 user@debian:~$ sudo NetworkManager down
  NetworkManager is already running (pid 2896)
5 user@debian:~$ sudo NetworkManager kiki
  NetworkManager is already running (pid 2896)
6 user@debian:~$ sudo NetworkManager toto
  NetworkManager is already running (pid 2896)
7 user@debian:~$ nmcli device disconnect wlan0        [départ de l'icône]
8 user@debian:~$ sudo ping -c 1 192.168.1.1
  connect: Network is unreachable
9 user@debian:~$ sudo kill 2896


En clair et sans décodeur, (a) tu relances NetworkManager en croyant l'arrêter et (b) tu n'utilises pas Wicd mais NetworkManager... et sa jolie petite nicône wink

Dernière modification par èfpé (27-02-2017 08:24:42)

Hors ligne

#55 26-02-2017 15:37:19

Croutons
Membre
Distrib. : Handylinux 2.5 vers Jessie et Debian Stretch
Noyau : Linux 3.16.0-4-686-pae, Linux 4.9.0-3-686-pae
(G)UI : xfce
Inscription : 16-12-2016

Re : Le wifi se coupe tout seul

Bonjour
Un piste a tenté
Essai de voir si en mettant une adresse ip fixe tu as le même problème
Personnellement je trouve la Livebox un peux récalcitrante de ce coté, j'avais souvent avant des problèmes de connexion limité en CPL et même sur le portable en wifi avec Windows 8
Depuis que j'ai mon ip fixe sur le PC plus de soucis, par contre sur le portable obligé de redémarrer en cas de connexion limité

-->les cahiers du debutant<--      WikiDF-->Découvrir les principales commandes Linux<--
L' expérience, c'est le nom que chacun donne à ses erreurs. Oscar Wilde

Hors ligne

Pied de page des forums