Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 24-02-2017 01:20:18

Karmazani
Membre
Distrib. : Debien GNU/Linux 8
Noyau : Linux 3.16.0-4-amd64
(G)UI : gdm3
Inscription : 12-02-2017

[Résolu] startx en root :(

Bonsoir,

j'ai fais une bêtise !

Je viens de réinstaller debian à partir d'une clé usb après moultes problèmes graphiques.

J'ai eu envie de passer sur xfce. J'ai donc installé xfce4. En revanche je n'ai pas installé lightdm, j'ai conservé gdm3 qui était pré-installé.

Une fois xfce4 installé et après un

dpkg-reconfigure gdm3


j'ai rebooté en pensant que je serai sur une session xfce mais non sad.

N'ayant pas trouvé comment passer sur xfce ou n'ayant pas suffisamment cherché big_smile, je me suis souvenu d'une certaine commande "startx"...

Sauf que j’étais en root quand je j'ai lancé et j'ai bien une nouvelle session graphique d'ouverte qui est toujours celle de base mais sans mes petites configurations du début. Par exemple tous mes settings sur firefox se sont évaporés... Le plus gros problème c'est qu'à chaque fois que je lance un terminal je suis directement en root et je ne sais pas comment repasser en user...

Donc trois questions:

1) Est-ce que je peux revenir sur ma session graphique d'avant ? Celle ou j'avais commencé à configurer quelques petits trucs.
2) Comment passer sur xfce proprement à partir de gdm3 ? C'est quand même ce que je voulais faire au début hmm.
3) Lors de l'installation debian une des dernières étapes consiste à cocher l'ensemble des "programmes" ou environnements graphiques qu'on veut préinstaller. J'ai tout decoché sauf bien sur l'environement graphique de base (premier de la liste). Comment s'appel cet environement ? J'ai l'impression que ça ressemble à du gnome mais en même temps je n'ai pas coché gnome alors j'imagine que ce n'est pas tout à fait ça.

Merci.

Dernière modification par Karmazani (25-02-2017 12:16:36)

Hors ligne

#2 24-02-2017 01:29:37

Severian
Membre
Distrib. : Debian GNU/Linux 8.7 (jessie)
Noyau : Linux 4.9.0-0.bpo.1-amd64
(G)UI : Openbox 3.6.1-4
Inscription : 13-12-2014

Re : [Résolu] startx en root :(

bonsoir
sachant que tes "petites configurations" que tu avais commencé était avec ton utilisateur normal, elles sont donc stocké dans le dossier /home/ton_user/
en te connectant en root, tu as les configurations graphique qui sont dans le dossier /root/

il est donc normal que tu n'ai pas ce que tu avais fais avant

déconnecte toi de la session graphique root
en console tu te connecte avec ton user puis tu fais le startx

"il est urgent d'attendre" (bendia)
ob3-de10.pngbanner98x30.png

Hors ligne

#3 24-02-2017 07:43:44

robert2a
Membre
Lieu : France
Distrib. : Stretch 9
Noyau : Linux 4.9.0-3 4.9.30-2
(G)UI : Mate
Inscription : 15-11-2014

Re : [Résolu] startx en root :(

oui c'est gnome par défaut avec l installateur debian (donc tu a actuellement gnome et xfce installé avec gdm3 comme lanceur )

pour choisir le bureau a partir de gdm3 tu a un petit engrenage en dessous le logging graphique qui te permet de choisir le bureau que tu veut lancer

pour te sortir du mode root , un redémarrage (de la machine ) peut aussi te sortir d'affaire si tu n'est pas sur de toi wink

Dernière modification par robert2a (24-02-2017 07:45:45)

Hors ligne

#4 24-02-2017 08:11:55

IceF0x
Membre
Distrib. : Jessie 8.7
Noyau : Linux 3.16.0-4-amd64
(G)UI : OpenBox
Inscription : 05-02-2012

Re : [Résolu] startx en root :(

J'utilise toujours startx pour lancer la session graphique, je ne vois d'ailleurs pas l'utilité d'un gestionnaire de session graphique, tout cela pour mettre une case autour du login et d'un mot de passe et un fond d'écran qu'on ne vois que quelques secondes.

sinon la réponse est simple

systemctl tonloginmanager.service start



Remplace tonloginmanager par le nom exact de ton gestionnaire de login, et ensuite

systemctl tonloginmanager.service enable



Normalement au prochain boot ça devrait fonctionner, mais je ne peux te le garantir, car comme expliqué au début, je n'utilise pas ces trucs useless.


1475862269.gif

Hors ligne

#5 25-02-2017 12:16:10

Karmazani
Membre
Distrib. : Debien GNU/Linux 8
Noyau : Linux 3.16.0-4-amd64
(G)UI : gdm3
Inscription : 12-02-2017

Re : [Résolu] startx en root :(

Merci beaucoup j'ai retrouvé mon bureau Xfce tongue.

Hors ligne

#6 25-02-2017 12:17:19

smolski
administrateur quasi...modo
Lieu : AIN
Distrib. : 8 (jessie) 64 bits + backports
Noyau : 3.16.0-4-amd64 - 3.16.39-1
(G)UI : gnome 1:3.14+3
Inscription : 21-10-2008

Re : [Résolu] startx en root :(

Ah ! Si c'est résolu alors...
Voir le tuto : C'est résolu ! Bravo mais il faut l'indiquer dans l'titre.

Edit :
Zut alors.. trop tard pour le point choco df dit donc §
biggreen.gif

Dernière modification par smolski (25-02-2017 12:18:43)


"Théo et Adama te rappellent pourquoi Zyed et Bouna couraient…"
"L'utopie ne signifie pas l'irréalisable, mais l'irréalisée." - T Monod (source :  La zone de Siné)
"Je peux rire de tout mais pas avec n'importe qui." - P Desproges
"saque eud dun" (patois chtimi : fonce dedans)

Hors ligne

#7 25-02-2017 12:29:16

robert2a
Membre
Lieu : France
Distrib. : Stretch 9
Noyau : Linux 4.9.0-3 4.9.30-2
(G)UI : Mate
Inscription : 15-11-2014

Re : [Résolu] startx en root :(

Le pauvre smolski , trop lent hmm , les réflexes plus trop top  tongue   cool

Hors ligne

Pied de page des forums