Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 27-02-2017 13:52:09

debianux
Membre
Distrib. : debian-jessie-8.7_LVM-chiffré_dual-boot-uefi-w10
Noyau : Linux 4.7.0-0.bpo.1-amd64
(G)UI : Xfce 4.10
Inscription : 19-05-2014

[resolu] update: erreur GPG sur clé publique

Bonjour,

dans un 'aptitude update' j'hérite de l'erreur suivante :

W: Une erreur s'est produite lors du contrôle de la signature. Le dépôt n'est pas mis à jour et les fichiers d'index précédents seront utilisés. Erreur de GPG : ftp://ftp.project-builder.org 8 Release : Les signatures suivantes n'ont pas pu être vérifiées car la clé publique n'est pas disponible : NO_PUBKEY 8AB63AFD171EFF9E

W: impossible de récupérer ftp://ftp.project-builder.org//debian/dists/8/Release :
W: Échec du téléchargement pour certains fichiers d'index. Soit ils ont été ignorés, soit les anciens fichiers ont été utilisés à la place.
 



sur une 'inspiration' issue d'ici:
https://debian-facile.org/doc:systeme:apt:signatures

gpg --keyserver hkp://wwwkeys.eu.pgp.net --recv-keys 8AB63AFD171EFF9E

 


gpg: répertoire « /root/.gnupg » créé
gpg: nouveau fichier de configuration « /root/.gnupg/gpg.conf » créé
gpg: Attention : les options de « /root/.gnupg/gpg.conf » ne sont pas encore actives cette fois
gpg: le porte-clefs « /root/.gnupg/secring.gpg » a été créé
gpg: le porte-clefs « /root/.gnupg/pubring.gpg » a été créé
gpg: demande de la clef 171EFF9E sur le serveur hkp wwwkeys.eu.pgp.net
?: wwwkeys.eu.pgp.net: Host not found
gpgkeys: HTTP fetch error 7: couldn't connect: Success
gpg: aucune donnée OpenPGP valable n'a été trouvée.
gpg:       Quantité totale traitée : 0
 



j'essaye la seconde adresse :

gpg --keyserver hkp://wwwkeys.pgp.net --recv-keys 8AB63AFD171EFF9E

 


gpg: demande de la clef 171EFF9E sur le serveur hkp wwwkeys.pgp.net
gpg: le délai d'attente du serveur de clefs a expiré
gpg: échec de réception depuis le serveur de clefs : erreur du serveur de clefs
 



en suivant ici:
https://debian-facile.org/viewtopic.php?id=13673

j'essaye:

wget -q -O - ftp://ftp.project-builder.org/archive.asc



. pas de réaction apparente à cette commande.

apt-key add 8AB63AFD171EFF9E

 


gpg: impossible d'ouvrir « 8AB63AFD171EFF9E » : Aucun fichier ou dossier de ce type
 



ici:
ftp://ftp.project-builder.org/debian/8/
figure une 'afio.pubkey'
ftp://ftp.project-builder.org/debian/8/afio.pubkey
j'essaye:

wget -q -O - ftp://ftp.project-builder.org/debian/8/afio.pubkey
 


-----BEGIN PGP PUBLIC KEY BLOCK-----
Version: GnuPG v1

mQGiBDuG0wERBADKl/D8AtrBOlaONPx9V2ELz0xanifHmQEcsU17HvFKlXIiIqpd ....
 



si je relance 'apt-key add 8AB63AFD171EFF9E' : même résultat.

qu'est-ce qui m'échappe ?

merci d'avance.
cordialement
debianux

Dernière modification par debianux (27-02-2017 18:06:58)

Hors ligne

#2 27-02-2017 18:05:17

debianux
Membre
Distrib. : debian-jessie-8.7_LVM-chiffré_dual-boot-uefi-w10
Noyau : Linux 4.7.0-0.bpo.1-amd64
(G)UI : Xfce 4.10
Inscription : 19-05-2014

Re : [resolu] update: erreur GPG sur clé publique

finalement, après installation de 'sudo' et 'réglages' conseillés ici :
https://debian-facile.org/doc:systeme:sudo

j'ai suivi les indications d'ici :
http://www.commentcamarche.net/faq/4445 … -gpg-error

gpg --keyserver pgpkeys.mit.edu --recv-key 8AB63AFD171EFF9E


gpg: demande de la clef 171EFF9E sur le serveur hkp pgpkeys.mit.edu
gpg: clef 171EFF9E : clef publique « Bruno Cornec <Bruno.Cornec@hp.com> » importée
gpg: 3 marginale(s) nécessaire(s), 1 complète(s) nécessaire(s),
     modèle de confiance PGP
gpg: profondeur : 0  valables :   1  signées :   0
     confiance : 0 i., 0 n.d., 0 j., 0 m., 0 t., 1 u.
gpg: la prochaine vérification de la base de confiance aura lieu le 2021-11-22
gpg:       Quantité totale traitée : 1
gpg:                     importées : 1
 


suivi par :

gpg -a --export 8AB63AFD171EFF9E | sudo apt-key add -

 


[sudo] password for jlg:
OK
 



et voilà un 'update' tout 'propre' smile

Hors ligne

#3 27-02-2017 18:12:41

debianux
Membre
Distrib. : debian-jessie-8.7_LVM-chiffré_dual-boot-uefi-w10
Noyau : Linux 4.7.0-0.bpo.1-amd64
(G)UI : Xfce 4.10
Inscription : 19-05-2014

Re : [resolu] update: erreur GPG sur clé publique

ps: ai ajouté cette option à 'Methode 2' de https://debian-facile.org/doc:systeme:a … #methode-2

Hors ligne

Pied de page des forums