Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 05-03-2017 16:36:17

debianux
Membre
Distrib. : debian-jessie-8.7_LVM-chiffré_dual-boot-uefi-w10
Noyau : Linux 4.7.0-0.bpo.1-amd64
(G)UI : Xfce 4.10
Inscription : 19-05-2014

[resolu] accès à nas refusé

Bonjour,

la question, que j'essaye de poster ici, ne passe pas avec les balises correspondantes, qui n'indiquent pas d'erreur de syntaxe : la copie du texte avec balises que j'ai copié en début de message apparaît en fin (?) : je n'ai pas réussi à identifier ce qui coince dans l'affichage...

Bonjour,
sur un réseau local, j'ai un nas synology 'ds411' sous linux, auquel je, 'jlg', peux me connecter avec un t460s et qui se refuse à 'mlbg' sur un x220, les deux sous debian jessie sad
à partir du t460s, connecté en ssh : le ds411 a les droits suivants :




les id:





donc sauf erreur d'interprétation, mlbg appartient bien au groupe jlg, qui a les droits 'rwx'

sur le t460s:


le gid est bien '65536', que j'ai modifié pour qu'il soit le même que celui attribué par le nas.

sur le x220: mlbg:


'1027' était le précédent gid de jlg, modifié pour correspondre au gid attribué par le nas.

je le modifie: à partir de 'mlbg@ThinkPad-X220':


vérification:
à partir de mlbg@ThinkPad-X220:



re-vérif: à partir de mlbg:



je suis toujours avec '1027' au lieu de '65536' sad

re-re-vérif: à partir de mlbg: ici: sudo au lieu d'une connexion en root:




si je fais la liste des groupes:



si j'essaye de supprimer le groupe 'jlg' pour repartir sur de 'bonnes bases':



quoi-qui-m-echappe?:)

merci d'avance
cordialement
debianux






Bonjour,
sur un réseau local, j'ai un nas synology 'ds411' sous linux, auquel je, 'jlg', peux me connecter avec un t460s et qui se refuse à 'mlbg' sur un x220, les deux sous debian jessie sad
à partir du t460s, connecté en ssh : le ds411 a les droits suivants :




les id:





donc sauf erreur d'interprétation, mlbg appartient bien au groupe jlg, qui a les droits 'rwx'

sur le t460s:


le gid est bien '65536', que j'ai modifié pour qu'il soit le même que celui attribué par le nas.

sur le x220: mlbg:


'1027' était le précédent gid de jlg, modifié pour correspondre au gid attribué par le nas.

je le modifie: à partir de 'mlbg@ThinkPad-X220':


vérification:
à partir de mlbg@ThinkPad-X220:



re-vérif: à partir de mlbg:



je suis toujours avec '1027' au lieu de '65536' sad

re-re-vérif: à partir de mlbg: ici: sudo au lieu d'une connexion en root:




si je fais la liste des groupes:


root
daemon
bin
sys
adm
tty
disk
lp
mail
news
uucp
man
proxy
kmem
dialout
fax
voice
cdrom
floppy
tape
sudo
audio
dip
www-data
backup
operator
list
irc
src
gnats
shadow
utmp
video
sasl
plugdev
staff
games
users
nogroup
libuuid
crontab
syslog
fuse
colord
scanner
messagebus
lightdm
nopasswdlogin
mlocate
ssh
avahi-autoipd
avahi
netdev
bluetooth
lpadmin
ssl-cert
admin
pulse
pulse-access
utempter
rtkit
saned
mlbg
sambashare
mysql
guest-nBhL4f
whoopsie
jlg
zeroinst
 



si j'essaye de supprimer le groupe 'jlg' pour repartir sur de 'bonnes bases':


sudo delgroup jlg
 



/usr/sbin/delgroup: « jlg » possèdent toujours « jlg » en tant que
groupe primaire !
 



quoi-qui-m-echappe?:)

merci d'avance
cordialement
debianux


ls -al
 



Edit à toto :
Tu avais un crochet ouvrant qui manquait à la fin de la liste des groupes ici :

jlg
zeroinst
/code]



je l'ai ajouté.
Regarde si tu n'as pas la même chose pour les commandes précédentes sans résultat affiché.

Dernière modification par debianux (07-03-2017 16:53:31)

Hors ligne

#2 05-03-2017 20:35:05

debianux
Membre
Distrib. : debian-jessie-8.7_LVM-chiffré_dual-boot-uefi-w10
Noyau : Linux 4.7.0-0.bpo.1-amd64
(G)UI : Xfce 4.10
Inscription : 19-05-2014

Re : [resolu] accès à nas refusé

merci 'edit à toto' smile
malheureusement je n'ai plus le texte du terminal...

sur le x220, j'ai essayé de modifier 'jlg' car je pense qu'il y a un pb avec le numéro de groupe 'jlg' (=1027, au lieu de 65536):

1/ suppression de 'jlg':

sudo deluser jlg
 




[sudo] password for mlbg:
Suppression de l'utilisateur « jlg »...
Fait.
 



2/

sudo useradd -u 1027 jlg

 




useradd : le groupe jlg existe - si vous voulez ajouter cet utilisateur à ce groupe, utilisez -g.
 



3/ vérification:

id jlg
 




id: jlg : utilisateur inexistant
 



4/ vérification liste utilisateurs:

cat /etc/passwd | awk -F: '{print $ 1}'
 




root
daemon
bin
sys
sync
games
man
lp
mail
news
uucp
proxy
www-data
backup
list
irc
gnats
nobody
libuuid
syslog
colord
messagebus
lightdm
avahi-autoipd
avahi
usbmux
kernoops
pulse
rtkit
speech-dispatcher
hplip
saned
mlbg
mysql
guest-nBhL4f
whoopsie
zeroinst
statd
sshd
 



pas de 'jlg'

5/ vérification des groupes :

cat /etc/group | awk -F: '{print $ 1}'
 




root
daemon
bin
sys
adm
tty
disk
lp
mail
news
uucp
man
proxy
kmem
dialout
fax
voice
cdrom
floppy
tape
sudo
audio
dip
www-data
backup
operator
list
irc
src
gnats
shadow
utmp
video
sasl
plugdev
staff
games
users
nogroup
libuuid
crontab
syslog
fuse
colord
scanner
messagebus
lightdm
nopasswdlogin
mlocate
ssh
avahi-autoipd
avahi
netdev
bluetooth
lpadmin
ssl-cert
admin
pulse
pulse-access
utempter
rtkit
saned
mlbg
sambashare
mysql
guest-nBhL4f
whoopsie
jlg
zeroinst
 



6/ suppression du groupe 'jlg':

sudo delgroup jlg
 




Suppression du groupe « jlg »...
Fait.
 



7/ vérification des groupes:

cat /etc/group | awk -F: '{print $ 1}'
 




root
daemon
bin
sys
adm
tty
disk
lp
mail
news
uucp
man
proxy
kmem
dialout
fax
voice
cdrom
floppy
tape
sudo
audio
dip
www-data
backup
operator
list
irc
src
gnats
shadow
utmp
video
sasl
plugdev
staff
games
users
nogroup
libuuid
crontab
syslog
fuse
colord
scanner
messagebus
lightdm
nopasswdlogin
mlocate
ssh
avahi-autoipd
avahi
netdev
bluetooth
lpadmin
ssl-cert
admin
pulse
pulse-access
utempter
rtkit
saned
mlbg
sambashare
mysql
guest-nBhL4f
whoopsie
zeroinst
 



pas de groupe 'jlg'

8/ re-vérification des utilisateurs:

cat /etc/passwd | awk -F: '{print $ 1}'
 




root
daemon
bin
sys
sync
games
man
lp
mail
news
uucp
proxy
www-data
backup
list
irc
gnats
nobody
libuuid
syslog
colord
messagebus
lightdm
avahi-autoipd
avahi
usbmux
kernoops
pulse
rtkit
speech-dispatcher
hplip
saned
mlbg
mysql
guest-nBhL4f
whoopsie
zeroinst
statd
sshd
 


pas de 'jlg'

9/ création utilisateur 'jlg':

sudo adduser -u 1027 jlg
 




Ajout de l'utilisateur « jlg » ...
Ajout du nouveau groupe « jlg » (1027) ...
Ajout du nouvel utilisateur « jlg » (1027) avec le groupe « jlg » ...
Le répertoire personnel « /home/jlg » existe déjà.  Rien n'est copié depuis « /etc/skel ».
Entrez le nouveau mot de passe UNIX :
Retapez le nouveau mot de passe UNIX :
passwd : le mot de passe a été mis à jour avec succès
Modification des informations relatives à l'utilisateur jlg
Entrez la nouvelle valeur ou « Entrée » pour conserver la valeur proposée
    Nom complet []:
    N° de bureau []:
    Téléphone professionnel []:
    Téléphone personnel []:
    Autre []:
Ces informations sont-elles correctes ? [O/n] O
 


user 'jlg' créé avec uid=1027, qui est le numéro décidé par le nas

10/ modification du numéro de groupe :

sudo groupmod -g 65536 jlg
 



pour reprendre le numéro de groupe décidé par le nas

11/ vérification de l'id 'jlg':

id jlg
 




uid=1027(jlg) gid=65536(jlg) groupes=65536(jlg)
 



ça semble ok

12/ ajout de 'mlbg' au groupe 'jlg', qui a les droits sur le nas :

sudo adduser mlbg jlg
 




Ajout de l'utilisateur « mlbg » au groupe « jlg »...
Ajout de l'utilisateur mlbg au groupe jlg
Fait.
 



13/ vérification de l'id de 'mlbg', qui a la session ouverte sur x220:

id
 




uid=1028(mlbg) gid=1000(mlbg) groupes=1000(mlbg),4(adm),20(dialout),24(cdrom),46(plugdev),116(lpadmin),118(admin),124(sambashare),1027
 



'immense' déception : le groupe '65536' n'apparaît pas et ré-apparaît le groupe '1027' sad

re-quoi-qui-m-echappe-?

Hors ligne

#3 05-03-2017 21:06:25

otyugh
Membre
Lieu : Quimperlé/Arzano
Distrib. : Debian Stable
Inscription : 20-09-2016

Re : [resolu] accès à nas refusé

Faut juste te relogger en tant que mlbg (su mlbg) ou rebooter pour que la prise en compte du groupe soit effective wink

Dernière modification par otyugh (05-03-2017 21:09:18)


Agenda du libre : se faire dépanner/dépanner IRL ! Le libre n'est pas qu'un phénomène internet.
Framapad sur les balados : Emissions audio pro/amateur, votre radio sur-mesure !

Hors ligne

#4 05-03-2017 23:49:37

debianux
Membre
Distrib. : debian-jessie-8.7_LVM-chiffré_dual-boot-uefi-w10
Noyau : Linux 4.7.0-0.bpo.1-amd64
(G)UI : Xfce 4.10
Inscription : 19-05-2014

Re : [resolu] accès à nas refusé

salut otyugh !
tu sais qu't'es doué, toi ?
smile

su mlbg
 




Mot de passe :

 


mlbg:

id
 



uid=1028(mlbg) gid=1000(mlbg) groupes=1000(mlbg),4(adm),20(dialout),24(cdrom),46(plugdev),116(lpadmin),118(admin),124(sambashare),65536(jlg)
 



bon, ça mouline : j'espère qu'il va 'autoriser' le passage vers le ds411... smile

Hors ligne

#5 07-03-2017 16:52:49

debianux
Membre
Distrib. : debian-jessie-8.7_LVM-chiffré_dual-boot-uefi-w10
Noyau : Linux 4.7.0-0.bpo.1-amd64
(G)UI : Xfce 4.10
Inscription : 19-05-2014

Re : [resolu] accès à nas refusé

bonjour,
ça y est je viens d'avoir à nouveau accès au x220, qui a la joie de vous annoncer son accès au nas smile

Hors ligne

Pied de page des forums