Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 12-03-2017 14:07:27

KillPeach
Membre
Distrib. : Debian 8.7 Cinnamon
Noyau : Linux 4.9.0-0.bpo.2-amd64
Inscription : 27-02-2016

[Résolu] Problème de son beaucoup trop fort

Bonjour à tous,

Je viens d'installer debian 8.7 sur mon alienware 17r2 et je rencontre un problème de son.
Ce problème est valable tout le temps avec ou sans casque branché.

Je vais dans alsamixer et je règle pcm sur 4 j'ai du son et je peux regarder ma vidéo sans soucis. Comme une image vaut mieux qu'un long discours j'ai fait un screen :
mini_310867Capturedu20170312123036.png
Et j'ai du son même si c'est à 0% dans vlc (je suppose que c'est entre 0 et 1% donc vlc affiche 0)

Par contre lorsque je veut augmenter légèrement le son (d'un cran) en faisant fn+f5 sur mon clavier, j'ai bien vlc qui augmente légèrement en passant à 5%, mais sur alsa pcm qui passe directement à 100% ce qui donne une destruction de mes tympans lol.
Voilà le screen :
mini_895617Capturedu20170312123119.png


Ma carte son :

lspci | grep -i audio


00:03.0 Audio device: Intel Corporation Crystal Well HD Audio Controller (rev 08)
00:1b.0 Audio device: Intel Corporation 8 Series/C220 Series Chipset High Definition Audio Controller (rev 05)
 



Merci d'avance pour votre aide.

Dernière modification par KillPeach (13-03-2017 19:40:01)

Hors ligne

#2 12-03-2017 17:24:12

otyugh
Membre
Lieu : Quimperlé/Arzano
Distrib. : Debian Stable
Inscription : 20-09-2016

Re : [Résolu] Problème de son beaucoup trop fort

Tu utilises pulseaudio, je parie ? Il y a deux contrôleurs de volumes pavucontrol (le plus populaire) et veromix. Ils font grosso modo la même chose. S'ils ne sont pas déjà installés. Je ne dis pas que ça répond à ton problème (vu que je ne peux pas reproduire), mais c'est très probablement relié.

Pour règler ça la solution extrême est de supprimer pulseaudio, la solution modérée est de régler ça via un des contrôleurs de volumes de pulseaudio, et la solution que j'ai consiste à avoir désinstaller le gestionnaire de volume xfce pour mettre à la place quelques lignes de script pour bouger le volume via alsa seulement, puis de l'ajouter aux raccourcis de xfce...

Dernière modification par otyugh (12-03-2017 17:38:37)


Agenda du libre : se faire dépanner/dépanner IRL ! Le libre n'est pas qu'un phénomène internet.
Framapad sur les balados : Emissions audio pro/amateur, votre radio sur-mesure !

Hors ligne

#3 12-03-2017 19:01:54

KillPeach
Membre
Distrib. : Debian 8.7 Cinnamon
Noyau : Linux 4.9.0-0.bpo.2-amd64
Inscription : 27-02-2016

Re : [Résolu] Problème de son beaucoup trop fort

Merci pour t'as réponse.

J'ai essayé la version extrême j'ai donc taper :

apt-get autoremove --purge pulseaudio



Problème avec cette solution c'est qu'au démarrage je ne pouvait plus me connecter j'avais ce message : "debian failed to load session cinnamon" résolu en réinstallant l'environnement.

Via le contrôleur de volume de pulseaudio j'ai le même problème.
Pour la solution du script je ne sais pas du tout comment il faut faire c'est au delà de mes compétences  pour le moment.

Hors ligne

#4 12-03-2017 19:04:56

golgot200
Membre
Inscription : 05-08-2007

Re : [Résolu] Problème de son beaucoup trop fort

Bonsoir,

si ça peut aider :

PCM toujours à 100% après reboot.
https://debian-facile.org/viewtopic.php?id=13495

Dernière modification par golgot200 (12-03-2017 19:05:24)

Hors ligne

#5 12-03-2017 19:13:28

otyugh
Membre
Lieu : Quimperlé/Arzano
Distrib. : Debian Stable
Inscription : 20-09-2016

Re : [Résolu] Problème de son beaucoup trop fort

Tu n'a pas essayé pavucontrol ? Il me semble qu'il se souvient de ses réglage par appli. En général ça suffit.

Pour le script je, trouve pas ça idéal, mais je peux toujours le refiler hein (pas forcément besoin de l'utiliser tel quel, tu vois bien ce qui est utile dedans).
Moi je mets ça dans /usr/local/bin/alsamixer2 ; et dans "raccourcis" je lie tout à la main "alsamixer2 up", "alsamixer down", etc.
A la place tu pourrais simplement faire "amixer set Master 10%+", c'est tout à fait équivalent. J'utilise ce script dans l'idée d'aide-mémoire centralisé x)

#!/bin/sh

SINK=1

case "$1" in
        up)
                #pactl set-sink-volume "$SINK" +10%
                amixer set Master 10%+
        ;;
        down)
                #pactl set-sink-volume "$SINK" -- -10%
                amixer set Master 10%-
        ;;
        mute)
                #pactl set-sink-mute "$SINK" toggle
                amixer set Master toggle
        ;;
        *)
                echo "incorrect arg"
esac


(tout ce qui est en commentaire c'est l'équivalent pour pulseaudio directement)

Dernière modification par otyugh (12-03-2017 19:15:29)


Agenda du libre : se faire dépanner/dépanner IRL ! Le libre n'est pas qu'un phénomène internet.
Framapad sur les balados : Emissions audio pro/amateur, votre radio sur-mesure !

Hors ligne

#6 12-03-2017 22:50:24

KillPeach
Membre
Distrib. : Debian 8.7 Cinnamon
Noyau : Linux 4.9.0-0.bpo.2-amd64
Inscription : 27-02-2016

Re : [Résolu] Problème de son beaucoup trop fort

golgot avec ton lien j'ai pu régler le son pcm à 4% par contre ça ne règle pas le problème du passage de 4% à 100% par un appui sur fn+f5.

J'ai recherché sur le web et j'ai trouvé ça :
https://www.reddit.com/r/linuxquestions … d_blaster/

Apparemment c'est un problème c'est un problème sur les Alienware doter d'une carte Sound Blaster Recon3di.
Il a le même problème et il dit qu'il a réussi à le régler en installant ctefx.bin par contre j'ignore comment il faut faire.

Hors ligne

#7 12-03-2017 23:26:57

kyodev
Banni(e)
Lieu : Lyon
Distrib. : Debian
Noyau : probablement stretch
(G)UI : variable selon l'humeur de naguam
Inscription : 18-08-2013

Re : [Résolu] Problème de son beaucoup trop fort

ctefx se trouve dans ce package:
       https://packages.debian.org/jessie-back … sc-nonfree
dans les backports que tu as déjà, vu ton profil, donc:

apt-get install firmware-misc-nonfree


[mode aéré]

Hors ligne

#8 13-03-2017 19:38:05

KillPeach
Membre
Distrib. : Debian 8.7 Cinnamon
Noyau : Linux 4.9.0-0.bpo.2-amd64
Inscription : 27-02-2016

Re : [Résolu] Problème de son beaucoup trop fort

J'ai donc installer le package avec la commande que tu m'as donné :

apt-get install firmware-misc-nonfree



Et ça fonctionne nickel merci beaucoup à vous tous.

Hors ligne

Pied de page des forums