Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 13-03-2017 15:41:07

d33p
Adhérent(e)
Lieu : Lorraine
Distrib. : Debian testing buster 64bits
Noyau : En fonction des updates testing buster
(G)UI : En fonction des updates testing buster
Inscription : 01-12-2015

[RESOLU] Passage Jessie vers Stretch -> aie! :-)

Hello,

Ce matin, je me suis décidé à passer de Jessie à Stretch.
J'ai édité sources.list en remplaçant Jessie par Stretch:
Voici ce que ça donne:

#

# deb cdrom:[Debian GNU/Linux 8.6.0 _stretch_ - Official amd64 DVD Binary-1 20160917-14:25]/ stretch contrib main

# deb cdrom:[Debian GNU/Linux 8.6.0 _stretch_ - Official amd64 DVD Binary-1 20160917-14:25]/ stretch contrib main

deb http://httpredir.debian.org/debian/ stretch main
deb-src http://httpredir.debian.org/debian/ stretch main

deb http://security.debian.org/ stretch/updates main contrib
deb-src http://security.debian.org/ stretch/updates main contrib

# stretch-updates, previously known as 'volatile'
deb http://httpredir.debian.org/debian/ stretch-updates main contrib
deb-src http://httpredir.debian.org/debian/ stretch-updates main contrib

#non-free
# - duplicate - deb http://ftp.fr.debian.org/debian/ stretch main non-free contrib
deb-src http://ftp.fr.debian.org/debian/ stretch main non-free contrib

#stretch-backports
deb http://ftp.debian.org/debian stretch-backports main
deb http://httpredir.debian.org/debian stretch-backports main contrib non-free

#deb http://security.debian.org/ stretch/updates main contrib non-free
deb http://ftp.fr.debian.org/debian/ stretch main contrib non-free
deb http://ftp.fr.debian.org/debian/ stretch-updates main contrib non-free
deb http://ftp.fr.debian.org/debian/ stretch-backports main contrib non-free

#experimental
#deb http://httpredir.debian.org/debian experimental main

# - duplicate - deb http://security.debian.org stretch/updates main


Ensuite j'ai lancé un:

sudo apt-get update


Puis un:

sudo apt-get dist-upgrade



Et là, après un redémarrage:

- 1
Dans Grub:
Si je lance la 1ere entrée, c'est à dire : Debian GNU/LINUX -> j'arrive sur la console et l'interface graphique ne se lance pas... (ici c'est le kernel 4.9.0-2-amd64)
(pourtant si tout s'était bien déroulé, cela devrait fonctionner)

- 2
Dans Grub:
Je dois aller dans "Advanced option for Debian GNU/LINUX" puis lancer le kernel 4.9.0.0.bpo.1-amd64.
Avec ceci, j'arrive à lancer l'interface graphique et entrer dans ma session.


Quelqu'un a une idée de pourquoi?
Car bien evidemment j'aimerais bien tourner avec le noyau actuel pour Stretch qui semble être le 4.9.0-2-amd64 (il me l'a installé lors du dist-upgrade)
Et vu comment ça a réagi, je suppose que quelque chose à "déconné" (je l'accorde, j'y suis pour quelque chose, enfin je pense tongue )

Partir sur une fresh install, ça m'embete un peu car j'ai beaucoup de logiciels installés / configurés.

Merci, à bientôt

d33p

Dernière modification par d33p (13-03-2017 18:52:55)


science sans conscience n'est que ruine de l'âme...

Hors ligne

#2 13-03-2017 16:03:24

chalu
Modératrice
Lieu : Anjou
Distrib. : Debian Stretch
Noyau : Linux 4.9.0-3-amd64
(G)UI : Mate 1.16
Inscription : 11-03-2016

Re : [RESOLU] Passage Jessie vers Stretch -> aie! :-)

Bonjour smile
Je pense à un problème de carte graphique avec des pilotes non mis à jour avec la version du noyau de stretch
Un retour de la commande quand tu es dans la console devrait aider:

lspci

Hors ligne

#3 13-03-2017 16:23:00

d33p
Adhérent(e)
Lieu : Lorraine
Distrib. : Debian testing buster 64bits
Noyau : En fonction des updates testing buster
(G)UI : En fonction des updates testing buster
Inscription : 01-12-2015

Re : [RESOLU] Passage Jessie vers Stretch -> aie! :-)

Hello Chalu.

lspci


Donne:

00:00.0 Host bridge: Intel Corporation Xeon E3-1200 v2/3rd Gen Core processor DRAM Controller (rev 09)
00:01.0 PCI bridge: Intel Corporation Xeon E3-1200 v2/3rd Gen Core processor PCI Express Root Port (rev 09)
00:14.0 USB controller: Intel Corporation 7 Series/C210 Series Chipset Family USB xHCI Host Controller (rev 04)
00:16.0 Communication controller: Intel Corporation 7 Series/C216 Chipset Family MEI Controller #1 (rev 04)
00:19.0 Ethernet controller: Intel Corporation 82579V Gigabit Network Connection (rev 04)
00:1a.0 USB controller: Intel Corporation 7 Series/C216 Chipset Family USB Enhanced Host Controller #2 (rev 04)
00:1b.0 Audio device: Intel Corporation 7 Series/C216 Chipset Family High Definition Audio Controller (rev 04)
00:1c.0 PCI bridge: Intel Corporation 7 Series/C216 Chipset Family PCI Express Root Port 1 (rev c4)
00:1c.4 PCI bridge: Intel Corporation 7 Series/C210 Series Chipset Family PCI Express Root Port 5 (rev c4)
00:1c.7 PCI bridge: Intel Corporation 7 Series/C210 Series Chipset Family PCI Express Root Port 8 (rev c4)
00:1d.0 USB controller: Intel Corporation 7 Series/C216 Chipset Family USB Enhanced Host Controller #1 (rev 04)
00:1f.0 ISA bridge: Intel Corporation Z77 Express Chipset LPC Controller (rev 04)
00:1f.2 SATA controller: Intel Corporation 7 Series/C210 Series Chipset Family 6-port SATA Controller [AHCI mode] (rev 04)
00:1f.3 SMBus: Intel Corporation 7 Series/C216 Chipset Family SMBus Controller (rev 04)
01:00.0 VGA compatible controller: NVIDIA Corporation GP106 [GeForce GTX 1060 3GB] (rev a1)
01:00.1 Audio device: NVIDIA Corporation Device 10f1 (rev a1)
03:00.0 USB controller: ASMedia Technology Inc. ASM1042 SuperSpeed USB Host Controller
04:00.0 SATA controller: ASMedia Technology Inc. ASM1062 Serial ATA Controller (rev 01)



Au cas ou, lorsque je demarre sur le 4.9.0-2-amd64 et que j'arrive en console, j'ai essayé de refaire:

sudo apt-get dist-upgrade


sudo aptitude full-upgrade


J'ai en retour que tout est deja à jour

&

sudo apt-get install nvidia-driver


J'ai en retour que c'est deja le dernier driver nvidia installé, ici là version 375.39



merci, à bientôt.

d33p

Dernière modification par d33p (13-03-2017 16:23:53)


science sans conscience n'est que ruine de l'âme...

Hors ligne

#4 13-03-2017 16:41:37

hector
Membre
Distrib. : Debian Sid
Noyau : 4.11.0-2-amd64
(G)UI : KDE Plasma 5
Inscription : 13-12-2011

Re : [RESOLU] Passage Jessie vers Stretch -> aie! :-)

Slt d33p,

Dans un premier temps je vérifierais si tout c'est vraiment bien passé avec la commande :

apt-get -f install

Hors ligne

#5 13-03-2017 16:54:53

d33p
Adhérent(e)
Lieu : Lorraine
Distrib. : Debian testing buster 64bits
Noyau : En fonction des updates testing buster
(G)UI : En fonction des updates testing buster
Inscription : 01-12-2015

Re : [RESOLU] Passage Jessie vers Stretch -> aie! :-)

Hello hector,

apt-get -f install


Donne:

Reading package lists...
Building dependency tree...
Reading state information...
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.



merci.

d33p


science sans conscience n'est que ruine de l'âme...

Hors ligne

#6 13-03-2017 17:41:57

chalu
Modératrice
Lieu : Anjou
Distrib. : Debian Stretch
Noyau : Linux 4.9.0-3-amd64
(G)UI : Mate 1.16
Inscription : 11-03-2016

Re : [RESOLU] Passage Jessie vers Stretch -> aie! :-)

si tu fais

apt-get -s install nvidia-kernel-dkms nvidia-settings nvidia-driver linux-headers-$(uname -r)


Quand tu es dans la console noire avec le noyau de stretch et non des backports, ça te dit que tout est déjà installé ?

Hors ligne

#7 13-03-2017 18:32:54

d33p
Adhérent(e)
Lieu : Lorraine
Distrib. : Debian testing buster 64bits
Noyau : En fonction des updates testing buster
(G)UI : En fonction des updates testing buster
Inscription : 01-12-2015

Re : [RESOLU] Passage Jessie vers Stretch -> aie! :-)

chalu;
J'ai lancé

apt-get -s install nvidia-kernel-dkms nvidia-settings nvidia-driver linux-headers-$(uname -r)


Le resultat etait:

Reading package lists...
Building dependency tree...
Reading state information...
nvidia-settings is already the newest version (375.26-3).
nvidia-driver is already the newest version (375.39-1).
nvidia-kernel-dkms is already the newest version (375.39-1).
The following additional packages will be installed:
  linux-compiler-gcc-6-x86 linux-headers-4.9.0-2-common
The following NEW packages will be installed:
  linux-compiler-gcc-6-x86 linux-headers-4.9.0-2-amd64
  linux-headers-4.9.0-2-common
0 upgraded, 3 newly installed, 0 to remove and 0 not upgraded.
Inst linux-compiler-gcc-6-x86 (4.9.13-1 Debian:testing [amd64])
Inst linux-headers-4.9.0-2-common (4.9.13-1 Debian:testing [all])
Inst linux-headers-4.9.0-2-amd64 (4.9.13-1 Debian:testing [amd64])
Conf linux-compiler-gcc-6-x86 (4.9.13-1 Debian:testing [amd64])
Conf linux-headers-4.9.0-2-common (4.9.13-1 Debian:testing [all])
Conf linux-headers-4.9.0-2-amd64 (4.9.13-1 Debian:testing [amd64])



J'ai donc relancé la commande:

apt-get -s install nvidia-kernel-dkms nvidia-settings nvidia-driver linux-headers-$(uname -r)


sans le -s

Il a installé:

The following additional packages will be installed:
  linux-compiler-gcc-6-x86 linux-headers-4.9.0-2-common
The following NEW packages will be installed:
  linux-compiler-gcc-6-x86 linux-headers-4.9.0-2-amd64
  linux-headers-4.9.0-2-common



J'ai redémarré, et là.... youpi, it works!!

Un GRAND MERCI Chalu!

Dans la suite logique de ce post, je fais comment pour clean toute la vieille installation, les choses obsoletes etc...??
apt-get autoremove ? dpkg autoremove? apt-get clean?

merci, à bientôt.

d33p


science sans conscience n'est que ruine de l'âme...

Hors ligne

#8 13-03-2017 18:43:26

chalu
Modératrice
Lieu : Anjou
Distrib. : Debian Stretch
Noyau : Linux 4.9.0-3-amd64
(G)UI : Mate 1.16
Inscription : 11-03-2016

Re : [RESOLU] Passage Jessie vers Stretch -> aie! :-)

alors oui autoremove en regardant bien quand même tongue mais j'ai l'impression qu'il n'y a rien d'après ton retour de commande.
Je crois que clean et autoclean aussi pourraientt être bien
https://debian-facile.org/doc:systeme:a … rincipales
sinon si tu veux parler de supprimer le noyau des backports et les linux-headers qui vont avec, ça se fait un par un je pense avec la commande habituelle pour supprimer un paquet

Hors ligne

#9 13-03-2017 18:52:30

d33p
Adhérent(e)
Lieu : Lorraine
Distrib. : Debian testing buster 64bits
Noyau : En fonction des updates testing buster
(G)UI : En fonction des updates testing buster
Inscription : 01-12-2015

Re : [RESOLU] Passage Jessie vers Stretch -> aie! :-)

D'accord, en tout cas, merci!

je passe ce post en résolu, je sens que je vais en relancer car comme c'est tout nouveau tongue

d33p

Dernière modification par d33p (13-03-2017 18:53:46)


science sans conscience n'est que ruine de l'âme...

Hors ligne

#10 13-03-2017 19:39:35

d33p
Adhérent(e)
Lieu : Lorraine
Distrib. : Debian testing buster 64bits
Noyau : En fonction des updates testing buster
(G)UI : En fonction des updates testing buster
Inscription : 01-12-2015

Re : [RESOLU] Passage Jessie vers Stretch -> aie! :-)

Juste encore une petite chose.
Comment je peux etre sur que tous les packages ont bien été installés?
Car cela semblait être le cas, mais en fait non...

merci

d33p

science sans conscience n'est que ruine de l'âme...

Hors ligne

#11 14-03-2017 15:44:08

chalu
Modératrice
Lieu : Anjou
Distrib. : Debian Stretch
Noyau : Linux 4.9.0-3-amd64
(G)UI : Mate 1.16
Inscription : 11-03-2016

Re : [RESOLU] Passage Jessie vers Stretch -> aie! :-)

Regarde si tu as le paquet linux-headers-amd64
si la réponse est non, ça expliquerait pourquoi les linux headers de ton noyau n'ont pas été installés

Hors ligne

#12 14-03-2017 16:28:08

d33p
Adhérent(e)
Lieu : Lorraine
Distrib. : Debian testing buster 64bits
Noyau : En fonction des updates testing buster
(G)UI : En fonction des updates testing buster
Inscription : 01-12-2015

Re : [RESOLU] Passage Jessie vers Stretch -> aie! :-)

ok, je vais zieuter,

merci chalu


d33p

science sans conscience n'est que ruine de l'âme...

Hors ligne

Pied de page des forums