Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 15-03-2017 11:24:39

Michel007
Membre
Distrib. : Stretch
Noyau : 4.9.0.3
(G)UI : gnome
Inscription : 13-03-2017

Pas de Grub au redémarrage après l'installation. [ RESOLU ]

Bonjour,



J'ai chargé ma clé USB avec" debian-8.7.1-amd64-i386-netinst "
J'ai réglé le Boot pour démarrer sur la clé USB ( sur Acer, touche 12, si ca peut intéresser )
Au démarrrage, l'écran d'installation apparaît
Je clique sur " install graphique 64 "
Toute l'installation se passe bien.
Suivant l'indication, je retire la clé et je redémarre
Là, j'arrive sur W10 kernal_panic.gif

Un help s'impose.....

Dernière modification par Michel007 (16-03-2017 17:19:31)

Hors ligne

#2 15-03-2017 11:43:38

chalu
Modératrice
Lieu : Anjou
Distrib. : Debian Stretch
Noyau : Linux 4.9.0-3-amd64
(G)UI : Mate 1.16
Inscription : 11-03-2016

Re : Pas de Grub au redémarrage après l'installation. [ RESOLU ]

Bonjour,
ça doit être un souci lié à l'UEFI
en attendant des interventions plus pertinentes, je te donne des pistes du wiki à lire :
https://debian-facile.org/doc:install:i … er-debian1
https://debian-facile.org/doc:install:d … -de-l-uefi
Et en particulier
https://debian-facile.org/doc:install:u … -lance-pas

Hors ligne

#3 15-03-2017 12:56:28

Michel007
Membre
Distrib. : Stretch
Noyau : 4.9.0.3
(G)UI : gnome
Inscription : 13-03-2017

Re : Pas de Grub au redémarrage après l'installation. [ RESOLU ]

Bonjour Chalu,

Résultat de "bcdedit /set {bootmgr} path EFI\debian\grubx64.efi"

"Impossible d'ouvrir le magasin des données." **

** Windows qui ne veux pas ouvrir un magasin...:lol:

Dernière modification par Michel007 (15-03-2017 17:07:04)

Hors ligne

#4 15-03-2017 13:59:28

chalu
Modératrice
Lieu : Anjou
Distrib. : Debian Stretch
Noyau : Linux 4.9.0-3-amd64
(G)UI : Mate 1.16
Inscription : 11-03-2016

Re : Pas de Grub au redémarrage après l'installation. [ RESOLU ]

Et si tu donnais le maximum d'infos sur ton PC pour que ceux qui ont l'expérience des installations en dual-boot puissent t'aider wink

Hors ligne

#5 15-03-2017 14:09:21

Michel007
Membre
Distrib. : Stretch
Noyau : 4.9.0.3
(G)UI : gnome
Inscription : 13-03-2017

Re : Pas de Grub au redémarrage après l'installation. [ RESOLU ]

Pas faux....arrow.gif

Acer E17  E5-774G-54R5
Intel core i5-6200U  2.3 GHz
NVIDIA gtx 950M avec 2Gb dedicated VRAM
4Gb DDR4 Memory
1000GB HDD

Hors ligne

#6 16-03-2017 06:45:35

Michel007
Membre
Distrib. : Stretch
Noyau : 4.9.0.3
(G)UI : gnome
Inscription : 13-03-2017

Re : Pas de Grub au redémarrage après l'installation. [ RESOLU ]

Personne ? smile

Hors ligne

#7 16-03-2017 08:07:43

chalu
Modératrice
Lieu : Anjou
Distrib. : Debian Stretch
Noyau : Linux 4.9.0-3-amd64
(G)UI : Mate 1.16
Inscription : 11-03-2016

Re : Pas de Grub au redémarrage après l'installation. [ RESOLU ]

Pas encore smile
Détailles ce que tu as fait pour installer. D'après https://debian-facile.org/doc:install:d … -de-l-uefi il y a des réglages à faire dans le BIOS pour le dualboot UEFI.
As tu fais comme sur ce lien ?

Hors ligne

#8 16-03-2017 08:13:47

raleur
Membre
Inscription : 03-10-2014

Re : Pas de Grub au redémarrage après l'installation. [ RESOLU ]

Michel007 a écrit :

J'ai réglé le Boot pour démarrer sur la clé USB ( sur Acer, touche 12, si ca peut intéresser )


Quelles étaient, et quelles sont les choix possibles affichés par F12 ?

Michel007 a écrit :

Au démarrrage, l'écran d'installation apparaît


L'écran d'installation EFI (c'est écrit) ou traditionnel ?

Hors ligne

#9 16-03-2017 10:18:07

Michel007
Membre
Distrib. : Stretch
Noyau : 4.9.0.3
(G)UI : gnome
Inscription : 13-03-2017

Re : Pas de Grub au redémarrage après l'installation. [ RESOLU ]

@ chalu: Oui

@raleur: F12>  - USB HDD ( la clé usb )
                       - Boot windows

Ecran d'installation EFI


Je me  ( vous  ) pose une question:

A la fin d l'installation, comment retirer la clé ?

Pour ma part, je l'ais retirée à la main.

Dernière modification par Michel007 (16-03-2017 11:24:55)

Hors ligne

#10 16-03-2017 12:01:18

raleur
Membre
Inscription : 03-10-2014

Re : Pas de Grub au redémarrage après l'installation. [ RESOLU ]

Pas d'entrée d'amorçage EFI pour Debian, forcément c'est Windows qui démarre.

Michel007 a écrit :

A la fin d l'installation, comment retirer la clé ?


En tirant dessus, en général. Quel est le but de la question ?

Redémarre sur la clé USB avec l'installateur en mode EFI, sélectionne "Rescue 64 bits", monte la racine du système Debian installé, affiche la table de partition du disque et le contenu de /etc/fstab pour les poster ici.

Hors ligne

#11 16-03-2017 13:10:50

chalu
Modératrice
Lieu : Anjou
Distrib. : Debian Stretch
Noyau : Linux 4.9.0-3-amd64
(G)UI : Mate 1.16
Inscription : 11-03-2016

Re : Pas de Grub au redémarrage après l'installation. [ RESOLU ]

raleur a écrit :

En tirant dessus, en général. Quel est le but de la question ?


Sûrement par rapport à la consigne "éjecter la clé avant de la retirer" que ce soit sur windows ou linux.

raleur a écrit :

Pas d'entrée d'amorçage EFI pour Debian, forcément c'est Windows qui démarre.


N'y aurait il pas un point du tutoriel du wiki, s'il a été suivi, à éclaircir pour avoir cette entrée ?

Hors ligne

#12 16-03-2017 14:08:18

raleur
Membre
Inscription : 03-10-2014

Re : Pas de Grub au redémarrage après l'installation. [ RESOLU ]

chalu a écrit :

Sûrement par rapport à la consigne "éjecter la clé avant de la retirer"


1) A la fin de l'installation, l'installateur demande explicitement de retirer le support d'installation avant de redémarrer.
2) De toute façon, le système de fichiers ISO 9660 de l'installateur n'est pas modifiable et ne peut être monté qu'en lecture seule, comme un CD, donc pas besoin de précautions particulières.

Hors ligne

#13 16-03-2017 14:09:56

raleur
Membre
Inscription : 03-10-2014

Re : Pas de Grub au redémarrage après l'installation. [ RESOLU ]

chalu a écrit :

N'y aurait il pas un point du tutoriel du wiki, s'il a été suivi, à éclaircir pour avoir cette entrée ?


Je ne lis pas les tutoriels.
L'entrée d'amorçage EFI pour Debian est normalement créée automatiquement par la commande grub-install lors de l'installation du chargeur d'amorçage GRUB, à condition que l'installateur Debian ait été lancé en mode EFI.

Dernière modification par raleur (16-03-2017 14:10:56)

Hors ligne

#14 16-03-2017 17:18:11

Michel007
Membre
Distrib. : Stretch
Noyau : 4.9.0.3
(G)UI : gnome
Inscription : 13-03-2017

Re : Pas de Grub au redémarrage après l'installation. [ RESOLU ]

J'ai réussi. je place le sujet en résolu.

Hors ligne

#15 16-03-2017 20:56:49

chalu
Modératrice
Lieu : Anjou
Distrib. : Debian Stretch
Noyau : Linux 4.9.0-3-amd64
(G)UI : Mate 1.16
Inscription : 11-03-2016

Re : Pas de Grub au redémarrage après l'installation. [ RESOLU ]

D'accord mais tu as réussi comment ? La solution va intéresser tous les lecteurs du fil wink

Hors ligne

#16 17-03-2017 06:37:09

Michel007
Membre
Distrib. : Stretch
Noyau : 4.9.0.3
(G)UI : gnome
Inscription : 13-03-2017

Re : Pas de Grub au redémarrage après l'installation. [ RESOLU ]

Voici la manoeuvre ( trouvée sur le forum ubuntu )

Intaller Débian

Redémarrer par le BIOS

sélectionner le 3è onglet Security, définir un mot de passe pour pouvoir accéder à
select an uefi as trusted for executing
ce qui ouvre la fenêtre InsydeH20 Setup Utility,
sélectionner HDD0 en faisant [enter], ce qui ouvre le menu suivant,
sélectionner EFI, puis ubuntu, puis shimx64.efi. ( pour ma part, j'avais" grub x64.efi " )
Un pop-up s'ouvre:
Do you wish to add this file to allowable database? Boot Description [                ]
Entrer un nom entre les crochets,(celui que l'on veut par exemple EFI File Boot 0)  et seléctionner Yes

Retourner dans le menu principal du BIOS et aller à l'onglet Boot,
descendre dans le Boot priority order jusqu'à la dernière ligne, où l'on va retrouver le nom que l'on a écrit entre les crochets. Le faire remonter de la dernière place à la première avec la touche F6, et on se retrouve avec l'ordre de boot reconfiguré:
1. EFI File Boot 0 :
2. Windows Boot Manager
3. ...
F10 pour save and exit et Yes pour confirmer

Apparait alors un joli Grub avec Débian en premier

Pour finir, pousser un grand cri de jouissance...woohoo.gif

Dernière modification par Michel007 (17-03-2017 07:45:53)

Hors ligne

#17 17-03-2017 08:34:01

chalu
Modératrice
Lieu : Anjou
Distrib. : Debian Stretch
Noyau : Linux 4.9.0-3-amd64
(G)UI : Mate 1.16
Inscription : 11-03-2016

Re : Pas de Grub au redémarrage après l'installation. [ RESOLU ]

Merci Michel007 smile
Je vais ajouter un lien vers ton message dans le wiki wink

@raleur : ok dommage. Espérons que des utilisateurs avertis le maintiennent à jour et vérifient sa justesse.  Les installations EFI se multipliant.

Hors ligne

Pied de page des forums