Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 25-03-2017 14:32:35

aurelein
Membre
Distrib. : Debian Jessie
Noyau : Linux 3.16.0-4-686-pae
(G)UI : GNOME
Inscription : 20-03-2017

[Résolu] probleme lors de l'installation d'un firmware

Bonjour,
j'ai en fait plusieurs problemes en un, en essayant de corriger le premier je crois que j'ai mal fait quelque chose:

-Je viens d'installer debian en dual boot mais j'avais un probleme de résolution, les parametres ne me proposant qu'une seule resolution possible.
-Je pensais que c'etait du à ma carte graphique qui demande un pilote proprietaire. J'ai donc voulu l'installer comme expliqué ci dessous :
https://wiki.debian.org/fr/NvidiaGraphicsDrivers
-Maintenant je n'ai plus acces à rien. Pendant le demarage il ffiche :

Failed to start load kernel modules


puis  j'ai une image avec le message : "A problem has occured and the system cant recover please log out and try again"
puis un ecran noir.

Est-ce que je peux faire quelque chose ou dois-je recommencer l'installation depuis le début?

Dernière modification par aurelein (25-03-2017 19:10:27)

Hors ligne

#2 25-03-2017 14:48:31

robert2a
Membre
Lieu : France
Distrib. : Stretch 9
Noyau : Linux 4.9.0-3 4.9.30-2
(G)UI : Mate
Inscription : 15-11-2014

Re : [Résolu] probleme lors de l'installation d'un firmware

Bonjour
si tu veu comprendre et tenter de réparer c'est possible

la combinaison de touches te donne une console pure #Ctrl+Alt+F1"  ?

si oui premiere chose ton sources.list (ouvrir une session root dans ta console pure )


nano /etc/apt/sources.list
 



et tu poste le retour sur le forum

Dernière modification par robert2a (25-03-2017 14:51:25)

Hors ligne

#3 25-03-2017 15:37:05

aurelein
Membre
Distrib. : Debian Jessie
Noyau : Linux 3.16.0-4-686-pae
(G)UI : GNOME
Inscription : 20-03-2017

Re : [Résolu] probleme lors de l'installation d'un firmware

Merci!
Ctrl+Alt+F1 fonctionne bien.
Le sources.list contient :

deb http://ftp.fr.debian.org/debian/ jessie main contrib non-free
deb http://security.debian.org/ jessie/updates main contrib non-free
deb http://ftp.fr.debian.org/debian/ jessie-updates main contrib non-free
deb http://httpredir.debian.org/debian/ jessie main contrib non-free
 


Et quelques lignes commentés... (les deb-src et cdrom)

Dernière modification par aurelein (25-03-2017 16:17:10)

Hors ligne

#4 25-03-2017 15:54:22

robert2a
Membre
Lieu : France
Distrib. : Stretch 9
Noyau : Linux 4.9.0-3 4.9.30-2
(G)UI : Mate
Inscription : 15-11-2014

Re : [Résolu] probleme lors de l'installation d'un firmware

le bon



deb http://ftp.fr.debian.org/debian/ jessie main contrib non-free
deb http://security.debian.org/ jessie/updates main contrib non-free
deb http://ftp.fr.debian.org/debian/ jessie-updates main contrib non-free



cette ligne tu peut la supprimer elle fait double emploi


deb http://httpredir.debian.org/debian/ jessie main contrib non-free
 



ensuite un update


apt-get update
 



il ne doit pas y avoir d erreur

puis un upgrade


apt-get upgrade
 

Dernière modification par robert2a (25-03-2017 15:57:17)

Hors ligne

#5 25-03-2017 15:57:17

Croutons
Membre
Distrib. : Handylinux 2.5 vers Jessie et Debian Stretch
Noyau : Linux 3.16.0-4-686-pae, Linux 4.9.0-3-686-pae
(G)UI : xfce
Inscription : 16-12-2016

Re : [Résolu] probleme lors de l'installation d'un firmware

Bonjour
peut être tu pourrais utiliser la commande history pour que on sache ce que tu as fais exatement
Note que y'a 2 history , un pour user et un autre pour root
le wiki décrit comment sauvegarder dans un fichier
Met pas tout quand même hein big_smile juste les commandes qui ont servit lors de tes modifs

-->les cahiers du debutant<--      WikiDF-->Découvrir les principales commandes Linux<--
L' expérience, c'est le nom que chacun donne à ses erreurs. Oscar Wilde

Hors ligne

#6 25-03-2017 16:03:08

aurelein
Membre
Distrib. : Debian Jessie
Noyau : Linux 3.16.0-4-686-pae
(G)UI : GNOME
Inscription : 20-03-2017

Re : [Résolu] probleme lors de l'installation d'un firmware

Ce que j'ai fais c'est justement ajouter la ligne que robert2a me dit d'enlever.
Je vais vais regarder quand meme ce que dit history et ce qui se passe si je l'enleve.

Hors ligne

#7 25-03-2017 16:05:09

robert2a
Membre
Lieu : France
Distrib. : Stretch 9
Noyau : Linux 4.9.0-3 4.9.30-2
(G)UI : Mate
Inscription : 15-11-2014

Re : [Résolu] probleme lors de l'installation d'un firmware

installe l utilitaire nvidia-detect  (si au dessus tout est correct)


apt-get install nvidia-detect
 


puis tape la commande


nvidia-detect
 


ça va te donner le driver conseillé
le retour de lspci


lspci
 


poste le retour sur le forum

nota : c est la meme chose ces 2 lignes (tu interroge le meme dépot on appelle cela un doublon  tongue


deb http://ftp.fr.debian.org/debian/ jessie main contrib non-free

deb http://httpredir.debian.org/debian/ jessie main contrib non-free
 

Dernière modification par robert2a (25-03-2017 16:07:57)

Hors ligne

#8 25-03-2017 16:16:03

aurelein
Membre
Distrib. : Debian Jessie
Noyau : Linux 3.16.0-4-686-pae
(G)UI : GNOME
Inscription : 20-03-2017

Re : [Résolu] probleme lors de l'installation d'un firmware

J'ai bien modifier le sources.list mais apres redemarrage ca me donne toujours le meme message d'erreur.
Dois-je installer nvidia-detect maintenant ou attendre d'avoir reussi à faire revenir GNOME ?

history ne m'indique que 2 commandes qui ont fait du changement :
le nano qui m'a fait modifier le fichier et

# apt-get install linux-headers-$(uname -r|sed 's,[^-]*-[^-]*-,,')

Hors ligne

#9 25-03-2017 16:27:35

robert2a
Membre
Lieu : France
Distrib. : Stretch 9
Noyau : Linux 4.9.0-3 4.9.30-2
(G)UI : Mate
Inscription : 15-11-2014

Re : [Résolu] probleme lors de l'installation d'un firmware

si l update fonctionne et l upgrade aussi oui installe nvidia-detect et lance la commande

donne le retour du nvidia-detect et de lspci (comme demandé au dessus )
gnome fonctionnera quand ton driver video sera correct (en fonction de la carte video que tu a d' installée )
une autre question ta machine n'est pas compatible "amd64"  (je vois que tu a "686-pae" dans ton profil )

Dernière modification par robert2a (25-03-2017 16:40:41)

Hors ligne

#10 25-03-2017 16:51:40

aurelein
Membre
Distrib. : Debian Jessie
Noyau : Linux 3.16.0-4-686-pae
(G)UI : GNOME
Inscription : 20-03-2017

Re : [Résolu] probleme lors de l'installation d'un firmware

l update et l upgrade fonctionnent bien.
Pour le lspci c'est bien la ligne VGA qui nous interessent?


nvidia-detect


It is recommanded to install the
ncidia-driver/jessie-backports



lspci


VGA compatible controller : nvidia corporations device 1401 (reva1)



Je ne suis pas sur de comprendre la derniere question?

Dernière modification par aurelein (25-03-2017 16:52:47)

Hors ligne

#11 25-03-2017 16:58:01

robert2a
Membre
Lieu : France
Distrib. : Stretch 9
Noyau : Linux 4.9.0-3 4.9.30-2
(G)UI : Mate
Inscription : 15-11-2014

Re : [Résolu] probleme lors de l'installation d'un firmware

c'est bien une GTX960 ta carte nvidia ?

tu doit installer le driver des backports de jessie

quel driver tu a installé ?  (quelle commande a tu utilisé )

pour lspci je voulais tout le retour (tu a quoi comme processeur , machine de bureau , portable ? )

Dernière modification par robert2a (25-03-2017 17:01:55)

Hors ligne

#12 25-03-2017 17:01:44

aurelein
Membre
Distrib. : Debian Jessie
Noyau : Linux 3.16.0-4-686-pae
(G)UI : GNOME
Inscription : 20-03-2017

Re : [Résolu] probleme lors de l'installation d'un firmware

oui c'est bien une GTX960.
installer le driver des backports de jessie  c'est ce que j'essayais de faire mais je ne sais pas trop comment je dois proceder.
J'ai utilisé :

apt-get install -t jessie-backports nvidia-driver


je crois (je vais verifier)

Dernière modification par aurelein (25-03-2017 17:03:30)

Hors ligne

#13 25-03-2017 17:03:00

robert2a
Membre
Lieu : France
Distrib. : Stretch 9
Noyau : Linux 4.9.0-3 4.9.30-2
(G)UI : Mate
Inscription : 15-11-2014

Re : [Résolu] probleme lors de l'installation d'un firmware

je me pose la question pourquoi ne pas etre en amd64 avec une GTX960 , donc j aimerai des infos sur ta machine
si tu dois faire une installation en amd64 peut pas la peine de chercher a réparer  wink
ou que tu m explique ton choix

Dernière modification par robert2a (25-03-2017 17:05:01)

Hors ligne

#14 25-03-2017 17:05:57

aurelein
Membre
Distrib. : Debian Jessie
Noyau : Linux 3.16.0-4-686-pae
(G)UI : GNOME
Inscription : 20-03-2017

Re : [Résolu] probleme lors de l'installation d'un firmware

Il se peut que "Linux 3.16.0-4-686-pae" ne soit pas le plus aproprié. Je n'ai pas souvenir davoir choisit. Quelles information veux tu exactement?

Hors ligne

#15 25-03-2017 17:11:20

robert2a
Membre
Lieu : France
Distrib. : Stretch 9
Noyau : Linux 4.9.0-3 4.9.30-2
(G)UI : Mate
Inscription : 15-11-2014

Re : [Résolu] probleme lors de l'installation d'un firmware

la référence du processeur par exemple , la quantité de mémoire ou meme le chipset  (avec lspci ça renvoie quoi ? )

le wiki  =>  https://debian-facile.org/doc:materiel: … ia:accueil

Dernière modification par robert2a (25-03-2017 17:12:42)

Hors ligne

#16 25-03-2017 17:15:42

aurelein
Membre
Distrib. : Debian Jessie
Noyau : Linux 3.16.0-4-686-pae
(G)UI : GNOME
Inscription : 20-03-2017

Re : [Résolu] probleme lors de l'installation d'un firmware

C'est un ordinateur du commerce donc je recopie les caracteristiques du constructeurs, ca ira plus vite que lspci(sauf si il en manque) :

Marque du processeur     Nvidia
Modèle du processeur     Core™ i5-6400
Mémoire vive (RAM) installée     8 Go
Type de disque dur     HDD
Capacité du disque dur SATA     1000 Go
Capacité du disque dur SSD     8 Go
Marque du processeur graphique     Nvidia
Modèle du processeur graphique     GeForce GTX 950
Mémoire vidéo dédiée     2048 Mo

http://www.darty.com/nav/achat/informat … 3-715.html

Dernière modification par aurelein (25-03-2017 17:19:06)

Hors ligne

#17 25-03-2017 17:20:20

robert2a
Membre
Lieu : France
Distrib. : Stretch 9
Noyau : Linux 4.9.0-3 4.9.30-2
(G)UI : Mate
Inscription : 15-11-2014

Re : [Résolu] probleme lors de l'installation d'un firmware

ok , je te conseille d installer une debian amd64
ton windows est en 64 bits ?

sinon la partie du wiki qui t interresse
Pilote graphique Nvidia récente installation via backports (Debian jessie stable)

# Debian Jessie, dépôt principal + paquets non libres
ajouter la ligne des backports
attention remplace ton ancien sources.list (ne pas mélanger "httpredir" et "ftp.fr" )


    deb http://httpredir.debian.org/debian/ jessie main contrib non-free
    # Debian Jessie, mises-à-jour de sécurité + paquets non libres
    deb http://security.debian.org/ jessie/updates main contrib non-free
    # Debian Jessie, mises-à-jour "volatiles" + paquets non libres
    deb http://httpredir.debian.org/debian/ jessie-updates main contrib non-free
    # Debian Jessie, dépôt de rétroportages ("backports")
    deb http://httpredir.debian.org/debian jessie-backports main contrib non-free
 


mettre a jour le cache


apt-get update
 


faire une simulation de l installation du driver


apt-get -s install -t jessie-backports nvidia-kernel-dkms nvidia-settings nvidia-driver linux-headers-$(uname -r)
 


pour installer (supprimer -s )


apt-get install -t jessie-backports nvidia-kernel-dkms nvidia-settings nvidia-driver linux-headers-$(uname -r)
 



nota : la section backports du wiki est mauvaise (ou je suis fatigué tongue )
ce que je t ai noté est correct fait une simulation quand meme avant .

pas de fichier xorg.conf a créer .  juste un reboot a la fin de l installation (la mise a jour du noyau prend un peu de temps c est normal )

il y a 2 possibilités , soit avec le noyau 3.16 de jessie (comme ci dessus ) soit avec un noyau des backports
les 2 sont bonnes mais pour un materiel récent le noyau des backports peut etre plus adapté

sinon si cela ne te pose pas de problème ouvre un post pour installer "debian jessie amd64"  ou pourquoi pas "debian stretch amd64"

Dernière modification par robert2a (25-03-2017 17:36:12)

Hors ligne

#18 25-03-2017 17:34:01

aurelein
Membre
Distrib. : Debian Jessie
Noyau : Linux 3.16.0-4-686-pae
(G)UI : GNOME
Inscription : 20-03-2017

Re : [Résolu] probleme lors de l'installation d'un firmware

Je ne comprends pas bien ce que tu m'as donné :

 deb http://security.debian.org/ jessie/updates main contrib non-free  


est la ligne que j'ai effacé avant car elle faisait doublon.

Ça m'ennuie un peu de recommencer : peux tu me dire en un mot l'avantage de passer sur amd 64? (Ou m'expliquer comment trouver les différences entre les deux en cherchant moi même.

Dernière modification par aurelein (25-03-2017 17:36:28)

Hors ligne

#19 25-03-2017 17:38:56

robert2a
Membre
Lieu : France
Distrib. : Stretch 9
Noyau : Linux 4.9.0-3 4.9.30-2
(G)UI : Mate
Inscription : 15-11-2014

Re : [Résolu] probleme lors de l'installation d'un firmware

non je t ai donné ceci comme doublon


deb http://ftp.fr.debian.org/debian/ jessie main contrib non-free

deb http://httpredir.debian.org/debian/ jessie main contrib non-free
 



ce que tu me montre c est l upgrade pour la sécurité , il la faut soit comme ci dessus soit avec "httpredir"

tu vide ton fichier et tu met ce que je te donne au dessus (il est complet ) et un apt-get update pour rafraichir le cache d apt

Dernière modification par robert2a (25-03-2017 17:40:29)

Hors ligne

#20 25-03-2017 17:39:14

aurelein
Membre
Distrib. : Debian Jessie
Noyau : Linux 3.16.0-4-686-pae
(G)UI : GNOME
Inscription : 20-03-2017

Re : [Résolu] probleme lors de l'installation d'un firmware

J'ai compris en fait !
Je n'avais pas vu qu'il fallait remplacer le sources.list : dans ce cas là je comprends mieux.

Hors ligne

#21 25-03-2017 17:41:50

robert2a
Membre
Lieu : France
Distrib. : Stretch 9
Noyau : Linux 4.9.0-3 4.9.30-2
(G)UI : Mate
Inscription : 15-11-2014

Re : [Résolu] probleme lors de l'installation d'un firmware

tout est noté , mais je sais pas ce que ça va donner avec ta tentative d installation précédente ( d ou le conseil de simuler avant )

désolé je rafraichis mon post au fur et a mesure , prend ton temps et relit bien  wink

Dernière modification par robert2a (25-03-2017 17:43:35)

Hors ligne

#22 25-03-2017 17:55:56

aurelein
Membre
Distrib. : Debian Jessie
Noyau : Linux 3.16.0-4-686-pae
(G)UI : GNOME
Inscription : 20-03-2017

Re : [Résolu] probleme lors de l'installation d'un firmware

Je crois avoir compris. J'ai fait tout ça jusqu'à la simulation mais je ne suis pas sûr de bien interpréter ce qu'elle dit :

NVIDIA-settings est déjà là plus récente version disponible
NVIDIA-settings est passé en "installé manuellement
NVIDIA-driver est déjà là plus récente version disponible.
NVIDIA-kernel-dkms est déjà là plus récente version disponible
NVIDIA-kernel-dkms est passé en "installé manuellement"  
Les paquets supplémentaires suivants seront installés
[...]
 

Hors ligne

#23 25-03-2017 17:59:25

robert2a
Membre
Lieu : France
Distrib. : Stretch 9
Noyau : Linux 4.9.0-3 4.9.30-2
(G)UI : Mate
Inscription : 15-11-2014

Re : [Résolu] probleme lors de l'installation d'un firmware

tu utilisera cette commande plutot pour l installation


apt-get --reinstall install -t jessie-backports nvidia-kernel-dkms nvidia-settings nvidia-driver linux-headers-$(uname -r)
 



la liste est longue pour ceci => "Les paquets supplémentaires suivants seront installés"
[...]

j aimerai savoir les paquets qu il doit installer

pour la ligne ci dessus tu peut simuler aussi avec -s devant --reinstall
comme ceci


apt-get -s --reinstall install -t jessie-backports nvidia-kernel-dkms nvidia-settings nvidia-driver linux-headers-$(uname -r)
 

Dernière modification par robert2a (25-03-2017 18:03:05)

Hors ligne

#24 25-03-2017 18:09:10

aurelein
Membre
Distrib. : Debian Jessie
Noyau : Linux 3.16.0-4-686-pae
(G)UI : GNOME
Inscription : 20-03-2017

Re : [Résolu] probleme lors de l'installation d'un firmware

les paquets supplémentaires suivants seront installés :
cpp-4.8 gcc-4.8 libasan0 libgcc-4.8-dev linux-compiler-gcc-4.8-x86 linux-headers-3.16.0-4-common linux-kbuild-3.16
Paquets suggérés :
[...]
Les NOUVEAUX paquets suivants seront installés :
cpp-4.8 gcc-4.8 libasan0 libgcc-4.8-dev linux-compiler-gcc-4.8-x86
0 mises à jour, 8 nouvellement installés, 0 à enlever et 170 non mis à jour.
[...]

 



La simulation de la deuxième commande que tu m'as suggéré renvoit exactement la même chose.

Dernière modification par aurelein (25-03-2017 18:16:35)

Hors ligne

#25 25-03-2017 18:23:21

robert2a
Membre
Lieu : France
Distrib. : Stretch 9
Noyau : Linux 4.9.0-3 4.9.30-2
(G)UI : Mate
Inscription : 15-11-2014

Re : [Résolu] probleme lors de l'installation d'un firmware

deux trucs me chagrine

0 à enlever et 170 non mis à jour.  ta jessie est pas a jour ?  (je pense que c est les backports qui donnent 170 non mit a jour tongue )

ici ok  => linux-compiler-gcc-4.8-x86  mais la => linux-headers-3.16.0-4-common (pas de différence entre x86 et amd64 ? )

que te renvoie la commande :


uname -a
 



et un apt-get upgrade donne quoi (simulation )


apt-get -s upgrade
 



il te reste plus qu a envoyer la commande d installation du driver (sans simulation)

Dernière modification par robert2a (25-03-2017 18:24:53)

Hors ligne

Pied de page des forums