Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 21-05-2017 13:31:42

Zorglmorkin
Membre
Distrib. : Debian Stable (DFlinux)
Noyau : Linux 3.16.0-4-amd64
(G)UI : XFCE
Inscription : 23-01-2016

-force -openGL

Bonjour !

J'avais installé quelques petits jeux linux sur mon ordi, via GOG ou Steam, il y a un bout de temps, dont certains ne marchaient qu'en les ouvrant via le terminal en ajoutant '-force -openGL' (c'est en tout cas la solution que j'avais trouvée en farfouillant sauvagement sur internet). Après une mise à jour, je ne sais plus laquelle il y a quelques mois je crois, cette solution n'a plus fonctionné. Comme je ne joue pas vraiment, je ne m'en suis pas préoccupé à ce moment-là, mais là j'aimerais quand même refaire fonctionner tout ça, si possible.

Exemple de ce que ça donne aujourd'hui :

 $ ./Kingdom.x86 -force -openGL
Set current directory to /home/constant/GOG Games/Kingdom New Lands/game
Found path: /home/constant/GOG Games/Kingdom New Lands/game/Kingdom.x86
Mono path[0] = '/home/constant/GOG Games/Kingdom New Lands/game/Kingdom_Data/Managed'
Mono path[1] = '/home/constant/GOG Games/Kingdom New Lands/game/Kingdom_Data/Mono'
Mono config path = '/home/constant/GOG Games/Kingdom New Lands/game/Kingdom_Data/Mono/etc'
displaymanager : xrandr version warning. 1.4
displaymanager : trying .X11-unix
client :0 has 1 screens
displaymanager screen (0): 1366 x 768
Using libudev for joystick management


Importing game controller configs
 



Y a une sorte de flash noir, comme si le programme s'ouvrait et crashait dans la seconde, ce que -force -openGL corrigeait à une époque, mais... plus maintenant.

Hors ligne

Pied de page des forums