Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 15-09-2009 10:50:54

bjm
Membre
Distrib. : Wheezy 7.1
(G)UI : AWESOME ; Ratpoison
Inscription : 23-02-2008

Install XBMC sur lenny

Bonjour  smile
J'ai tenté d'installer xbmc sur ma debian.
J'ai utilisé ce tuto:
http://wiki.tuxgasy.fr/doku.php?id=xbmc … bian_light

au téléchargement de xbmc
$ svn checkout https://xbmc.svn.sourceforge.net/svnroo … xport/XBMC
Dans le répertoire créer XBMC il n'y a pas de fichier configure.
Il y a un ficher install-sh que j'ai tenté de lancé par:
./install-sh
bash install-sh
sh install-sh
Le résultat est toujours:
install-sh: no input file specified.:(

Hors ligne

#2 15-09-2009 12:31:02

phlinux
Membre
Lieu : S-M
Distrib. : Jessie
Noyau : 4.6
(G)UI : Openbox (+Rox+Feh)
Inscription : 10-05-2009

Re : Install XBMC sur lenny

bjr,
questions bêtes  :
- tu es dans le répertoire créé ?
- c'est vraiment install-sh et pas install.sh ?
- le rendre exécutable ?

chmod +x ton_fichier


Pages perso : feh, omegat, udisks, sa station de travail comme passerelle

Hors ligne

#3 15-09-2009 16:28:11

bjm
Membre
Distrib. : Wheezy 7.1
(G)UI : AWESOME ; Ratpoison
Inscription : 23-02-2008

Re : Install XBMC sur lenny

bjr smile
Je suis dans le repertoire créer
Dans ce repertoire :

$ ls
bootstrap                 known_issues.txt               scripts
Build.bat                 language                       skin
config.guess              LICENSE.GPL                    sounds
config.sub                Makefile.in                    system
configure.in              Makefile.include.in            tools
copying.txt               media                          userdata
credits                   MS_Extender_Remote_keymap.zip  visualisations
docs                      project                        web
guilib                    README.linux                   xbmc
install-sh                README.osx                     XBMC.kdevelop
keymapping-schematic.pdf  README.ubuntu                  XBMC.xcodeproj
keymapping.txt            screensavers                   xbmc-xrandr.c


Le contenu de ce fichier install-sh

#!/bin/sh
# install - install a program, script, or datafile

scriptversion=2006-10-14.15

# This originates from X11R5 (mit/util/scripts/install.sh), which was
# later released in X11R6 (xc/config/util/install.sh) with the
# following copyright and license.
#
# Copyright (C) 1994 X Consortium
#
# Permission is hereby granted, free of charge, to any person obtaining a copy
# of this software and associated documentation files (the "Software"), to
# deal in the Software without restriction, including without limitation the
# rights to use, copy, modify, merge, publish, distribute, sublicense, and/or
# sell copies of the Software, and to permit persons to whom the Software is
# furnished to do so, subject to the following conditions:
#
# The above copyright notice and this permission notice shall be included in
# all copies or substantial portions of the Software.
#
# THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND, EXPRESS OR
# IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF MERCHANTABILITY,
# FITNESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT.  IN NO EVENT SHALL THE
# X CONSORTIUM BE LIABLE FOR ANY CLAIM, DAMAGES OR OTHER LIABILITY, WHETHER IN
# AN ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING FROM, OUT OF OR IN CONNEC-
# TION WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS IN THE SOFTWARE.
#
# Except as contained in this notice, the name of the X Consortium shall not
# be used in advertising or otherwise to promote the sale, use or other deal-
# ings in this Software without prior written authorization from the X Consor-
# tium.
#
#
# FSF changes to this file are in the public domain.
#
# Calling this script install-sh is preferred over install.sh, to prevent
# `make' implicit rules from creating a file called install from it
# when there is no Makefile.
#
# This script is compatible with the BSD install script, but was written
# from scratch.

nl='
'
IFS=" ""  $nl"

# set DOITPROG to echo to test this script

# Don't use :- since 4.3BSD and earlier shells don't like it.
doit="${DOITPROG-}"
if test -z "$doit"; then
  doit_exec=exec
else
  doit_exec=$doit
fi

# Put in absolute file names if you don't have them in your path;
# or use environment vars.

mvprog="${MVPROG-mv}"
cpprog="${CPPROG-cp}"
chmodprog="${CHMODPROG-chmod}"
chownprog="${CHOWNPROG-chown}"
chgrpprog="${CHGRPPROG-chgrp}"
stripprog="${STRIPPROG-strip}"
rmprog="${RMPROG-rm}"
mkdirprog="${MKDIRPROG-mkdir}"

posix_glob=
posix_mkdir=

# Desired mode of installed file.
mode=0755

chmodcmd=$chmodprog
chowncmd=
chgrpcmd=
stripcmd=
rmcmd="$rmprog -f"
mvcmd="$mvprog"
src=
dst=
dir_arg=
dstarg=
no_target_directory=

usage="Usage: $0 [OPTION]... [-T] SRCFILE DSTFILE
   or: $0 [OPTION]... SRCFILES... DIRECTORY
   or: $0 [OPTION]... -t DIRECTORY SRCFILES...
   or: $0 [OPTION]... -d DIRECTORIES...

In the 1st form, copy SRCFILE to DSTFILE.
In the 2nd and 3rd, copy all SRCFILES to DIRECTORY.
In the 4th, create DIRECTORIES.

Options:
-c         (ignored)
-d         create directories instead of installing files.
-g GROUP   $chgrpprog installed files to GROUP.
-m MODE    $chmodprog installed files to MODE.
-o USER    $chownprog installed files to USER.
-s         $stripprog installed files.
-t DIRECTORY  install into DIRECTORY.
-T         report an error if DSTFILE is a directory.
--help     display this help and exit.
--version  display version info and exit.

Environment variables override the default commands:
  CHGRPPROG CHMODPROG CHOWNPROG CPPROG MKDIRPROG MVPROG RMPROG STRIPPROG
"

while test $# -ne 0; do
  case $1 in
    -c) shift
        continue;;

    -d) dir_arg=true
        shift
        continue;;

    -g) chgrpcmd="$chgrpprog $2"
        shift
        shift
        continue;;

    --help) echo "$usage"; exit $?;;

    -m) mode=$2
        shift
        shift
  case $mode in
    *' '* | *'  '* | *'
'*    | *'*'* | *'?'* | *'['*)
      echo "$0: invalid mode: $mode" >&2
      exit 1;;
  esac
        continue;;

    -o) chowncmd="$chownprog $2"
        shift
        shift
        continue;;

    -s) stripcmd=$stripprog
        shift
        continue;;

    -t) dstarg=$2
  shift
  shift
  continue;;

    -T) no_target_directory=true
  shift
  continue;;

    --version) echo "$0 $scriptversion"; exit $?;;

    --) shift
  break;;

    -*) echo "$0: invalid option: $1" >&2
  exit 1;;

    *)  break;;
  esac
done

if test $# -ne 0 && test -z "$dir_arg$dstarg"; then
  # When -d is used, all remaining arguments are directories to create.
  # When -t is used, the destination is already specified.
  # Otherwise, the last argument is the destination.  Remove it from $@.
  for arg
  do
    if test -n "$dstarg"; then
      # $@ is not empty: it contains at least $arg.
      set fnord "$@" "$dstarg"
      shift # fnord
    fi
    shift # arg
    dstarg=$arg
  done
fi

if test $# -eq 0; then
  if test -z "$dir_arg"; then
    echo "$0: no input file specified." >&2
    exit 1
  fi
  # It's OK to call `install-sh -d' without argument.
  # This can happen when creating conditional directories.
  exit 0
fi

if test -z "$dir_arg"; then
  trap '(exit $?); exit' 1 2 13 15

  # Set umask so as not to create temps with too-generous modes.
  # However, 'strip' requires both read and write access to temps.
  case $mode in
    # Optimize common cases.
    *644) cp_umask=133;;
    *755) cp_umask=22;;

    *[0-7])
      if test -z "$stripcmd"; then
  u_plus_rw=
      else
  u_plus_rw='% 200'
      fi
      cp_umask=`expr '(' 777 - $mode % 1000 ')' $u_plus_rw`;;
    *)
      if test -z "$stripcmd"; then
  u_plus_rw=
      else
  u_plus_rw=,u+rw
      fi
      cp_umask=$mode$u_plus_rw;;
  esac
fi

for src
do
  # Protect names starting with `-'.
  case $src in
    -*) src=./$src ;;
  esac

  if test -n "$dir_arg"; then
    dst=$src
    dstdir=$dst
    test -d "$dstdir"
    dstdir_status=$?
  else

    # Waiting for this to be detected by the "$cpprog $src $dsttmp" command
    # might cause directories to be created, which would be especially bad
    # if $src (and thus $dsttmp) contains '*'.
    if test ! -f "$src" && test ! -d "$src"; then
      echo "$0: $src does not exist." >&2
      exit 1
    fi

    if test -z "$dstarg"; then
      echo "$0: no destination specified." >&2
      exit 1
    fi

    dst=$dstarg
    # Protect names starting with `-'.
    case $dst in
      -*) dst=./$dst ;;
    esac

    # If destination is a directory, append the input filename; won't work
    # if double slashes aren't ignored.
    if test -d "$dst"; then
      if test -n "$no_target_directory"; then
  echo "$0: $dstarg: Is a directory" >&2
  exit 1
      fi
      dstdir=$dst
      dst=$dstdir/`basename "$src"`
      dstdir_status=0
    else
      # Prefer dirname, but fall back on a substitute if dirname fails.
      dstdir=`
  (dirname "$dst") 2>/dev/null ||
  expr X"$dst" : 'X\(.*[^/]\)//*[^/][^/]*/*$' \| \
       X"$dst" : 'X\(//\)[^/]' \| \
       X"$dst" : 'X\(//\)$' \| \
       X"$dst" : 'X\(/\)' \| . 2>/dev/null ||
  echo X"$dst" |
      sed '/^X\(.*[^/]\)\/\/*[^/][^/]*\/*$/{
       s//\1/
       q
     }
     /^X\(\/\/\)[^/].*/{
       s//\1/
       q
     }
     /^X\(\/\/\)$/{
       s//\1/
       q
     }
     /^X\(\/\).*/{
       s//\1/
       q
     }
     s/.*/./; q'
      `

      test -d "$dstdir"
      dstdir_status=$?
    fi
  fi

  obsolete_mkdir_used=false

  if test $dstdir_status != 0; then
    case $posix_mkdir in
      '')
  # Create intermediate dirs using mode 755 as modified by the umask.
  # This is like FreeBSD 'install' as of 1997-10-28.
  umask=`umask`
  case $stripcmd.$umask in
    # Optimize common cases.
    *[2367][2367]) mkdir_umask=$umask;;
    .*0[02][02] | .[02][02] | .[02]) mkdir_umask=22;;

    *[0-7])
      mkdir_umask=`expr $umask + 22 \
        - $umask % 100 % 40 + $umask % 20 \
        - $umask % 10 % 4 + $umask % 2
      `;;
    *) mkdir_umask=$umask,go-w;;
  esac

  # With -d, create the new directory with the user-specified mode.
  # Otherwise, rely on $mkdir_umask.
  if test -n "$dir_arg"; then
    mkdir_mode=-m$mode
  else
    mkdir_mode=
  fi

  posix_mkdir=false
  case $umask in
    *[123567][0-7][0-7])
      # POSIX mkdir -p sets u+wx bits regardless of umask, which
      # is incompatible with FreeBSD 'install' when (umask & 300) != 0.
      ;;
    *)
      tmpdir=${TMPDIR-/tmp}/ins$RANDOM-$$
      trap 'ret=$?; rmdir "$tmpdir/d" "$tmpdir" 2>/dev/null; exit $ret' 0

      if (umask $mkdir_umask &&
    exec $mkdirprog $mkdir_mode -p -- "$tmpdir/d") >/dev/null 2>&1
      then
        if test -z "$dir_arg" || {
       # Check for POSIX incompatibilities with -m.
       # HP-UX 11.23 and IRIX 6.5 mkdir -m -p sets group- or
       # other-writeable bit of parent directory when it shouldn't.
       # FreeBSD 6.1 mkdir -m -p sets mode of existing directory.
       ls_ld_tmpdir=`ls -ld "$tmpdir"`
       case $ls_ld_tmpdir in
         d????-?r-*) different_mode=700;;
         d????-?--*) different_mode=755;;
         *) false;;
       esac &&
       $mkdirprog -m$different_mode -p -- "$tmpdir" && {
         ls_ld_tmpdir_1=`ls -ld "$tmpdir"`
         test "$ls_ld_tmpdir" = "$ls_ld_tmpdir_1"
       }
     }
        then posix_mkdir=:
        fi
        rmdir "$tmpdir/d" "$tmpdir"
      else
        # Remove any dirs left behind by ancient mkdir implementations.
        rmdir ./$mkdir_mode ./-p ./-- 2>/dev/null
      fi
      trap '' 0;;
  esac;;
    esac

    if
      $posix_mkdir && (
  umask $mkdir_umask &&
  $doit_exec $mkdirprog $mkdir_mode -p -- "$dstdir"
      )
    then :
    else

      # The umask is ridiculous, or mkdir does not conform to POSIX,
      # or it failed possibly due to a race condition.  Create the
      # directory the slow way, step by step, checking for races as we go.

      case $dstdir in
  /*) prefix=/ ;;
  -*) prefix=./ ;;
  *)  prefix= ;;
      esac

      case $posix_glob in
        '')
    if (set -f) 2>/dev/null; then
      posix_glob=true
    else
      posix_glob=false
    fi ;;
      esac

      oIFS=$IFS
      IFS=/
      $posix_glob && set -f
      set fnord $dstdir
      shift
      $posix_glob && set +f
      IFS=$oIFS

      prefixes=

      for d
      do
  test -z "$d" && continue

  prefix=$prefix$d
  if test -d "$prefix"; then
    prefixes=
  else
    if $posix_mkdir; then
      (umask=$mkdir_umask &&
       $doit_exec $mkdirprog $mkdir_mode -p -- "$dstdir") && break
      # Don't fail if two instances are running concurrently.
      test -d "$prefix" || exit 1
    else
      case $prefix in
        *\'*) qprefix=`echo "$prefix" | sed "s/'/'\\\\\\\\''/g"`;;
        *) qprefix=$prefix;;
      esac
      prefixes="$prefixes '$qprefix'"
    fi
  fi
  prefix=$prefix/
      done

      if test -n "$prefixes"; then
  # Don't fail if two instances are running concurrently.
  (umask $mkdir_umask &&
   eval "\$doit_exec \$mkdirprog $prefixes") ||
    test -d "$dstdir" || exit 1
  obsolete_mkdir_used=true
      fi
    fi
  fi

  if test -n "$dir_arg"; then
    { test -z "$chowncmd" || $doit $chowncmd "$dst"; } &&
    { test -z "$chgrpcmd" || $doit $chgrpcmd "$dst"; } &&
    { test "$obsolete_mkdir_used$chowncmd$chgrpcmd" = false ||
      test -z "$chmodcmd" || $doit $chmodcmd $mode "$dst"; } || exit 1
  else

    # Make a couple of temp file names in the proper directory.
    dsttmp=$dstdir/_inst.$$_
    rmtmp=$dstdir/_rm.$$_

    # Trap to clean up those temp files at exit.
    trap 'ret=$?; rm -f "$dsttmp" "$rmtmp" && exit $ret' 0

    # Copy the file name to the temp name.
    (umask $cp_umask && $doit_exec $cpprog "$src" "$dsttmp") &&

    # and set any options; do chmod last to preserve setuid bits.
    #
    # If any of these fail, we abort the whole thing.  If we want to
    # ignore errors from any of these, just make sure not to ignore
    # errors from the above "$doit $cpprog $src $dsttmp" command.
    #
    { test -z "$chowncmd" || $doit $chowncmd "$dsttmp"; } \
      && { test -z "$chgrpcmd" || $doit $chgrpcmd "$dsttmp"; } \
      && { test -z "$stripcmd" || $doit $stripcmd "$dsttmp"; } \
      && { test -z "$chmodcmd" || $doit $chmodcmd $mode "$dsttmp"; } &&

    # Now rename the file to the real destination.
    { $doit $mvcmd -f "$dsttmp" "$dst" 2>/dev/null \
      || {
     # The rename failed, perhaps because mv can't rename something else
     # to itself, or perhaps because mv is so ancient that it does not
     # support -f.

     # Now remove or move aside any old file at destination location.
     # We try this two ways since rm can't unlink itself on some
     # systems and the destination file might be busy for other
     # reasons.  In this case, the final cleanup might fail but the new
     # file should still install successfully.
     {
       if test -f "$dst"; then
         $doit $rmcmd -f "$dst" 2>/dev/null \
         || { $doit $mvcmd -f "$dst" "$rmtmp" 2>/dev/null \
         && { $doit $rmcmd -f "$rmtmp" 2>/dev/null; :; }; }\
         || {
     echo "$0: cannot unlink or rename $dst" >&2
     (exit 1); exit 1
         }
       else
         :
       fi
     } &&

     # Now rename the file to the real destination.
     $doit $mvcmd "$dsttmp" "$dst"
   }
    } || exit 1

    trap '' 0
  fi
done

# Local variables:
# eval: (add-hook 'write-file-hooks 'time-stamp)
# time-stamp-start: "scriptversion="
# time-stamp-format: "%:y-%02m-%02d.%02H"
# time-stamp-end: "$"
# End:


Le contenu du fichier README.linux

TOC
1. Introduction
2. Getting the source code
3. Installing the required libraries and headers
4. How to compile
5. How to run
6. Uninstalling
8. Endword

-----------------------------------------------------------------------------
1. Introduction
-----------------------------------------------------------------------------

A gfx-adapter with OpenGL acceleration is highly recommended and 24/32 bitdepth
is required with OpenGL.

NOTE TO NEW LINUX USERS: All lines that are prefixed with the '$'
character are commands that need to be typed into a terminal window /
console (similar to the command prompt for Windows). Note that the '$'
character itself should NOT be typed as part of the command.


-----------------------------------------------------------------------------
2. Getting the source code
-----------------------------------------------------------------------------

You will have to grab the source code of course. First install the subversion
package provided by your distribution. Then from a terminal, type:

   $ cd $HOME
   $ svn checkout https://xbmc.svn.sourceforge.net/svnroot/xbmc/branches/linuxport/XBMC

-----------------------------------------------------------------------------
3. Installing the required libraries and headers
-----------------------------------------------------------------------------

You will then need the required libraries. The following is the list of packages
that are used to build XBMC packages on Debian/Ubuntu (with all supported
external libraries enabled).

Build-Depends: debhelper (>= 7.0.50), quilt, python-support, cmake,
 autotools-dev, autoconf, automake, unzip, libboost-dev,
 libgl1-mesa-dev | libgl-dev, libglu-dev, libglew-dev, libmad0-dev, libjpeg-dev,
 libsamplerate-dev, libogg-dev, libvorbis-dev, libfreetype6-dev,
 libfontconfig-dev, libbz2-dev, libfribidi-dev, libsqlite3-dev,
 libmysqlclient-dev, libasound-dev, libpng-dev, libpcre3-dev, liblzo2-dev,
 libcdio-dev, libsdl-dev, libsdl-image1.2-dev, libsdl-mixer1.2-dev, libenca-dev,
 libjasper-dev, libxt-dev, libxtst-dev, libxmu-dev, libxinerama-dev,
 libcurl4-gnutls-dev | libcurl-dev, libdbus-1-dev, libhal-storage-dev,
 libhal-dev, libpulse-dev, libavahi-common-dev, libavahi-client-dev,
 libxrandr-dev, libavcodec-dev, libavformat-dev, libavutil-dev, libpostproc-dev,
 libswscale-dev, liba52-dev, libdts-dev, libfaad-dev, libmp4ff-dev,
 libmpeg2-4-dev, libass-dev, libmpcdec-dev, libflac-dev, libwavpack-dev,
 python-dev, gawk, gperf, nasm [!amd64], libcwiid1-dev, libbluetooth-dev,
 zlib1g-dev, libmms-dev, libsmbclient-dev,

*** For developers and anyone else who compiles frequently it is recommended to
use ccache

--------------------------------------------------------------
3.1. Using the XBMC PPA to get all build dependencies (Debian/Ubuntu only)
--------------------------------------------------------------

For this, you need to specify the PPA in your apt sources. Please find them on
the forum.

http://xbmc.org/forum/showthread.php?t=33327

Update apt:
   $ sudo apt-get update

Here is the magic command to get the build dependencies (used to compile the
version on the PPA).
   $ sudo apt-get build-dep xbmc

-----------------------------------------------------------------------------
4. How to compile
-----------------------------------------------------------------------------

To create the XBMC executable manually perform these steps:

.0  $ ./bootstrap

.1  $ ./configure <option1> <option2> ...

These configure options exist (among others):
  --disable-option-checking  ignore unrecognized --enable/--with options
  --disable-FEATURE       do not include FEATURE (same as --enable-FEATURE=no)
  --enable-FEATURE[=ARG]  include FEATURE [ARG=yes]
  --enable-debug          enable debugging information (default is yes)
  --enable-optimizations  enable optimization (default is yes)
  --enable-gl             enable OpenGL rendering (default is yes)
  --enable-vdpau          enable VDPAU decoding (default is yes)
  --enable-profiling      enable gprof profiling (default is no)
  --enable-joystick       enable SDL joystick support (default is yes)
  --enable-xrandr         enable XRandR support (default is yes)
  --enable-ccache         enable building with ccache feature (default is yes
                          if ccache is installed)
  --enable-pulse          enable PulseAudio support (default is yes)
  --enable-faac           enable FAAC support (default is yes)
  --enable-dvdcss         enable DVDCSS support (default is yes)
  --enable-mid            enable MID support (default is no)
  --disable-avahi         disable Avahi support (default is enabled if
                          libavahi-common and libavahi-client is found)
  --enable-external-libraries
                          enable use of all supported external libraries
                          (default is no) 'Linux only'
  --enable-external-ffmpeg
                          enable use of external ffmpeg libraries (default is
                          no) 'Linux only'
  --enable-external-libmad
                          enable use of external libmad library (default is
                          no) 'Linux only'
  --enable-external-liba52
                          enable use of external liba52 library (default is
                          no) 'Linux only'
  --enable-external-libdts
                          enable use of external libdts library (default is
                          no) 'Linux only'
  --enable-external-libfaad
                          enable use of external libfaad library (default is
                          no) 'Linux only'
  --enable-external-libmpeg2
                          enable use of external libmpeg2 library (default is
                          no) 'Linux only'
  --enable-external-libass
                          enable use of external libass library (default is
                          no) 'Linux only'
  --enable-external-libvorbis
                          enable use of external libvorbis library (default is
                          no) 'Linux only'
  --enable-external-libogg
                          enable use of external libogg library (default is
                          no) 'Linux only'
  --enable-external-libmpcdec
                          enable use of external libmpcdec library (default is
                          no) 'Linux only'
  --enable-external-libflac
                          enable use of external libflac library (default is
                          no) 'Linux only'
  --enable-external-libwavpack
                          enable use of external libwavpack library (default
                          is no) 'Linux only'
  --enable-external-python
                          enable use of external python library (default is
                          no) 'Linux only'

A full listing of supported options can be viewed by typing
'./configure --help'.

.2  $ make

Tip: by adding -j<number> to the make command, you describe how many
     concurrent jobs will be used. So for dualcore the command is:

    $ make -j2

.3  $ make install

This will install XBMC in the prefix provided in 4.1 as well as a launcher script.

NOTE: You may need to run this with sudo (sudo make install) if your user
doesn't have write permissions to the prefix you have provided (as in the
default case, /usr/local).

Tip: To override the location that XBMC is installed, use PREFIX=<path>.
For example.

    $ make install PREFIX=$HOME/xbmc

-----------------------------------------------------------------------------
5. How to run
-----------------------------------------------------------------------------
How to run xbmc depends on the type of installation you have done. It is
possible to run XBMC without the requirement to install xbmc anywhere else. In
this case, type the following from the top source directory.

    $ ./xbmc.bin

If you chose to install XBMC using '/usr' or '/usr/local' as the PREFIX, you
can just issue 'xbmc' in a teminal session.

If you overridden PREFIX to install XBMC into some non-standard location, you
will have to run xbmc by directly running 'xbmc.bin'. For example.

    $ $HOME/xbmc/usr/share/xbmc.bin

If you wish to use VDPAU decoding you will now have to change the Render Method
in Settings->Videos->Player from "Auto Detect" to "VDPAU".

-----------------------------------------------------------------------------
6. Uninstalling
-----------------------------------------------------------------------------
Issue "make uninstall"  ("sudo make uninstall" if you user doesn't have write
permission to the install directory) from your source tree. If you would like
to also remove any settings and 3rd party addons (skins, scripts, etc) you
should also run "rm -rf ~/.xbmc".

NOTE: If you have rerun configure with a different prefix, you will either need
to rerun configure with the correct prefix for this step to work correctly.

-----------------------------------------------------------------------------
7. Endword
-----------------------------------------------------------------------------

Have fun!

EOF


Il est en anglais , je ne parle pas l'anglais

Dernière modification par bjm (15-09-2009 16:32:58)

Hors ligne

#4 15-09-2009 18:01:52

phlinux
Membre
Lieu : S-M
Distrib. : Jessie
Noyau : 4.6
(G)UI : Openbox (+Rox+Feh)
Inscription : 10-05-2009

Re : Install XBMC sur lenny

re-
Moi aussi je lis assez mal cette langue.
Un outil ? > http://translate.google.fr/#.
On copie le texte dans la fenêtre, on choisit de quelle langue on part et celle de destination > Traduire

bon je regarde de mon coté

Pages perso : feh, omegat, udisks, sa station de travail comme passerelle

Hors ligne

#5 06-10-2009 09:37:31

kinroux
Membre
Lieu : Boulogne/mer
Distrib. : Squeeze
Noyau : 2.6.32-5-amd64
(G)UI : Gnome
Inscription : 27-06-2008

Re : Install XBMC sur lenny

Salut,

J'avais aussi essayé de l'installer, mais j'ai laissé tomber par manque de temps. J'ai vu que XBMC était présent dans les dépots debian-multimedia (unstable) depuis peu. Je n'ai pas testé.

Bon courage.

Hors ligne

#6 06-10-2009 16:12:41

bjm
Membre
Distrib. : Wheezy 7.1
(G)UI : AWESOME ; Ratpoison
Inscription : 23-02-2008

Re : Install XBMC sur lenny

Bonjour kinroux
Merci pour l'info , je suis sous lenny éventuellement je l'aurai bien essayé avec squeeeze .

J'ai pas trouver de solution hmm

Hors ligne

#7 06-10-2009 19:37:23

phlinux
Membre
Lieu : S-M
Distrib. : Jessie
Noyau : 4.6
(G)UI : Openbox (+Rox+Feh)
Inscription : 10-05-2009

Re : Install XBMC sur lenny

Bjr,
Excuses. J'avais écrit que je regarderais, mais j'ai complètement zappé.

En fait comme l'écrit kinroux xmbc est dans les dépots unstable-multimédia.

Pour voir ce que tu peux faire j'ai simulé l'install en ajoutant unstable-multimédia dans le sources.list et une entrée "Package xbmc " dans le fichier preferences. Mais vu le résultat, je pense que cela te ferait installer un bon nombre de paquets en sid, ce qui demande ensuite un suivi attentif.

Je mets la sortie de la simul, si quelqu'un veut se pencher dessus pour t'aider plus avant.

debian:/home/phlinux# apt-get install -s xbmc -t unstable
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances      
Lecture des informations d'état... Fait
Certains paquets ne peuvent être installés. Ceci peut signifier
que vous avez demandé l'impossible, ou bien, si vous utilisez
la distribution unstable, que certains paquets n'ont pas encore
été créés ou ne sont pas sortis d'Incoming.
L'information suivante devrait vous aider à résoudre la situation :

Les paquets suivants contiennent des dépendances non satisfaites :
  xbmc: Dépend: xbmc-bin (>= 9.04.1+svn20091002-0.0) mais ne sera pas installé
        Dépend: xbmc-data (>= 9.04.1+svn20091002-0.0) mais ne sera pas installé
        Dépend: xbmc-skin-pm3-hd (>= 9.04.1+svn20091002-0.0) mais ne sera pas installé
E: Paquets défectueux


Pages perso : feh, omegat, udisks, sa station de travail comme passerelle

Hors ligne

#8 06-10-2009 20:04:21

smolski
administrateur quasi...modo
Lieu : AIN
Distrib. : 8 (jessie) 64 bits + backports
Noyau : 4.6.0-0.bpo.1-amd64
(G)UI : gnome 3.14.1
Inscription : 21-10-2008

Re : Install XBMC sur lenny

Ah !

C'est sympa ça phlinux, merci ! cool

Amitié, Joel

"Définition d'eric besson : S'il fallait en chier des tonnes pour devenir ministre, il aurait 2 trous du cul." - JP Douillon
"L'utopie ne signifie pas l'irréalisable, mais l'irréalisée." - T Monod (source :  La zone de Siné)
"Je peux rire de tout mais pas avec n'importe qui." - P Desproges
"saque eud dun" (patois chtimi : fonce dedans)

En ligne

#9 06-10-2009 23:45:31

phlinux
Membre
Lieu : S-M
Distrib. : Jessie
Noyau : 4.6
(G)UI : Openbox (+Rox+Feh)
Inscription : 10-05-2009

Re : Install XBMC sur lenny

re-
Au fait, le site original semble un peu différent > http://xbmc.org/wiki/?title=HOW-TO_comp … ian/Ubuntu

Essaies cette méthode, peut être ?

Demande s'il y a des termes que tu ne comprend pas

Pages perso : feh, omegat, udisks, sa station de travail comme passerelle

Hors ligne

#10 07-10-2009 00:08:11

bjm
Membre
Distrib. : Wheezy 7.1
(G)UI : AWESOME ; Ratpoison
Inscription : 23-02-2008

Re : Install XBMC sur lenny

Bonjour phlinux
Dans l'archive il n'y a pas de fichier configure , ce qui me semble bizarre ou il y a une autre façon de compiler ?

Hors ligne

#11 07-10-2009 03:07:27

martinux_qc
Administrateur
Lieu : Montréal (Québec)
Distrib. : Sid
Noyau : Linux 4.7.0-1-amd64
(G)UI : XFCE 4.12
Inscription : 12-10-2008

Re : Install XBMC sur lenny

phlinux a écrit :

Bjr,
Excuses. J'avais écrit que je regarderais, mais j'ai complètement zappé.

En fait comme l'écrit kinroux xmbc est dans les dépots unstable-multimédia.

Pour voir ce que tu peux faire j'ai simulé l'install en ajoutant unstable-multimédia dans le sources.list et une entrée "Package xbmc " dans le fichier preferences. Mais vu le résultat, je pense que cela te ferait installer un bon nombre de paquets en sid, ce qui demande ensuite un suivi attentif.

Je mets la sortie de la simul, si quelqu'un veut se pencher dessus pour t'aider plus avant.

debian:/home/phlinux# apt-get install -s xbmc -t unstable
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances      
Lecture des informations d'état... Fait
Certains paquets ne peuvent être installés. Ceci peut signifier
que vous avez demandé l'impossible, ou bien, si vous utilisez
la distribution unstable, que certains paquets n'ont pas encore
été créés ou ne sont pas sortis d'Incoming.
L'information suivante devrait vous aider à résoudre la situation :

Les paquets suivants contiennent des dépendances non satisfaites :
  xbmc: Dépend: xbmc-bin (>= 9.04.1+svn20091002-0.0) mais ne sera pas installé
        Dépend: xbmc-data (>= 9.04.1+svn20091002-0.0) mais ne sera pas installé
        Dépend: xbmc-skin-pm3-hd (>= 9.04.1+svn20091002-0.0) mais ne sera pas installé
E: Paquets défectueux


Salut

Je viens de faire moi aussi la simulation. J'ai pris le fichier sources.list du wiki ainsi que le preferences qui va avec (avec les corrections apportées aujourd'hui).  Par contre, je ne vois pas l'utilité de mettre cela :

une entrée "Package xbmc " dans le fichier preferences


Avec l'option -t on se retrouve momentanément dans la branche sid pour aller chercher ce que l'on veut. De plus, les dépendances non satisfaites dans le message de phlinux n'en sont pas vraiment. Les paquets sont bien dans le dépôt debian-multimedia pour sid.

Donc j'ai fait un :

debian:~# apt-get -s install xbmc -t unstable


comme phlinux.

Voici le résultat :

debian:~# apt-get -s install xbmc -t unstable
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances      
Lecture des informations d'état... Fait
Les paquets suivants ont été installés automatiquement et ne sont plus nécessaires :
  libcap1
Veuillez utiliser « apt-get autoremove » pour les supprimer.
Les paquets supplémentaires suivants seront installés :
  libasound2 libavcodec52 libavformat52 libavutil50 libcdio10 libdb4.8
  libdirac-encoder0 libenca0 libfaac0 libfaad2 libglew1.5 libgsm1 libmikmod2
  libmms0 libmp3lame0 libmysqlclient16 liboil0.3 libopencore-amrnb0
  libopencore-amrwb0 libopenjpeg2 libpcre3 libpostproc51 libpulse0
  libsamplerate0 libschroedinger-1.0-0 libsdl-mixer1.2 libsmpeg0 libsndfile1
  libsqlite3-0 libswscale0 libvorbis0a libvorbisfile3 libx264-76 libxvidcore4
  mesa-utils mysql-common python2.4 python2.4-minimal xbmc-bin xbmc-data
  xbmc-skin-pm3-hd
Paquets suggérés :
  libasound2-plugins glew-utils pulseaudio python2.4-doc python-profiler
  binfmt-support xbmc-third-parties xbmc-test-helper
Les NOUVEAUX paquets suivants seront installés :
  libavcodec52 libavutil50 libcdio10 libdb4.8 libdirac-encoder0 libenca0
  libfaac0 libfaad2 libglew1.5 libmikmod2 libmms0 libmp3lame0 libmysqlclient16
  libopencore-amrnb0 libopencore-amrwb0 libopenjpeg2 libsamplerate0
  libschroedinger-1.0-0 libsdl-mixer1.2 libsmpeg0 libsndfile1 libswscale0
  libvorbisfile3 libx264-76 libxvidcore4 mesa-utils mysql-common python2.4
  python2.4-minimal xbmc xbmc-bin xbmc-data xbmc-skin-pm3-hd
Les paquets suivants seront mis à jour :
  libasound2 libavformat52 libgsm1 liboil0.3 libpcre3 libpostproc51 libpulse0
  libsqlite3-0 libvorbis0a


La même chose avec aptitude :

debian:~# aptitude -s install xbmc -t unstable


Donne :

debian:~# aptitude -s install xbmc -t unstable
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances      
Lecture des informations d'état... Fait
Lecture de l'information d'état étendu      
Initialisation de l'état des paquets... Fait
Lecture des descriptions de tâches... Fait  
Les NOUVEAUX paquets suivants vont être installés :
  libavcodec52{a} libavutil50{a} libcdio10{a} libdb4.8{a}
  libdirac-encoder0{a} libenca0{a} libfaac0{a} libfaad2{a} libglew1.5{a}
  libmikmod2{a} libmms0{a} libmp3lame0{a} libmysqlclient16{a}
  libopencore-amrnb0{a} libopencore-amrwb0{a} libopenjpeg2{a}
  libsamplerate0{a} libschroedinger-1.0-0{a} libsdl-mixer1.2{a}
  libsmpeg0{a} libsndfile1{a} libswscale0{a} libvorbisfile3{a}
  libx264-76{a} libxvidcore4{a} mesa-utils{a} mysql-common{a} python2.4{a}
  python2.4-minimal{a} xbmc xbmc-bin{a} xbmc-data{a} xbmc-skin-pm3-hd{a}
Les paquets suivants seront ENLEVÉS :
  libcap1{u}
Les paquets suivants seront mis à jour :
  libasound2 libavformat52 libgsm1 liboil0.3 libpcre3 libpostproc51
  libpulse0 libsqlite3-0 libvorbis0a


Au final, beaucoup de nouveaux paquets installés, mais rien qui fait changer de branche ou apporte des changements trop drastiques. Donc, c'est jouable. À vous de voir.

Martin

Dernière modification par martinux_qc (07-10-2009 03:42:47)


"L'éducation vise à former des citoyens pas trop tatas et non pas à envoyer le plus de tatas possible à l'université."
Pierre Foglia (Journaliste à la retraite à La Presse)
Note : au Québec, le mot tata a un sens péjoratif qui sert à désigner une personne un peu idiote ou insignifiante. D'où les expressions familières : Espèce de grand, de gros tata! Être, avoir l'air tata.

Hors ligne

#12 07-10-2009 11:40:32

kinroux
Membre
Lieu : Boulogne/mer
Distrib. : Squeeze
Noyau : 2.6.32-5-amd64
(G)UI : Gnome
Inscription : 27-06-2008

Re : Install XBMC sur lenny

Est ce vraiment utile de préciser -t unstable puisque le paquet xbmc est présent seulement dans les dépots multimedia unstable ?
aptitude install xbmc ne donnerait pas le même résultat ?

Hors ligne

#13 07-10-2009 11:43:46

smolski
administrateur quasi...modo
Lieu : AIN
Distrib. : 8 (jessie) 64 bits + backports
Noyau : 4.6.0-0.bpo.1-amd64
(G)UI : gnome 3.14.1
Inscription : 21-10-2008

Re : Install XBMC sur lenny

Bonjour,

En fait, pour savoir les versions dispo, un :

apt-cache madison paquet nom_du_paquet


donnera les versions et, effectivement, s'il n'y a que sid pour avoir xmbc, le -t n'est pas insdispensable...

Edit : Ah oui, voir plus loin la réponse de martin... -t permet d'installer toutes les dépendances nécessaires, on ne peut donc s'en passer, sinon à tout installer à la main : paquet principal et indépendances...

Amitié, joel

Dernière modification par smolski (08-10-2009 07:01:00)


"Définition d'eric besson : S'il fallait en chier des tonnes pour devenir ministre, il aurait 2 trous du cul." - JP Douillon
"L'utopie ne signifie pas l'irréalisable, mais l'irréalisée." - T Monod (source :  La zone de Siné)
"Je peux rire de tout mais pas avec n'importe qui." - P Desproges
"saque eud dun" (patois chtimi : fonce dedans)

En ligne

#14 07-10-2009 12:00:48

phlinux
Membre
Lieu : S-M
Distrib. : Jessie
Noyau : 4.6
(G)UI : Openbox (+Rox+Feh)
Inscription : 10-05-2009

Re : Install XBMC sur lenny

Bjr,

martin_mtl a écrit :

Par contre, je ne vois pas l'utilité de mettre cela :

une entrée "Package xbmc " dans le fichier preferences


Perso je n'y connais rien. J'ai juste tenter de suivre le wiki.

Illustration de l'option -t

Supposons que je veuille installer le paquet XYZ qui se trouve dans une autre branche du sources.list que celle utilisée en priorité.

Si j'utilise le slash “/” ainsi :

apt-get install XYZ/<branche>

Cela installe le paquet XYZ de la branche donnée en argument.

Si je fais maintenant un :

apt-get install XYZ -t <branche>

Cela installe le paquet XYZ tout en définissant temporairement la branche donnée en argument comme branche par défaut (priorité de 990).
Concrètement :

    *
      avec l'option -t,

les éventuelles dépendances du paquet XYZ seront facilement accessibles car elles auront, comme XYZ, une priorité temporaire de 990.

    *
      Alors qu'avec /,

elles gardent la priorité définie dans le fichier /etc/apt/preferences ou celle par défaut (500).

Après cette commande, nous sommes toujours dans la branche mentionnée par l'option -t !
Il nous faut :

fermer le terminal root pour revenir dans la branche prioritaire du fichier preferences.

Si nous voulons suivre une application installée avec l'option -t

(et les dépendances qui vont avec…)
Nous devons écrire une entrée dans le fichier preferences (voir exemple ci-dessous).

Par exemple :

Pour un paquet XYZ de la branche unstable nous ajouterions au fichier preferences ces lignes :

Package: XYZ
Pin: release a=unstable
Pin-Priority: 400


L'option que tu prends est différente : tu changes tout le sources.list, donc forcément c'est plus facile. Et c'est justement ce que je voulais éviter.
J'ai bien vu que la libc6 n'est pas upgradée : mais vu le nombre de nouveaux paquets, à terme ça sent le bronx (pour une Lenny tout du moins. D'ailleurs de mémoire dans le wiki c'est indiqué : mélange stable et unstable à éviter )


Pages perso : feh, omegat, udisks, sa station de travail comme passerelle

Hors ligne

#15 07-10-2009 12:31:03

bjm
Membre
Distrib. : Wheezy 7.1
(G)UI : AWESOME ; Ratpoison
Inscription : 23-02-2008

Re : Install XBMC sur lenny

En fait c'est ça qui me plait pas trop
" mélange stable et unstable à éviter "

Hors ligne

#16 07-10-2009 12:34:42

phlinux
Membre
Lieu : S-M
Distrib. : Jessie
Noyau : 4.6
(G)UI : Openbox (+Rox+Feh)
Inscription : 10-05-2009

Re : Install XBMC sur lenny

re-
C'est de mémoire : alors à vérifier dans le wiki (et sur le net)

Pages perso : feh, omegat, udisks, sa station de travail comme passerelle

Hors ligne

#17 08-10-2009 01:29:40

martinux_qc
Administrateur
Lieu : Montréal (Québec)
Distrib. : Sid
Noyau : Linux 4.7.0-1-amd64
(G)UI : XFCE 4.12
Inscription : 12-10-2008

Re : Install XBMC sur lenny

bjm a écrit :

En fait c'est ça qui me plait pas trop
" mélange stable et unstable à éviter "


Tout à fait d'accord avec toi. En ce qui me concerne, pour la branche stable je suggère fortement de se limiter aux dépôts Debian. Ensuite, on peut ajouter au besoin le dépôt debian-multimedia pour lenny ainsi que le dépôt lenny-backports. Point.

D'un autre côté, on est libre de faire ce que l'on veut. Ici, je montrais seulement que c'est possible d'aller chercher l'application désirée, XMBC, sans trop perturber lenny. Dans d'autres situations, cela n'aurait pas été possible. Maintenant, une fois que tu as l'information, comme je l'ai déjà dit c'est à toi de voir si tu tentes le coup ou non. Une personne qui voudra absolument cette version de XBMC tentera le coup, les autres s'abstiendront prudemment.

Martin


"L'éducation vise à former des citoyens pas trop tatas et non pas à envoyer le plus de tatas possible à l'université."
Pierre Foglia (Journaliste à la retraite à La Presse)
Note : au Québec, le mot tata a un sens péjoratif qui sert à désigner une personne un peu idiote ou insignifiante. D'où les expressions familières : Espèce de grand, de gros tata! Être, avoir l'air tata.

Hors ligne

#18 08-10-2009 01:50:38

martinux_qc
Administrateur
Lieu : Montréal (Québec)
Distrib. : Sid
Noyau : Linux 4.7.0-1-amd64
(G)UI : XFCE 4.12
Inscription : 12-10-2008

Re : Install XBMC sur lenny

phlinux a écrit

L'option que tu prends est différente : tu changes tout le sources.list, donc forcément c'est plus facile. Et c'est justement ce que je voulais éviter.
J'ai bien vu que la libc6 n'est pas upgradée : mais vu le nombre de nouveaux paquets, à terme ça sent le bronx (pour une Lenny tout du moins. D'ailleurs de mémoire dans le wiki c'est indiqué : mélange stable et unstable à éviter )


Salut

Je change en effet tout le sources.list, mais dans le fond cela ne fait pas une grande différence. L'important ici c'est l'ajout du dépôt debian-multimedia pour sid. En utilisant l'option -t on se retrouve momentanément dans la branche sid. C'est pourquoi il est important de ne pas faire d'upgrade à ce moment. Les paquets qui ont des dépendances non satisfaites dans ton message #7 se retrouvent bien dans le debian-multimedia sid. Normalement en installant le paquet XBMC, apt-get aurait du aller chercher les bonnes dépendances. Ce qui n'est pas le cas avec ta simulation Il faut regarder cela de plus près. Je vais tenter pour vérifier tout cela une simulation avec un sources.list purement lenny + debian-multimedia sid sans mettre une entrée "Package xbmc " dans le fichier preferences.

L'extrait du wiki que tu cites explique à la fin comment modifier le preferences pour suivre un paquet pris dans une autre branche. Ici, on voulait seulement simuler l'installation pour voir si elle était possible. Le suivre ou non ça c'est une autre question.

Avant de tenter la simulation, j'ai vérifié moi aussi les dépendances des paquets sur debian-multimedia avant de procéder et comme toi j'ai vu que la version de libc6 de lenny était ok. Il y a en effet beaucoup de paquets à mettre à jour ou installer mais ce sont des bibliothèques multimédia nécessaires (les dépendances) pour xbmc-bin.

Enfin, pour le mélange stable/unstable, je ne le conseille vraiment pas comme je l'ai indiqué dans le message ci-haut et comme le dit si bien le wiki. Mais, encore une fois, on est libre de faire ce que l'on veut et si une personne désire vraiment elle version elle sera peut-être prête à prendre le risque. Libre à elle.

Dernière modification par martinux_qc (08-10-2009 02:05:09)


"L'éducation vise à former des citoyens pas trop tatas et non pas à envoyer le plus de tatas possible à l'université."
Pierre Foglia (Journaliste à la retraite à La Presse)
Note : au Québec, le mot tata a un sens péjoratif qui sert à désigner une personne un peu idiote ou insignifiante. D'où les expressions familières : Espèce de grand, de gros tata! Être, avoir l'air tata.

Hors ligne

#19 08-10-2009 01:56:44

martinux_qc
Administrateur
Lieu : Montréal (Québec)
Distrib. : Sid
Noyau : Linux 4.7.0-1-amd64
(G)UI : XFCE 4.12
Inscription : 12-10-2008

Re : Install XBMC sur lenny

kinroux a écrit :

Est ce vraiment utile de préciser -t unstable puisque le paquet xbmc est présent seulement dans les dépots multimedia unstable ?
aptitude install xbmc ne donnerait pas le même résultat ?


Salut

Cela dépend de ton fichier preferences. Le fichier sources.list qui inclus toutes les branches pour la stable utilise un fichier preferences avec des priorités négatives pour les branches autres que lenny afin d'aller chercher volontairement les paquets qui s'y trouvent. Avec l'option -t je me trouve temporairement dans cette branche et je peux installer un paquet ainsi que les dépendances qui s'y trouvent. Une fois cela fait, je retourne tranquillement dans ma branche stable. C'est d'ailleurs ce qu'il faut. Avec lenny, je ne voudrait tout de même pas que des paquets pris dans sid (ou dans testing) puissent s'installer facilement comme ça.


"L'éducation vise à former des citoyens pas trop tatas et non pas à envoyer le plus de tatas possible à l'université."
Pierre Foglia (Journaliste à la retraite à La Presse)
Note : au Québec, le mot tata a un sens péjoratif qui sert à désigner une personne un peu idiote ou insignifiante. D'où les expressions familières : Espèce de grand, de gros tata! Être, avoir l'air tata.

Hors ligne

Pied de page des forums