Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 10-06-2017 15:55:41

patatino
Membre
Lieu : Val d'Oise
Distrib. : Debian Jessie 8 amd64
Noyau : 3.16-04
(G)UI : Lxde+Gnome
Inscription : 18-01-2014

Mise à jour noyau impossible[résolu]

Bonjour,

J'ai essayé de mettre à jour le kernel de ma debian jessie (noyau 3.16-04) vers un noyau plus récent (4.9-amd64), car le 3.16.04 gère en fait très mal le cpu et donne au démarrage un message d'erreur : "Firmware bug: CPU1 tried to use APIC500 (LVT offset0) for vector 0x400 but the register is already in use for vector 0xf9 on another CPU" (voir  https://bugs.debian.org/cgi-bin/bugrepo … 93;msg=4r). Je n'y suis pas arrivé malgré la mise en application du tuto de debian-facile (pas à jour d'aiileurs et pas très clair) et celui de Debian.fr. Que ce soit le "rt" ou le signé aucun ne démarre debian. Je signale que j'ai installé le driver Nvidia propriétaire. Mais impossible de mettre à jour.

Quelqu'un a-t-il une idée ,

Merci pour les réponses.

Dernière modification par patatino (22-06-2017 10:07:39)

Hors ligne

#2 10-06-2017 16:24:41

robert2a
Membre
Lieu : France
Distrib. : Stretch 9
Noyau : Linux 4.9.0-3 4.9.30-2
(G)UI : Mate
Inscription : 15-11-2014

Re : Mise à jour noyau impossible[résolu]

Bonjour
pas très clair , tu est en jessie amd64 , ton profil n'est pas a jour
pour avoir sur jessie le noyau des backports c'est cette commande (pour amd64 a modifier en fonction du type de machine 32 ou 64 )


apt-get install -t jessie-backports linux-image-amd64
 



si tu renvoie le resultat de la commande


uname -a
 


on pourra te donner la commande exacte

Hors ligne

#3 10-06-2017 16:28:06

chalu
Modératrice
Lieu : Anjou
Distrib. : Debian Jessie (saveur Handylinux 2.5) à jour
Noyau : Linux 3.16.0-4-amd64
(G)UI : XFCE - xfwm4
Inscription : 11-03-2016

Re : Mise à jour noyau impossible[résolu]

Bonjour,
Tu actives le dépôt Jessie-backports puis

apt-get update


apt-get -t jessie-backports linux-image-686-pae linux-headers-686-pae


Je t'ai mis la version 686-pae de ton profil mais je ne sais pas s'il est à jour pour la version car il ne l'est pas pour le système
J'ai ajouté linux-headers si tu utilises dkms pour le driver Nvidia. je ne sais pas si tu es obligé de passer à la version backports pour Nvidia, ça se pourrait ...
Si tu as le WiFi, il faudra peut être aussi mettre à jour le firmware.

Edit : devancée par robert2a, il va te guider pour Nvidia s'il y a besoin wink


Bien débuter sur Debian :
->Les cahiers du débutant + le wiki Découvrir les principales commandes Linux
-> Le projet DFlinux (DebianFacileLinux) pour débutants: ISOs (i386 et amd64) basées sur Debian stable avec des outils facilitants
-> Retours et avis sur DFLinux dans ce fil

Hors ligne

#4 10-06-2017 16:38:19

robert2a
Membre
Lieu : France
Distrib. : Stretch 9
Noyau : Linux 4.9.0-3 4.9.30-2
(G)UI : Mate
Inscription : 15-11-2014

Re : Mise à jour noyau impossible[résolu]

son profil indique wheezy je suis inquiet  tongue


    Distrib. : HandyLinux-1.0-wheezy
    Noyau : 3.2.04.686.pae
 


le retour de la commande "uname -a" va dissiper les doutes smile

pour nvidia il faut ajouter les headers comme indiqué par chalu au dessus
sinon il faut le type de carte graphique pour savoir quel driver utilisé et si il faut le prendre sur les backports

Hors ligne

#5 10-06-2017 23:34:22

patatino
Membre
Lieu : Val d'Oise
Distrib. : Debian Jessie 8 amd64
Noyau : 3.16-04
(G)UI : Lxde+Gnome
Inscription : 18-01-2014

Re : Mise à jour noyau impossible[résolu]

Merci pour vos réponses et mille excuses en ce qui concerne mon profil. Ce dernier a été mis à jour. J'ai laissé tomber Handylinux et me suis fait une Debian jessie 8 amd64 "perso" avec l'installation minimum par le net + lxde (le gestionnaire le plus simple et le plus convivial) et les paquets dont j'ai besoin. Je précise que je ne suis pas un "débutant linux" et que toutes les manips indiquées ont été faites (d'ailleurs au passage le métapackage en "rt" est mieux que le simple amd64).. Le driver Nvidia a été correctement installé (avec les headers) et correspond bien à la version de ma carte (Geforce 8400 GS).Je me suis d'ailleurs servi du "Nvidia config".

J'ai essayé plusieurs noyaux (4.8, 4.9) pour ne plus avoir ce message au démarrage comme indiqué dans mon post et sur le lien donné dans ce dernier, mais aucun d'entre eux, bien qu'installés et figurant dans le menu Grub,.n'a voulu démarrer. J''ai installér le driver Nvidia sous le noyau 3.16-04 avant de mettre à jour le kernel, mais l'écran reste noir........

Hors ligne

#6 11-06-2017 00:30:42

robert2a
Membre
Lieu : France
Distrib. : Stretch 9
Noyau : Linux 4.9.0-3 4.9.30-2
(G)UI : Mate
Inscription : 15-11-2014

Re : Mise à jour noyau impossible[résolu]

ta carte est ancienne , jessie doit gérer tout ça convenablement , a la rigueur gnome + gdm3 peu poser problème
meme en libre avec nouveau ça devrait bien tourner
par contre la 8400 je connais pas , les 8800GT tournent très bien avec jessie .

pour le driver nvidia il faut le compiler sur le 4.9 , le noyau est pas mit a jour mais remplacé (tu dois avoir un démarrage possible en 3.16 et 4.9 (le 3.16 doit etre dans option du menu grub )
pour compiler le driver nvidia (ça va mettre a jour le noyau et les outils de compilation)

apt-get install -t jessie-backports linux-image-amd64 linux-image-headers
 



pour le driver voir wiki  =>  https://debian-facile.org/doc:materiel: … ia:accueil

installer nvidia-detect


apt-get install nvidia-detect
 



lancer nvidia-detect


nvidia-detect
 



le driver graphique de jessie ( a faire sur le noyau que tu veut utiliser  , donc si tu démarre sur le 3.16 faire l installation ci dessous )


apt-get install nvidia-kernel-dkms nvidia-settings nvidia-driver linux-headers-$(uname -r)
 



le driver graphique des backports  ( a faire sur le noyau que tu veut utiliser  , donc si tu démarre sur le 4.9.0-3 faire l installation ci dessous )


apt-get install -t jessie-backports nvidia-kernel-dkms nvidia-settings nvidia-driver linux-headers-$(uname -r)
 



avec cette carte jessie sans backports devrait fonctionner ,  nvidia-driver te dira quel driver tu peut utiliser

nota : il faut bien nettoyer les installations précédentes avant de faire ceci
un sources.list correct pour le nonfree  et un apt-get update et jessie a jour

la version actuelle de jessie  =>  https://packages.debian.org/fr/jessie/x … deo-nvidia     (prend en charge la serie 8xxx )

la version des backports de jessie  =>  https://packages.debian.org/fr/jessie-b … deo-nvidia
a vérifier si elle prend des vieilles cartes comme la tienne
ça commence a fermi , donc je dirai que non , le driver ne va pas fonctionner  (utiliser le 340 )

Dernière modification par robert2a (11-06-2017 00:49:16)

Hors ligne

#7 11-06-2017 07:43:25

chalu
Modératrice
Lieu : Anjou
Distrib. : Debian Jessie (saveur Handylinux 2.5) à jour
Noyau : Linux 3.16.0-4-amd64
(G)UI : XFCE - xfwm4
Inscription : 11-03-2016

Re : Mise à jour noyau impossible[résolu]

patatino a écrit :

d'ailleurs au passage le métapackage en "rt" est mieux que le simple amd64)


C'est quoi ce métapackage ?

Edit trouvé ici https://packages.debian.org/jessie-back … 3-rt-amd64
et des explications ici https://fr.m.wikipedia.org/wiki/Linux-rt


Bien débuter sur Debian :
->Les cahiers du débutant + le wiki Découvrir les principales commandes Linux
-> Le projet DFlinux (DebianFacileLinux) pour débutants: ISOs (i386 et amd64) basées sur Debian stable avec des outils facilitants
-> Retours et avis sur DFLinux dans ce fil

Hors ligne

#8 11-06-2017 18:28:35

patatino
Membre
Lieu : Val d'Oise
Distrib. : Debian Jessie 8 amd64
Noyau : 3.16-04
(G)UI : Lxde+Gnome
Inscription : 18-01-2014

Re : Mise à jour noyau impossible[résolu]

Merci pour les réponses. Je n'ai pas mis à jour le driver nvidia sous le noyau 4.9 et vais donc essaiyer les manips indiquées.
Quelqu'un a-t-il fait cette mise à jour sans problème ? D'après ce que j'ai lu sur le net, le noyau 3.16 est ancien et semble gèrer très mal les cpu à plusieurs core. Cela semble résolu à partir du 4.9.1. C'est d'ailleurs bizarre car j'utilise aussi la distribution Slitaz dans laquelle ce problème n'existe pas..

En ce qui concerne le metapackage "rt" voici ce qu'indique wikipedia. : https://fr.wikipedia.org/wiki/Linux-rt.

Je vous tiens au courant. Juste une petite question : comment je fais pour mettre à jour la compilation du driver nvidia si je n'ai pas accès au noyau 4.9 ?

Dernière modification par patatino (11-06-2017 18:49:32)

Hors ligne

#9 11-06-2017 19:00:50

robert2a
Membre
Lieu : France
Distrib. : Stretch 9
Noyau : Linux 4.9.0-3 4.9.30-2
(G)UI : Mate
Inscription : 15-11-2014

Re : Mise à jour noyau impossible[résolu]

@patatino

il faut que tu enlève toutes traces du driver nvdia


apt-get remove --purge nvidia*
 


il faut que tu supprime tous les xorg.conf


rm /etc/X11/xorg.conf
 


bien purger


apt-get autoremove --purge
 


un reboot de la machine , tu dois etre avec nouveau et le bureau doit fonctionner avec les 2 noyau

je t en parle sur mon post , avec ta machine il faut jessie et le driver nonfree nvidia  de jessie  (version 340 ) . (celui des backports est trop récent , ne prend surement plus ta carte en charge )
ta carte est ancienne GT 8400

le noyau 3.16 de jessie suffit , inutile de mettre celui des backports

après pour gnome (+ gdm3 ) je me souvient plus si la GT8400 suffi comme ressources pour gérer convenablement le noyau .

Dernière modification par robert2a (11-06-2017 19:06:53)

Hors ligne

#10 11-06-2017 19:37:26

patatino
Membre
Lieu : Val d'Oise
Distrib. : Debian Jessie 8 amd64
Noyau : 3.16-04
(G)UI : Lxde+Gnome
Inscription : 18-01-2014

Re : Mise à jour noyau impossible[résolu]

Merci ! Opération réussie. Je suis bien en 4.9 et ai accès au bureau. Je n'ai donc plus le driver nvidia et fonctionne sur "nouveau". En fait sur le net il est indiqué que ce "driver nouveau" ne gère pas bien la 3D par rapport au driver Nvidia. Est-ce vrai ?
Nvidia-detect m'indique que le pilote est le 304 et non le 340. Faut-il que je recompile le nvidia 304 sous ce nouveau noyau ou que je laisse tel quel ?

Par contre j'ai toujours ce message d'erreur au démarrage. Le noyau 4.10 correctif de ce dernier ne semble pas disponible dans les dépôts Debian. Puis-je tenter de le prendre sur kernel.org où le dernier doit être en 4.11 ?

Euh, par curiosité je vois que tu es toujours sous Sid. Pour quelles raisons ?

Dernière modification par patatino (11-06-2017 19:48:29)

Hors ligne

#11 11-06-2017 19:48:31

robert2a
Membre
Lieu : France
Distrib. : Stretch 9
Noyau : Linux 4.9.0-3 4.9.30-2
(G)UI : Mate
Inscription : 15-11-2014

Re : Mise à jour noyau impossible[résolu]

Sur ce genre de carte un driver nonfree ne va pas t' apporter grand chose , moi j' utiliserai nouveau. (en plus avec un noyau très récent comme le 4.9 )
pour la version tu a peut etre raison , nvidia-detect donne la bonne version en général a utiliser smile

nota : pour Sid j' attend la prochaine debian Buster en autre pour du matériel trés récent comme Ryzen (Amd)
encore 7 jours et je mettrai mon profil a jour  wink

Dernière modification par robert2a (11-06-2017 19:52:04)

Hors ligne

#12 12-06-2017 15:42:13

patatino
Membre
Lieu : Val d'Oise
Distrib. : Debian Jessie 8 amd64
Noyau : 3.16-04
(G)UI : Lxde+Gnome
Inscription : 18-01-2014

Re : Mise à jour noyau impossible[résolu]

Merci encore pour ce coup de main. En fait c'est bien le driver nvidia qui bloquait la mise à jour du noyau. As-tu déjà essayé de mettre à jour un noyau provenant de kernel.org et non des dépôts Debian et si oui comment as-tu fait (juste pour ma connaissance personnelle) ? Le dernier est le 4.11-4.

Et puisque tu as l'air de connaître plein de trucs, as-tu des infos sur mon message d'erreur au démarrage : "Firmware bug: CPU1 tried to use APIC500 (LVT offset0) for vector 0x400 but the register is already in use for vector 0xf9 on another CPU".?  Si j'ai bien compris cela vient de la version du noyau. C'est bizarre car j'utilise la même configuration sur Slitaz et je n'ai pas ce type de problème (le noyau de Slitaz (rolling 64) est le 3.2-71.

Dernière modification par patatino (12-06-2017 15:50:10)

Hors ligne

Pied de page des forums