Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 27-06-2017 13:03:45

d33p
Adhérent(e)
Lieu : Lorraine
Distrib. : Debian testing buster 64bits
Noyau : En fonction des updates testing buster
(G)UI : En fonction des updates testing buster
Inscription : 01-12-2015

[RESOLU] apt-get install flashplugin-nonfree sous Stretch - disparu?

Hello,

Soit mon sources.list n'est pas correct, soit ce package a disparu?

# stretch-base
deb http://deb.debian.org/debian/ stretch main contrib non-free

# stretch-securite
deb http://security.debian.org/ stretch/updates main contrib non-free

# stretch-updates, previously known as 'volatile'
deb http://deb.debian.org/debian/ stretch-updates main contrib non-free
 



sudo apt-get install flashplugin-nonfree



Reading package lists... Done
Building dependency tree      
Reading state information... Done
Package flashplugin-nonfree is not available, but is referred to by another package.
This may mean that the package is missing, has been obsoleted, or
is only available from another source

E: Package 'flashplugin-nonfree' has no installation candidate
 



flash c'est bel & bien fini?

Dernière modification par d33p (27-06-2017 13:51:43)


science sans conscience n'est que ruine de l'âme...

Hors ligne

#2 27-06-2017 13:14:11

otyugh
Membre
Lieu : Quimperlé/Arzano
Distrib. : Debian Stable
Inscription : 20-09-2016

Re : [RESOLU] apt-get install flashplugin-nonfree sous Stretch - disparu?

YESSS ! smile
C'était en effet écrit dans la release note du dernier DFLinux stretch.

Mais on peut toujours l'installer à la main...

Agenda du libre : se faire dépanner/dépanner IRL ! Le libre n'est pas qu'un phénomène internet.
Framapad sur les balados : Emissions audio pro/amateur, votre radio sur-mesure !

En ligne

#3 27-06-2017 13:49:45

d33p
Adhérent(e)
Lieu : Lorraine
Distrib. : Debian testing buster 64bits
Noyau : En fonction des updates testing buster
(G)UI : En fonction des updates testing buster
Inscription : 01-12-2015

Re : [RESOLU] apt-get install flashplugin-nonfree sous Stretch - disparu?

merci pour la confirmation otyugh.

les tutos que j'ai trouvé preconisent de copier "libflashplayer.so" dans "/usr/lib/flashplugin-nonfree" en general...
comme il n'existe plus...
j'ai fait une legere variante et ça a fonctionné...
au lieu de suivre ceci à la lettre:
https://wiki.debian.org/FlashPlayer

As root, extract the tar.gz package and copy libflashplayer.so to /usr/lib/flashplugin-nonfree


j'ai plutot copié "libflashplayer.so" ici:

sudo cp /home/d33p/Downloads/flash/libflashplayer.so /usr/lib/mozilla/plugins/


+

Copy the Flash Player Local Settings configurations files to the /usr directory.  At the prompt type:
        + sudo cp -r usr/* /usr


(que l'on retrouve dans le readme.txt de l'archive flash)
et cela fonctionne impec.

en esperant que ça aide...

d33p

Dernière modification par d33p (27-06-2017 13:50:49)


science sans conscience n'est que ruine de l'âme...

Hors ligne

#4 27-06-2017 13:57:06

nIQnutn
Modérateur
Lieu : Lyon
Distrib. : Stretch
Noyau : Linux 4.9.0-3-amd64
(G)UI : Gnome
Inscription : 16-03-2012
Site Web

Re : [RESOLU] apt-get install flashplugin-nonfree sous Stretch - disparu?

dans la doc  https://debian-facile.org/doc:media:fla … in-nonfree (pas très à jour), il y avait un petit lien vers https://blog.niqnutn.com/index.php?arti … er-23-beta où tout est expliqué.

Hors ligne

#5 27-06-2017 13:58:37

chalu
Modératrice
Lieu : Anjou
Distrib. : Debian Stretch
Noyau : Linux 4.9.0-3-amd64
(G)UI : Mate 1.16
Inscription : 11-03-2016

Re : [RESOLU] apt-get install flashplugin-nonfree sous Stretch - disparu?

Salut smile
J'ai vu l'explication pour installer flash pour Firefox sur DFlinux version strectch dans la documentation dédiée

Hors ligne

#6 27-06-2017 16:30:38

d33p
Adhérent(e)
Lieu : Lorraine
Distrib. : Debian testing buster 64bits
Noyau : En fonction des updates testing buster
(G)UI : En fonction des updates testing buster
Inscription : 01-12-2015

Re : [RESOLU] apt-get install flashplugin-nonfree sous Stretch - disparu?

Hello,
ok genial, je n'avais pas vu ces liens. merci.
pour une fois que je pensais avoir trouvé un truc cool pour aider tongue

et ceci:
https://dflinux.frama.io/documentation/
ça a un rapport avec Debian Facile?

Dernière modification par d33p (27-06-2017 16:31:11)


science sans conscience n'est que ruine de l'âme...

Hors ligne

#7 27-06-2017 16:35:26

chalu
Modératrice
Lieu : Anjou
Distrib. : Debian Stretch
Noyau : Linux 4.9.0-3-amd64
(G)UI : Mate 1.16
Inscription : 11-03-2016

Re : [RESOLU] apt-get install flashplugin-nonfree sous Stretch - disparu?

C'est la doc pour utiliser DFlinux projet soutenu par Debian-Facile comme d'autres projets que l'on retrouve sur le forum smile

Hors ligne

#8 27-06-2017 16:43:07

d33p
Adhérent(e)
Lieu : Lorraine
Distrib. : Debian testing buster 64bits
Noyau : En fonction des updates testing buster
(G)UI : En fonction des updates testing buster
Inscription : 01-12-2015

Re : [RESOLU] apt-get install flashplugin-nonfree sous Stretch - disparu?

je n'ai pas encore cliqué sur chaque lien du forum .... ooooh malheur à moi tongue
mais ça m'a l'air bien fourni, c'est cool.

encore merci pour vos participations.

d33p

science sans conscience n'est que ruine de l'âme...

Hors ligne

#9 27-06-2017 16:58:36

Coconuts
Membre
Lieu : Ici dans un Rucher d'abeilles
Distrib. : kissOs-Stretch /(Trueos-stable)
Noyau : FreeBSD 12.0-CURRENT
(G)UI : FluxBox / Lumina-desktop 1.3.0
Inscription : 29-06-2014

Re : [RESOLU] apt-get install flashplugin-nonfree sous Stretch - disparu?

d33p a écrit :

mais ça m'a l'air bien fourni, c'est cool.


Salut d33p c'est cool c'est comme KissOs wink  tongue
1498575294.png

Dernière modification par Coconuts (27-06-2017 17:21:09)

Hors ligne

#10 28-06-2017 09:26:47

d33p
Adhérent(e)
Lieu : Lorraine
Distrib. : Debian testing buster 64bits
Noyau : En fonction des updates testing buster
(G)UI : En fonction des updates testing buster
Inscription : 01-12-2015

Re : [RESOLU] apt-get install flashplugin-nonfree sous Stretch - disparu?

jamendo.... je ne connaissais pas, j'vais zieuter ceci tongue

science sans conscience n'est que ruine de l'âme...

Hors ligne

#11 01-07-2017 02:21:59

Tristan07
Membre
Distrib. : Debian 9, Stretch
Noyau : Linux 4.9.0-4-amd64
(G)UI : Gnome / Cinnamon
Inscription : 21-05-2016
Site Web

Re : [RESOLU] apt-get install flashplugin-nonfree sous Stretch - disparu?

Bonjour,

J'ai installé Flashplayer-firefox et chromium depuis le dépôt multimedia. Je voulais l'éviter mais Deezer le nécessite. (Compte premium depuis > Nuvola Player)
Merci pour l'astuce en tous cas ... peut-être préférable au dépôt multimedia ?
bonne soirée

Hors ligne

#12 01-07-2017 08:03:27

deuchdeb
Moderato ma non troppo
Lieu : Pays de Cocagne
Distrib. : Strtch 9 + backports
Noyau : Noyau stable
(G)UI : KDE 5.8 - Gnome 3.22
Inscription : 13-01-2010

Re : [RESOLU] apt-get install flashplugin-nonfree sous Stretch - disparu?

Hors ligne

#13 01-07-2017 08:45:00

chalu
Modératrice
Lieu : Anjou
Distrib. : Debian Stretch
Noyau : Linux 4.9.0-3-amd64
(G)UI : Mate 1.16
Inscription : 11-03-2016

Re : [RESOLU] apt-get install flashplugin-nonfree sous Stretch - disparu?

D'après différents fils, le dépôt multimédia est à éviter quand c'est possible et là c'est possible smile

Hors ligne

#14 01-07-2017 09:33:01

deuchdeb
Moderato ma non troppo
Lieu : Pays de Cocagne
Distrib. : Strtch 9 + backports
Noyau : Noyau stable
(G)UI : KDE 5.8 - Gnome 3.22
Inscription : 13-01-2010

Re : [RESOLU] apt-get install flashplugin-nonfree sous Stretch - disparu?

Oui je sais et c'est pour ça que dans le tuto je crée un fichier préférences pour que les dépôts deb-multimedia aient une priorité inférieure au dépôts officiels Debians.

De plus pour les mises à jour elles sont automatiques et je pense que c'est mieux car on est sûre qu'elles seront faites.

De toutes façon les méthodes manuelles vont être ajoutées et alors chacun aura le choix. peace_flag.gif

Hors ligne

#15 01-07-2017 10:20:43

chalu
Modératrice
Lieu : Anjou
Distrib. : Debian Stretch
Noyau : Linux 4.9.0-3-amd64
(G)UI : Mate 1.16
Inscription : 11-03-2016

Re : [RESOLU] apt-get install flashplugin-nonfree sous Stretch - disparu?

Ah oui je n'ai regardé que le premier lien et pas vu le deuxième avec ce dépôt mais avec le fichier de préférences ça doit aller wink
Je pense que ceux qui ont eu des soucis avec le dépôt n'en avaient pas fait sans doute ?

Hors ligne

#16 02-07-2017 23:07:09

Tristan07
Membre
Distrib. : Debian 9, Stretch
Noyau : Linux 4.9.0-4-amd64
(G)UI : Gnome / Cinnamon
Inscription : 21-05-2016
Site Web

Re : [RESOLU] apt-get install flashplugin-nonfree sous Stretch - disparu?

chalu a écrit :

Ah oui je n'ai regardé que le premier lien et pas vu le deuxième avec ce dépôt mais avec le fichier de préférences ça doit aller wink
Je pense que ceux qui ont eu des soucis avec le dépôt n'en avaient pas fait sans doute ?



Bonsoir,

Si je peux partager mon cas de figure :
J'ai suivi dans un premier temps la doc et paramétré les préférences du dépôt multimedia. Mais alors, apt ne trouve pas flash où d'autres logiciels souhaités. Par synaptic non plus bien sur.
Si après l’installation des logiciels souhaités je réitère les préférences du dépôt, dois-je craindre une absence de mis à jour éventuellement conséquentes pour les plugins Flash par exemple ? Ou d'autres logiciels issues de ce même dépôt ?
Merci

Dernière modification par Tristan07 (02-07-2017 23:08:40)

Hors ligne

#17 03-07-2017 09:13:29

chalu
Modératrice
Lieu : Anjou
Distrib. : Debian Stretch
Noyau : Linux 4.9.0-3-amd64
(G)UI : Mate 1.16
Inscription : 11-03-2016

Re : [RESOLU] apt-get install flashplugin-nonfree sous Stretch - disparu?

Dans ce cas, il faut spécifier le dépôt pour l'installation du paquet comme on le fait pour les backports.

apt-get -t nom-du-dépôt install nom-du-paquet


Tu as bien fait un apt-get update pour mettre à jour la liste des paquets avant d'installer ?

Hors ligne

#18 04-07-2017 12:28:17

Tristan07
Membre
Distrib. : Debian 9, Stretch
Noyau : Linux 4.9.0-4-amd64
(G)UI : Gnome / Cinnamon
Inscription : 21-05-2016
Site Web

Re : [RESOLU] apt-get install flashplugin-nonfree sous Stretch - disparu?

chalu a écrit :

Dans ce cas, il faut spécifier le dépôt pour l'installation du paquet comme on le fait pour les backports.

apt-get -t nom-du-dépôt install nom-du-paquet


Tu as bien fait un apt-get update pour mettre à jour la liste des paquets avant d'installer ?



Oui, merci chalu, l'update est faite après chaque mise en place de nouveau dépôt ou avant des MAJ.
Pour le moment tout ceci est en test, aucune urgence.
Merci pour les précisions ...

Dernière modification par Tristan07 (04-07-2017 12:28:50)

Hors ligne

#19 11-07-2017 02:23:48

Tristan07
Membre
Distrib. : Debian 9, Stretch
Noyau : Linux 4.9.0-4-amd64
(G)UI : Gnome / Cinnamon
Inscription : 21-05-2016
Site Web

Re : [RESOLU] apt-get install flashplugin-nonfree sous Stretch - disparu?

Bonsoir,

Un petit Retour :
Installation en dur sur portable de Debian 9, SANS installation du dépôt multimedia. J'ai installé flash à la main pour firefox et pour le moment cela semble fonctionner et n'empêche pas non plus d'écouter Deezer via Nuvola Player
https://tiliado.github.io/nuvolaplayer/ … ebian.html
N'ayant pas de lecteur dvd sur celui-ci je ne sais si je pourrai m'en passer sur le Bureau lorsque je migrerai (je l’espéré) ce dernier au retour des vacances. (Libdvdcss2 essentiellement)
Sauf erreur de ma part, j'ai donc des sources neuves et relativement clean ... pour le moment tux.png m'évitant une  crash.gif avec les erreurs GPG key malgré l'installation de debian-archive-keyring ...
Mais c'est un autre sujet (bien débattu ici semble t-il ...)

deb http://deb.debian.org/debian/ stretch main contrib non-free
deb-src http://deb.debian.org/debian/ stretch main contrib non-free


deb http://security.debian.org/debian-security stretch/updates main contrib non-free
deb-src http://security.debian.org/debian-security stretch/updates main contrib non-free


# stretch-updates, previously known as 'volatile'
deb http://deb.debian.org/debian/ stretch-updates main contrib non-free
deb-src http://deb.debian.org/debian/ stretch-updates main contrib non-free



Merci pour vos solutions cool

Dernière modification par Tristan07 (11-07-2017 02:26:28)

Hors ligne

Pied de page des forums