Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 01-07-2017 15:32:50

Mercredi
Membre
Distrib. : Testing
Noyau : 4.13
(G)UI : Gnome
Inscription : 25-09-2015

[Abandonné] Apt en erreur cause erreur fatale python

Bonjour,

Un petit souci dont je n'arrive pas à me dépatouiller seule :

apt upgrade


Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances      
Lecture des informations d'état... Fait
Calcul de la mise à jour... Fait
Les paquets suivants ont été installés automatiquement et ne sont plus nécessaires :
  docutils-common python-babel-localedata python3-alabaster python3-babel python3-docutils python3-imagesize python3-jinja2 python3-pygments python3-roman python3-tz
Veuillez utiliser « apt autoremove » pour les supprimer.
Les paquets suivants seront mis à jour :
  python3-sip
1 mis à jour, 0 nouvellement installés, 0 à enlever et 0 non mis à jour.
2 partiellement installés ou enlevés.
Il est nécessaire de prendre 0 o/88,7 ko dans les archives.
Après cette opération, 237 ko d'espace disque supplémentaires seront utilisés.
Souhaitez-vous continuer ? [O/n]
Récupération des rapports de bogue… Fait
Analyse des informations Trouvé/Corrigé… Fait
Could not find platform independent libraries <prefix>
Consider setting $PYTHONHOME to <prefix>[:<exec_prefix>]
Fatal Python error: Py_Initialize: Unable to get the locale encoding
LookupError: no codec search functions registered: can't find encoding

Current thread 0x00007fa1403d1700 (most recent call first):
Aborted
E: Le sous-processus /usr/bin/apt-listchanges --apt || test $? -lt 10 a renvoyé un code d'erreur (1)
E: Failure running script /usr/bin/apt-listchanges --apt || test $? -lt 10



Je pense que la cause de ce bazar vient d'un ménage un peu trop sévère fait dans les paquets hier : à la suite j'ai eu un premier souci de maj sur le paquet python3-cairo, que j'ai forcé avec un

dpkg -i --force-overwrite /var/cache/apt/archives/python3-cairo_1.10.0+dfsg-5+b2_amd64.deb


Je reconnais que ce n'était pas une bonne idée hmm mais on apprend de ses erreurs ...

J'ai tenté les trucs habituels : apt-get, dist-upgrade, full-upgrade, -f install sans succès. Pas mieux avec Synaptic.

Les cas que j'ai trouvé sur le web ne sont pas suffisamment similaires pour apporter une solution.

Désinstaller ou installer le moindre paquet est impossible, ça semble bloquer à cause de python3-sip (qui bloque à cause de python3-cairo et de ma boulette en --force), pas pu essayer avec aptitude car pas installé.

Une idée à laquelle je n'ai pas pensé pour réparer ?

Mon /etc/apt/apt.conf.d/20listchanges si ça peut aider :

DPkg::Pre-Install-Pkgs { "/usr/bin/apt-listchanges --apt || test $? -lt 10"; };
DPkg::Tools::Options::/usr/bin/apt-listchanges::Version "2";
DPkg::Tools::Options::/usr/bin/apt-listchanges::InfoFD "20";

Dernière modification par Mercredi (02-07-2017 16:19:22)


De toutes les forces de l'univers, la plus dure à surmonter, c'est la force de l'habitude. T.Pratchett - Trois Soeurcières.

Hors ligne

#2 01-07-2017 16:46:35

Mercredi
Membre
Distrib. : Testing
Noyau : 4.13
(G)UI : Gnome
Inscription : 25-09-2015

Re : [Abandonné] Apt en erreur cause erreur fatale python

Juste pour confirmer que ce sont mes 2 paquets python3-sip et python3-cairo qui mettent la zone :

dpkg --configure -a


dpkg: erreur de traitement du paquet python3-sip (--configure) :
 le paquet est dans un état vraiment incohérent; vous devriez
 le réinstaller avant de tenter de le configurer.
Paramétrage de python3-cairo (1.10.0+dfsg-5+b3) ...
Could not find platform independent libraries <prefix>
Consider setting $PYTHONHOME to <prefix>[:<exec_prefix>]
Fatal Python error: Py_Initialize: Unable to get the locale encoding
LookupError: no codec search functions registered: can't find encoding

Current thread 0x00007f132c7ff700 (most recent call first):
Aborted
dpkg: erreur de traitement du paquet python3-cairo (--configure) :
 le sous-processus script post-installation installé a retourné une erreur de sortie d'état 134
Des erreurs ont été rencontrées pendant l'exécution :
 python3-sip
 python3-cairo
 



Apt et consorts étant inutilisables pour installer, réinstaller ou désinstaller quoi que ce soit sur mon système, est-ce qu'un chroot depuis un live le permettrait ?


De toutes les forces de l'univers, la plus dure à surmonter, c'est la force de l'habitude. T.Pratchett - Trois Soeurcières.

Hors ligne

#3 01-07-2017 16:48:05

robert2a
Membre
Lieu : France
Distrib. : Stretch 9
Noyau : Linux 4.9.0-3 4.9.30-2
(G)UI : Mate
Inscription : 15-11-2014

Re : [Abandonné] Apt en erreur cause erreur fatale python

Bonjour
alors le meme souci que toi mais sans forcer je suis passée de buster a buster + stretch (sources.list ) , abandon de la mise a jour (hier ) et ce matin tout est passé normalement.
faut pas forcer l installation  roll
je cherche sur quelle machine j'ai le log de l erreur

python3-sip tu  en a besoin , moi il est pas installé ?


dpkg: erreur de traitement du paquet python3-sip (--configure) :
 



idem pour python-cairo (soit revenir a la version de stable soit le désinstaller )

j'ai eu exactement la meme chose que toi mais je suis vite revenu en arrière

et ce matin tout correct


2017-07-01 06:32:27 startup archives unpack
2017-07-01 06:32:27 upgrade rsyslog:amd64 8.27.0-3 8.27.0-4
2017-07-01 06:32:27 status half-configured rsyslog:amd64 8.27.0-3
2017-07-01 06:32:27 status unpacked rsyslog:amd64 8.27.0-3
2017-07-01 06:32:27 status half-installed rsyslog:amd64 8.27.0-3
2017-07-01 06:32:27 status triggers-pending systemd:amd64 233-9
2017-07-01 06:32:27 status triggers-pending man-db:amd64 2.7.6.1-2
2017-07-01 06:32:28 status half-installed rsyslog:amd64 8.27.0-3
2017-07-01 06:32:28 status unpacked rsyslog:amd64 8.27.0-4
2017-07-01 06:32:28 status unpacked rsyslog:amd64 8.27.0-4
2017-07-01 06:32:28 upgrade wget:amd64 1.19.1-3 1.19.1-4
2017-07-01 06:32:28 status half-configured wget:amd64 1.19.1-3
2017-07-01 06:32:28 status unpacked wget:amd64 1.19.1-3
2017-07-01 06:32:28 status half-installed wget:amd64 1.19.1-3
2017-07-01 06:32:28 status half-installed wget:amd64 1.19.1-3
2017-07-01 06:32:29 status unpacked wget:amd64 1.19.1-4
2017-07-01 06:32:29 status unpacked wget:amd64 1.19.1-4
2017-07-01 06:32:29 upgrade whiptail:amd64 0.52.20-1 0.52.20-1+b1
2017-07-01 06:32:29 status half-configured whiptail:amd64 0.52.20-1
2017-07-01 06:32:29 status unpacked whiptail:amd64 0.52.20-1
2017-07-01 06:32:29 status half-installed whiptail:amd64 0.52.20-1
2017-07-01 06:32:29 status half-installed whiptail:amd64 0.52.20-1
2017-07-01 06:32:29 status unpacked whiptail:amd64 0.52.20-1+b1
2017-07-01 06:32:29 status unpacked whiptail:amd64 0.52.20-1+b1
2017-07-01 06:32:29 startup packages configure
2017-07-01 06:32:29 configure whiptail:amd64 0.52.20-1+b1 <aucune>
2017-07-01 06:32:29 status unpacked whiptail:amd64 0.52.20-1+b1
2017-07-01 06:32:30 status half-configured whiptail:amd64 0.52.20-1+b1
2017-07-01 06:32:30 status installed whiptail:amd64 0.52.20-1+b1
2017-07-01 06:32:30 trigproc systemd:amd64 233-9 <aucune>
2017-07-01 06:32:30 status half-configured systemd:amd64 233-9
2017-07-01 06:32:30 status installed systemd:amd64 233-9
2017-07-01 06:32:30 configure wget:amd64 1.19.1-4 <aucune>
2017-07-01 06:32:30 status unpacked wget:amd64 1.19.1-4
2017-07-01 06:32:30 status unpacked wget:amd64 1.19.1-4
2017-07-01 06:32:30 status half-configured wget:amd64 1.19.1-4
2017-07-01 06:32:30 status installed wget:amd64 1.19.1-4
2017-07-01 06:32:30 trigproc man-db:amd64 2.7.6.1-2 <aucune>
2017-07-01 06:32:30 status half-configured man-db:amd64 2.7.6.1-2
2017-07-01 06:32:31 status installed man-db:amd64 2.7.6.1-2
2017-07-01 06:32:31 configure rsyslog:amd64 8.27.0-4 <aucune>
2017-07-01 06:32:31 status unpacked rsyslog:amd64 8.27.0-4
2017-07-01 06:32:31 status unpacked rsyslog:amd64 8.27.0-4
2017-07-01 06:32:31 status unpacked rsyslog:amd64 8.27.0-4
2017-07-01 06:32:31 status unpacked rsyslog:amd64 8.27.0-4
2017-07-01 06:32:31 status unpacked rsyslog:amd64 8.27.0-4
2017-07-01 06:32:31 status unpacked rsyslog:amd64 8.27.0-4
2017-07-01 06:32:31 status half-configured rsyslog:amd64 8.27.0-4
2017-07-01 06:32:31 status installed rsyslog:amd64 8.27.0-4
2017-07-01 06:33:06 startup archives unpack
2017-07-01 06:33:06 upgrade libselinux1:amd64 2.6-3+b1 2.6-3+b2
2017-07-01 06:33:06 status triggers-pending libc-bin:amd64 2.24-12
2017-07-01 06:33:06 status half-configured libselinux1:amd64 2.6-3+b1
2017-07-01 06:33:07 status unpacked libselinux1:amd64 2.6-3+b1
2017-07-01 06:33:07 status half-installed libselinux1:amd64 2.6-3+b1
2017-07-01 06:33:07 status half-installed libselinux1:amd64 2.6-3+b1
2017-07-01 06:33:07 status unpacked libselinux1:amd64 2.6-3+b2
2017-07-01 06:33:07 status unpacked libselinux1:amd64 2.6-3+b2
2017-07-01 06:33:07 startup packages configure
2017-07-01 06:33:07 configure libselinux1:amd64 2.6-3+b2 <aucune>
2017-07-01 06:33:07 status unpacked libselinux1:amd64 2.6-3+b2
2017-07-01 06:33:07 status half-configured libselinux1:amd64 2.6-3+b2
2017-07-01 06:33:07 status installed libselinux1:amd64 2.6-3+b2
2017-07-01 06:33:07 startup archives unpack
2017-07-01 06:33:08 upgrade libnewt0.52:amd64 0.52.20-1 0.52.20-1+b1
2017-07-01 06:33:08 status half-configured libnewt0.52:amd64 0.52.20-1
2017-07-01 06:33:08 status unpacked libnewt0.52:amd64 0.52.20-1
2017-07-01 06:33:08 status half-installed libnewt0.52:amd64 0.52.20-1
2017-07-01 06:33:08 status half-installed libnewt0.52:amd64 0.52.20-1
2017-07-01 06:33:08 status unpacked libnewt0.52:amd64 0.52.20-1+b1
2017-07-01 06:33:08 status unpacked libnewt0.52:amd64 0.52.20-1+b1
2017-07-01 06:33:08 upgrade nano:amd64 2.7.4-1 2.8.5-1
2017-07-01 06:33:08 status half-configured nano:amd64 2.7.4-1
2017-07-01 06:33:09 status unpacked nano:amd64 2.7.4-1
2017-07-01 06:33:09 status half-installed nano:amd64 2.7.4-1
2017-07-01 06:33:09 status triggers-pending man-db:amd64 2.7.6.1-2
2017-07-01 06:33:09 status half-installed nano:amd64 2.7.4-1
2017-07-01 06:33:09 status unpacked nano:amd64 2.8.5-1
2017-07-01 06:33:09 status unpacked nano:amd64 2.8.5-1
2017-07-01 06:33:09 upgrade libxml2:amd64 2.9.4+dfsg1-2.2 2.9.4+dfsg1-2.2+b1
2017-07-01 06:33:09 status half-configured libxml2:amd64 2.9.4+dfsg1-2.2
2017-07-01 06:33:09 status unpacked libxml2:amd64 2.9.4+dfsg1-2.2
2017-07-01 06:33:09 status half-installed libxml2:amd64 2.9.4+dfsg1-2.2
2017-07-01 06:33:10 status half-installed libxml2:amd64 2.9.4+dfsg1-2.2
2017-07-01 06:33:10 status unpacked libxml2:amd64 2.9.4+dfsg1-2.2+b1
2017-07-01 06:33:10 status unpacked libxml2:amd64 2.9.4+dfsg1-2.2+b1
2017-07-01 06:33:10 startup packages configure
2017-07-01 06:33:10 configure libxml2:amd64 2.9.4+dfsg1-2.2+b1 <aucune>
2017-07-01 06:33:10 status unpacked libxml2:amd64 2.9.4+dfsg1-2.2+b1
2017-07-01 06:33:10 status half-configured libxml2:amd64 2.9.4+dfsg1-2.2+b1
2017-07-01 06:33:10 status installed libxml2:amd64 2.9.4+dfsg1-2.2+b1
2017-07-01 06:33:10 configure nano:amd64 2.8.5-1 <aucune>
2017-07-01 06:33:10 status unpacked nano:amd64 2.8.5-1
2017-07-01 06:33:10 status unpacked nano:amd64 2.8.5-1
2017-07-01 06:33:10 status half-configured nano:amd64 2.8.5-1
2017-07-01 06:33:10 status installed nano:amd64 2.8.5-1
2017-07-01 06:33:11 trigproc libc-bin:amd64 2.24-12 <aucune>
2017-07-01 06:33:11 status half-configured libc-bin:amd64 2.24-12
2017-07-01 06:33:11 status installed libc-bin:amd64 2.24-12
2017-07-01 06:33:11 trigproc man-db:amd64 2.7.6.1-2 <aucune>
2017-07-01 06:33:11 status half-configured man-db:amd64 2.7.6.1-2
2017-07-01 06:33:11 status installed man-db:amd64 2.7.6.1-2
2017-07-01 06:33:11 configure libnewt0.52:amd64 0.52.20-1+b1 <aucune>
2017-07-01 06:33:11 status triggers-pending libc-bin:amd64 2.24-12
2017-07-01 06:33:11 status unpacked libnewt0.52:amd64 0.52.20-1+b1
2017-07-01 06:33:11 status unpacked libnewt0.52:amd64 0.52.20-1+b1
2017-07-01 06:33:11 status half-configured libnewt0.52:amd64 0.52.20-1+b1
2017-07-01 06:33:12 status installed libnewt0.52:amd64 0.52.20-1+b1
2017-07-01 06:33:12 trigproc libc-bin:amd64 2.24-12 <aucune>
2017-07-01 06:33:12 status half-configured libc-bin:amd64 2.24-12
2017-07-01 06:33:12 status installed libc-bin:amd64 2.24-12
2017-07-01 06:33:46 startup archives unpack
2017-07-01 06:33:46 upgrade python3-apt:amd64 1.4.0~beta3 1.4.0~beta3+b1
2017-07-01 06:33:46 status half-configured python3-apt:amd64 1.4.0~beta3
2017-07-01 06:33:47 status unpacked python3-apt:amd64 1.4.0~beta3
2017-07-01 06:33:47 status half-installed python3-apt:amd64 1.4.0~beta3
2017-07-01 06:33:47 status half-installed python3-apt:amd64 1.4.0~beta3
2017-07-01 06:33:47 status unpacked python3-apt:amd64 1.4.0~beta3+b1
2017-07-01 06:33:47 status unpacked python3-apt:amd64 1.4.0~beta3+b1
2017-07-01 06:33:47 upgrade python-apt:amd64 1.4.0~beta3 1.4.0~beta3+b1
2017-07-01 06:33:47 status half-configured python-apt:amd64 1.4.0~beta3
2017-07-01 06:33:47 status unpacked python-apt:amd64 1.4.0~beta3
2017-07-01 06:33:47 status half-installed python-apt:amd64 1.4.0~beta3
2017-07-01 06:33:48 status half-installed python-apt:amd64 1.4.0~beta3
2017-07-01 06:33:48 status unpacked python-apt:amd64 1.4.0~beta3+b1
2017-07-01 06:33:48 status unpacked python-apt:amd64 1.4.0~beta3+b1
2017-07-01 06:33:48 upgrade python-cffi-backend:amd64 1.9.1-2 1.9.1-2+b1
2017-07-01 06:33:48 status half-configured python-cffi-backend:amd64 1.9.1-2
2017-07-01 06:33:48 status unpacked python-cffi-backend:amd64 1.9.1-2
2017-07-01 06:33:48 status half-installed python-cffi-backend:amd64 1.9.1-2
2017-07-01 06:33:48 status half-installed python-cffi-backend:amd64 1.9.1-2
2017-07-01 06:33:48 status unpacked python-cffi-backend:amd64 1.9.1-2+b1
2017-07-01 06:33:48 status unpacked python-cffi-backend:amd64 1.9.1-2+b1
2017-07-01 06:33:49 upgrade python-pycurl:amd64 7.43.0-2 7.43.0-2+b1
2017-07-01 06:33:49 status half-configured python-pycurl:amd64 7.43.0-2
2017-07-01 06:33:49 status unpacked python-pycurl:amd64 7.43.0-2
2017-07-01 06:33:49 status half-installed python-pycurl:amd64 7.43.0-2
2017-07-01 06:33:49 status half-installed python-pycurl:amd64 7.43.0-2
2017-07-01 06:33:49 status unpacked python-pycurl:amd64 7.43.0-2+b1
2017-07-01 06:33:49 status unpacked python-pycurl:amd64 7.43.0-2+b1
2017-07-01 06:33:49 upgrade python3-cups:amd64 1.9.73-1 1.9.73-1+b1
2017-07-01 06:33:49 status half-configured python3-cups:amd64 1.9.73-1
2017-07-01 06:33:49 status unpacked python3-cups:amd64 1.9.73-1
2017-07-01 06:33:49 status half-installed python3-cups:amd64 1.9.73-1
2017-07-01 06:33:49 status half-installed python3-cups:amd64 1.9.73-1
2017-07-01 06:33:50 status unpacked python3-cups:amd64 1.9.73-1+b1
2017-07-01 06:33:50 status unpacked python3-cups:amd64 1.9.73-1+b1
2017-07-01 06:33:50 upgrade python3-pycurl:amd64 7.43.0-2 7.43.0-2+b1
2017-07-01 06:33:50 status half-configured python3-pycurl:amd64 7.43.0-2
2017-07-01 06:33:50 status unpacked python3-pycurl:amd64 7.43.0-2
2017-07-01 06:33:50 status half-installed python3-pycurl:amd64 7.43.0-2
2017-07-01 06:33:50 status half-installed python3-pycurl:amd64 7.43.0-2
2017-07-01 06:33:50 status unpacked python3-pycurl:amd64 7.43.0-2+b1
2017-07-01 06:33:50 status unpacked python3-pycurl:amd64 7.43.0-2+b1
2017-07-01 06:33:51 upgrade python3-smbc:amd64 1.0.15.6-1 1.0.15.6-1+b1
2017-07-01 06:33:51 status half-configured python3-smbc:amd64 1.0.15.6-1
2017-07-01 06:33:51 status unpacked python3-smbc:amd64 1.0.15.6-1
2017-07-01 06:33:51 status half-installed python3-smbc:amd64 1.0.15.6-1
2017-07-01 06:33:51 status half-installed python3-smbc:amd64 1.0.15.6-1
2017-07-01 06:33:51 status unpacked python3-smbc:amd64 1.0.15.6-1+b1
2017-07-01 06:33:51 status unpacked python3-smbc:amd64 1.0.15.6-1+b1
2017-07-01 06:33:51 startup packages configure
2017-07-01 06:33:51 configure python3-pycurl:amd64 7.43.0-2+b1 <aucune>
2017-07-01 06:33:51 status unpacked python3-pycurl:amd64 7.43.0-2+b1
2017-07-01 06:33:51 status half-configured python3-pycurl:amd64 7.43.0-2+b1
2017-07-01 06:33:51 status installed python3-pycurl:amd64 7.43.0-2+b1
2017-07-01 06:33:52 configure python3-cups:amd64 1.9.73-1+b1 <aucune>
2017-07-01 06:33:52 status unpacked python3-cups:amd64 1.9.73-1+b1
2017-07-01 06:33:52 status half-configured python3-cups:amd64 1.9.73-1+b1
2017-07-01 06:33:52 status installed python3-cups:amd64 1.9.73-1+b1
2017-07-01 06:33:52 configure python3-apt:amd64 1.4.0~beta3+b1 <aucune>
2017-07-01 06:33:52 status unpacked python3-apt:amd64 1.4.0~beta3+b1
2017-07-01 06:33:52 status half-configured python3-apt:amd64 1.4.0~beta3+b1
2017-07-01 06:33:52 status installed python3-apt:amd64 1.4.0~beta3+b1
2017-07-01 06:33:52 configure python-pycurl:amd64 7.43.0-2+b1 <aucune>
2017-07-01 06:33:52 status unpacked python-pycurl:amd64 7.43.0-2+b1
2017-07-01 06:33:52 status half-configured python-pycurl:amd64 7.43.0-2+b1
2017-07-01 06:33:52 status installed python-pycurl:amd64 7.43.0-2+b1
2017-07-01 06:33:52 configure python-cffi-backend:amd64 1.9.1-2+b1 <aucune>
2017-07-01 06:33:52 status unpacked python-cffi-backend:amd64 1.9.1-2+b1
2017-07-01 06:33:52 status half-configured python-cffi-backend:amd64 1.9.1-2+b1
2017-07-01 06:33:52 status installed python-cffi-backend:amd64 1.9.1-2+b1
2017-07-01 06:33:52 configure python-apt:amd64 1.4.0~beta3+b1 <aucune>
2017-07-01 06:33:52 status unpacked python-apt:amd64 1.4.0~beta3+b1
2017-07-01 06:33:52 status half-configured python-apt:amd64 1.4.0~beta3+b1
2017-07-01 06:33:53 status installed python-apt:amd64 1.4.0~beta3+b1
2017-07-01 06:33:53 configure python3-smbc:amd64 1.0.15.6-1+b1 <aucune>
2017-07-01 06:33:53 status unpacked python3-smbc:amd64 1.0.15.6-1+b1
2017-07-01 06:33:53 status half-configured python3-smbc:amd64 1.0.15.6-1+b1
2017-07-01 06:33:53 status installed python3-smbc:amd64 1.0.15.6-1+b1
2017-07-01 06:34:06 startup archives unpack
2017-07-01 06:34:06 upgrade python3-cairo:amd64 1.10.0+dfsg-5+b1 1.10.0+dfsg-5+b3
2017-07-01 06:34:06 status half-configured python3-cairo:amd64 1.10.0+dfsg-5+b1
2017-07-01 06:34:06 status unpacked python3-cairo:amd64 1.10.0+dfsg-5+b1
2017-07-01 06:34:06 status half-installed python3-cairo:amd64 1.10.0+dfsg-5+b1
2017-07-01 06:34:07 status half-installed python3-cairo:amd64 1.10.0+dfsg-5+b1
2017-07-01 06:34:07 status unpacked python3-cairo:amd64 1.10.0+dfsg-5+b3
2017-07-01 06:34:07 status unpacked python3-cairo:amd64 1.10.0+dfsg-5+b3
2017-07-01 06:34:07 startup packages configure
2017-07-01 06:34:07 configure python3-cairo:amd64 1.10.0+dfsg-5+b3 <aucune>
2017-07-01 06:34:07 status unpacked python3-cairo:amd64 1.10.0+dfsg-5+b3
2017-07-01 06:34:07 status half-configured python3-cairo:amd64 1.10.0+dfsg-5+b3
2017-07-01 06:34:07 status installed python3-cairo:amd64 1.10.0+dfsg-5+b3
 


sur 4 machines en Buster

python-sip n'existe que dans stable d'aprés synaptic
mon sources.list actuel :


#stretch 9
deb http://deb.debian.org/debian/ stretch main contrib non-free
deb http://deb.debian.org/debian stretch-updates main contrib non-free
deb http://security.debian.org/ stretch/updates main contrib non-free
#deb http://deb.debian.org/debian stretch-backports main contrib non-free

#buster 10
deb http://deb.debian.org/debian/ buster main contrib non-free
deb http://deb.debian.org/debian buster-updates main contrib non-free
deb http://security.debian.org/ buster/updates main contrib non-free
#deb http://deb.debian.org/debian buster-backports main contrib non-free
 



j'arrive pas a trouver l'erreur normalement c'est dans le log de dpkg roll  , en plus j'ai une chance sur quatre d'etre sur la mauvaise machine hmm

sur Sid je n'ai que fait la mise a jour de python-cairo (qui a demandé la mise a jour de python3-gi ) et j'ai ajouté python-sip en installation


Récupération des rapports de bogue… Fait
Analyse des informations Trouvé/Corrigé… Fait
Sélection du paquet python-sip précédemment désélectionné.
(Lecture de la base de données... 186772 fichiers et répertoires déjà installés.)
Préparation du dépaquetage de .../python-sip_4.18.1+dfsg-2+b1_amd64.deb ...
Dépaquetage de python-sip (4.18.1+dfsg-2+b1) ...
Préparation du dépaquetage de .../python3-gi-cairo_3.22.0-2+b1_amd64.deb ...
Dépaquetage de python3-gi-cairo (3.22.0-2+b1) sur (3.22.0-2) ...
Préparation du dépaquetage de .../python3-gi_3.22.0-2+b1_amd64.deb ...
Dépaquetage de python3-gi (3.22.0-2+b1) sur (3.22.0-2) ...
Paramétrage de python3-gi (3.22.0-2+b1) ...
Traitement des actions différées (« triggers ») pour libc-bin (2.24-12) ...
Paramétrage de python-sip (4.18.1+dfsg-2+b1) ...
Paramétrage de python3-gi-cairo (3.22.0-2+b1) ...
Traitement des actions différées (« triggers ») pour libc-bin (2.24-12) ...
 


le log de dpkg


2017-07-01 17:21:39 startup archives unpack
2017-07-01 17:21:46 install python-sip:amd64 <aucune> 4.18.1+dfsg-2+b1
2017-07-01 17:21:46 status half-installed python-sip:amd64 4.18.1+dfsg-2+b1
2017-07-01 17:21:46 status unpacked python-sip:amd64 4.18.1+dfsg-2+b1
2017-07-01 17:21:46 status unpacked python-sip:amd64 4.18.1+dfsg-2+b1
2017-07-01 17:21:47 upgrade python3-gi-cairo:amd64 3.22.0-2 3.22.0-2+b1
2017-07-01 17:21:47 status triggers-pending libc-bin:amd64 2.24-12
2017-07-01 17:21:47 status half-configured python3-gi-cairo:amd64 3.22.0-2
2017-07-01 17:21:47 status unpacked python3-gi-cairo:amd64 3.22.0-2
2017-07-01 17:21:47 status half-installed python3-gi-cairo:amd64 3.22.0-2
2017-07-01 17:21:47 status half-installed python3-gi-cairo:amd64 3.22.0-2
2017-07-01 17:21:47 status unpacked python3-gi-cairo:amd64 3.22.0-2+b1
2017-07-01 17:21:47 status unpacked python3-gi-cairo:amd64 3.22.0-2+b1
2017-07-01 17:21:48 upgrade python3-gi:amd64 3.22.0-2 3.22.0-2+b1
2017-07-01 17:21:48 status half-configured python3-gi:amd64 3.22.0-2
2017-07-01 17:21:48 status unpacked python3-gi:amd64 3.22.0-2
2017-07-01 17:21:48 status half-installed python3-gi:amd64 3.22.0-2
2017-07-01 17:21:48 status half-installed python3-gi:amd64 3.22.0-2
2017-07-01 17:21:48 status unpacked python3-gi:amd64 3.22.0-2+b1
2017-07-01 17:21:49 status unpacked python3-gi:amd64 3.22.0-2+b1
2017-07-01 17:21:49 startup packages configure
2017-07-01 17:21:49 configure python3-gi:amd64 3.22.0-2+b1 <aucune>
2017-07-01 17:21:49 status unpacked python3-gi:amd64 3.22.0-2+b1
2017-07-01 17:21:49 status half-configured python3-gi:amd64 3.22.0-2+b1
2017-07-01 17:21:49 status installed python3-gi:amd64 3.22.0-2+b1
2017-07-01 17:21:49 trigproc libc-bin:amd64 2.24-12 <aucune>
2017-07-01 17:21:49 status half-configured libc-bin:amd64 2.24-12
2017-07-01 17:21:50 status installed libc-bin:amd64 2.24-12
2017-07-01 17:21:50 configure python-sip:amd64 4.18.1+dfsg-2+b1 <aucune>
2017-07-01 17:21:50 status unpacked python-sip:amd64 4.18.1+dfsg-2+b1
2017-07-01 17:21:50 status half-configured python-sip:amd64 4.18.1+dfsg-2+b1
2017-07-01 17:21:50 status installed python-sip:amd64 4.18.1+dfsg-2+b1
2017-07-01 17:21:50 configure python3-gi-cairo:amd64 3.22.0-2+b1 <aucune>
2017-07-01 17:21:50 status triggers-pending libc-bin:amd64 2.24-12
2017-07-01 17:21:50 status unpacked python3-gi-cairo:amd64 3.22.0-2+b1
2017-07-01 17:21:51 status half-configured python3-gi-cairo:amd64 3.22.0-2+b1
2017-07-01 17:21:51 status installed python3-gi-cairo:amd64 3.22.0-2+b1
2017-07-01 17:21:51 trigproc libc-bin:amd64 2.24-12 <aucune>
2017-07-01 17:21:51 status half-configured libc-bin:amd64 2.24-12
2017-07-01 17:21:51 status installed libc-bin:amd64 2.24-12
 



a mon avis le plus propre tu enlèves le  paquet qui pose problème python-sip , tu revients a une version de stable pour les deux ou  tu retente une mise a jour.
par exemple avec synaptic tu peu les mettre a jour un par un , tu peu le faire a partir de sid ou buster (pour ces 2 paquets )
apt-get clean et apt-get update et tu revients sur Buster sans soucis (aprés avoir remit correctement le sources.list )

Dernière modification par robert2a (01-07-2017 17:37:39)

Hors ligne

#4 01-07-2017 17:37:14

Mercredi
Membre
Distrib. : Testing
Noyau : 4.13
(G)UI : Gnome
Inscription : 25-09-2015

Re : [Abandonné] Apt en erreur cause erreur fatale python

Salut Robert,

Donc si tu as eu le problème aussi, je peux éliminer la piste du "ménage trop virulent dans mes paquets" fait hier, aucun de ceux que j'ai supprimé n'avaient de rapport avec python mais il me restait quand même un doute que tu viens de lever.

Et oui faut pas forcer ... je suis un peu bourrin des fois cthulhu.gif mais maintenant je le saurai.

python-sip semble avoir des liens avec hplip-gui et convertall que j'utilise.
Dispo dans Buster d'après les packages debian : https://packages.debian.org/buster/python-sip

J'ai bien essayé de désinstaller python3-sip et python3-cairo, quitte à réinstaller ensuite les Gedit et autres choses que ça enlèverait mais Apt , Apt-get ou Synaptic ne veulent pas, ils restent bloqués sur l'erreur quoique je fasse.
Pareil si j'essaie d'installer Aptitude, la même erreur et rien ne s'installe.

Mon sources.list :

#testing
deb http://ftp.fr.debian.org/debian/ testing main contrib non-free
deb http://security.debian.org/ testing/updates main contrib non-free

#Sid
#deb http://ftp.fr.debian.org/debian/ sid main


De toutes les forces de l'univers, la plus dure à surmonter, c'est la force de l'habitude. T.Pratchett - Trois Soeurcières.

Hors ligne

#5 01-07-2017 17:44:07

robert2a
Membre
Lieu : France
Distrib. : Stretch 9
Noyau : Linux 4.9.0-3 4.9.30-2
(G)UI : Mate
Inscription : 15-11-2014

Re : [Abandonné] Apt en erreur cause erreur fatale python

j'ai rajouté des choses sur mon #3 au dessus
ajoute stretch a ton sources et provisoirement sid , il y a énormément de paquet de stretch dans buster et sid permet d'éviter le bug (un autoclean ou un clean te permet de revenir  a une buster pure aprés un update )

le retour de :


apt-get -s remove --purge python-sip
 



la meme version que stretch => https://packages.debian.org/stretch/python-sip

c'est dommage que je retrouve pas l'erreur que j'ai eu  sad

ps: petite astuce en plus du sources exotique , je fais les mise a jour en sélectif (pas tout d un coup ) et par exemple le driver nvidia nonfree et cuda toujours en dernier (beaucoup de paquets )
un truc de vieux   old_geek.gif   tongue   wink

je me suis trompé de paquet au dessus , voici python-cairo


Récupération des rapports de bogue… Fait
Analyse des informations Trouvé/Corrigé… Fait
(Lecture de la base de données... 186785 fichiers et répertoires déjà installés.)
Préparation du dépaquetage de .../python3-cairo_1.10.0+dfsg-5+b3_amd64.deb ...
Dépaquetage de python3-cairo (1.10.0+dfsg-5+b3) sur (1.10.0+dfsg-5+b1) ...
Paramétrage de python3-cairo (1.10.0+dfsg-5+b3) ...
 

Dernière modification par robert2a (01-07-2017 17:59:32)

Hors ligne

#6 01-07-2017 17:56:33

chalu
Modératrice
Lieu : Anjou
Distrib. : Debian Stretch
Noyau : Linux 4.9.0-3-amd64
(G)UI : Mate 1.16
Inscription : 11-03-2016

Re : [Abandonné] Apt en erreur cause erreur fatale python

Bonjour smile
Et essayer une réinstallation du paquet comme indiqué dans le retour du terminal, ça ne marche pas non plus ?
ou forcer à une réinstallation d'une version antérieure ?

En ligne

#7 01-07-2017 18:03:00

robert2a
Membre
Lieu : France
Distrib. : Stretch 9
Noyau : Linux 4.9.0-3 4.9.30-2
(G)UI : Mate
Inscription : 15-11-2014

Re : [Abandonné] Apt en erreur cause erreur fatale python

a mon avis il y a un mélange de version entre stretch et buster/sid  pour cela qu il faut une référence a stable (pour avoir de disponible des versions anterieures )
en tout cas aujourd'hui tout est correct a partir de buster ou sid sur python

si Mercredi nous renvoi l'erreur en simulation ou en réel du remove de python-sip
dpkg doit renvoyer quelque chose dans le log du 01/05 ( /var/log/dpkg.log )

Dernière modification par robert2a (01-07-2017 18:05:55)

Hors ligne

#8 01-07-2017 18:07:32

Mercredi
Membre
Distrib. : Testing
Noyau : 4.13
(G)UI : Gnome
Inscription : 25-09-2015

Re : [Abandonné] Apt en erreur cause erreur fatale python

apt-get -s remove --purge python-sip


Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances      
Lecture des informations d'état... Fait
Le paquet « python-sip » n'est pas installé, et ne peut donc être supprimé
Les paquets suivants ont été installés automatiquement et ne sont plus nécessaires :
  docutils-common python-babel-localedata python3-alabaster python3-babel python3-docutils python3-imagesize python3-jinja2 python3-pygments python3-roman python3-tz
Veuillez utiliser « apt autoremove » pour les supprimer.
0 mis à jour, 0 nouvellement installés, 0 à enlever et 2 non mis à jour.
2 partiellement installés ou enlevés.
Conf python3-cairo (1.10.0+dfsg-5+b3 Debian:testing [amd64])



La même avec python3-sip :

apt-get -s remove --purge python3-sip


Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances      
Lecture des informations d'état... Fait
Les paquets suivants ont été installés automatiquement et ne sont plus nécessaires :
  docutils-common gksu libgksu2-0 libqt4-declarative libqt4-designer libqt4-help libqt4-script libqt4-scripttools libqt4-sql libqt4-svg libqt4-test libqt4-xmlpatterns libqt5test5 libqtassistantclient4
  python-babel-localedata python3-alabaster python3-babel python3-dbus.mainloop.pyqt5 python3-docutils python3-imagesize python3-jinja2 python3-pygments python3-roman python3-tz
Veuillez utiliser « apt autoremove » pour les supprimer.
Les paquets suivants seront ENLEVÉS :
  convertall* hplip-gui* python3-pyqt4* python3-pyqt5* python3-sip*
0 mis à jour, 0 nouvellement installés, 5 à enlever et 1 non mis à jour.
2 partiellement installés ou enlevés.
Purg convertall [0.6.1-2]
Purg python3-pyqt4 [4.11.4+dfsg-2+b1]
Purg hplip-gui [3.17.6+repack0-1]
Purg python3-pyqt5 [5.7+dfsg-5]
Purg python3-sip [4.18.1+dfsg-2]
Conf python3-cairo (1.10.0+dfsg-5+b3 Debian:testing [amd64])



Après avoir rajouté les sources de Stretch + update :

apt upgrade


Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances      
Lecture des informations d'état... Fait
Calcul de la mise à jour... Fait
Les paquets suivants ont été installés automatiquement et ne sont plus nécessaires :
  docutils-common python-babel-localedata python3-alabaster python3-babel python3-docutils python3-imagesize python3-jinja2 python3-pygments python3-roman python3-tz
Veuillez utiliser « apt autoremove » pour les supprimer.
Les paquets suivants seront mis à jour :
  linux-image-4.9.0-3-amd64 python3-sip
2 mis à jour, 0 nouvellement installés, 0 à enlever et 0 non mis à jour.
2 partiellement installés ou enlevés.
Il est nécessaire de prendre 38,7 Mo/38,8 Mo dans les archives.
Après cette opération, 237 ko d'espace disque supplémentaires seront utilisés.
Souhaitez-vous continuer ? [O/n]
Réception de:1 http://security-cdn.debian.org stable/updates/main amd64 linux-image-4.9.0-3-amd64 amd64 4.9.30-2+deb9u2 [38,7 MB]
38,7 Mo réceptionnés en 1min 52s (344 ko/s)                                                                                                                                                                      
Récupération des rapports de bogue… Fait
Analyse des informations Trouvé/Corrigé… Fait
Could not find platform independent libraries <prefix>
Consider setting $PYTHONHOME to <prefix>[:<exec_prefix>]
Fatal Python error: Py_Initialize: Unable to get the locale encoding
LookupError: no codec search functions registered: can't find encoding

Current thread 0x00007f5261540700 (most recent call first):
Aborted
E: Le sous-processus /usr/bin/apt-listchanges --apt || test $? -lt 10 a renvoyé un code d'erreur (1)
E: Failure running script /usr/bin/apt-listchanges --apt || test $? -lt 10



Ps : pas trouvé trace des erreurs non plus dans le log de dpkg

Edit @ Chalu, réinstaller me retourne la même erreur que pour installer ou supprimer, comme dans la tentative de maj juste au-dessus. En fait apt, apt-get et Synaptic bloquent complètement là-dessus et ne veulent plus rien faire hmm

Dernière modification par Mercredi (01-07-2017 18:10:24)


De toutes les forces de l'univers, la plus dure à surmonter, c'est la force de l'habitude. T.Pratchett - Trois Soeurcières.

Hors ligne

#9 01-07-2017 18:13:37

Mercredi
Membre
Distrib. : Testing
Noyau : 4.13
(G)UI : Gnome
Inscription : 25-09-2015

Re : [Abandonné] Apt en erreur cause erreur fatale python

Le retour sans simulation de suppression de python3-sip :

apt-get remove --purge python3-sip


Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances      
Lecture des informations d'état... Fait
Les paquets suivants ont été installés automatiquement et ne sont plus nécessaires :
  docutils-common gksu libgksu2-0 libqt4-declarative libqt4-designer libqt4-help libqt4-script libqt4-scripttools libqt4-sql libqt4-svg libqt4-test libqt4-xmlpatterns libqt5test5 libqtassistantclient4
  python-babel-localedata python3-alabaster python3-babel python3-dbus.mainloop.pyqt5 python3-docutils python3-imagesize python3-jinja2 python3-pygments python3-roman python3-tz
Veuillez utiliser « apt autoremove » pour les supprimer.
Les paquets suivants seront ENLEVÉS :
  convertall* hplip-gui* python3-pyqt4* python3-pyqt5* python3-sip*
0 mis à jour, 0 nouvellement installés, 5 à enlever et 1 non mis à jour.
2 partiellement installés ou enlevés.
Après cette opération, 31,5 Mo d'espace disque seront libérés.
Souhaitez-vous continuer ? [O/n]
Could not find platform independent libraries <prefix>
Consider setting $PYTHONHOME to <prefix>[:<exec_prefix>]
Fatal Python error: Py_Initialize: Unable to get the locale encoding
LookupError: no codec search functions registered: can't find encoding

Current thread 0x00007fd2a6551700 (most recent call first):
Aborted
E: Le sous-processus /usr/bin/apt-listchanges --apt || test $? -lt 10 a renvoyé un code d'erreur (1)
E: Failure running script /usr/bin/apt-listchanges --apt || test $? -lt 10



Ça veut pas.


De toutes les forces de l'univers, la plus dure à surmonter, c'est la force de l'habitude. T.Pratchett - Trois Soeurcières.

Hors ligne

#10 01-07-2017 18:18:40

robert2a
Membre
Lieu : France
Distrib. : Stretch 9
Noyau : Linux 4.9.0-3 4.9.30-2
(G)UI : Mate
Inscription : 15-11-2014

Re : [Abandonné] Apt en erreur cause erreur fatale python

le reste pour aujourd'hui sur sid (mise a jour python )


Récupération des rapports de bogue… Fait
Analyse des informations Trouvé/Corrigé… Fait
Sélection du paquet python-asn1crypto précédemment désélectionné.
(Lecture de la base de données... 186786 fichiers et répertoires déjà installés.)
Préparation du dépaquetage de .../0-python-asn1crypto_0.22.0-1_all.deb ...
Dépaquetage de python-asn1crypto (0.22.0-1) ...
Préparation du dépaquetage de .../1-python-cffi-backend_1.9.1-2+b1_amd64.deb ...
Dépaquetage de python-cffi-backend (1.9.1-2+b1) sur (1.9.1-2) ...
Préparation du dépaquetage de .../2-python-crypto_2.6.1-7+b1_amd64.deb ...
Dépaquetage de python-crypto (2.6.1-7+b1) sur (2.6.1-7) ...
Préparation du dépaquetage de .../3-python-cryptography_1.9-1_amd64.deb ...
Dépaquetage de python-cryptography (1.9-1) sur (1.7.1-3) ...
Préparation du dépaquetage de .../4-python-gi_3.22.0-2+b1_amd64.deb ...
Dépaquetage de python-gi (3.22.0-2+b1) sur (3.22.0-2) ...
Préparation du dépaquetage de .../5-python-pil_4.0.0-4+b1_amd64.deb ...
Dépaquetage de python-pil:amd64 (4.0.0-4+b1) sur (4.0.0-4) ...
Préparation du dépaquetage de .../6-python3-cups_1.9.73-1+b1_amd64.deb ...
Dépaquetage de python3-cups (1.9.73-1+b1) sur (1.9.73-1) ...
Préparation du dépaquetage de .../7-python3-pil_4.0.0-4+b1_amd64.deb ...
Dépaquetage de python3-pil:amd64 (4.0.0-4+b1) sur (4.0.0-4) ...
Paramétrage de python-asn1crypto (0.22.0-1) ...
Paramétrage de python3-pil:amd64 (4.0.0-4+b1) ...
Paramétrage de python3-cups (1.9.73-1+b1) ...
Paramétrage de python-crypto (2.6.1-7+b1) ...
Paramétrage de python-cffi-backend (1.9.1-2+b1) ...
Paramétrage de python-gi (3.22.0-2+b1) ...
Paramétrage de python-cryptography (1.9-1) ...
Paramétrage de python-pil:amd64 (4.0.0-4+b1) ...
 



je sais pas comment  régler ça 


Could not find platform independent libraries <prefix>
Consider setting $PYTHONHOME to <prefix>[:<exec_prefix>]
Fatal Python error: Py_Initialize: Unable to get the locale encoding
LookupError: no codec search functions registered: can't find encoding
 



le $PYTHONHOME  me parle , je l'ai peu etre eu aussi dans mon erreur

python3-sip pas de dépendances demandé (comme python-sip)


Récupération des rapports de bogue… Fait
Analyse des informations Trouvé/Corrigé… Fait
Sélection du paquet python3-sip précédemment désélectionné.
(Lecture de la base de données... 186831 fichiers et répertoires déjà installés.)
Préparation du dépaquetage de .../python3-sip_4.18.1+dfsg-2+b1_amd64.deb ...
Dépaquetage de python3-sip (4.18.1+dfsg-2+b1) ...
Paramétrage de python3-sip (4.18.1+dfsg-2+b1) ...
 



si apt-get veut plus hmm  , je sais pas , avec dpkg en direct , on doit pouvoir remove (genre dpkg -r nomdu paquet) a vérifier quand meme

Dernière modification par robert2a (01-07-2017 18:24:12)

Hors ligne

#11 01-07-2017 18:26:37

Mercredi
Membre
Distrib. : Testing
Noyau : 4.13
(G)UI : Gnome
Inscription : 25-09-2015

Re : [Abandonné] Apt en erreur cause erreur fatale python

robert2a a écrit :



je sais pas comment  régler ça 


Could not find platform independent libraries <prefix>
Consider setting $PYTHONHOME to <prefix>[:<exec_prefix>]
Fatal Python error: Py_Initialize: Unable to get the locale encoding
LookupError: no codec search functions registered: can't find encoding
 



le $PYTHONHOME  me parle , je l'ai peu etre eu aussi dans mon erreur



Moi non plus mais je pense que la clé du problème est là.

Une erreur proche mais pas totalement identique : https://techglimpse.com/error-executing … -solution/
J'ai testé au cas où mais ça ne change rien.

Ps : j'ai sauvegardé mes données et j'ai un autre pc prêt à prendre le relais si besoin donc je peux tout essayer et risquer de tout casser tongue

Je vais tenter avec dpkg direct, je redis après.

Dernière modification par Mercredi (01-07-2017 18:28:05)


De toutes les forces de l'univers, la plus dure à surmonter, c'est la force de l'habitude. T.Pratchett - Trois Soeurcières.

Hors ligne

#12 01-07-2017 18:31:39

robert2a
Membre
Lieu : France
Distrib. : Stretch 9
Noyau : Linux 4.9.0-3 4.9.30-2
(G)UI : Mate
Inscription : 15-11-2014

Re : [Abandonné] Apt en erreur cause erreur fatale python

la commande


dpkg -r -p python3-sip
 



-r pour --remove et -p pour --purge

tu a l option -s pour status  et -l pour état  , misère je suis jamais aller aussi loin avec dpkg   tongue

un exemple avec le -l (c'est un "le" pas "i" )


dpkg -l python3-sip
 


retour


Souhait=inconnU/Installé/suppRimé/Purgé/H=à garder
| État=Non/Installé/fichier-Config/dépaqUeté/échec-conFig/H=semi-installé/W=attend-traitement-déclenchements
|/ Err?=(aucune)/besoin Réinstallation (État,Err: majuscule=mauvais)
||/ Nom                                                           Version                             Architecture                        Description
+++-=============================================================-===================================-===================================-================================================================================================================================
ii  python3-sip                                                   4.18.1+dfsg-2+b1                    amd64                               Python 3/C++ bindings generator runtime library
 

Dernière modification par robert2a (01-07-2017 18:38:59)

Hors ligne

#13 01-07-2017 18:42:59

Mercredi
Membre
Distrib. : Testing
Noyau : 4.13
(G)UI : Gnome
Inscription : 25-09-2015

Re : [Abandonné] Apt en erreur cause erreur fatale python

Retour intéressant avec dpkg :

dpkg -r python3-sip


dpkg: un problème de dépendance empêche la suppression de python3-sip :
 python3-pyqt4 dépend de sip-py3api-11.3 ; cependant :
  Le paquet sip-py3api-11.3 n'est pas installé.
  Le paquet python3-sip qui fournit sip-py3api-11.3 doit être supprimé.
 python3-pyqt5 dépend de sip-py3api-11.3 ; cependant :
  Le paquet sip-py3api-11.3 n'est pas installé.
  Le paquet python3-sip qui fournit sip-py3api-11.3 doit être supprimé.

dpkg: erreur de traitement du paquet python3-sip (--remove) :
 problème de dépendance - suppression ignorée
Des erreurs ont été rencontrées pendant l'exécution :
 python3-sip



Avec -l je ne sais pas comment interpréter le retour scratchhead.gif

dpkg -l python3-sip


Souhait=inconnU/Installé/suppRimé/Purgé/H=à garder
| État=Non/Installé/fichier-Config/dépaqUeté/échec-conFig/H=semi-installé/W=attend-traitement-déclenchements
|/ Err?=(aucune)/besoin Réinstallation (État,Err: majuscule=mauvais)
||/ Nom            Version      Architecture Description
+++-==============-============-============-=================================
rFR python3-sip    4.18.1+dfsg- amd64        Python 3/C++ bindings generator r



Edit : je ne trouve pas de paquet correspondant à sip-py3api-11.3 roll

Dernière modification par Mercredi (01-07-2017 18:45:58)


De toutes les forces de l'univers, la plus dure à surmonter, c'est la force de l'habitude. T.Pratchett - Trois Soeurcières.

Hors ligne

#14 01-07-2017 18:43:16

chalu
Modératrice
Lieu : Anjou
Distrib. : Debian Stretch
Noyau : Linux 4.9.0-3-amd64
(G)UI : Mate 1.16
Inscription : 11-03-2016

Re : [Abandonné] Apt en erreur cause erreur fatale python

Est-ce que tu as essayé de réinstaller pyton3-cairo version stretch que tu as forcé à buster dans le premier message ?

En ligne

#15 01-07-2017 18:49:34

Mercredi
Membre
Distrib. : Testing
Noyau : 4.13
(G)UI : Gnome
Inscription : 25-09-2015

Re : [Abandonné] Apt en erreur cause erreur fatale python

chalu a écrit :

Est-ce que tu as essayé de réinstaller pyton3-cairo version stretch que tu as forcé à buster dans le premier message ?


Oui smile mais ça veut pas, la même erreur qui ressort.
Quand j'ai forcé python3-cairo, je pense que ça a modifié un truc et que du coup apt ne retrouve plus ses petits.

À votre avis j'ai une chance de remettre les choses en ordre en téléchargeant l'archive deb directement sur le site de Debian, enfin si elle veut bien s'installer ?


De toutes les forces de l'univers, la plus dure à surmonter, c'est la force de l'habitude. T.Pratchett - Trois Soeurcières.

Hors ligne

#16 01-07-2017 18:52:18

robert2a
Membre
Lieu : France
Distrib. : Stretch 9
Noyau : Linux 4.9.0-3 4.9.30-2
(G)UI : Mate
Inscription : 15-11-2014

Re : [Abandonné] Apt en erreur cause erreur fatale python

un paquet virtuel  => https://packages.debian.org/fr/sid/sip-py3api-11.3

si tu fait un dpkg -i avec le paquet python3-sip


dpkg -i python3-sip.deb
 


et la meme chose avec python3-cairo.deb

pour info en sid en fin de mise a jour de python3 il me propose


(Lecture de la base de données... 186837 fichiers et répertoires déjà installés.)
Suppression de python-pyasn1 (0.1.9-2) ...
 


on suit le mouvement........  hmm

Dernière modification par robert2a (01-07-2017 19:10:52)

Hors ligne

#17 01-07-2017 19:02:37

Mercredi
Membre
Distrib. : Testing
Noyau : 4.13
(G)UI : Gnome
Inscription : 25-09-2015

Re : [Abandonné] Apt en erreur cause erreur fatale python

Ah oui le paquet sip-py3api-11.3 est dans Sid, je ne l'avais pas cherché là:rolleyes:

dpkg -i python3-sip


dpkg: erreur: cannot access archive 'python3-sip': Aucun fichier ou dossier de ce type


dpkg -i python3-cairo


dpkg: erreur: cannot access archive 'python3-cairo': Aucun fichier ou dossier de ce type



Les bugs de python3-cairo :
https://bugs.debian.org/cgi-bin/bugrepo … bug=866724
https://bugs.debian.org/cgi-bin/bugrepo … bug=866663


De toutes les forces de l'univers, la plus dure à surmonter, c'est la force de l'habitude. T.Pratchett - Trois Soeurcières.

Hors ligne

#18 01-07-2017 19:06:25

chalu
Modératrice
Lieu : Anjou
Distrib. : Debian Stretch
Noyau : Linux 4.9.0-3-amd64
(G)UI : Mate 1.16
Inscription : 11-03-2016

Re : [Abandonné] Apt en erreur cause erreur fatale python

il faut installer les *.deb

En ligne

#19 01-07-2017 19:07:51

Mercredi
Membre
Distrib. : Testing
Noyau : 4.13
(G)UI : Gnome
Inscription : 25-09-2015

Re : [Abandonné] Apt en erreur cause erreur fatale python

Je m'absente un moment (apéro, faire la popote ...) ad'taleur et  merci.gif

De toutes les forces de l'univers, la plus dure à surmonter, c'est la force de l'habitude. T.Pratchett - Trois Soeurcières.

Hors ligne

#20 01-07-2017 19:10:26

robert2a
Membre
Lieu : France
Distrib. : Stretch 9
Noyau : Linux 4.9.0-3 4.9.30-2
(G)UI : Mate
Inscription : 15-11-2014

Re : [Abandonné] Apt en erreur cause erreur fatale python

oui en .deb  tongue  dpkg -i (je modifie smile   )

a l'instant encore du python a mettre a jour   cool


Récupération des rapports de bogue… Fait
Analyse des informations Trouvé/Corrigé… Fait
Sélection du paquet python-olefile précédemment désélectionné.
(Lecture de la base de données... 186784 fichiers et répertoires déjà installés.)
Préparation du dépaquetage de .../python-olefile_0.44-1_all.deb ...
Dépaquetage de python-olefile (0.44-1) ...
Préparation du dépaquetage de .../python-pil_4.1.1-3_amd64.deb ...
Dépaquetage de python-pil:amd64 (4.1.1-3) sur (4.0.0-4+b1) ...
Sélection du paquet python3-olefile précédemment désélectionné.
Préparation du dépaquetage de .../python3-olefile_0.44-1_all.deb ...
Dépaquetage de python3-olefile (0.44-1) ...
Préparation du dépaquetage de .../python3-pil_4.1.1-3_amd64.deb ...
Dépaquetage de python3-pil:amd64 (4.1.1-3) sur (4.0.0-4+b1) ...
Paramétrage de python3-olefile (0.44-1) ...
Paramétrage de python-olefile (0.44-1) ...
Paramétrage de python-pil:amd64 (4.1.1-3) ...
Paramétrage de python3-pil:amd64 (4.1.1-3) ...
 

Dernière modification par robert2a (01-07-2017 19:14:23)

Hors ligne

#21 01-07-2017 22:08:54

Mercredi
Membre
Distrib. : Testing
Noyau : 4.13
(G)UI : Gnome
Inscription : 25-09-2015

Re : [Abandonné] Apt en erreur cause erreur fatale python

Effectivement c'est mieux avec le .deb, j'ai même pas percuté ops.gif

Mais même problème :

dpkg -i python3-cairo_1.10.0+dfsg-5+b3_amd64.deb


(Lecture de la base de données... 190954 fichiers et répertoires déjà installés.)
Préparation du dépaquetage de python3-cairo_1.10.0+dfsg-5+b3_amd64.deb ...
Could not find platform independent libraries <prefix>
Consider setting $PYTHONHOME to <prefix>[:<exec_prefix>]
Fatal Python error: Py_Initialize: Unable to get the locale encoding
LookupError: no codec search functions registered: can't find encoding

Current thread 0x00007f3336bb3700 (most recent call first):
Aborted
dpkg: avertissement: le sous-processus ancien script pre-removal a retourné une erreur de sortie d'état 134
dpkg: tentative d'exécution du script du nouveau paquet à la place...
Could not find platform independent libraries <prefix>
Consider setting $PYTHONHOME to <prefix>[:<exec_prefix>]
Fatal Python error: Py_Initialize: Unable to get the locale encoding
LookupError: no codec search functions registered: can't find encoding

Current thread 0x00007f203448e700 (most recent call first):
Aborted
dpkg: erreur de traitement de l'archive python3-cairo_1.10.0+dfsg-5+b3_amd64.deb (--install) :
 le sous-processus nouveau script pre-removal a retourné une erreur de sortie d'état 134
Could not find platform independent libraries <prefix>
Consider setting $PYTHONHOME to <prefix>[:<exec_prefix>]
Fatal Python error: Py_Initialize: Unable to get the locale encoding
LookupError: no codec search functions registered: can't find encoding

Current thread 0x00007fea82e5b700 (most recent call first):
Aborted
dpkg: error while cleaning up:
 le sous-processus script post-installation installé a retourné une erreur de sortie d'état 134
Des erreurs ont été rencontrées pendant l'exécution :
 python3-cairo_1.10.0+dfsg-5+b3_amd64.deb



Je continue de fouiller le web mais les exemples que je trouve ne bloquent pas le gestionnaire de paquet et se résolvent avec une réinstallation ou suppression, sauf que moi je ne peux rien supprimer ou réinstaller.


De toutes les forces de l'univers, la plus dure à surmonter, c'est la force de l'habitude. T.Pratchett - Trois Soeurcières.

Hors ligne

#22 01-07-2017 22:48:29

Mercredi
Membre
Distrib. : Testing
Noyau : 4.13
(G)UI : Gnome
Inscription : 25-09-2015

Re : [Abandonné] Apt en erreur cause erreur fatale python

Je vais tenter un nettoyage a la mano selon la méthode nucléaire de Seboos666 :https://blog.seboss666.info/2016/08/sup … e-de-dpkg/
C'est une solution extrême mais si je ne récupère pas l'usage de apt je ne n'avancerais pas. Et si ça pète tout bah je serais bonne pour réinstaller lol

De toutes les forces de l'univers, la plus dure à surmonter, c'est la force de l'habitude. T.Pratchett - Trois Soeurcières.

Hors ligne

#23 02-07-2017 16:18:55

Mercredi
Membre
Distrib. : Testing
Noyau : 4.13
(G)UI : Gnome
Inscription : 25-09-2015

Re : [Abandonné] Apt en erreur cause erreur fatale python

Bonjour,
La suppression à la main de python3-cairo n'a pas suffit à réparer Apt, toujours la même erreur :

Could not find platform independent libraries <prefix>
Consider setting $PYTHONHOME to <prefix>[:<exec_prefix>]
Fatal Python error: Py_Initialize: Unable to get the locale encoding
LookupError: no codec search functions registered: can't find encoding



Du coup j'ai réinstallé hmm J'aurais préféré réparer et comprendre mais tant pis, au moins je repars au propre et ça m'apprendra à faire n'importe quoi.

Merci encore pour l'aide apportée smile


De toutes les forces de l'univers, la plus dure à surmonter, c'est la force de l'habitude. T.Pratchett - Trois Soeurcières.

Hors ligne

#24 02-07-2017 16:46:41

robert2a
Membre
Lieu : France
Distrib. : Stretch 9
Noyau : Linux 4.9.0-3 4.9.30-2
(G)UI : Mate
Inscription : 15-11-2014

Re : [Abandonné] Apt en erreur cause erreur fatale python

Bonjour
Après recherche (pour la première ligne de ton message d'erreur )

Could not find platform independent libraries <prefix>

Impossible de trouver des bibliothèques indépendantes de la plate-forme <préfixe>

Le problème est probablement dû à de multiples installations python dans votre système. Vous avez deux variables PYTHONPATH et PYTHONHOME. Le module py3compile recherche différentes ressources en utilisant ces deux variables. La variable PYTHONPATH augmente le chemin de recherche par défaut pour les fichiers de module. PYTHONHOME est utilisé pour les bibliothèques Python standard. Le format est identique à PATH du shell. Vous devez définir ces variables comme suit:


export PYTHONPATH='/path/to/pythondir:/path/to/pythondir/lib-dynload:/path/to/pythondir/site-packages' export PYTHONHOME='/path/to/pythondir'
 



roll tongue  hmm

Hors ligne

#25 02-07-2017 17:06:25

Mercredi
Membre
Distrib. : Testing
Noyau : 4.13
(G)UI : Gnome
Inscription : 25-09-2015

Re : [Abandonné] Apt en erreur cause erreur fatale python

Ça arrive trop tard pour que je teste sad mais ce sera peut-être utile à d'autres smile
Merci.

/me s'en va essayer d'autres moteurs de recherche aussi, parce que celle-là je ne l'ai pas trouvée et pourtant j'ai cherché un sacré bout de temps roll

De toutes les forces de l'univers, la plus dure à surmonter, c'est la force de l'habitude. T.Pratchett - Trois Soeurcières.

Hors ligne

Pied de page des forums