Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 08-07-2017 23:00:08

Grompf
Adhérent(e)
Distrib. : LMDE 2
Noyau : Linux 3.16.0-4-amd64
(G)UI : Cinnamon
Inscription : 08-06-2016

soucis avec les mises à jour de LMDE

Bonsoir,
On dirait bien qu'on s'est un peu mélangé les pinceaux chez Linux Mint récemment avec les mises à jour de LMDE.

Sur LMDE 32B Mate, on propose une mise à jour pour cinnamon-nemo
Sur LMDE 64B Mate, une série de mises à jour a mis mon serveur graphique KO, sur un PC doté d'une carte graphique Radeon (remarque : je n'ai pas eu ce problème avec d'autres matériels). J'ai ensuite fait une mise à jour depuis la console, qui portait sur des paquets qui n'avaient pas été selectionnés par l'utilitaire de mises à jour de Mint. Mon problème a été réglé. J'en ai conclu que la première série de mises à jour (sélectionnées par Linux Mint) amenaient une incompatibilité avec la carte graphique et que cette incompatibilité a été réglée par la 2e série de mises à jour (qui n'étaient pas elles sélectionnées par Linux Mint).

Bon, concernant LMDE, ils annoncent la couleur :

(...) it is not recommended for novice users.
(...) It’s more risky, but more exciting.


Sur mes 2 PC principaux, j'utilise LMDE Mate sans aucun problème depuis 1 année, et j'avais du coup oublié cette mise en garde...


CONFIGURATION :
    1. Lenovo Thinkpad X220 i5 - carte graphique Intel Corporation (2nd generation Core...) - Debian Stretch Cinnamon - noyau 4.9..0-3-amd64
    2. Lenovo Thinkpad T510 i7 - carte graphique : NVIDIA GT218M (NVS 3100M) - LMDE 2 Cinnamon - noyau 3.4.6

Hors ligne

#2 09-07-2017 02:59:49

robert2a
Membre
Lieu : France
Distrib. : Stretch 9
Noyau : Linux 4.9.0-3 4.9.30-2
(G)UI : Mate
Inscription : 15-11-2014

Re : soucis avec les mises à jour de LMDE

Bonjour
je connais pas comme distribution , mais les versions de paquets sont mit a jour en permanence .
faut voir le noyau actuel , la version du paquet radeon , du firmware amdgpu , la version de mesa  et des libdrm , et le type de ta carte vidéo installé  .
ça risque d' etre plus sportif que debian Sid  tongue

Hors ligne

#3 10-07-2017 10:33:20

Grompf
Adhérent(e)
Distrib. : LMDE 2
Noyau : Linux 3.16.0-4-amd64
(G)UI : Cinnamon
Inscription : 08-06-2016

Re : soucis avec les mises à jour de LMDE

robert2a a écrit :

Bonjour
je connais pas comme distribution , mais les versions de paquets sont mit a jour en permanence .
faut voir le noyau actuel , la version du paquet radeon , du firmware amdgpu , la version de mesa  et des libdrm , et le type de ta carte vidéo installé  .
ça risque d' etre plus sportif que debian Sid  tongue


Sur mes 2 PC principaux, ça a été que du bonheur. Pas de soucis en 1 année.
Linux Mint Debian Edition est stable, en principe.
Mais ils ont un outil de mises à jour, comme sur la Linux Mint basée sur Ubuntu, qui classe les mises à jour en niveaux, de 1 à 5 (selon le risque qu'il y a d'affecter le système). Et l'utilisateur peut choisir quels sont les niveaux qu'il veut sélectionner automatiquement pour la mises à jour (je résume grossièrement). Et ça fonctionne bien. Rien n'empêche l'utilisateur ensuite de rajouter à la main des mises à jour considérées comme plus délicates, pour faire ces mises à jour une à une, histoire de voir si qqch casse.
Sauf que dans mon cas, il y a 2 mises à jour qui auraient dû se faire en même temps, visiblement...
Donc leur politique de mises à jour peut causer des soucis.

Si tu es curieux, je peut faire un copier/coller de ces mises à jour, tu verras. Si j'ai bien compris, on a touché au noyau alors que la mises à jour pour le pilote graphique correspondant n'avais pas été sélectionnée.


CONFIGURATION :
    1. Lenovo Thinkpad X220 i5 - carte graphique Intel Corporation (2nd generation Core...) - Debian Stretch Cinnamon - noyau 4.9..0-3-amd64
    2. Lenovo Thinkpad T510 i7 - carte graphique : NVIDIA GT218M (NVS 3100M) - LMDE 2 Cinnamon - noyau 3.4.6

Hors ligne

Pied de page des forums