Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 11-07-2017 22:23:35

Mercredi
Membre
Distrib. : Testing
Noyau : 4.13
(G)UI : Gnome
Inscription : 25-09-2015

[Résolu] Paquet conservé - non mis à jour par apt

Bonsoir,

La dernière mise à jour me laisse 3 paquets dans l'état "conservé" :

apt list --upgradable


cpp-6/testing 6.4.0-1 amd64 [upgradable from: 6.3.0-18]
gcc-6-base/testing 6.4.0-1 amd64 [upgradable from: 6.3.0-18]
libgfortran3/testing 6.4.0-1 amd64 [upgradable from: 6.3.0-18]



apt upgrade


Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances      
Lecture des informations d'état... Fait
Calcul de la mise à jour... Fait
Les paquets suivants ont été conservés :
  cpp-6 gcc-6-base libgfortran3
0 mis à jour, 0 nouvellement installés, 0 à enlever et 3 non mis à jour.



L'usage de apt full-upgrade ou apt-get dist-upgrade ne donne rien de mieux.
Tous les autres paquets se sont mis à jour normalement, y compris le noyau qui est passé en 4.11.

À noter que j'ai également eu le bug des clés non lisibles par l'utilisateur apt, comme sur ce fil : https://debian-facile.org/viewtopic.php?id=18290

The key(s) in the keyring /etc/apt/trusted.gpg are ignored as the file is not readable by user '_apt' executing apt-key.

Dernière modification par Mercredi (13-07-2017 13:20:16)


De toutes les forces de l'univers, la plus dure à surmonter, c'est la force de l'habitude. T.Pratchett - Trois Soeurcières.

Hors ligne

#2 12-07-2017 00:03:01

robert2a
Membre
Lieu : France
Distrib. : Stretch 9
Noyau : Linux 4.9.0-3 4.9.30-2
(G)UI : Mate
Inscription : 15-11-2014

Re : [Résolu] Paquet conservé - non mis à jour par apt

Bonjour
comment tu te débrouille tongue


apt-get update
 


retour


Ign:1 http://deb.debian.org/debian stretch InRelease
Réception de:2 http://deb.debian.org/debian stretch-updates InRelease [88,5 kB]
Atteint:3 http://security.debian.org/debian-security stretch/updates InRelease
Atteint:4 http://security.debian.org/debian-security buster/updates InRelease  
Réception de:5 http://deb.debian.org/debian buster InRelease [107 kB]
Réception de:6 http://deb.debian.org/debian buster-updates InRelease [46,0 kB]
Atteint:7 http://deb.debian.org/debian stretch Release      
242 ko réceptionnés en 1s (228 ko/s)
Lecture des listes de paquets... Fait
 



apt-get upgrade
 




retour


Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances      
Lecture des informations d'état... Fait
Calcul de la mise à jour... Fait
0 mis à jour, 0 nouvellement installés, 0 à enlever et 0 non mis à jour.
 


tongue  lol
ne force rien laisse faire ça va surement se réparer tout seul , parfois faut etre patient  wink

si je simule l installation de cpp-6


apt-get -s install cpp-6
 


retour


Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances      
Lecture des informations d'état... Fait
cpp-6 is already the newest version (6.4.0-1).
cpp-6 passé en « installé manuellement ».
0 mis à jour, 0 nouvellement installés, 0 à enlever et 0 non mis à jour.
 



les deux autres idem

Dernière modification par robert2a (12-07-2017 00:07:33)

Hors ligne

#3 12-07-2017 07:58:17

chalu
Modératrice
Lieu : Anjou
Distrib. : Debian Stretch
Noyau : Linux 4.9.0-3-amd64
(G)UI : Mate 1.16
Inscription : 11-03-2016

Re : [Résolu] Paquet conservé - non mis à jour par apt

Bonjour r smile
Tu dois avoir un probleme de dépendance.
Si tu essaies une simulation de l'installation des 3 paquets, tu verras peut être les paquets qui bloquent (sans doute pas encore mis à jour sur testing ?)

Hors ligne

#4 12-07-2017 09:31:46

Mercredi
Membre
Distrib. : Testing
Noyau : 4.13
(G)UI : Gnome
Inscription : 25-09-2015

Re : [Résolu] Paquet conservé - non mis à jour par apt

Bonjour,

Merci Chalu, je me doutais bien que c'était une histoire de dépendances mais je ne trouvais pas comment voir lesquelles coinçaient.
Pas pensé à essayer une installation vu que c'est déjà installé mais ça permet en effet de voir les dépendances qui bloquent smile

Exemple avec cpp-6

apt -s install ccp-6


Certains paquets ne peuvent être installés. Ceci peut signifier
que vous avez demandé l'impossible, ou bien, si vous utilisez
la distribution unstable, que certains paquets n'ont pas encore
été créés ou ne sont pas sortis d'Incoming.
L'information suivante devrait vous aider à résoudre la situation :

Les paquets suivants contiennent des dépendances non satisfaites :
 cpp-6 : Dépend: gcc-6-base (= 6.4.0-1) mais 6.3.0-18 devra être installé
E: Impossible de corriger les problèmes, des paquets défectueux sont en mode « garder en l'état ».



Avec ça je vais peut-être arriver à démêler les nœuds. Je regarde plus en détail ce midi et je vous redis, là je passe en coup de vent.

robert2a a écrit :

comment tu te débrouille tongue


J'ai un don pour le bizarre lol


De toutes les forces de l'univers, la plus dure à surmonter, c'est la force de l'habitude. T.Pratchett - Trois Soeurcières.

Hors ligne

#5 12-07-2017 12:37:41

robert2a
Membre
Lieu : France
Distrib. : Stretch 9
Noyau : Linux 4.9.0-3 4.9.30-2
(G)UI : Mate
Inscription : 15-11-2014

Re : [Résolu] Paquet conservé - non mis à jour par apt

Bonjour
tu a aptitude aussi qui te propose des solutions. ( a part -f qui me fait toujours un peu peur  roll  )

comme dit chalu tester une simulation (-s) avec un des 3 paquets (voir la réponse )  tu a "apt-get -s --reinstall install lepaquet"  comme nuance

comme je n'ai eu aucun soucis avec ces 3 paquets , il doit y avoir surement une raison , faut trouver le pourquoi  hmm

Hors ligne

#6 12-07-2017 12:43:10

nIQnutn
Modérateur
Lieu : Lyon
Distrib. : Stretch
Noyau : Linux 4.9.0-3-amd64
(G)UI : Gnome
Inscription : 16-03-2012
Site Web

Re : [Résolu] Paquet conservé - non mis à jour par apt

robert2a a écrit :

il doit y avoir surement une raison , faut trouver le pourquoi  hmm


un problème de karma out.gif

Hors ligne

#7 12-07-2017 13:23:50

robert2a
Membre
Lieu : France
Distrib. : Stretch 9
Noyau : Linux 4.9.0-3 4.9.30-2
(G)UI : Mate
Inscription : 15-11-2014

Re : [Résolu] Paquet conservé - non mis à jour par apt

nIQnutn a écrit :

robert2a a écrit :

il doit y avoir surement une raison , faut trouver le pourquoi  hmm


un problème de karma



comme j'ai 4 machines sans ce souci  peut etre  tongue  tongue
sur Sid j'ai eu mand.db indisponible pour mise a jour et j'ai refusé 2 paquets avec un bogue  ce matin
si la machine tourne en permanence peut etre aussi un reboot c'est bien roll

Dernière modification par robert2a (12-07-2017 13:25:21)

Hors ligne

#8 12-07-2017 17:24:25

Mercredi
Membre
Distrib. : Testing
Noyau : 4.13
(G)UI : Gnome
Inscription : 25-09-2015

Re : [Résolu] Paquet conservé - non mis à jour par apt

nIQnutn a écrit :

un problème de karma


Ptêt bien lol
J'ai testé sur une VM en Testing pas mise à jour depuis plusieurs jours -> aucun souci.

Le reboot a été testé wink
Si je simule la réinstallation de gcc-6-base, apt veut me désinstaller Debian presque au complet scratchhead.gif
Je me demande si la migration Stretch -> Testing est bien allée jusqu'au bout quand j'ai réinstallé il y a 10 jours. Pas eu de message d'erreur mais sait-on jamais. Je passerai en pure console tout à l'heure, après une sauvegarde et en stoppant gdm pour voir ce que ça donne "en vrai".

Edit : après essai toujours au même point, aptitude ne propose pas mieux.

robert2a a écrit :

ne force rien laisse faire ça va surement se réparer tout seul , parfois faut etre patient  wink



Je vais suivre ce conseil et attendre quelques jours voir ce qui se passe smile je mets le fil en pause en attendant.

merci.gif

Dernière modification par Mercredi (12-07-2017 21:58:14)


De toutes les forces de l'univers, la plus dure à surmonter, c'est la force de l'habitude. T.Pratchett - Trois Soeurcières.

Hors ligne

#9 13-07-2017 13:20:00

Mercredi
Membre
Distrib. : Testing
Noyau : 4.13
(G)UI : Gnome
Inscription : 25-09-2015

Re : [Résolu] Paquet conservé - non mis à jour par apt

Bonjour,

À force d'agacer Aptitude il a fini par proposer une solution tongue je trouve quand même étrange qu'il donne d'abord les solutions qui désinstallent presque tout en premier. roll

Le paquet "dépendant" qui bloquait est libstdc++6, resté en version 6.3.0-18 car épinglé par apt-listbugs pour ce bug : https://bugs.debian.org/cgi-bin/bugrepo … bug=866354
En autorisant sa mise à jour en version 7.1.0-9 (je prends le risque du bug, sous la haute protection de mon karma lol ) , mes 3 autres paquets se mettent à jour aussi smile

Merci à tous cool

De toutes les forces de l'univers, la plus dure à surmonter, c'est la force de l'habitude. T.Pratchett - Trois Soeurcières.

Hors ligne

#10 13-07-2017 14:04:48

robert2a
Membre
Lieu : France
Distrib. : Stretch 9
Noyau : Linux 4.9.0-3 4.9.30-2
(G)UI : Mate
Inscription : 15-11-2014

Re : [Résolu] Paquet conservé - non mis à jour par apt

Bonjour

il me semble que ce bug touche "armel" mais pas "amd64"  sur ton lien ?
sur testing ou sid j' évite de bloquer les paquets sur une version , je ne le sélectionne pas pour mise a jour , a la prochaine il va etre de nouveau dans la liste des mises a jour .

ps: sur stable j'ai bloqué plusieurs dizaines de paquets pour rester sur une version mais ça reste sportif aussi  tongue

Aptitude est bien pratique parfois  smile

Hors ligne

#11 13-07-2017 22:50:26

Mercredi
Membre
Distrib. : Testing
Noyau : 4.13
(G)UI : Gnome
Inscription : 25-09-2015

Re : [Résolu] Paquet conservé - non mis à jour par apt

Ah oui j'avais juste focalisé sur mesa qui si j'ai bien compris intervient dans  l'accélération graphique.

Faudra que j'étudie un peu plus aptitude, comme tu dis bien pratique parfois, je ne m'en serais pas sortie avec apt.

De toutes les forces de l'univers, la plus dure à surmonter, c'est la force de l'habitude. T.Pratchett - Trois Soeurcières.

Hors ligne

#12 14-07-2017 01:53:38

robert2a
Membre
Lieu : France
Distrib. : Stretch 9
Noyau : Linux 4.9.0-3 4.9.30-2
(G)UI : Mate
Inscription : 15-11-2014

Re : [Résolu] Paquet conservé - non mis à jour par apt

tu fonctionne avec un driver libre ?
oui Mesa prend en charge le matériel graphique , 3D (OpenGL  OpenCL (équivalent en libre ), et Vulkan ) , la lecture des  vidéos
les deux paquets principaux encore pas mal de bugs  hmm


libgl1-mesa-dri (56 bugs: 0, 53, 3, 0)
libgl1-mesa-glx (11 bugs: 0, 10, 1, 0)
 


au total 102 bugs mais je me demande si c'est que pour Mesa17
mais bon avec Amd j' avance pas trop , soit la carte est trop vieille , soit trop récente .
avec Blender pas moyen de faire fonctionner le gpu , comme option j'ai "none"  tongue
PS : je sais pas pourquoi ils sont passé de la version 13 directement a 17  roll

Hors ligne

#13 14-07-2017 16:32:45

Mercredi
Membre
Distrib. : Testing
Noyau : 4.13
(G)UI : Gnome
Inscription : 25-09-2015

Re : [Résolu] Paquet conservé - non mis à jour par apt

Bonjour,

J'ai des paquets liés à mesa qui sont installés automatiquement par Debian, ceux que tu cites en font partie.
Ensuite j'ajoute le paquet firmware-amd-graphics sinon l'affichage est vilain.

Après je vire les paquets xserver-xorg-video-ati + xserver-xorg-video-radeon + xserver-xorg-video-amdgpu comme tu l'avais expliqué pour forcer la prise en charge de la carte directement par le noyau (kernel mode setting).
Avec kms la fluidité - rapidité d'affichage est équivalente à celle de Gome Wayland smile

Ps : j'ai un peu de mal avec la gestion du matériel, j'apprends/comprends à la vitesse d'un escargot.

Dernière modification par Mercredi (14-07-2017 16:33:09)


De toutes les forces de l'univers, la plus dure à surmonter, c'est la force de l'habitude. T.Pratchett - Trois Soeurcières.

Hors ligne

#14 14-07-2017 21:31:34

robert2a
Membre
Lieu : France
Distrib. : Stretch 9
Noyau : Linux 4.9.0-3 4.9.30-2
(G)UI : Mate
Inscription : 15-11-2014

Re : [Résolu] Paquet conservé - non mis à jour par apt

Bonjour
tout dépend de la carte graphique , avec la RX550 le xserver-xorg-video-amdgpu fonctionne bien , KMS pas terrible
pour mesa dans synaptic , sur "recherche" tu tape "mesa" , il va te donner la liste , personnellement j' installe tout (avec le driver libre ), tu a quelques paquets en dépendances aussi.
la ou je rale c'est que mesa coince avec certaines applications propriétaire , c'est pas juste .....   roll   old_geek.gif
surtout que pour Amd le driver propriétaire je m'en passe volontier  tongue
peut etre qu avec Vulkan les choses vont changer ( installe "mesa vulkan" meme si pour l'instant pas trop d application l utilise )
bien vérifier que tout les paquets sont en versions 17 (normalement oui )
tu a des utilitaires pour tester (clinfo , glxinfo , glxgears , vulkaninfo  etc .... ) meme si on comprend pas les retours parfois c'est utile  tongue

PS: ce soir mise a jour de sécurité pour Mate , l'afficheur de document evince et dépendances sur Buster  (pas fait attention si c'est le cas sur Sid )
avec le sources.list  Stretch + Buster

Dernière modification par robert2a (15-07-2017 00:03:04)

Hors ligne

#15 15-07-2017 16:43:31

Mercredi
Membre
Distrib. : Testing
Noyau : 4.13
(G)UI : Gnome
Inscription : 25-09-2015

Re : [Résolu] Paquet conservé - non mis à jour par apt

Bonjour,

Il faudra que je regarde ça en détail quand je serais tranquille smile

De toutes les forces de l'univers, la plus dure à surmonter, c'est la force de l'habitude. T.Pratchett - Trois Soeurcières.

Hors ligne

Pied de page des forums