Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 30-09-2009 02:44:27

Goret
Membre
Inscription : 30-09-2009

Installer mencoder-1.0rc1

Bonjour les gens,

J'ai un petit souci sur lequel je commence à tourner en rond.

Soit la situation suivante : un serveur LAMP installé sur une Debian Etch et avec comme sources.list

deb http://ftp.fr.debian.org/debian/ etch main
deb-src http://ftp.fr.debian.org/debian/ etch main
## security
deb http://security.debian.org/ etch/updates main
deb-src http://security.debian.org/ etch/updates main
## volatile
deb http://volatile.debian.org/debian-volatile etch/volatile main contrib non-free
deb http://ftp2.de.debian.org/debian-volatile etch/volatile main
## multimedia
deb http://www.debian-multimedia.org etch main
deb-src http://www.debian-multimedia.org etch main


Sur ce serveur, je dois faire tourner un site de vidéos qui fonctionne avec le script ClipShare. Pour que ce script fonctionne, il faut installer un certain nombre de programmes, ce qui a été fait à l'aide de apt-get.

Jusqu'ici, c'est une installation que j'avais déjà faite auparavant (pour un autre site de vidéos) et qui a très bien marché.

Seulement là, je suis passé sur une distribution virtualisée (Proxmox) et il y a comme qui dirait un binz : les vidéos uploadées sur le site ne sont pas converties.

Après des recherches sur le forum de ClipShare, je me suis rendu compte que c'est probablement dû au fait que la version de mencoder que j'ai installée (apt-get mencoder) est :

MEncoder dev-SVN-rUNKNOWN-4.1.2 (C) 2000-2006 MPlayer Team


Or, pour bien faire, il faudrait que j'aie une version plus ancienne. Idéalement la 1.0rc1.

Comme je ne suis pas un cador de Debian (ni de Linux en règle générale), est-ce qu'une bonne âme pourrait m'expliquer la marche à suivre pour "downgrader" le soft ? smile

Hors ligne

#2 30-09-2009 02:52:07

martinux_qc
Administrateur
Lieu : Montréal (Québec)
Distrib. : Sid
Noyau : Linux 4.7.0-1-amd64
(G)UI : XFCE 4.12
Inscription : 12-10-2008

Re : Installer mencoder-1.0rc1

Salut

Si je regarde sur le site de debian-multimedia, la version de mencoder semble bien corresponde à celle que tu cherches. Où as-tu celle qui tu as présentement ?

En faisant un

man apt-get


On peut lire ceci

On peut choisir d´installer une version particulière d´un paquet en faisant suivre son nom par un signe égal et par la version. Cette version sera recherchée et l´installation sera demandée.


Avant de procéder, il est toujours bon de faire un

apt-get -s install le_paquet


L'option -s c'est pour simulation.

Martin

Dernière modification par martinux_qc (30-09-2009 03:03:14)


"L'éducation vise à former des citoyens pas trop tatas et non pas à envoyer le plus de tatas possible à l'université."
Pierre Foglia (Journaliste à la retraite à La Presse)
Note : au Québec, le mot tata a un sens péjoratif qui sert à désigner une personne un peu idiote ou insignifiante. D'où les expressions familières : Espèce de grand, de gros tata! Être, avoir l'air tata.

Hors ligne

#3 30-09-2009 03:02:06

Goret
Membre
Inscription : 30-09-2009

Re : Installer mencoder-1.0rc1

Salut Martin,

Merci de ta réponse rapide.

De fait, la version semble être la bonne (c'est probablement pour cela que mes installations précédentes n'ont pas posé de problème). Mais malheureusement, cette fois-ci, cela ne semble pas marcher comme il faut. Voici ce qui se passe à la désinstallation / réisnatllation :

# apt-get remove mencoder
Reading package lists... Done
Building dependency tree... Done
The following packages will be REMOVED:
  mencoder
0 upgraded, 0 newly installed, 1 to remove and 0 not upgraded.
Need to get 0B of archives.
After unpacking 5226kB disk space will be freed.
Do you want to continue [Y/n]? y
(Reading database ... 59058 files and directories currently installed.)
Removing mencoder ...

# apt-get install  mencoder
Reading package lists... Done
Building dependency tree... Done
Suggested packages:
  libdvdcss mplayer-doc
The following NEW packages will be installed:
  mencoder
0 upgraded, 1 newly installed, 0 to remove and 0 not upgraded.
Need to get 0B/2627kB of archives.
After unpacking 5226kB of additional disk space will be used.
Selecting previously deselected package mencoder.
(Reading database ... 59044 files and directories currently installed.)
Unpacking mencoder (from .../mencoder_1%3a1.0-rc1svn20070225-0.3etch1_i386.deb) ...
Setting up mencoder (1.0-rc1svn20070225-0.3etch1) ...


Je me retrouve systématiquement avec cette version "SVN" qui fait buguer ClipShare sad

Hors ligne

#4 30-09-2009 03:05:22

martinux_qc
Administrateur
Lieu : Montréal (Québec)
Distrib. : Sid
Noyau : Linux 4.7.0-1-amd64
(G)UI : XFCE 4.12
Inscription : 12-10-2008

Re : Installer mencoder-1.0rc1

Salut

Je viens d'éditer mon message précédent. Tente le coup en spécifiant la version désirée.

Regarde aussi dans le man de apt-get. Tu peux faire un apt-get clean ou autoclean pour enlever les anciens paquets présents sur ton ordi.

Tu n'as pas dit d'où provient cette version récente de mencoder.

Martin

Dernière modification par martinux_qc (30-09-2009 03:08:49)


"L'éducation vise à former des citoyens pas trop tatas et non pas à envoyer le plus de tatas possible à l'université."
Pierre Foglia (Journaliste à la retraite à La Presse)
Note : au Québec, le mot tata a un sens péjoratif qui sert à désigner une personne un peu idiote ou insignifiante. D'où les expressions familières : Espèce de grand, de gros tata! Être, avoir l'air tata.

Hors ligne

#5 30-09-2009 03:10:07

martinux_qc
Administrateur
Lieu : Montréal (Québec)
Distrib. : Sid
Noyau : Linux 4.7.0-1-amd64
(G)UI : XFCE 4.12
Inscription : 12-10-2008

Re : Installer mencoder-1.0rc1

Que donne un

apt-cache policy mencoder


?


"L'éducation vise à former des citoyens pas trop tatas et non pas à envoyer le plus de tatas possible à l'université."
Pierre Foglia (Journaliste à la retraite à La Presse)
Note : au Québec, le mot tata a un sens péjoratif qui sert à désigner une personne un peu idiote ou insignifiante. D'où les expressions familières : Espèce de grand, de gros tata! Être, avoir l'air tata.

Hors ligne

#6 30-09-2009 03:20:10

Goret
Membre
Inscription : 30-09-2009

Re : Installer mencoder-1.0rc1

Rectification par rapport à mon message précédent : la version de debian-multimedia est également une SVN, ce qu'il me faudrait éviter.

martin_mtl a écrit :

Regarde aussi dans le man de apt-get. Tu peux faire un apt-get clean ou autoclean pour enlever les anciens paquets présents sur ton ordi.


Tu as raison, il est peut-être temps que je fasse un petit "man apt-get" roll

martin_mtl a écrit :

Tu n'as pas dit d'où provient cette version récente de mencoder.


Des dépot qui se trouvent dans mon sources.list : je n'ai rien fait d'autre que des "apt-get install" et des "apt-get remove".

martin_mtl a écrit :

Que donne un

apt-cache policy mencoder


?


# apt-cache policy mencoder
mencoder:
  Installed: (none)
  Candidate: 1:1.0-rc1svn20070225-0.3etch1
  Version table:
     1:1.0-rc1svn20070225-0.3etch1 0
        500 http://www.debian-multimedia.org etch/main Packages

Hors ligne

#7 30-09-2009 03:26:37

martinux_qc
Administrateur
Lieu : Montréal (Québec)
Distrib. : Sid
Noyau : Linux 4.7.0-1-amd64
(G)UI : XFCE 4.12
Inscription : 12-10-2008

Re : Installer mencoder-1.0rc1

Salut

apt-cache policy mencoder
mencoder:
  Installed: (none)
  Candidate: 1:1.0-rc1svn20070225-0.3etch1
  Version table:
     1:1.0-rc1svn20070225-0.3etch1 0
        500 http://www.debian-multimedia.org etch/main Packages


J'ai manqué quelque chose où le dernier apt-get install n'a pas fonctionné. Là, mencoder n'est pas installé.

Pour avoir une version plus ancienne de mencoder je vois deux solutions :
1) Faire une recherche sur internet pour voir s'il existe un .deb pour la version recherchée.
2) Sinon, essayer de trouver les sources de la version visée puis la compiler.

Avoir une version plus ancienne que celle existant pour l'ancienne stable, cela demande un peu de recherche. C'est pas évident. Pour le moment, je ne sais pas. Si je trouve quelque chose que viendrai le poster ici.

Martin

Dernière modification par martinux_qc (30-09-2009 03:45:31)


"L'éducation vise à former des citoyens pas trop tatas et non pas à envoyer le plus de tatas possible à l'université."
Pierre Foglia (Journaliste à la retraite à La Presse)
Note : au Québec, le mot tata a un sens péjoratif qui sert à désigner une personne un peu idiote ou insignifiante. D'où les expressions familières : Espèce de grand, de gros tata! Être, avoir l'air tata.

Hors ligne

#8 30-09-2009 19:12:03

Goret
Membre
Inscription : 30-09-2009

Re : Installer mencoder-1.0rc1

Me revoici avec quelques heures d'essais supplémentaires.

martin_mtl a écrit :

Salut

apt-cache policy mencoder
mencoder:
  Installed: (none)
  Candidate: 1:1.0-rc1svn20070225-0.3etch1
  Version table:
     1:1.0-rc1svn20070225-0.3etch1 0
        500 http://www.debian-multimedia.org etch/main Packages


J'ai manqué quelque chose où le dernier apt-get install n'a pas fonctionné. Là, mencoder n'est pas installé.


Tu as raison j'avais lancé "apt-cache policy mencoder" entre deux désinstallation/réinstallation de mencoder. Avec le programme installé, cela donne évidemment ceci :

# apt-cache policy mencoder
mencoder:
  Installed: 1:1.0-rc1svn20070225-0.3etch1
  Candidate: 1:1.0-rc1svn20070225-0.3etch1
  Version table:
*** 1:1.0-rc1svn20070225-0.3etch1 0
        500 http://www.debian-multimedia.org etch/main Packages
        100 /var/lib/dpkg/status


martin_mtl a écrit :

Pour avoir une version plus ancienne de mencoder je vois deux solutions :
1) Faire une recherche sur internet pour voir s'il existe un .deb pour la version recherchée.
2) Sinon, essayer de trouver les sources de la version visée puis la compiler.


J'avais pensé à ces deux solutions (comme quoi j'étais parti sur les bonnes pistes, ça me rassure un peu smile).

1) Je n'ai trouvé aucun .deb qui corresponde à ce que je cherche après moult googelisations.
2) Tout ce que j'ai trouvé sont les sources de MPlayer (que je n'ai pas encore osé compiler jusqu'à présent).

En désepoir de cause, j'ai donc décidé de prendre le problème par l'autre bout : puisque les dépôts Debian ne peuvent satisfaire le script, essayons d'adapter le script à ce que me fournit Debian. J'ai donc passé quelques heures sur les instructions kilométriques de mencoder et j'ai fini par réussir à lui faire convertir les vidéos comme je le souhaite. Il ne restait plus alors qu'à modifier le code PHP du script et ... cela marche désormais très bien : le site est opérationnel smile

Quoi qu'il en soit, je te remercie chaleureusement de ton dévouement (et je reste à l'écoute sur les questions de downgrade : elles ont titillé ma curiosité smile).

Dernière modification par Goret (30-09-2009 19:14:30)

Hors ligne

Pied de page des forums