Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 29-07-2017 11:25:07

gargamel79
Membre
Lieu : Bressuire
Distrib. : wheezy et jessie
(G)UI : xfce
Inscription : 15-11-2009

[Résolu] Impossible de réparer des paquets cassés

Bonjour , j'ai des problèmes de mise à jour avec jessie.
Après install de netSurf, est-ce un hasard?
Avec synaptic, commande  : Tout mettre à niveau
message :
Impossible de mettre à jour le système. Corrigez d'abord les paquets cassés.

Etat | Dépendances cassées -> rien

Nouvelle ouverture de synaptic
A désinstaller
vlc-plugin-notify
A installer
lib-vlc-bin
vlc-bin
vlc-l10n
A mettre à jour
libvlc5

E:Erreur, pkgProblem::Resolve a généré des ruptures, ce qui a pu être causé par les paquets devant être gardés en l'état.

J'ai essayé de déinstaller complétement vlc, j'obtiens le même genre de message.

Merci pour un peu d'aide, je ne vois rien sur le forum qui corresponde à mon problème.

Dernière modification par gargamel79 (29-07-2017 19:27:16)

Hors ligne

#2 29-07-2017 11:53:27

Croutons
Membre
Distrib. : Handylinux 2.5 vers Jessie et Debian Stretch
Noyau : Linux 3.16.0-4-686-pae, Linux 4.9.0-3-686-pae
(G)UI : xfce
Inscription : 16-12-2016

Re : [Résolu] Impossible de réparer des paquets cassés

Bonjour
Que te renvoi

apt-cache policy vlc


-->les cahiers du debutant<--      WikiDF-->Découvrir les principales commandes Linux<--
L' expérience, c'est le nom que chacun donne à ses erreurs. Oscar Wilde

Hors ligne

#3 29-07-2017 12:13:04

gargamel79
Membre
Lieu : Bressuire
Distrib. : wheezy et jessie
(G)UI : xfce
Inscription : 15-11-2009

Re : [Résolu] Impossible de réparer des paquets cassés

Merci pour ta réponse, voici ce que la commande renvoie:
# apt-cache policy vlc
vlc:
  Installé : 1:2.2.1-dmo3+deb8u3
  Candidat : 1:2.2.6-dmo2+deb9u1
Table de version :
     1:2.2.6-dmo2+deb9u1 0
        500 http://www.deb-multimedia.org/ stable/main amd64 Packages
*** 1:2.2.1-dmo3+deb8u3 0
        100 /var/lib/dpkg/status
     2.2.6-1~deb8u1 0
        500 http://ftp.fr.debian.org/debian/ jessie/main amd64 Packages
        500 http://security.debian.org/ jessie/updates/main amd64 Packages

Edit à toto :

Voilà comment présenter une commande user et son retour lisiblement par tous :

apt-cache policy vlc


vlc:
  Installé : 1:2.2.1-dmo3+deb8u3
  Candidat : 1:2.2.6-dmo2+deb9u1
Table de version :
     1:2.2.6-dmo2+deb9u1 0
        500 http://www.deb-multimedia.org/ stable/main amd64 Packages
*** 1:2.2.1-dmo3+deb8u3 0
        100 /var/lib/dpkg/status
     2.2.6-1~deb8u1 0
        500 http://ftp.fr.debian.org/debian/ jessie/main amd64 Packages
        500 http://security.debian.org/ jessie/updates/main amd64 Packages

Hors ligne

#4 29-07-2017 14:29:14

gargamel79
Membre
Lieu : Bressuire
Distrib. : wheezy et jessie
(G)UI : xfce
Inscription : 15-11-2009

Re : [Résolu] Impossible de réparer des paquets cassés

J'avais commis une petite erreur: il s'agissait de commandes dans synaptic, j'ai corrigé dans mon premier poste.

Hors ligne

#5 29-07-2017 15:14:22

Croutons
Membre
Distrib. : Handylinux 2.5 vers Jessie et Debian Stretch
Noyau : Linux 3.16.0-4-686-pae, Linux 4.9.0-3-686-pae
(G)UI : xfce
Inscription : 16-12-2016

Re : [Résolu] Impossible de réparer des paquets cassés

Comme tu peux le voir 2 versions existe celle du depot externe multimedia et celle du depots Debian
Le dépôts multumédia possède la même priorité que Jessie main
Me semble que tu as un mélange des 2 versions, je ne sais pas comment interpreter

Candidat : 1:2.2.6-dmo2+deb9u1


chez moi

apt-cache policy vlc


Installé : 1:2.2.1-dmo3+deb8u1
  Candidat : 1:2.2.1-dmo3+deb8u1
 Table de version :
 *** 1:2.2.1-dmo3+deb8u1 0
        100 /var/lib/dpkg/status
     2.2.6-1~deb8u1 0
        500 http://httpredir.debian.org/debian/ jessie/main i386 Packages
        500 http://security.debian.org/ jessie/updates/main i386 Packages
 


Version installé et candidat sont les mêmes, la version a été mise a jour depuis le dépot multimedia un jour ou celui ci était activé
mais maintenant je reste avec cette version
De maniére générale je commente la ligne du dépôt multimédia
tente de deinstaller puis de réinstaller depuis les depots Debian

apt-get purge vlc


apt update

pour recharger la liste des dépots

apres soit tu commente le dépot multimedia dans tes sources ou tu forces l'installation de la version dépot Debian
perso je préfere activé le dépot multimedia quand il y a besoin çà évite d'avoir des mises a jour supplémentaire qui ne sont pas necessaire

apt install  vlc/oldstable

installera la version 2.2.6 depuis oldstable c'est a dire Jessie puisque maintenant Stretch est la nouvelle version stable
si tu change le sources.list pense a refaire

apt update


-->les cahiers du debutant<--      WikiDF-->Découvrir les principales commandes Linux<--
L' expérience, c'est le nom que chacun donne à ses erreurs. Oscar Wilde

Hors ligne

#6 29-07-2017 19:26:02

gargamel79
Membre
Lieu : Bressuire
Distrib. : wheezy et jessie
(G)UI : xfce
Inscription : 15-11-2009

Re : [Résolu] Impossible de réparer des paquets cassés

Merci pour ton aide qui m'a été précieuse. Voici ce que j'ai fait;
1) j'ai pu supprimer vlc avec : apt-get purge vlc  Ce que je n'arrivais pas à faire avec synaptic.
   A partir de là, je n'avais plus de problème de mise à jour avec synaptic.
2) j'ai modifié le sources.list
   pour le dépôt multimédia, j'ai effectivement remplacé "stable" par "oldstable"
3) la réinstallation de vlc par : apt install  vlc/oldstable s'est bien passée
  Avec: apt-cache policy vlc j'obtiens bien:
    vlc:
     Installé : 1:2.2.1-dmo3+deb8u4
     Candidat : 1:2.2.1-dmo3+deb8u4
  Encore merci pour ton aide smile

Hors ligne

#7 30-07-2017 09:50:43

Croutons
Membre
Distrib. : Handylinux 2.5 vers Jessie et Debian Stretch
Noyau : Linux 3.16.0-4-686-pae, Linux 4.9.0-3-686-pae
(G)UI : xfce
Inscription : 16-12-2016

Re : [Résolu] Impossible de réparer des paquets cassés

Bonjour
Bien que ce soit résolu, petite précision
Il est préférable de mettre le nom de version Jessie dans le sources liste

deb http://www.deb-multimedia.org jessie main non-free


Il est probable que tu rencontres d'autre problèmes car en ayant mis le nom d'archive stable sur le dépôt multimedia tu as a changé de version de dépot automatiquement des que Debian 9 Stretch est passé en version stable
Autrement dit tu dois avoir des paquets qui proviennent de Debian Strecht, donc un mélange Stretch et Jessie pas cool

Je t'invite a consulter le wiki sur ce sujet-->sources.list
Surtout l'avertissement
On ne mélange jamais nom de code et nom d’archive dans le même sources.list.


-->les cahiers du debutant<--      WikiDF-->Découvrir les principales commandes Linux<--
L' expérience, c'est le nom que chacun donne à ses erreurs. Oscar Wilde

Hors ligne

Pied de page des forums