Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 29-07-2017 22:35:46

Philou92
Adhérent(e)
Lieu : Hauts de Seine
Distrib. : Debian Jessie 8.9
Noyau : Linux 3.16.0-4-amd64
(G)UI : Gnome 3.14
Inscription : 29-04-2015

Enigmail ne se met pas à jour dans jessie avec la v52 de Thunderbird

Hello,

Une mise à jour de sécurité est disponible pour enigmail mais elle ne s'installe pas avec au apt-get upgrade.

Note J'ai la dernière vesrion Thunderbird  1.52

Quand je consulte le site  https://packages.debian.org/search?keyw … lla-search

Chose curieuse, il y a deux versions de paquet pour la même source.

jessie (oldstable) (mail): GPG support for Thunderbird and Debian Icedove
2:1.9.8.1-1~deb8u1 [security]: all
2:1.8.2-4~deb8u1: amd64 arm64 armel armhf i386 mips mipsel powerpc ppc64el s390x



Je ne sais pas si cela a une relation mais depuis enigmail ne déchiffre plus mes mails.

Comment mettre à jour enigmail ?sos.gif


Dernière minute j'ai trouvé une déclaration de bug critique à ce sujet, néamoins si vous avez un début de solution ce serai chouette. smile
https://bugs.debian.org/cgi-bin/bugrepo … bug=869774

Dernière modification par Philou92 (29-07-2017 23:52:14)

Hors ligne

#2 29-07-2017 23:15:35

nono47
Membre
Lieu : dans l'engrenage ...
Distrib. : sid
Noyau : Linux 4.13.0-1-amd64
(G)UI : gnome-shell
Inscription : 09-05-2012

Re : Enigmail ne se met pas à jour dans jessie avec la v52 de Thunderbird

Salut,

Pour éviter d'installer des paquets bogués, il y a le paquet apt-listbugs .
Des explications et le mode d'emploi sur le wiki ; https://debian-facile.org/doc:systeme:apt:apt-listbugs

Sinon pour enigmail, tu peux essayer avec aptitude en ligne de commande à la place de apt-get, il résout les dépendances différemment,
tu peux lui répondre (n)on pour qu'il te cherche une autre solution .
Vois si il te propose une solution pertinente ( genre retourner à l'ancienne version ) .

Pour utiliser aptitude : https://debian-facile.org/doc:systeme:apt:aptitude
L'option -s permet de simuler avant de faire des changements .

Mais bon si le bug est connu, il devrait être corriger bientôt .

smile

Dernière modification par nono47 (29-07-2017 23:19:53)

Hors ligne

#3 29-07-2017 23:41:01

Trefix
Adhérent(e)
Lieu : 48
Distrib. : kiss0s-0.5
Noyau : Linux 3.16.0-4-amd64
(G)UI : Fluxbox by arpinux
Inscription : 15-02-2015

Re : Enigmail ne se met pas à jour dans jessie avec la v52 de Thunderbird

Coucou.

Message pour dire qu'il ne déchiffre plus et lien vers la mise-à-jour (version 1.9). Ensuite, installation depuis TB et ça roule.

Par contre le procédé de la mise à jour "forcée" me hérisse et je vais chercher un autre client PGP, ça risque, avec ma "tête de con"...

HL > DF // Les cahiers du débutant // DFLinux
.
JE SUIS toujours abonné à CHARLIE

Hors ligne

#4 29-07-2017 23:51:19

Philou92
Adhérent(e)
Lieu : Hauts de Seine
Distrib. : Debian Jessie 8.9
Noyau : Linux 3.16.0-4-amd64
(G)UI : Gnome 3.14
Inscription : 29-04-2015

Re : Enigmail ne se met pas à jour dans jessie avec la v52 de Thunderbird

Merci pour vos réponses.

Bon je me suis fadé la lecture des mails du rapport de bug. En résumé il y a eu un loupé pour l'intégration de la mise à jour pour jessie bien que les mainteneurs connaissaient le problème.

Je pense comme le propose nono47 d'attendre un correctif plutôt que d'installer le le module complémentaire mozilla à la place.

En attendant je laisse ouvert le sujet et j'amende le titre pour être plus précis.

Hors ligne

#5 30-07-2017 00:05:33

Trefix
Adhérent(e)
Lieu : 48
Distrib. : kiss0s-0.5
Noyau : Linux 3.16.0-4-amd64
(G)UI : Fluxbox by arpinux
Inscription : 15-02-2015

Re : Enigmail ne se met pas à jour dans jessie avec la v52 de Thunderbird

Ben c'est ch... de ne pas pouvoir lire ses mails (ceux qui viennent d'utilisateurs sérieux qui chiffrent). Mais je suis nettement 1786228450.gif

HL > DF // Les cahiers du débutant // DFLinux
.
JE SUIS toujours abonné à CHARLIE

Hors ligne

#6 31-07-2017 23:40:54

Philou92
Adhérent(e)
Lieu : Hauts de Seine
Distrib. : Debian Jessie 8.9
Noyau : Linux 3.16.0-4-amd64
(G)UI : Gnome 3.14
Inscription : 29-04-2015

Re : Enigmail ne se met pas à jour dans jessie avec la v52 de Thunderbird

Hello,

Le paquet mis à jour tant attendu est arrivé. smile

Je l'ai installé, Enigmail fonctionne de nouveau mais... neutral

Lors d'un déchiffrage de mail il me lance ce message : sad

GnuPG a rapporté une erreur de communication avec gpg-agent (un composant de GnuPG).

Ceci est une erreur d'installation ou de configuration qui empêche Enigmail de fonctionner correctement et qui ne peut pas être corrigée automatiquement.

Nous vous conseillons vivement de consulter notre page de soutien sur notre site Internet à l'adresse https://enigmail.net/faq.



En cliquouillant (néologisme Massignolesque tongue) sur "OK" 3 à 4 fois, enigmail (le bougre) consent à déchiffrer mon message.

Note je n'ai rien trouvé de pertinent dans la faq enigmail.

En cherchant dans le menu préférence-Général à l'alinéa Fichier et répertoires Il déclare GnuPG trouvé dans /usr/bin/gpg2

N'est-ce pas la le souci sachant que gpg2 n'est actif que dans Strech (gpg2 est a priori une biliothèque) ?
Faut-il forcer GnuPG à pointer sur le fichier /usr/bin/gpg ?
Quelqu'un a-t-il gardé l'ancienne version thunderbird v45 et pourrait-il me donner ce qui est écrit dans ce même menu?

A vo't bon cœur. smile

...Dernière minute, pour l'envoi de mail signé, même message d'erreur. Mais cette fois le mail n'est pas envoyé... sad sad sad

Dernière modification par Philou92 (31-07-2017 23:48:28)

Hors ligne

#7 01-08-2017 08:34:42

èfpé
Membre
Inscription : 10-07-2016

Re : Enigmail ne se met pas à jour dans jessie avec la v52 de Thunderbird

Bonjour,

Enigmail 1.9.x requiert GnuPG 2.x, donc pas de souci de ce côté-là (ce n'est pas que gpg2 n'est actif que sur Stretch, c'est que sur Stretch gpg2 s'appelle gpg et que sur Jessie, les deux versions peuvent coexister) ; pour ce qui concerne ton souci il semble que l'entrée « Resolving issues with GnuPG 2.x and gpg-agent » est un petit peu pertinente quand même (vois ici ou ). La version courte smile

Dernière modification par èfpé (01-08-2017 09:04:42)

Hors ligne

#8 01-08-2017 22:12:37

Philou92
Adhérent(e)
Lieu : Hauts de Seine
Distrib. : Debian Jessie 8.9
Noyau : Linux 3.16.0-4-amd64
(G)UI : Gnome 3.14
Inscription : 29-04-2015

Re : Enigmail ne se met pas à jour dans jessie avec la v52 de Thunderbird

èfpé a écrit :

et que sur Jessie, les deux versions peuvent coexister)



Ah! Et comment faire quand on est en stable et qu'on souhaite le rester ?

Sinon je ne comprends toujours pas comment résoudre le problème.

Bon en attendant je lorgne coté "evolution", cela à l'air plus stable dans le rythme des montées de version et la maintenance des plus vieilles.

Dernière modification par Philou92 (04-08-2017 09:51:52)

Hors ligne

#9 01-08-2017 23:30:48

Philou92
Adhérent(e)
Lieu : Hauts de Seine
Distrib. : Debian Jessie 8.9
Noyau : Linux 3.16.0-4-amd64
(G)UI : Gnome 3.14
Inscription : 29-04-2015

Re : Enigmail ne se met pas à jour dans jessie avec la v52 de Thunderbird

Petite vérification que j'aurais dû faire avant d'écrire trop vite. gnupg gnupg2 sont installés tous les deux sur ma machine.

Pour les solutions exposées dans les liens, trop compliquées pour moi.

Je préfère attendre la mise à jour vers strech.

Dernière modification par Philou92 (01-08-2017 23:42:23)

Hors ligne

#10 01-08-2017 23:42:11

Philou92
Adhérent(e)
Lieu : Hauts de Seine
Distrib. : Debian Jessie 8.9
Noyau : Linux 3.16.0-4-amd64
(G)UI : Gnome 3.14
Inscription : 29-04-2015

Re : Enigmail ne se met pas à jour dans jessie avec la v52 de Thunderbird

A force de faire des manips tordues j'ai réussi à lui (enigmail) faire cracher le morceau.

Il demande une version gnupg2 supérieure ou égale à la 2.07 et la version installée sur jessie est la 2.02. Je reste sur l'idée que le problème est insoluble sous jessie.

Dernière modification par Philou92 (01-08-2017 23:42:35)

Hors ligne

#11 31-08-2017 23:58:40

Philou92
Adhérent(e)
Lieu : Hauts de Seine
Distrib. : Debian Jessie 8.9
Noyau : Linux 3.16.0-4-amd64
(G)UI : Gnome 3.14
Inscription : 29-04-2015

Re : Enigmail ne se met pas à jour dans jessie avec la v52 de Thunderbird

J'ai contourné le problème en utilisant Evolution. Il semble que le rythme des mises à jours logicielles de Thunderbird soit trop fréquent (pour une stable) ce qui ne laisse pas le temps nécessaire aux mainteneurs de paquet pour garantir que les modules complémentaires sont compatibles.

Tout compte fait je le trouve Evolution beaucoup plus simple à utiliser et configurer que Thunderbird, et de plus la plupart des fonctions de chiffrage, connexion agenda et contacts sont déjà pré-intégré. Cela augure une meilleure stabilité dans le temps sur une machine Debian.

Note aux éventuels Chocovores, le titre est trop long pour y coller un [IRRÉSOLU] dans le texte. Na ! tongue

Dernière modification par Philou92 (01-09-2017 00:01:34)

Hors ligne

Pied de page des forums