Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 28-08-2017 14:09:34

AraignéeMan
Membre
Inscription : 27-08-2017

Problème affichage et freeze Nvidia Geforce GTX 960

Bonjour à tous,

    Voilà mon problème :

    Je viens d’installer Debian 9.1 sur mon PC et j’ai installé les pilotes Nvidia proprio.
Par moment l’affichage bug. Par exemple quand je suis sur le page du wiki de Debian-facile et que je fais défiler l’écran des sortes de rouleau ou de vague apparaissent sur l’écran qui vont d’un côté a l’autre de la page.
Le problème n’est évidement pas que sur le wiki mais sur la plupart des pages que je peux scroller.
Le même phénomène apparaît parfois pendant la lecture de vidéo et parfois le système se fige si je passe d’un passage à l’autre d’une vidéo dans VLC.


Merci pour votre aide.

Debian 9.1 Cinnamon 3.2.7
AMD FX6300
Nvidia GeForce GTX 960

Hors ligne

#2 28-08-2017 14:48:53

robert2a
Membre
Lieu : France
Distrib. : Stretch 9
Noyau : Linux 4.9.0-3 4.9.30-2
(G)UI : Mate
Inscription : 15-11-2014

Re : Problème affichage et freeze Nvidia Geforce GTX 960

Bonjour
si tu peu donner le retour de la commande lspci


lspci
 



tu a installé le driver propriétaire comment ?
a partir des dépots debian , ou avec le site de Nvidia
quelle carte graphique tu a ?
si c'est a partir des dépots debian avec quelle commande (ou a partir de synaptic par exemple)
pour vlc je lui préfère mpv plutot

la question qui fache tongue  , un PC de bureau ou portable ?

Hors ligne

#3 28-08-2017 15:03:48

AraignéeMan
Membre
Inscription : 27-08-2017

Re : Problème affichage et freeze Nvidia Geforce GTX 960

Merci pour ta réponse.
Voilà le retour de la commande :

   lspci
 


00:00.0 Host bridge: Advanced Micro Devices, Inc. [AMD/ATI] RD9x0/RX980 Host Bridge (rev 02)
00:00.2 IOMMU: Advanced Micro Devices, Inc. [AMD/ATI] RD890S/RD990 I/O Memory Management Unit (IOMMU)
00:02.0 PCI bridge: Advanced Micro Devices, Inc. [AMD/ATI] RD890/RD9x0/RX980 PCI to PCI bridge (PCI Express GFX port 0)
00:09.0 PCI bridge: Advanced Micro Devices, Inc. [AMD/ATI] RD890/RD9x0/RX980 PCI to PCI bridge (PCI Express GPP Port 4)
00:0a.0 PCI bridge: Advanced Micro Devices, Inc. [AMD/ATI] RD890/RD9x0/RX980 PCI to PCI bridge (PCI Express GPP Port 5)
00:11.0 SATA controller: Advanced Micro Devices, Inc. [AMD/ATI] SB7x0/SB8x0/SB9x0 SATA Controller [IDE mode] (rev 40)
00:12.0 USB controller: Advanced Micro Devices, Inc. [AMD/ATI] SB7x0/SB8x0/SB9x0 USB OHCI0 Controller
00:12.2 USB controller: Advanced Micro Devices, Inc. [AMD/ATI] SB7x0/SB8x0/SB9x0 USB EHCI Controller
00:13.0 USB controller: Advanced Micro Devices, Inc. [AMD/ATI] SB7x0/SB8x0/SB9x0 USB OHCI0 Controller
00:13.2 USB controller: Advanced Micro Devices, Inc. [AMD/ATI] SB7x0/SB8x0/SB9x0 USB EHCI Controller
00:14.0 SMBus: Advanced Micro Devices, Inc. [AMD/ATI] SBx00 SMBus Controller (rev 42)
00:14.1 IDE interface: Advanced Micro Devices, Inc. [AMD/ATI] SB7x0/SB8x0/SB9x0 IDE Controller (rev 40)
00:14.2 Audio device: Advanced Micro Devices, Inc. [AMD/ATI] SBx00 Azalia (Intel HDA) (rev 40)
00:14.3 ISA bridge: Advanced Micro Devices, Inc. [AMD/ATI] SB7x0/SB8x0/SB9x0 LPC host controller (rev 40)
00:14.4 PCI bridge: Advanced Micro Devices, Inc. [AMD/ATI] SBx00 PCI to PCI Bridge (rev 40)
00:14.5 USB controller: Advanced Micro Devices, Inc. [AMD/ATI] SB7x0/SB8x0/SB9x0 USB OHCI2 Controller
00:15.0 PCI bridge: Advanced Micro Devices, Inc. [AMD/ATI] SB700/SB800/SB900 PCI to PCI bridge (PCIE port 0)
00:16.0 USB controller: Advanced Micro Devices, Inc. [AMD/ATI] SB7x0/SB8x0/SB9x0 USB OHCI0 Controller
00:16.2 USB controller: Advanced Micro Devices, Inc. [AMD/ATI] SB7x0/SB8x0/SB9x0 USB EHCI Controller
00:18.0 Host bridge: Advanced Micro Devices, Inc. [AMD] Family 15h Processor Function 0
00:18.1 Host bridge: Advanced Micro Devices, Inc. [AMD] Family 15h Processor Function 1
00:18.2 Host bridge: Advanced Micro Devices, Inc. [AMD] Family 15h Processor Function 2
00:18.3 Host bridge: Advanced Micro Devices, Inc. [AMD] Family 15h Processor Function 3
00:18.4 Host bridge: Advanced Micro Devices, Inc. [AMD] Family 15h Processor Function 4
00:18.5 Host bridge: Advanced Micro Devices, Inc. [AMD] Family 15h Processor Function 5
01:00.0 VGA compatible controller: NVIDIA Corporation GM206 [GeForce GTX 960] (rev a1)
01:00.1 Audio device: NVIDIA Corporation Device 0fba (rev a1)
02:00.0 USB controller: Renesas Technology Corp. uPD720202 USB 3.0 Host Controller (rev 02)
03:00.0 USB controller: Renesas Technology Corp. uPD720202 USB 3.0 Host Controller (rev 02)
05:00.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller (rev 06




J’ai installé les drivers avec la commande :

 apt-get install nvidia-kernel-dkms nvidia-settings nvidia-driver linux-headers-$(uname -r)
 




Ma carte graphique est une Nvidia GeForce GTX 960.
C’est un ordinateur de bureau.

    J’apprécie aussi MPV, mais j’avais pris l’habitude d’utiliser VLC, car il y avait un problème de décalage entre le son et l’image que je n’arrivais pas à résoudre quand j’utilisai Solus.


Debian 9.1 Cinnamon 3.2.7
AMD FX6300
Nvidia GeForce GTX 960

Hors ligne

#4 28-08-2017 15:22:49

robert2a
Membre
Lieu : France
Distrib. : Stretch 9
Noyau : Linux 4.9.0-3 4.9.30-2
(G)UI : Mate
Inscription : 15-11-2014

Re : Problème affichage et freeze Nvidia Geforce GTX 960

tout a l'air ok , la commande est bonne , celle du wiki de debian_facile
la carte est bien pris en charge par le driver de stretch

j'utilise le meme matériel que toi avec le bureau mate . (tu peu donner le bureau que tu utilise , mais je pense pas que cela en soit la cause )
il te manque peut etre des paquets sur l installation du driver
je suis sur le machine avec une GTX960 ( driver nvidia + cuda )


01:00.0 VGA compatible controller: NVIDIA Corporation GM206 [GeForce GTX 960] (rev a1)
01:00.1 Audio device: NVIDIA Corporation Device 0fba (rev a1)
 



tu a le paquet nvidia-settings installé ?  (utilitaire graphique dans ton menu du bureau )

ouvre le tu a "VDPAU information" (pour la partie lecture video )
ps : je te conseille d'installer mpv pour vérifier si le meme problème que vlc

je suis en 375.82 pour la version du driver ( en buster (testing)) mais jamais eu de souci avant

Dernière modification par robert2a (28-08-2017 15:34:39)

Hors ligne

#5 28-08-2017 15:33:55

AraignéeMan
Membre
Inscription : 27-08-2017

Re : Problème affichage et freeze Nvidia Geforce GTX 960

Merci pour ta réponse.

J’utilise cinnamon, mais j’ai aussi testé avec mate et les problèmes sont aussi présents.

Oui, le paquet nvidia-settings est bien présent.

Debian 9.1 Cinnamon 3.2.7
AMD FX6300
Nvidia GeForce GTX 960

Hors ligne

#6 28-08-2017 15:37:54

robert2a
Membre
Lieu : France
Distrib. : Stretch 9
Noyau : Linux 4.9.0-3 4.9.30-2
(G)UI : Mate
Inscription : 15-11-2014

Re : Problème affichage et freeze Nvidia Geforce GTX 960

le paquet nvidia-vdpau-driver est installé  ?

si tu a synaptic installé une recherche avec le mot clé "nvidia" va te donner tous les paquets disponibles

les vagues sur l affichage sur le wiki debian , sur la page d'accueil ou un pdf particulier ?
quand tu utilise la molette de la souris pour te déplacer dans le document ?

nota : je pense a quelque chose , je suis sur intel (I3 skylake) toi sur amd (quel processeur ? )
tu a pensé a activer IOMMU dans le bios (si il ne l ai pas déja ) ?

la lecture vidéo et les vagues de droite a gauche , 2 soucis et en plus parfois freeze  hmm (freeze = lag la machine ne plante pas ? )
quelque chose ne fonctionne pas correctement c'est sur roll

Dernière modification par robert2a (28-08-2017 15:47:07)

Hors ligne

#7 28-08-2017 15:46:15

AraignéeMan
Membre
Inscription : 27-08-2017

Re : Problème affichage et freeze Nvidia Geforce GTX 960

Le bug visuel semble moins présent avec MPV et il ne plante pas quand je saute des passages.
Le paquet nvidia-vdpau-driver est bien installé.
Il affiche les codecs supportés.

Debian 9.1 Cinnamon 3.2.7
AMD FX6300
Nvidia GeForce GTX 960

Hors ligne

#8 28-08-2017 15:48:14

robert2a
Membre
Lieu : France
Distrib. : Stretch 9
Noyau : Linux 4.9.0-3 4.9.30-2
(G)UI : Mate
Inscription : 15-11-2014

Re : Problème affichage et freeze Nvidia Geforce GTX 960

tu a des erreurs au chargement du noyau (kernel) ?

donne le retour de cette commande en root


journalctl -r -p err
 



nota : question bète tongue , tu a redémarré la machine depuis l'installation du driver ?

ps : avec mpv c'est mieux mais pas parfait ?

tu a crée un xorg.conf pour ton driver nvidia ou tu laisse faire le système ? (il n'est plus obligatoire depuis stretch , moi je tourne sans fichier , installation par défaut )

tu a une commande nvidia-smi en console ( et sur buster j'ai un paquet nvidia-smi et nvidia-smi:i386 )


nvidia-smi
 


ça donne pour moi


Mon Aug 28 15:55:50 2017      
+-----------------------------------------------------------------------------+
| NVIDIA-SMI 375.82                 Driver Version: 375.82                    |
|-------------------------------+----------------------+----------------------+
| GPU  Name        Persistence-M| Bus-Id        Disp.A | Volatile Uncorr. ECC |
| Fan  Temp  Perf  Pwr:Usage/Cap|         Memory-Usage | GPU-Util  Compute M. |
|===============================+======================+======================|
|   0  GeForce GTX 960     Off  | 0000:01:00.0      On |                  N/A |
| 64%   64C    P2    99W / 130W |    157MiB /  1996MiB |    100%      Default |
+-------------------------------+----------------------+----------------------+
                                                                               
+-----------------------------------------------------------------------------+
| Processes:                                                       GPU Memory |
|  GPU       PID  Type  Process name                               Usage      |
|=============================================================================|
|    0       556    G   /usr/lib/xorg/Xorg                              69MiB |
|    0      2433    C   ...AMD64/NVIDIA/Fermi/Core_21.fah/FahCore_21    84MiB |
+-----------------------------------------------------------------------------+
 

Dernière modification par robert2a (28-08-2017 15:58:53)

Hors ligne

#9 28-08-2017 16:06:50

AraignéeMan
Membre
Inscription : 27-08-2017

Re : Problème affichage et freeze Nvidia Geforce GTX 960

Voila pour la commande :

journalctl -r -p err
 


-- Logs begin at Mon 2017-08-28 08:27:07 CEST, end at Mon 2017-08-28 15:56:11 CE
août 28 11:19:50 marvin pulseaudio[2789]: [alsa-sink-USB Audio] alsa-sink.c: We
août 28 11:19:50 marvin pulseaudio[2789]: [alsa-sink-USB Audio] alsa-sink.c: Mos
août 28 11:19:50 marvin pulseaudio[2789]: [alsa-sink-USB Audio] alsa-sink.c: ALS
août 28 09:47:22 marvin pulseaudio[2789]: [pulseaudio] bluez5-util.c: GetManaged
août 28 09:46:57 marvin pulseaudio[2811]: [pulseaudio] pid.c: Daemon already run
août 28 08:59:39 marvin kernel: ath: phy0: Failed to wakeup in 500us
août 28 08:59:39 marvin kernel: ath: phy0: RX failed to go idle in 10 ms RXSM=0x
août 28 08:59:39 marvin kernel: ath: phy0: Failed to wakeup in 500us
août 28 08:54:32 marvin pulseaudio[1189]: [pulseaudio] bluez5-util.c: GetManaged
août 28 08:54:10 marvin pulseaudio[1359]: [pulseaudio] pid.c: Daemon already run
août 28 08:54:10 marvin pulseaudio[1357]: [pulseaudio] pid.c: Daemon already run
août 28 08:27:09 marvin systemd[1]: Failed to start Raise network interfaces.
août 28 08:27:09 marvin dhclient[586]: exiting.
août 28 08:27:09 marvin dhclient[586]:
août 28 08:27:09 marvin dhclient[586]: process and the information we find helpf
août 28 08:27:09 marvin dhclient[586]: before submitting a bug.  These pages exp
août 28 08:27:09 marvin dhclient[586]: bugs on either our web page at www.isc.or
août 28 08:27:09 marvin dhclient[586]: than a configuration issue please read th
août 28 08:27:09 marvin dhclient[586]: If you think you have received this messa
août 28 08:27:09 marvin dhclient[586]:
août 28 08:27:09 marvin dhclient[586]: Failed to get interface index: No such de
août 28 08:27:08 marvin avahi-daemon[401]: chroot.c: open() failed: No such file
lines 1-23...skipping...
-- Logs begin at Mon 2017-08-28 08:27:07 CEST, end at Mon 2017-08-28 15:56:11 CEST. --
août 28 11:19:50 marvin pulseaudio[2789]: [alsa-sink-USB Audio] alsa-sink.c: We were woken up with POLLOUT set -- however a subsequent snd_pcm_avail() returned 0 or another value < min_avail.
août 28 11:19:50 marvin pulseaudio[2789]: [alsa-sink-USB Audio] alsa-sink.c: Most likely this is a bug in the ALSA driver 'snd_usb_audio'. Please report this issue to the ALSA developers.
août 28 11:19:50 marvin pulseaudio[2789]: [alsa-sink-USB Audio] alsa-sink.c: ALSA woke us up to write new data to the device, but there was actually nothing to write.
août 28 09:47:22 marvin pulseaudio[2789]: [pulseaudio] bluez5-util.c: GetManagedObjects() failed: org.freedesktop.DBus.Error.NoReply: Did not receive a reply. Possible causes include: the remote application did
août 28 09:46:57 marvin pulseaudio[2811]: [pulseaudio] pid.c: Daemon already running.
août 28 08:59:39 marvin kernel: ath: phy0: Failed to wakeup in 500us
août 28 08:59:39 marvin kernel: ath: phy0: RX failed to go idle in 10 ms RXSM=0x209ece84
août 28 08:59:39 marvin kernel: ath: phy0: Failed to wakeup in 500us
août 28 08:54:32 marvin pulseaudio[1189]: [pulseaudio] bluez5-util.c: GetManagedObjects() failed: org.freedesktop.DBus.Error.TimedOut: Failed to activate service 'org.bluez': timed out
août 28 08:54:10 marvin pulseaudio[1359]: [pulseaudio] pid.c: Daemon already running.
août 28 08:54:10 marvin pulseaudio[1357]: [pulseaudio] pid.c: Daemon already running.
août 28 08:27:09 marvin systemd[1]: Failed to start Raise network interfaces.
août 28 08:27:09 marvin dhclient[586]: exiting.
août 28 08:27:09 marvin dhclient[586]:
août 28 08:27:09 marvin dhclient[586]: process and the information we find helpful for debugging..
août 28 08:27:09 marvin dhclient[586]: before submitting a bug.  These pages explain the proper
août 28 08:27:09 marvin dhclient[586]: bugs on either our web page at www.isc.org or in the README file
août 28 08:27:09 marvin dhclient[586]: than a configuration issue please read the section on submitting
août 28 08:27:09 marvin dhclient[586]: If you think you have received this message due to a bug rather
août 28 08:27:09 marvin dhclient[586]:
août 28 08:27:09 marvin dhclient[586]: Failed to get interface index: No such device
août 28 08:27:08 marvin avahi-daemon[401]: chroot.c: open() failed: No such file or directory
août 28 08:27:08 marvin kernel: usb 2-1: no suitable firmware found!
août 28 08:27:08 marvin kernel: usb 2-1: firmware: failed to load htc_9271.fw (-2)
août 28 08:27:08 marvin kernel: usb 2-1: firmware: failed to load ath9k_htc/htc_9271-1.4.0.fw (-2)
août 28 08:27:07 marvin kernel: sp5100_tco: I/O address 0x0cd6 already in use
 



J'ai redémarré plusieurs fois depuis l’installation du driver.

C’est beaucoup mieux avec Mpv mais pas parfait. 

Je n’ai pas de fichier xorg.

Voilà le résultat :

nvidia-smi
 


Mon Aug 28 16:04:08 2017      
+-----------------------------------------------------------------------------+
| NVIDIA-SMI 375.66                 Driver Version: 375.66                    |
|-------------------------------+----------------------+----------------------+
| GPU  Name        Persistence-M| Bus-Id        Disp.A | Volatile Uncorr. ECC |
| Fan  Temp  Perf  Pwr:Usage/Cap|         Memory-Usage | GPU-Util  Compute M. |
|===============================+======================+======================|
|   0  GeForce GTX 960     Off  | 0000:01:00.0      On |                  N/A |
|  4%   62C    P0    29W / 128W |    265MiB /  4037MiB |      1%      Default |
+-------------------------------+----------------------+----------------------+
                                                                               
+-----------------------------------------------------------------------------+
| Processes:                                                       GPU Memory |
|  GPU       PID  Type  Process name                               Usage      |
|=============================================================================|
|    0      2618    G   /usr/lib/xorg/Xorg                             161MiB |
|    0      2822    G   cinnamon                                        99MiB |
|    0      6438    G   /usr/lib/firefox-esr/plugin-container            1MiB |
|    0      8074    G   nvidia-settings                                  0MiB |
+-----------------------------------------------------------------------------+
 


Debian 9.1 Cinnamon 3.2.7
AMD FX6300
Nvidia GeForce GTX 960

Hors ligne

#10 28-08-2017 16:19:21

robert2a
Membre
Lieu : France
Distrib. : Stretch 9
Noyau : Linux 4.9.0-3 4.9.30-2
(G)UI : Mate
Inscription : 15-11-2014

Re : Problème affichage et freeze Nvidia Geforce GTX 960

pour IOMMU le retour de ma machine amd (FX8320E )


Aug 28 16:08:45 debian4 kernel: [    1.465895] pci 0000:01:00.0: Video device with shadowed ROM at [mem 0x000c0000-0x000dffff]
Aug 28 16:08:45 debian4 kernel: [    1.466135] PCI: CLS 64 bytes, default 64
Aug 28 16:08:45 debian4 kernel: [    1.466174] Unpacking initramfs...
Aug 28 16:08:45 debian4 kernel: [    1.724714] Freeing initrd memory: 17860K (ffff891fb5d0d000 - ffff891fb6e7e000)
Aug 28 16:08:45 debian4 kernel: [    1.725190] iommu: Adding device 0000:00:00.0 to group 0
Aug 28 16:08:45 debian4 kernel: [    1.725262] iommu: Adding device 0000:00:02.0 to group 1
Aug 28 16:08:45 debian4 kernel: [    1.725334] iommu: Adding device 0000:00:04.0 to group 2
Aug 28 16:08:45 debian4 kernel: [    1.725408] iommu: Adding device 0000:00:05.0 to group 3
Aug 28 16:08:45 debian4 kernel: [    1.725480] iommu: Adding device 0000:00:07.0 to group 4
Aug 28 16:08:45 debian4 kernel: [    1.725552] iommu: Adding device 0000:00:11.0 to group 5
Aug 28 16:08:45 debian4 kernel: [    1.725659] iommu: Adding device 0000:00:12.0 to group 6
Aug 28 16:08:45 debian4 kernel: [    1.725672] iommu: Adding device 0000:00:12.2 to group 6
Aug 28 16:08:45 debian4 kernel: [    1.725753] iommu: Adding device 0000:00:13.0 to group 7
Aug 28 16:08:45 debian4 kernel: [    1.725767] iommu: Adding device 0000:00:13.2 to group 7
Aug 28 16:08:45 debian4 kernel: [    1.725840] iommu: Adding device 0000:00:14.0 to group 8
Aug 28 16:08:45 debian4 kernel: [    1.725913] iommu: Adding device 0000:00:14.2 to group 9
Aug 28 16:08:45 debian4 kernel: [    1.725987] iommu: Adding device 0000:00:14.3 to group 10
Aug 28 16:08:45 debian4 kernel: [    1.726061] iommu: Adding device 0000:00:14.4 to group 11
Aug 28 16:08:45 debian4 kernel: [    1.726135] iommu: Adding device 0000:00:14.5 to group 12
Aug 28 16:08:45 debian4 kernel: [    1.726216] iommu: Adding device 0000:00:16.0 to group 13
Aug 28 16:08:45 debian4 kernel: [    1.726230] iommu: Adding device 0000:00:16.2 to group 13
Aug 28 16:08:45 debian4 kernel: [    1.726322] iommu: Adding device 0000:01:00.0 to group 14
Aug 28 16:08:45 debian4 kernel: [    1.726344] iommu: Adding device 0000:01:00.1 to group 14
Aug 28 16:08:45 debian4 kernel: [    1.726421] iommu: Adding device 0000:02:00.0 to group 15
Aug 28 16:08:45 debian4 kernel: [    1.726499] iommu: Adding device 0000:03:00.0 to group 16
Aug 28 16:08:45 debian4 kernel: [    1.726577] iommu: Adding device 0000:04:00.0 to group 17
Aug 28 16:08:45 debian4 kernel: [    1.804355] AMD-Vi: Found IOMMU at 0000:00:00.2 cap 0x40
Aug 28 16:08:45 debian4 kernel: [    1.804356] AMD-Vi: Interrupt remapping enabled
Aug 28 16:08:45 debian4 kernel: [    1.804459] AMD-Vi: Lazy IO/TLB flushing enabled
Aug 28 16:08:45 debian4 kernel: [    1.806029] perf: AMD NB counters detected
Aug 28 16:08:45 debian4 kernel: [    1.806222] LVT offset 0 assigned for vector 0x400
Aug 28 16:08:45 debian4 kernel: [    1.806306] perf: AMD IBS detected (0x000000ff)
 


mais a priori tu n'a pas d'erreur donc l option est activée

tu utilise quoi comme carte audio , celle du gpu ( en hdmi ou dvi ) ?
je vois pas mal d'erreur de pulseaudio

pour ceci peut etre quelque chose a faire ? (manque firmware )


août 28 08:27:08 marvin kernel: usb 2-1: no suitable firmware found!
août 28 08:27:08 marvin kernel: usb 2-1: firmware: failed to load htc_9271.fw (-2)
août 28 08:27:08 marvin kernel: usb 2-1: firmware: failed to load ath9k_htc/htc_9271-1.4.0.fw (-2)
 



peut etre ici  =>  https://packages.debian.org/stretch/firmware-atheros
ton matériel est dans la liste ?

si oui installation du paquet


apt-get --reinstall install firmware-atheros
 


ps : il faudra peut etre redémarrer la machine
tu peu vérifier si il est déja  installé


apt-cache policy firmware-atheros
 


retour


firmware-atheros:
  Installé : (aucun)
  Candidat : 20161130-3
 Table de version :
     20161130-3 500
        500 http://ftp.fr.debian.org/debian stretch/non-free amd64 Packages
        500 http://ftp.fr.debian.org/debian stretch/non-free i386 Packages
 


nota : moi installé aucun , tu a la version disponible sur stretch 20161130-3

pour ton souci du départ , donner des informations sur l audio , la résolution de l'écran ( combien de pouces ) , compatible  g-synchro (nvidia)  ou free-synchro (amd)
normalement avec une carte récente et le driver nonfree tu devrais pas avoir de problème  roll

le type de video , HD ou plus , en résolution ?
ça n'explique pas les vagues sur un pdf
je n utilise pas de gros écrans avec de grosse résolution donc je peu passer a coté d un problème du driver aussi  hmm (la je suis en 1920 x 1080 en 60hz sur la gtx980 et le fx8320e )

Dernière modification par robert2a (28-08-2017 16:47:15)

Hors ligne

#11 28-08-2017 17:43:30

AraignéeMan
Membre
Inscription : 27-08-2017

Re : Problème affichage et freeze Nvidia Geforce GTX 960

Le chipset audio de ma carte mère est un Realtek ALC887 et le son fonctionne parfaitement.

J’avais installé le paquet firmware-atheros un peu plus tôt, mais je n’avais pas redémarré, je viens de le faire et voila résultat de la commande après redémarrage.

journalctl -r -p err


-- Logs begin at Mon 2017-08-28 16:57:15 CEST, end at Mon 2017-08-28 16:59:04 CE
août 28 16:57:55 marvin pulseaudio[917]: [pulseaudio] bluez5-util.c: GetManagedO
août 28 16:57:31 marvin pulseaudio[1025]: [pulseaudio] pid.c: Daemon already run
août 28 16:57:16 marvin systemd[1]: Failed to start Raise network interfaces.
août 28 16:57:16 marvin dhclient[576]: exiting.
août 28 16:57:16 marvin dhclient[576]:
août 28 16:57:16 marvin dhclient[576]: process and the information we find helpf
août 28 16:57:16 marvin dhclient[576]: before submitting a bug.  These pages exp
août 28 16:57:16 marvin dhclient[576]: bugs on either our web page at www.isc.or
août 28 16:57:16 marvin dhclient[576]: than a configuration issue please read th
août 28 16:57:16 marvin dhclient[576]: If you think you have received this messa
août 28 16:57:16 marvin dhclient[576]:
août 28 16:57:16 marvin dhclient[576]: Failed to get interface index: No such de
août 28 16:57:16 marvin avahi-daemon[382]: chroot.c: open() failed: No such file
août 28 16:57:16 marvin kernel: sp5100_tco: I/O address 0x0cd6 already in use




L’écran est un Philips, 23 pouces, 1920 X 1080, 16:9.

    Après le redémarrage j’ai relancé mate et je constate que le problème j’avais en scrollant des pages web n’apparais qu’avec le gestionnaire de fenêtre marco avec compositeur logiciel mais pas avec marco avec compositeur GPU compton.  Mais sous mate il y des clignotements vert à la lecture des vidéos.


Debian 9.1 Cinnamon 3.2.7
AMD FX6300
Nvidia GeForce GTX 960

Hors ligne

#12 28-08-2017 18:57:21

moi4567
Membre
Distrib. : Jessie
Noyau : Linux 3.16.0-4-amd64
(G)UI : Gnome 3
Inscription : 22-06-2015

Re : Problème affichage et freeze Nvidia Geforce GTX 960

Bonjour,

J'ai eu exactement le même problème avec ma GTX 780, pilote libre.

J'ai désinstallé le pilote libre (et les fichiers de conf) pour installer le driver propriétaire (à mon grand regret...). Ensuite j'ai recréer un fichier de conf:

nvidia-xconfig



Plus de soucis depuis!

Dernière modification par moi4567 (28-08-2017 18:57:37)

Hors ligne

#13 28-08-2017 21:27:04

AraignéeMan
Membre
Inscription : 27-08-2017

Re : Problème affichage et freeze Nvidia Geforce GTX 960

Bonjour,

Merci pour ta réponse.

Je viens de créer les fichiers de configuration, mais il n'y pas de changement.

Debian 9.1 Cinnamon 3.2.7
AMD FX6300
Nvidia GeForce GTX 960

Hors ligne

#14 28-08-2017 21:45:31

moi4567
Membre
Distrib. : Jessie
Noyau : Linux 3.16.0-4-amd64
(G)UI : Gnome 3
Inscription : 22-06-2015

Re : Problème affichage et freeze Nvidia Geforce GTX 960

As tu le paquet xserver-xorg-video-nouveau d'installé?

dpkg -l | grep xserver-xorg-video-nouveau



Si oui, il y a certainement conflit!
Si tu décide de le désinstaller pour tester prépares toi à devoir démarrer debian en mode rescue (run level 1 et pas d'interface graphique) pour le réinstaller.

Hors ligne

#15 28-08-2017 23:17:45

robert2a
Membre
Lieu : France
Distrib. : Stretch 9
Noyau : Linux 4.9.0-3 4.9.30-2
(G)UI : Mate
Inscription : 15-11-2014

Re : Problème affichage et freeze Nvidia Geforce GTX 960

la création d un fichier xorg.conf ne change rien , le virtuel créé par le système sera exactement le meme que le xorg.conf que tu a généré avec l utilitaire .
pour avoir une différence il faut le personnaliser en activant ou en désactivant des options
de plus avec un fichier xorg.conf , si tu remplace l'écran par exemple , ton fichier ne sera plus correct , alors qu en auto a chaque démarrage du serveur X le matériel est de nouveau détecté (la configuration mit a jour )
bon on me dira il suffit de générer a nouveau le fichier après la modification , mais faut t il encore y penser  wink
ce qu a fait debian est très bien pour l'utilisateur  (simplifié l installation et l utilisation du driver video )
une GTX780 qui fonctionne mal avec le driver propriétaire ce n'est pas normal
j'ai 2 GTX770 qui tourne parfaitement et des membres du forum ont meme des GTX780TI qui tournent correctement
avec le driver nonfree nouveau est désactivé , et surement que KMS est modifié aussi (DRM du driver nonfree qui remplace celle de debian )
pour revenir a l audio j ai ceci  avec lspci


00:14.2 Audio device: Advanced Micro Devices, Inc. [AMD/ATI] SBx00 Azalia (Intel HDA) (rev 40)
 


a part l audio de la carte vidéo pour toi je ne trouve rien (ou c'est la fatigue )

c'est la fatigue  wink (on a le meme circuit audio )


00:14.2 Audio device: Advanced Micro Devices, Inc. [AMD/ATI] SBx00 Azalia (Intel HDA) (rev 40)
 


pour l audio c'est ok , a part si quelqu'un a quelque chose a proposer en fonction des erreurs que tu a posté

pour l'instant ta machine a l'air propre ,
sur ma machine en AMD j'ai ceci comme erreur


-- Logs begin at Mon 2017-08-28 16:08:29 CEST, end at Mon 2017-08-28 23:23:41 CEST. --
août 28 16:11:20 debian4 pulseaudio[1233]: [pulseaudio] pid.c: Daemon already running.
août 28 16:11:20 debian4 pulseaudio[1231]: [pulseaudio] pid.c: Daemon already running.
août 28 16:11:20 debian4 pulseaudio[1229]: [pulseaudio] pid.c: Daemon already running.
août 28 16:08:37 debian4 kernel: sp5100_tco: I/O address 0x0cd6 already in use
 


tu a des choses a améliorer encore (ça tourne très bien avec debian stretch 9.1 )
je dit ça a cause des "freezes"  du peut etre a des erreurs répétitives .
pour les vagues en largeur je sais pas (ça ressemble pas a du tearing qui est plutot un déchirement de l image du a un affichage d'une image incomplette par la carte vidéo )

peut etre vérifier le log de X et tester mesa (OpenGL) avec le paquet mesa-utils


apt-get --reinstall install mesa-utils
 


lancer les tests (moi avec une GTX980


glxinfo -B
 


retour


name of display: :0
display: :0  screen: 0
direct rendering: Yes
OpenGL vendor string: NVIDIA Corporation
OpenGL renderer string: GeForce GTX 980/PCIe/SSE2
OpenGL core profile version string: 4.5.0 NVIDIA 375.66
OpenGL core profile shading language version string: 4.50 NVIDIA
OpenGL core profile context flags: (none)
OpenGL core profile profile mask: core profile

OpenGL version string: 4.5.0 NVIDIA 375.66
OpenGL shading language version string: 4.50 NVIDIA
OpenGL context flags: (none)
OpenGL profile mask: (none)

OpenGL ES profile version string: OpenGL ES 3.2 NVIDIA 375.66
OpenGL ES profile shading language version string: OpenGL ES GLSL ES 3.20
 



puis


glxgears
 


retour


Running synchronized to the vertical refresh.  The framerate should be
approximately the same as the monitor refresh rate.
290 frames in 5.0 seconds = 57.942 FPS
301 frames in 5.0 seconds = 59.997 FPS
301 frames in 5.0 seconds = 60.010 FPS
300 frames in 5.0 seconds = 59.996 FPS
300 frames in 5.0 seconds = 59.991 FPS
301 frames in 5.0 seconds = 60.007 FPS
300 frames in 5.0 seconds = 59.991 FPS
301 frames in 5.0 seconds = 60.015 FPS
300 frames in 5.0 seconds = 59.999 FPS
XIO:  fatal IO error 11 (Resource temporarily unavailable) on X server ":0"
      after 55 requests (55 known processed) with 0 events remaining.
 


tu dois tourner a 60 FPS environ ( qui correspond a ta synchro verticale )
pour stoper le test tu ferme avec la croix du petit carré ou les engrenages tournent

il reste le contenu du log de X (dans /var/log/Xorg.0.log )  et peut etre une personnalisation du bureau (dans ton /home/user ) mais la je connais pas trop  hmm

quand tu regarde une vidéo regarde l utilisation du cpu si pas trop importante (le gpu ne fait pas son taf correctement )

nota : si tu veut vraiment revenir au driver nouveau pour tester, il faudra purger correctement le nonfree nvidia et supprimer le fichier //etc/X11/xorg.conf
par contre avec une GTX960 meme avec le firmware-misc-nonfree installé je sais pas si ça fonctionne correctement ( je n utilise nouveau que jusqu au GTX780 , plus testé après pour les versions supérieures  )
pour le jeux j installe directement le nonfree (qui propose de meilleur performance )

Dernière modification par robert2a (29-08-2017 00:06:55)

Hors ligne

#16 30-08-2017 12:11:34

AraignéeMan
Membre
Inscription : 27-08-2017

Re : Problème affichage et freeze Nvidia Geforce GTX 960

Le retour de la commande glxinfo semble normal :



 glxinfo -B


name of display: :0
display: :0  screen: 0
direct rendering: Yes
OpenGL vendor string: NVIDIA Corporation
OpenGL renderer string: GeForce GTX 960/PCIe/SSE2
OpenGL core profile version string: 4.5.0 NVIDIA 375.66
OpenGL core profile shading language version string: 4.50 NVIDIA
OpenGL core profile context flags: (none)
OpenGL core profile profile mask: core profile

OpenGL version string: 4.5.0 NVIDIA 375.66
OpenGL shading language version string: 4.50 NVIDIA
OpenGL context flags: (none)
OpenGL profile mask: (none)

OpenGL ES profile version string: OpenGL ES 3.2 NVIDIA 375.66
OpenGL ES profile shading language version string: OpenGL ES GLSL ES 3.20




et glxgears aussi :

glxgears


Running synchronized to the vertical refresh.  The framerate should be
approximately the same as the monitor refresh rate.
290 frames in 5.0 seconds = 57.908 FPS
290 frames in 5.0 seconds = 57.998 FPS
287 frames in 5.0 seconds = 57.214 FPS
294 frames in 5.0 seconds = 58.606 FPS
288 frames in 5.0 seconds = 57.412 FPS
294 frames in 5.0 seconds = 58.799 FPS
295 frames in 5.0 seconds = 58.807 FPS
289 frames in 5.0 seconds = 57.610 FPS
291 frames in 5.0 seconds = 58.200 FPS
292 frames in 5.0 seconds = 58.207 FPS
287 frames in 5.0 seconds = 57.397 FPS
291 frames in 5.0 seconds = 58.012 FPS
XIO:  fatal IO error 11 (Resource temporarily unavailable) on X server ":0"
      after 53 requests (53 known processed) with 0 events remaining.




pendant la lecture d’une vidéo en 720p l’utilisation des cpu ne dépassent pas les 40 %.

Est-ce que cela peut venir d’un problème matériel ?
La température du GPU reste toujours autour de 60°c est-ce normal ?


Debian 9.1 Cinnamon 3.2.7
AMD FX6300
Nvidia GeForce GTX 960

Hors ligne

#17 30-08-2017 19:58:29

robert2a
Membre
Lieu : France
Distrib. : Stretch 9
Noyau : Linux 4.9.0-3 4.9.30-2
(G)UI : Mate
Inscription : 15-11-2014

Re : Problème affichage et freeze Nvidia Geforce GTX 960

Bonjour

mon FX8320 tourne avec 50 degrés avec une température ambiante de 35 degrés environ (un coeur a 100% ) , il a un bon refroidissement .
pour la lecture vidéo je sais pas , mais normalement il n'a pas grand chose a faire , la carte graphique doit le décharger
tes retours pour Mesa sont bon
la GTX960 est très récente , environ 2 a 3 ans a peu près , en lecture vidéo elle est performante (comme en jeux )

Hors ligne

Pied de page des forums