Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 15-09-2017 17:15:27

Harashi
Membre
Lieu : Paris
Distrib. : Debian 9.1 (Stretch)
Noyau : Linux 4.9.0-3-amd64
(G)UI : Lxde
Inscription : 15-09-2017

[Résolu] Bips horripilants

Bonjour à tous,

Depuis le début de mon installation j'ai un petit problème non résolu qui va bientôt devenir préoccupant. Lorsque je fais une erreur quelconque ou que j'appuie sur la touche retour/effacer alors que je suis dans un terminal, le menu whisker ou un autre élément du système (mais pas dans une application comme Firefox par exemple) alors qu'il n'y a rien à effacer, mon ordinateur fait un gros "bip" bien métallique. Je me souviens avoir désactivé les sons systèmes (même si depuis je n'arrive plus à retrouver l'endroit sous Xfce) sans succès. J'utilisais alors la commande

xset -b


pour désactiver cela. J'ai alors tenté un script dans /etc/init.d pour appliquer cette commande au démarrage mais ça ne fonctionne pas (et ce n'est pas le script qui ne se lance pas, j'ai vérifié).

Comme je compte me servir de cet ordinateur pour prendre mes cours à la fac, un tel bruit risque d'être plutôt gênant si jamais j'oublie de taper cette commande au démarrage (sans compter que c'est un peu contraignant). D'où ma question, y'a-t-il un moyen d'enlever ces sons définitivement ou, si impossible, d'automatiser cette commande au démarrage autrement que par un script dans init.d ?

Par ailleurs, j'ai eu un de ces bips tout à l'heure sans raison apparente et mon ordi, qui chauffait pas mal, a soudainement arrêté de faire du bruit (sans qu'il ne se passe rien de notable). Si quelqu'un en connaissait la raison ce serait une pierre de plus à mon édifice de la connaissance personnel.

Merci d'avance pour votre aide.

Dernière modification par Harashi (16-09-2017 10:28:52)


Dell-Latitude D430

Hors ligne

#2 15-09-2017 17:38:50

Croutons
Membre
Distrib. : Handylinux 2.5 vers Jessie et Debian Stretch
Noyau : Linux 3.16.0-4-686-pae, Linux 4.9.0-3-686-pae
(G)UI : xfce
Inscription : 16-12-2016

Re : [Résolu] Bips horripilants

Bonjour

Je me souviens avoir désactivé les sons systèmes (même si depuis je n'arrive plus à retrouver l'endroit sous Xfce) sans succès


Il faut pas négliger les bips qui sont des bips d'alerte
Les bips d'alerte en générale ne proviennent pas de la carte son mais d'un petit composant branché sur la carte mère


-->les cahiers du debutant<--      WikiDF-->Découvrir les principales commandes Linux<--
L' expérience, c'est le nom que chacun donne à ses erreurs. Oscar Wilde

Hors ligne

#3 15-09-2017 18:46:42

Harashi
Membre
Lieu : Paris
Distrib. : Debian 9.1 (Stretch)
Noyau : Linux 4.9.0-3-amd64
(G)UI : Lxde
Inscription : 15-09-2017

Re : [Résolu] Bips horripilants

Certes, mais là ces "bips d'alerte" ne se manifestent que pour des choses assez peu importantes (genre l'effacement alors qu'il n'y a rien à effacer). Pour les problèmes vraiment urgents les notifications graphiques me suffisent.

Croutons a écrit :

Les bips d'alerte en générale ne proviennent pas de la carte son mais d'un petit composant branché sur la carte mère


Il y a un moyen de les désactiver en software, ou bien il faut que je me saisisse d'un tournevis pour enlever directement le composant ?


Dell-Latitude D430

Hors ligne

#4 15-09-2017 18:59:12

dejieres
Membre
Lieu : Moselle
Distrib. : Jessie 64 bits
Noyau : Linux 3.16.0-4-amd64
(G)UI : Gnome 3.14+3 amd64
Inscription : 07-02-2017

Re : [Résolu] Bips horripilants

Ça donne quelque chose si tu tues le module pcspkr ?

modprobe -r pcspkr

Hors ligne

#5 15-09-2017 21:48:43

èfpé
Membre
Inscription : 10-07-2016

Re : [Résolu] Bips horripilants

Bonsoir Harashi,

D'où ma question, y'a-t-il un moyen d'enlever ces sons définitivement ou, si impossible, d'automatiser cette commande au démarrage autrement que par un script dans init.d ?


Horripilant est le terme qui convient, effectivement... et « blacklister » le module 'pcspkr' s'avère radical... alternativement tu peux automatiser la commande 'xset -b' via xfce4-session-settings :

Menu Whisker > Paramètres > Session et démarrage > Démarrage automatique > Ajouter


Ce qui aura pour effet de créer un fichier de configuration desktop dans le répertoire ~/.config/autostart.

Dernière modification par èfpé (15-09-2017 21:58:43)

Hors ligne

#6 15-09-2017 22:03:47

otyugh
Membre
Lieu : Quimperlé/Arzano
Distrib. : Debian Stable
Inscription : 20-09-2016

Re : [Résolu] Bips horripilants

Très complet sur le sujet (anglais) :
https://wiki.archlinux.org/index.php/PC_speaker

Agenda du libre : se faire dépanner/dépanner IRL ! Le libre n'est pas qu'un phénomène internet.
Framapad sur les balados : Emissions audio pro/amateur, votre radio sur-mesure !

Hors ligne

#7 16-09-2017 10:28:22

Harashi
Membre
Lieu : Paris
Distrib. : Debian 9.1 (Stretch)
Noyau : Linux 4.9.0-3-amd64
(G)UI : Lxde
Inscription : 15-09-2017

Re : [Résolu] Bips horripilants

Merci à tous pour vos conseils, j'ai parcouru l'article d'otyugh mais l'architecture de Arch n'étant pas tout à fait la même que Debian j'ai préféré éviter de bidouiller et suivi la solution d'èfpé. Apparemment ça fonctionne, les bips ont disparus (mais pour combien de temps...cthulhu.gif)

merci.gif

Dell-Latitude D430

Hors ligne

#8 16-09-2017 19:41:33

enicar
Membre
Lieu : Grenoble
Distrib. : debian/sid
Noyau : Linux 4.11.12
(G)UI : openbox
Inscription : 26-08-2010

Re : [Résolu] Bips horripilants

Pour les programmes qui utilisent la libreadline comme bash, dans le fichier
/etc/inputrc on peut mettre :


set bell-style none
 


C'est le réglage que j'utilise quand je ne peux pas virer le pcspkr.
Pour virer durablement le module, il faut le blacklister. Pour cela on crée un fichier
(appelons le pcspkr.conf) dans /etc/modprobe.d/ qui contient :


blacklist pcspkr
 


Après cela il faudra aussi faire une mise à jour de l'initramfs :


update-initramfs
 


À partir de là, tu n'entendra plus jamais les bips… sauf avec grub et les bips
du bios qui peuvent être très utiles.


La machine, c'est dépassé ! On va tout remplacer par des humains big_smile

Hors ligne

Pied de page des forums