Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 19-10-2017 06:15:41

SherrifPepper
Membre
Distrib. : Debian GNU/Linux Stretch 9.2
Noyau : Linux 4.9.0-4-amd4
(G)UI : Gestionnaire par défaut de GNOME 3
Inscription : 19-10-2017

[RESOLU]Soucis pour installer wine32 ... :/

Bonjour bonsoir à tous !
Eh oui, je ne suis pas le premier de notre histoire et sûrement pas le dernier : j'ai des soucis pour installer Wine. J'ai un peu attendu et cherché par moi-même avant d'atterrir ici mais bon, je sèche ...

J'ai reconverti un PC portable avant-hier pour l'utiliser pour la prog', et j'y ai mis Debian (Stretch 9.2, avec GNOME3), en amd64 (je voulais avoir Discord et c'est pas dispo en i386 big_smile )
Seulement voilà, après avoir installé le nécessaire prog (Atom, Eclipse, TexMaker, Maple, etc), je me suis dit que je mettrai bien mon petit Yu-Gi-Oh! Dawn of the New Era sur mon appareil ... et donc, vu que c'est du .exe, essayer Wine !

Mais, mais, mais ... les soucis ont commencé là. J'ai wine64 sans souci, mais strictement impossible d'avoir wine32 !

J'ai d'abord essayé de l'installer avec l'apk-get, pas de wine32. J'ai donc essayé le Multi-Arch, qui semble fonctionner, mais : impossible d'avoir wine32:i386. Avec le winehq-stable ? Eh non ! Via Git ? Toujours pas de version 32 ! En essayant avec les backports de Jessie ? Toujours rien !
Le pire, c'est que je peux installer des paquets manuellement, j'ai essayé, même en i386. J'ai commencé avec libc6:i386, libgcc1:i386, gcc6-base:i386, je peux ! Mais ça ne fait pas les héritages tout seul, et j'ai un peu la flemme de télécharger et d'installer manuellement touuuuuus les paquets dont dépend wine32:i386... J'en ai pour une journée non-stop je pense big_smile

J'ai pourtant bien ce qu'il me faut dans mon sources.list, je n'ai pas fait de fautes, et j'ai cherché toutes les solutions possibles et imaginales sur le web.... Aidez-moi, je veux mes cartes sur mon Debian :'( Je suis sur que c'est un truc tout bête en plus >.>

Ci-après les différentes commandes faites et les réponses :

apt-get install wine


Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances      
Lecture des informations d'état... Fait
wine is already the newest version (1.8.7-2~bpo8+1).
0 mis à jour, 0 nouvellement installés, 0 à enlever et 0 non mis à jour.


Ça, plutôt normal, vu que c'est déjà installé.

apt-get install wine32


Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances      
Lecture des informations d'état... Fait
Certains paquets ne peuvent être installés. Ceci peut signifier
que vous avez demandé l'impossible, ou bien, si vous utilisez
la distribution unstable, que certains paquets n'ont pas encore
été créés ou ne sont pas sortis d'Incoming.
L'information suivante devrait vous aider à résoudre la situation :

Les paquets suivants contiennent des dépendances non satisfaites :
 wine32:i386 : Dépend: libwine:i386 (= 1.8.7-2~bpo8+1) mais ne sera pas installé
E: Impossible de corriger les problèmes, des paquets défectueux sont en mode « garder en l'état ».


Donc pas de wine32

apt-get install wine32:i386


Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances      
Lecture des informations d'état... Fait
Certains paquets ne peuvent être installés. Ceci peut signifier
que vous avez demandé l'impossible, ou bien, si vous utilisez
la distribution unstable, que certains paquets n'ont pas encore
été créés ou ne sont pas sortis d'Incoming.
L'information suivante devrait vous aider à résoudre la situation :

Les paquets suivants contiennent des dépendances non satisfaites :
 wine32:i386 : Dépend: libwine:i386 (= 1.8.7-2~bpo8+1) mais ne sera pas installé
E: Impossible de corriger les problèmes, des paquets défectueux sont en mode « garder en l'état ».


Ça non plus !

apt-get install --install-recommends winehq-stable


Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances      
Lecture des informations d'état... Fait
Certains paquets ne peuvent être installés. Ceci peut signifier
que vous avez demandé l'impossible, ou bien, si vous utilisez
la distribution unstable, que certains paquets n'ont pas encore
été créés ou ne sont pas sortis d'Incoming.
L'information suivante devrait vous aider à résoudre la situation :

Les paquets suivants contiennent des dépendances non satisfaites :
 winehq-stable : Dépend: wine-stable (= 2.0.2~stretch)
E: Impossible de corriger les problèmes, des paquets défectueux sont en mode « garder en l'état ».


En passant par winhq non plus

apt-get -t jessie-backports install wine32


Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances      
Lecture des informations d'état... Fait
Certains paquets ne peuvent être installés. Ceci peut signifier
que vous avez demandé l'impossible, ou bien, si vous utilisez
la distribution unstable, que certains paquets n'ont pas encore
été créés ou ne sont pas sortis d'Incoming.
L'information suivante devrait vous aider à résoudre la situation :

Les paquets suivants contiennent des dépendances non satisfaites :
 wine32:i386 : Dépend: libwine:i386 (= 1.8.7-2~bpo8+1) mais ne sera pas installé
E: Impossible de corriger les problèmes, des paquets défectueux sont en mode « garder en l'état ».


Et par le backport non plus ...


Et libwine, c'est pire x)

apt-get -t jessie-backports install libwine:i386


Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances      
Lecture des informations d'état... Fait
Certains paquets ne peuvent être installés. Ceci peut signifier
que vous avez demandé l'impossible, ou bien, si vous utilisez
la distribution unstable, que certains paquets n'ont pas encore
été créés ou ne sont pas sortis d'Incoming.
L'information suivante devrait vous aider à résoudre la situation :

Les paquets suivants contiennent des dépendances non satisfaites :
 libwine:i386 : Dépend: libfontconfig1:i386 (>= 2.11) mais il n'est pas installable
                Dépend: libfreetype6:i386 (>= 2.2.1) mais il n'est pas installable
                Dépend: libncurses5:i386 (>= 5.5-5~) mais il n'est pas installable
                Dépend: libasound2:i386 (>= 1.0.16) mais il n'est pas installable
                Dépend: libglu1-mesa:i386 mais il n'est pas installable ou
                         libglu1:i386 mais il n'est pas installable
                Dépend: liblcms2-2:i386 (>= 2.2+git20110628) mais il n'est pas installable
                Dépend: libldap-2.4-2:i386 (>= 2.4.7) mais ne sera pas installé
                Dépend: libmpg123-0:i386 (>= 1.13.7) mais il n'est pas installable
                Dépend: libopenal1:i386 (>= 1.14) mais il n'est pas installable
                Dépend: libpcap0.8:i386 (>= 0.9.8) mais ne sera pas installé
                Dépend: libpulse0:i386 (>= 0.99.1) mais ne sera pas installé
                Dépend: libx11-6:i386 mais il n'est pas installable
                Dépend: libxext6:i386 mais il n'est pas installable
                Dépend: libxml2:i386 (>= 2.9.0) mais ne sera pas installé
                Dépend: ocl-icd-libopencl1:i386 mais il n'est pas installable ou
                         libopencl1:i386 mais il n'est pas installable
                Dépend: ocl-icd-libopencl1:i386 (>= 1.0) mais il n'est pas installable ou
                         libopencl-1.1-1:i386 mais il n'est pas installable
                Dépend: zlib1g:i386 (>= 1:1.1.4) mais il n'est pas installable
                Recommande: libcups2:i386 (>= 1.4.0) mais ne sera pas installé
                Recommande: libdbus-1-3:i386 (>= 1.0.2) mais il n'est pas installable
                Recommande: libgl1-mesa-glx:i386 mais ne sera pas installé ou
                            libgl1:i386
                Recommande: libgnutls-deb0-28:i386 (>= 3.3.0) mais il n'est pas installable
                Recommande: libgsm1:i386 (>= 1.0.13) mais il n'est pas installable
                Recommande: libjpeg62-turbo:i386 (>= 1.3.1) mais il n'est pas installable
                Recommande: libodbc1:i386 (>= 2.3.1) mais ne sera pas installé
                Recommande: libosmesa6:i386 (>= 10.2~) mais ne sera pas installé
                Recommande: libpng12-0:i386 (>= 1.2.13-4) mais il n'est pas installable
                Recommande: libtiff5:i386 (>= 4.0.3) mais ne sera pas installé
                Recommande: libxcomposite1:i386 (>= 1:0.3-1) mais il n'est pas installable
                Recommande: libxcursor1:i386 (> 1.1.2) mais il n'est pas installable
                Recommande: libxi6:i386 mais il n'est pas installable
                Recommande: libxinerama1:i386 mais il n'est pas installable
                Recommande: libxrandr2:i386 mais il n'est pas installable
                Recommande: libxrender1:i386 mais il n'est pas installable
                Recommande: libxslt1.1:i386 (>= 1.1.25) mais il n'est pas installable
                Recommande: libxxf86vm1:i386 mais il n'est pas installable
                Recommande: libgl1-mesa-dri:i386 mais ne sera pas installé
                Recommande: libasound2-plugins:i386 mais il n'est pas installable
E: Impossible de corriger les problèmes, des paquets défectueux sont en mode « garder en l'état ».



Je vous montre le source.list quand même :

deb [arch=amd64,i386] http://security.debian.org/debian-security stretch/updates main contrib
deb-src http://security.debian.org/debian-security stretch/updates main contrib

deb [arch=amd64,i386] http://ftp.fr.debian.org/debian/ stretch-updates main contrib
deb-src http://ftp.fr.debian.org/debian/ stretch-updates main contrib

deb [arch=amd64,i386] http://httpredir.debian.org/debian/ jessie-backports main
deb-src http://httpredir.debian.org/debian/ jessie-backports main

deb https://dl.winehq.org/wine-builds/debian/ stretch main



Voilà voilà ... Si quelqu'un peut me sauver, je lui offre des chocolats. Promis.

Edit à toto :

Mis les sources en couleur en ajoutant apt_sources au Code de la balise.

Dernière modification par SherrifPepper (19-10-2017 07:23:50)

Hors ligne

#2 19-10-2017 06:50:21

chalu
Modératrice
Lieu : Anjou
Distrib. : Debian Stretch
Noyau : Linux 4.9.0-3-amd64
(G)UI : Mate 1.16
Inscription : 11-03-2016

Re : [RESOLU]Soucis pour installer wine32 ... :/

Bonjour,
Pourquoi avoir jessie-backports sur une installation de Stretch ? Il manque en plus le dépôt principal de stretch
Le wiki pour avoir celui qu’il faut est ici : https://debian-facile.org/doc:systeme:a … st:stretch
Il faut commencer par corriger ça wink

Hors ligne

#3 19-10-2017 07:22:49

SherrifPepper
Membre
Distrib. : Debian GNU/Linux Stretch 9.2
Noyau : Linux 4.9.0-4-amd4
(G)UI : Gestionnaire par défaut de GNOME 3
Inscription : 19-10-2017

Re : [RESOLU]Soucis pour installer wine32 ... :/

Tu vois Denis Brognard ?
Tu vois le AH ?

... Bah voilà.
En fait j'ai un peu appris Linux sur le tas, et visiblement, l'une des choses que j'avais pas compris, c'est qu'il y avait une réelle différence entre :
http://ftp.fr.debian.org/debian/
et :
http://deb.debian.org/debian/

Ou comment passer 3h par pure obstination sur un truc alors que c'était tout simple >.>

Du coup ... Bah, si je te croise IRL un jour, je t'offre plein de chocolats.

Merci ^^'

Hors ligne

Pied de page des forums