Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 25-10-2017 14:33:08

hashut
Membre
Inscription : 06-10-2016

Problème Xorg

Bonjour

Après avoir upgrade Debian 6 vers Debian 7 impossible de lance Xorg

Xorg -configure :0


X.Org X Server 1.12.4
Release Date: 2012-08-27
X Protocol Version 11, Revision 0
Build Operating System: Linux 3.2.0-4-amd64 x86_64 Debian
Current Operating System: Linux debian.net-utyl.org 3.2.0-4-amd64 #1 SMP Debian 3.2.93-1 x86_64
Kernel command line: BOOT_IMAGE=/vmlinuz-3.2.0-4-amd64 root=UUID=56b695bc-26bc-4d8b-9853-7cc9a46d9bb8 ro quiet
Build Date: 13 July 2017  03:50:14PM
xorg-server 2:1.12.4-6+deb7u7 (Lucas Kanashiro <kanashiro@debian.org>)
Current version of pixman: 0.26.0
  Before reporting problems, check http://wiki.x.org
  to make sure that you have the latest version.
Markers: (--) probed, (**) from config file, (==) default setting,
  (++) from command line, (!!) notice, (II) informational,
  (WW) warning, (EE) error, (NI) not implemented, (??) unknown.
(==) Log file: "/var/log/Xorg.0.log", Time: Wed Oct 25 12:04:11 2017
List of video drivers:
  radeon
  mach64
  ark
  openchrome
  rendition
  savage
  siliconmotion
  voodoo
  chips
  tdfx
  intel
  s3
  neomagic
  apm
  ati
  sisusb
  s3virge
  vmware
  nouveau
  tseng
  i128
  cirrus
  trident
  mga
  r128
  sis
  fbdev
  vesa
(++) Using config file: "/root/xorg.conf.new"
(==) Using system config directory "/usr/share/X11/xorg.conf.d"
Number of created screens does not match number of detected devices.
  Configuration failed.
Server terminated with error (2). Closing log file.



Voici le log

X.Org X Server 1.12.4
Release Date: 2012-08-27
[  2003.038] X Protocol Version 11, Revision 0
[  2003.038] Build Operating System: Linux 3.2.0-4-amd64 x86_64 Debian
[  2003.038] Current Operating System: Linux debian.net-utyl.org 3.2.0-4-amd64 #1 SMP Debian 3.2.93-1 x86_64
[  2003.038] Kernel command line: BOOT_IMAGE=/vmlinuz-3.2.0-4-amd64 root=UUID=56b695bc-26bc-4d8b-9853-7cc9a46d9bb8 ro quiet
[  2003.038] Build Date: 13 July 2017  03:50:14PM
[  2003.038] xorg-server 2:1.12.4-6+deb7u7 (Lucas Kanashiro <kanashiro@debian.org>)
[  2003.038] Current version of pixman: 0.26.0
[  2003.038]  Before reporting problems, check http://wiki.x.org
  to make sure that you have the latest version.
[  2003.038] Markers: (--) probed, (**) from config file, (==) default setting,
  (++) from command line, (!!) notice, (II) informational,
  (WW) warning, (EE) error, (NI) not implemented, (??) unknown.
[  2003.039] (==) Log file: "/var/log/Xorg.0.log", Time: Wed Oct 25 12:04:11 2017
[  2003.039] (II) Loader magic: 0x7f8397df1ae0
[  2003.039] (II) Module ABI versions:
[  2003.039]  X.Org ANSI C Emulation: 0.4
[  2003.039]  X.Org Video Driver: 12.1
[  2003.039]  X.Org XInput driver : 16.0
[  2003.039]  X.Org Server Extension : 6.0
[  2003.040] (--) PCI:*(0:0:2:0) 8086:0042:1043:8383 rev 24, Mem @ 0xf7800000/4194304, 0xe0000000/268435456, I/O @ 0x0000cc00/8
[  2003.041] List of video drivers:
[  2003.041]  radeon
[  2003.042]  mach64
[  2003.042]  ark
[  2003.042]  openchrome
[  2003.042]  rendition
[  2003.042]  savage
[  2003.042]  siliconmotion
[  2003.042]  voodoo
[  2003.042]  chips
[  2003.042]  tdfx
[  2003.042]  intel
[  2003.042]  s3
[  2003.042]  neomagic
[  2003.042]  apm
[  2003.042]  ati
[  2003.042]  sisusb
[  2003.042]  s3virge
[  2003.042]  vmware
[  2003.042]  nouveau
[  2003.042]  tseng
[  2003.043]  i128
[  2003.043]  cirrus
[  2003.043]  trident
[  2003.043]  mga
[  2003.043]  r128
[  2003.043]  sis
[  2003.043]  fbdev
[  2003.043]  vesa
[  2003.043] (II) LoadModule: "radeon"
[  2003.043] (II) Loading /usr/lib/xorg/modules/drivers/radeon_drv.so
[  2003.044] (II) Module radeon: vendor="X.Org Foundation"
[  2003.044]  compiled for 1.12.4, module version = 6.14.99
[  2003.044]  Module class: X.Org Video Driver
[  2003.044]  ABI class: X.Org Video Driver, version 12.1
[  2003.044] (II) LoadModule: "mach64"
[  2003.044] (II) Loading /usr/lib/xorg/modules/drivers/mach64_drv.so
[  2003.045] (II) Module mach64: vendor="X.Org Foundation"
[  2003.045]  compiled for 1.12.1, module version = 6.9.1
[  2003.045]  Module class: X.Org Video Driver
[  2003.045]  ABI class: X.Org Video Driver, version 12.0
[  2003.045] (II) LoadModule: "ark"
[  2003.045] (II) Loading /usr/lib/xorg/modules/drivers/ark_drv.so
[  2003.045] (II) Module ark: vendor="X.Org Foundation"
[  2003.045]  compiled for 1.12.1, module version = 0.7.4
[  2003.045]  Module class: X.Org Video Driver
[  2003.045]  ABI class: X.Org Video Driver, version 12.0
[  2003.045] (II) LoadModule: "openchrome"
[  2003.046] (II) Loading /usr/lib/xorg/modules/drivers/openchrome_drv.so
[  2003.046] (II) Module openchrome: vendor="http://openchrome.org/"
[  2003.046]  compiled for 1.12.4, module version = 0.2.906
[  2003.046]  Module class: X.Org Video Driver
[  2003.046]  ABI class: X.Org Video Driver, version 12.1
[  2003.046] (II) LoadModule: "rendition"
[  2003.046] (II) Loading /usr/lib/xorg/modules/drivers/rendition_drv.so
[  2003.047] (II) Module rendition: vendor="X.Org Foundation"
[  2003.047]  compiled for 1.12.1, module version = 4.2.4
[  2003.047]  Module class: X.Org Video Driver
[  2003.047]  ABI class: X.Org Video Driver, version 12.0
[  2003.047] (II) LoadModule: "savage"
[  2003.047] (II) Loading /usr/lib/xorg/modules/drivers/savage_drv.so
[  2003.047] (II) Module savage: vendor="X.Org Foundation"
[  2003.047]  compiled for 1.12.1, module version = 2.3.4
[  2003.047]  Module class: X.Org Video Driver
[  2003.047]  ABI class: X.Org Video Driver, version 12.0
[  2003.047] (II) LoadModule: "siliconmotion"
[  2003.048] (II) Loading /usr/lib/xorg/modules/drivers/siliconmotion_drv.so
[  2003.048] (II) Module siliconmotion: vendor="X.Org Foundation"
[  2003.048]  compiled for 1.12.1, module version = 1.7.6
[  2003.048]  Module class: X.Org Video Driver
[  2003.048]  ABI class: X.Org Video Driver, version 12.0
[  2003.048] (II) LoadModule: "voodoo"
[  2003.048] (II) Loading /usr/lib/xorg/modules/drivers/voodoo_drv.so
[  2003.048] (II) Module voodoo: vendor="X.Org Foundation"
[  2003.048]  compiled for 1.12.1, module version = 1.1.0
[  2003.048]  Module class: X.Org Video Driver
[  2003.048]  ABI class: X.Org Video Driver, version 12.0
[  2003.048] (II) LoadModule: "chips"
[  2003.048] (II) Loading /usr/lib/xorg/modules/drivers/chips_drv.so
[  2003.048] (II) Module chips: vendor="X.Org Foundation"
[  2003.048]  compiled for 1.12.1, module version = 1.2.4
[  2003.048]  Module class: X.Org Video Driver
[  2003.048]  ABI class: X.Org Video Driver, version 12.0
[  2003.048] (II) LoadModule: "tdfx"
[  2003.049] (II) Loading /usr/lib/xorg/modules/drivers/tdfx_drv.so
[  2003.049] (II) Module tdfx: vendor="X.Org Foundation"
[  2003.049]  compiled for 1.12.1, module version = 1.4.4
[  2003.049]  Module class: X.Org Video Driver
[  2003.049]  ABI class: X.Org Video Driver, version 12.0
[  2003.049] (II) LoadModule: "intel"
[  2003.049] (II) Loading /usr/lib/xorg/modules/drivers/intel_drv.so
[  2003.049] (II) Module intel: vendor="X.Org Foundation"
[  2003.049]  compiled for 1.12.3.902, module version = 2.19.0
[  2003.049]  Module class: X.Org Video Driver
[  2003.049]  ABI class: X.Org Video Driver, version 12.1
[  2003.049] (II) LoadModule: "s3"
[  2003.049] (II) Loading /usr/lib/xorg/modules/drivers/s3_drv.so
[  2003.049] (II) Module s3: vendor="X.Org Foundation"
[  2003.049]  compiled for 1.12.4, module version = 0.6.3
[  2003.049]  Module class: X.Org Video Driver
[  2003.049]  ABI class: X.Org Video Driver, version 12.1
[  2003.049] (II) LoadModule: "neomagic"
[  2003.050] (II) Loading /usr/lib/xorg/modules/drivers/neomagic_drv.so
[  2003.050] (II) Module neomagic: vendor="X.Org Foundation"
[  2003.050]  compiled for 1.12.1, module version = 1.2.6
[  2003.050]  Module class: X.Org Video Driver
[  2003.050]  ABI class: X.Org Video Driver, version 12.0
[  2003.050] (II) LoadModule: "apm"
[  2003.050] (II) Loading /usr/lib/xorg/modules/drivers/apm_drv.so
[  2003.050] (II) Module apm: vendor="X.Org Foundation"
[  2003.050]  compiled for 1.12.1, module version = 1.2.3
[  2003.050]  Module class: X.Org Video Driver
[  2003.050]  ABI class: X.Org Video Driver, version 12.0
[  2003.050] (II) LoadModule: "ati"
[  2003.050] (II) Loading /usr/lib/xorg/modules/drivers/ati_drv.so
[  2003.050] (II) Module ati: vendor="X.Org Foundation"
[  2003.050]  compiled for 1.12.4, module version = 6.14.99
[  2003.050]  Module class: X.Org Video Driver
[  2003.050]  ABI class: X.Org Video Driver, version 12.1
[  2003.050] (II) LoadModule: "sisusb"
[  2003.050] (II) Loading /usr/lib/xorg/modules/drivers/sisusb_drv.so
[  2003.050] (II) Module sisusb: vendor="X.Org Foundation"
[  2003.050]  compiled for 1.12.1, module version = 0.9.4
[  2003.050]  Module class: X.Org Video Driver
[  2003.050]  ABI class: X.Org Video Driver, version 12.0
[  2003.051] (II) LoadModule: "s3virge"
[  2003.051] (II) Loading /usr/lib/xorg/modules/drivers/s3virge_drv.so
[  2003.051] (II) Module s3virge: vendor="X.Org Foundation"
[  2003.051]  compiled for 1.12.1, module version = 1.10.4
[  2003.051]  Module class: X.Org Video Driver
[  2003.051]  ABI class: X.Org Video Driver, version 12.0
[  2003.051] (II) LoadModule: "vmware"
[  2003.051] (II) Loading /usr/lib/xorg/modules/drivers/vmware_drv.so
[  2003.051] (II) Module vmware: vendor="X.Org Foundation"
[  2003.051]  compiled for 1.12.1, module version = 12.0.2
[  2003.051]  Module class: X.Org Video Driver
[  2003.051]  ABI class: X.Org Video Driver, version 12.0
[  2003.051] (II) LoadModule: "nouveau"
[  2003.051] (II) Loading /usr/lib/xorg/modules/drivers/nouveau_drv.so
[  2003.051] (II) Module nouveau: vendor="X.Org Foundation"
[  2003.051]  compiled for 1.12.4, module version = 1.0.1
[  2003.051]  Module class: X.Org Video Driver
[  2003.051]  ABI class: X.Org Video Driver, version 12.1
[  2003.051] (II) LoadModule: "tseng"
[  2003.052] (II) Loading /usr/lib/xorg/modules/drivers/tseng_drv.so
[  2003.052] (II) Module tseng: vendor="X.Org Foundation"
[  2003.052]  compiled for 1.12.1, module version = 1.1.0
[  2003.052]  Module class: X.Org Video Driver
[  2003.052]  ABI class: X.Org Video Driver, version 12.0
[  2003.052] (II) LoadModule: "i128"
[  2003.052] (II) Loading /usr/lib/xorg/modules/drivers/i128_drv.so
[  2003.052] (II) Module i128: vendor="X.Org Foundation"
[  2003.052]  compiled for 1.12.1, module version = 1.3.5
[  2003.052]  Module class: X.Org Video Driver
[  2003.052]  ABI class: X.Org Video Driver, version 12.0
[  2003.052] (II) LoadModule: "cirrus"
[  2003.052] (II) Loading /usr/lib/xorg/modules/drivers/cirrus_drv.so
[  2003.052] (II) Module cirrus: vendor="X.Org Foundation"
[  2003.052]  compiled for 1.12.1.902, module version = 1.4.0
[  2003.052]  Module class: X.Org Video Driver
[  2003.052]  ABI class: X.Org Video Driver, version 12.0
[  2003.052] (II) LoadModule: "trident"
[  2003.053] (II) Loading /usr/lib/xorg/modules/drivers/trident_drv.so
[  2003.053] (II) Module trident: vendor="X.Org Foundation"
[  2003.053]  compiled for 1.12.1, module version = 1.3.5
[  2003.053]  Module class: X.Org Video Driver
[  2003.053]  ABI class: X.Org Video Driver, version 12.0
[  2003.053] (II) LoadModule: "mga"
[  2003.053] (II) Loading /usr/lib/xorg/modules/drivers/mga_drv.so
[  2003.053] (II) Module mga: vendor="X.Org Foundation"
[  2003.053]  compiled for 1.12.4, module version = 1.5.0
[  2003.053]  Module class: X.Org Video Driver
[  2003.053]  ABI class: X.Org Video Driver, version 12.1
[  2003.053] (II) LoadModule: "r128"
[  2003.053] (II) Loading /usr/lib/xorg/modules/drivers/r128_drv.so
[  2003.053] (II) Module r128: vendor="X.Org Foundation"
[  2003.053]  compiled for 1.12.1, module version = 6.8.2
[  2003.053]  Module class: X.Org Video Driver
[  2003.053]  ABI class: X.Org Video Driver, version 12.0
[  2003.053] (II) LoadModule: "sis"
[  2003.054] (II) Loading /usr/lib/xorg/modules/drivers/sis_drv.so
[  2003.054] (II) Module sis: vendor="X.Org Foundation"
[  2003.054]  compiled for 1.12.1, module version = 0.10.4
[  2003.054]  Module class: X.Org Video Driver
[  2003.054]  ABI class: X.Org Video Driver, version 12.0
[  2003.054] (II) LoadModule: "fbdev"
[  2003.054] (II) Loading /usr/lib/xorg/modules/drivers/fbdev_drv.so
[  2003.054] (II) Module fbdev: vendor="X.Org Foundation"
[  2003.054]  compiled for 1.12.1, module version = 0.4.2
[  2003.054]  ABI class: X.Org Video Driver, version 12.0
[  2003.054] (II) LoadModule: "vesa"
[  2003.054] (II) Loading /usr/lib/xorg/modules/drivers/vesa_drv.so
[  2003.054] (II) Module vesa: vendor="X.Org Foundation"
[  2003.054]  compiled for 1.12.1, module version = 2.3.1
[  2003.054]  Module class: X.Org Video Driver
[  2003.054]  ABI class: X.Org Video Driver, version 12.0
[  2003.054] (WW) Falling back to old probe method for ark
[  2003.054] (WW) Falling back to old probe method for siliconmotion
[  2003.054] (WW) Falling back to old probe method for voodoo
[  2003.054] (II) intel: Driver for Intel Integrated Graphics Chipsets: i810,
  i810-dc100, i810e, i815, i830M, 845G, 854, 852GM/855GM, 865G, 915G,
  E7221 (i915), 915GM, 945G, 945GM, 945GME, Pineview GM, Pineview G,
  965G, G35, 965Q, 946GZ, 965GM, 965GME/GLE, G33, Q35, Q33, GM45,
  4 Series, G45/G43, Q45/Q43, G41, B43, B43, Clarkdale, Arrandale,
  Sandybridge Desktop (GT1), Sandybridge Desktop (GT2),
  Sandybridge Desktop (GT2+), Sandybridge Mobile (GT1),
  Sandybridge Mobile (GT2), Sandybridge Mobile (GT2+),
  Sandybridge Server, Ivybridge Mobile (GT1), Ivybridge Mobile (GT2),
  Ivybridge Desktop (GT1), Ivybridge Desktop (GT2), Ivybridge Server,
  Ivybridge Server (GT2)
[  2003.055] (WW) Falling back to old probe method for s3
[  2003.055] (WW) Falling back to old probe method for neomagic
[  2003.055] (WW) Falling back to old probe method for apm
[  2003.055] (WW) Falling back to old probe method for sisusb
[  2003.055] (WW) Falling back to old probe method for s3virge
[  2003.055] (WW) Falling back to old probe method for tseng
[  2003.055] (WW) Falling back to old probe method for i128
[  2003.055] (WW) Falling back to old probe method for cirrus
[  2003.055] (II) Loading sub module "cirrus_laguna"
[  2003.055] (II) LoadModule: "cirrus_laguna"
[  2003.055] (II) Loading /usr/lib/xorg/modules/drivers/cirrus_laguna.so
[  2003.055] (II) Module cirrus_laguna: vendor="X.Org Foundation"
[  2003.055]  compiled for 1.12.1.902, module version = 1.0.0
[  2003.055]  ABI class: X.Org Video Driver, version 12.0
[  2003.055] (II) Loading sub module "cirrus_alpine"
[  2003.055] (II) LoadModule: "cirrus_alpine"
[  2003.055] (II) Loading /usr/lib/xorg/modules/drivers/cirrus_alpine.so
[  2003.055] (II) Module cirrus_alpine: vendor="X.Org Foundation"
[  2003.055]  compiled for 1.12.1.902, module version = 1.0.0
[  2003.055]  ABI class: X.Org Video Driver, version 12.0
[  2003.056] (WW) Falling back to old probe method for trident
[  2003.056] (WW) Falling back to old probe method for sis
[  2003.056] (II) FBDEV: driver for framebuffer: fbdev
[  2003.056] (II) VESA: driver for VESA chipsets: vesa
[  2003.128] (++) Using config file: "/root/xorg.conf.new"
[  2003.128] (==) Using system config directory "/usr/share/X11/xorg.conf.d"
[  2003.129] (==) ServerLayout "X.org Configured"
[  2003.129] (**) |-->Screen "Screen0" (0)
[  2003.129] (**) |   |-->Monitor "Monitor0"
[  2003.129] (==) No device specified for screen "Screen0".
  Using the first device section listed.
[  2003.130] (**) |   |-->Device "Intel Graphics"
[  2003.130] (**) |-->Screen "Screen1" (1)
[  2003.130] (**) |   |-->Monitor "Monitor1"
[  2003.130] (**) |   |-->Device "Card1"
[  2003.130] (**) |-->Screen "Screen2" (2)
[  2003.130] (**) |   |-->Monitor "Monitor2"
[  2003.130] (**) |   |-->Device "Card2"
[  2003.130] (**) |-->Input Device "Mouse0"
[  2003.130] (**) |-->Input Device "Keyboard0"
[  2003.131] (==) Automatically adding devices
[  2003.131] (==) Automatically enabling devices
[  2003.131] (**) FontPath set to:
  /usr/share/fonts/X11/misc,
  /usr/share/fonts/X11/cyrillic,
  /usr/share/fonts/X11/100dpi/:unscaled,
  /usr/share/fonts/X11/75dpi/:unscaled,
  /usr/share/fonts/X11/Type1,
  /usr/share/fonts/X11/100dpi,
  /usr/share/fonts/X11/75dpi,
  /var/lib/defoma/x-ttcidfont-conf.d/dirs/TrueType,
  built-ins,
  /usr/share/fonts/X11/misc,
  /usr/share/fonts/X11/cyrillic,
  /usr/share/fonts/X11/100dpi/:unscaled,
  /usr/share/fonts/X11/75dpi/:unscaled,
  /usr/share/fonts/X11/Type1,
  /usr/share/fonts/X11/100dpi,
  /usr/share/fonts/X11/75dpi,
  /var/lib/defoma/x-ttcidfont-conf.d/dirs/TrueType,
  built-ins
[  2003.131] (**) ModulePath set to "/usr/lib/xorg/modules"
[  2003.131] (WW) Hotplugging is on, devices using drivers 'kbd', 'mouse' or 'vmmouse' will be disabled.
[  2003.131] (WW) Disabling Mouse0
[  2003.131] (WW) Disabling Keyboard0
[  2003.134] (WW) Falling back to old probe method for fbdev
[  2003.134] (II) Loading sub module "fbdevhw"
[  2003.134] (II) LoadModule: "fbdevhw"
[  2003.134] (II) Loading /usr/lib/xorg/modules/libfbdevhw.so
[  2003.134] (II) Module fbdevhw: vendor="X.Org Foundation"
[  2003.134]  compiled for 1.12.4, module version = 0.0.2
[  2003.134]  ABI class: X.Org Video Driver, version 12.1
[  2003.134] (WW) Falling back to old probe method for vesa
[  2003.134] Number of created screens does not match number of detected devices.
  Configuration failed.



 Startx


X.Org X Server 1.12.4
Release Date: 2012-08-27
X Protocol Version 11, Revision 0
Build Operating System: Linux 3.2.0-4-amd64 x86_64 Debian
Current Operating System: Linux debian.net-utyl.org 3.2.0-4-amd64 #1 SMP Debian 3.2.93-1 x86_64
Kernel command line: BOOT_IMAGE=/vmlinuz-3.2.0-4-amd64 root=UUID=56b695bc-26bc-4d8b-9853-7cc9a46d9bb8 ro quiet
Build Date: 13 July 2017  03:50:14PM
xorg-server 2:1.12.4-6+deb7u7 (Lucas Kanashiro <kanashiro@debian.org>)
Current version of pixman: 0.26.0
  Before reporting problems, check http://wiki.x.org
  to make sure that you have the latest version.
Markers: (--) probed, (**) from config file, (==) default setting,
  (++) from command line, (!!) notice, (II) informational,
  (WW) warning, (EE) error, (NI) not implemented, (??) unknown.
(==) Log file: "/var/log/Xorg.0.log", Time: Wed Oct 25 12:07:53 2017
(==) Using config file: "/etc/X11/xorg.conf"
(==) Using system config directory "/usr/share/X11/xorg.conf.d"
The XKEYBOARD keymap compiler (xkbcomp) reports:
> Warning:          Type "ONE_LEVEL" has 1 levels, but <RALT> has 2 symbols
>                   Ignoring extra symbols
Errors from xkbcomp are not fatal to the X server
The XKEYBOARD keymap compiler (xkbcomp) reports:
> Warning:          Compat map for group 2 redefined
>                   Using new definition
> Warning:          Compat map for group 3 redefined
>                   Using new definition
> Warning:          Compat map for group 4 redefined
>                   Using new definition
Errors from xkbcomp are not fatal to the X server
xinit: connection to X server lost

waiting for X server to shut down Server terminated successfully (0). Closing log file.

 



J ai tous essayer selon mes capacité mais la sa me dépasse
un peu aide serais la bien venus
Merci

Hors ligne

#2 25-10-2017 20:36:35

bonyred
Membre
Distrib. : Debian 9
Noyau : 4.9.0-3-686-pae
(G)UI : Openbox
Inscription : 15-05-2015

Re : Problème Xorg

Je ne sais pas trop mais je tenterais starx en simple user

startx




A plus

Dernière modification par bonyred (25-10-2017 20:37:05)

Hors ligne

#3 26-10-2017 18:52:46

robert2a
Membre
Lieu : France
Distrib. : Buster 10
Noyau : Linux 4.14.0-1 4.14.2-1
(G)UI : Mate/Gnome
Inscription : 15-11-2014

Re : Problème Xorg

Bonjour
je suis vieux , mais ta debian 6 je connais pas tongue
on va commencer par le retour de lspci


lspci
 


en première lecture je dirais que le serveur X n'arrive pas a trouver le bon driver pour ton matériel
a moins que tu sache quel est ta carte vidéo par exemple , pour clavier souris c'est du standart en ps2 ? (mini din violet et vert )
la description de ta machine peut etre utile aussi
nota : j'ai jamais vu X charger tous ces modules hmm , bon j'ai commencé GNU Linux milieu d année 2014 sous debian 7  tongue (sinon ça date de 2000 a 2002 mon premier contact sous woodou2 )
on va essayer de savoir pourquoi sous debian 6 ça fonctionne et pas sur debian 7

en deuxième lecture ceci me semble bizzare


[  2003.128] (++) Using config file: "/root/xorg.conf.new"
 



sur wheezy il me semble qu il faut un fichier de conf dans /etc/X11/xorg.conf

tu a fait le dist-upgrade dans les règles ?  ta wheezy est bien a jour ?

le problème semble se confirmer ici


(++) Using config file: "/root/xorg.conf.new"
(==) Using system config directory "/usr/share/X11/xorg.conf.d"
Number of created screens does not match number of detected devices.
  Configuration failed.
Server terminated with error (2). Closing log file.
 



il te faut créer un xorg.conf dans le bon dossier mais la j ai un doute , de mémoire sur wheezy et jessie le fichier est dans /etc/X11/xorg.conf  ou dans /etc/X11/xorg.conf.d/monfichier.conf
je n ai pas connu un fichier de conf dans /root/xorg.conf.new
si un ancien passe par la un coup de main svp   wink
mais je pense que le souci vient de la sous debian 7

Dernière modification par robert2a (26-10-2017 19:04:58)

Hors ligne

#4 27-10-2017 09:57:51

robert2a
Membre
Lieu : France
Distrib. : Buster 10
Noyau : Linux 4.14.0-1 4.14.2-1
(G)UI : Mate/Gnome
Inscription : 15-11-2014

Re : Problème Xorg

Bonjour
Après quelques recherche => https://wiki.debian.org/fr/Xorg

la commande plutot en user


$ cd /etc/X11/
 


puis en root


Xorg -configure
 


sinon le plus simple créer le fichier avec nano dans /etc/X11/xorg.conf.d/

le plus simple : ( modifier le nom du driver en fonction de la carte video , ici intel )


Section "Device"
  Identifier     "Device0"
  Driver         "intel"
EndSection
 



pour le créer avec nano


nano /etc/X11/xorg.conf.d/xorg-intel.conf
 



tu efface tous les autres xorg.conf


rm /etc/X11/xorg.conf
 


et


rm /root/xorg.conf.new
 



tu vérifie qu il n y a que le fichier que tu a créer dans /etc/X11/xorg.cond.d/ , sinon tu efface les anciens

tu redémarre le PC

ta carte vidéo


[  2003.040] (--) PCI:*(0:0:2:0) 8086:0042:1043:8383 rev 24, Mem @ 0xf7800000/4194304, 0xe0000000/268435456, I/O @ 0x0000cc00/8
 


mais je sais pas sa marque , intel , nvidia , radeon etc  (pour bien préciser le driver dans le fichier de conf )

Dernière modification par robert2a (27-10-2017 10:20:53)

Hors ligne

#5 27-10-2017 15:54:42

èfpé
Membre
Inscription : 10-07-2016

Re : Problème Xorg

Bonjour,

@robert2a : nous sommes bien sur de l'Intel Graphics et lspci devrait pourrait retourner un truc du style :

lspci -nnk | grep -A2 VGA

00:02.0 VGA compatible controller [0300]: Intel Corporation Core Processor Integrated Graphics Controller [8086:0042] (rev 18)
        Subsystem: ASUSTeK Computer Inc. Device [1043:8383]
        Kernel driver in use: i915


Note : dans « 8086:0042:1043:8383 rev 24 », 8086:0042 est l'identifiant PCI du contrôleur, 1043:8383 celui de la carte fille/mère et rev 24 le numéro de révision du bazar, en décimal.

Outre son emplacement exotique, le fichier xorg.conf doit comporter une erreur de syntaxe ;

cat /var/log/Xorg.0.log

retourne :

[  2003.128] (++) Using config file: "/root/xorg.conf.new"
[  2003.128] (==) Using system config directory "/usr/share/X11/xorg.conf.d"
[  2003.129] (==) ServerLayout "X.org Configured"
[  2003.129] (**) |-->Screen "Screen0" (0)
[  2003.129] (**) |   |-->Monitor "Monitor0"
[  2003.129] (==) No device specified for screen "Screen0".
  Using the first device section listed.
[  2003.130] (**) |   |-->Device "Intel Graphics"
[  2003.130] (**) |-->Screen "Screen1" (1)
[  2003.130] (**) |   |-->Monitor "Monitor1"
[  2003.130] (**) |   |-->Device "Card1"
[  2003.130] (**) |-->Screen "Screen2" (2)
[  2003.130] (**) |   |-->Monitor "Monitor2"
[  2003.130] (**) |   |-->Device "Card2"
[  2003.130] (**) |-->Input Device "Mouse0"
[  2003.130] (**) |-->Input Device "Keyboard0"
[  2003.131] (==) Automatically adding devices
[  2003.131] (==) Automatically enabling devices

au lieu de,

[  2003.128] (==) Using config file: "/etc/X11/xorg.conf"
[  2003.128] (==) Using system config directory "/usr/share/X11/xorg.conf.d"
[  2003.129] (==) ServerLayout "X.org Configured"
[  2003.129] (**) |-->Screen "Screen0" (0)
[  2003.129] (**) |   |-->Monitor "Monitor0"
[  2003.***] (**) |   |-->Device "Device0"
[  2003.***] (**) |-->Screen "Screen1" (1)
[  2003.***] (**) |   |-->Monitor "Monitor1"
[  2003.***] (**) |   |-->Device "Device1"
[  2003.***] (**) |-->Screen "Screen2" (2)
[  2003.***] (**) |   |-->Monitor "Monitor2"
[  2003.***] (**) |   |-->Device "Device2"
[  2003.***] (**) |-->Input Device "Mouse0"
[  2003.***] (**) |-->Input Device "Keyboard0"
[  2003.***] (==) Automatically adding devices
[  2003.***] (==) Automatically enabling devices


Donc peut-être regarder le contenu dudit fichier avant de le supprimer ? Juste mes 2 cents !

Hors ligne

Pied de page des forums